Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 261091 - media-libs/libgphoto2 flags bother upstream quite a bit
Summary: media-libs/libgphoto2 flags bother upstream quite a bit
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-03 18:46 UTC by Thomas Capricelli
Modified: 2009-03-04 00:03 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Capricelli 2009-03-03 18:46:28 UTC
hello, i have had a hard time to make my camera works. The reason was that i was using (in CAMERAS setting )the flag cameras_canon while i had to use cameras_ptp2 (my camera is a canon, my original choice made sense, didn't it?).

The guys on #gphoto were very helpful and nice, though they are really upset by gentoo. They say a lot of people comes with the same problem and that they are wasting a lot of time because of gentoo.

The purpose of libgphoto2 is to be plug&play, and the cameras_* stuff in gentoo breaks that. They see the CAMERAS' stuff in gentoo as breaking that, and I agree.

I understand their feeling, and thought i should report it here.

keep up the good work.

Reproducible: Always
Comment 1 Mr. Bones. (RETIRED) gentoo-dev 2009-03-03 19:51:06 UTC
Sounds like you didn't heed the warning in the ebuild:

"NOTICE: Upstream will not support you if you do not compile all camera drivers first"
Comment 2 Gilles Dartiguelongue gentoo-dev 2009-03-04 00:02:41 UTC
sorry but people not reading *important* *messages* in ebuilds are not of my concern. I'm really really sorry that some gentoo users don't understand that and prefer bothering upstream first than ask people that are closer to them in terms of distribution as known as the gentoo devs. I can fix software but not users.

We could probably turn all use flag on by default but that still wouldn't solve the issue since you encountered this problem because you restricted the set yourself already.
Comment 3 Gilles Dartiguelongue gentoo-dev 2009-03-04 00:03:03 UTC
cantfix per previous comment.