Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 260827 - gnome-extra/gnome-user-docs-2.26.2 fails w/ parallel make
Summary: gnome-extra/gnome-user-docs-2.26.2 fails w/ parallel make
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
: 263653 265695 290005 315125 (view as bug list)
Depends on: 260611
Blocks: gnome2.24 260063 gnome2.26
  Show dependency tree
 
Reported: 2009-03-02 07:42 UTC by Priit Laes (IRC: plaes)
Modified: 2010-04-13 23:11 UTC (History)
12 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Updated parallel make patch (gnome-user-docs-2.24.2-parallel-make.patch,2.43 KB, patch)
2009-03-06 11:25 UTC, Martin von Gagern
Details | Diff
Replacement parallel make patch (bug260827a.patch,5.50 KB, patch)
2009-03-06 11:27 UTC, Martin von Gagern
Details | Diff
Updated parallel make patch (gnome-user-docs-2.24.2-parallel-make.patch,3.71 KB, patch)
2009-03-06 11:39 UTC, Martin von Gagern
Details | Diff
Build log for gnome-user-docs-2.26.0 (1238722842-install-gnome-extra_gnome-user-docs-2.26.0:0::gnome.out,22.58 KB, text/plain)
2009-04-03 01:47 UTC, Jose daLuz
Details
Failed to emerge gnome-extra/gnome-user-docs-2.26.2 (gnome-extra_gnome-user-docs-2.26.2_20090604-210911.log,6.56 KB, text/plain)
2009-06-06 04:41 UTC, Oscar Florez
Details
gnome-user-docs-2.26.2-parallel-make-install.patch (gnome-user-docs-2.26.2-parallel-make-install.patch,2.75 KB, patch)
2009-08-06 21:26 UTC, Gilles Dartiguelongue
Details | Diff
gnome-user-docs-2.26.2.ebuild.patch (gnome-user-docs-2.26.2.ebuild.patch,1.32 KB, patch)
2009-08-06 21:28 UTC, Gilles Dartiguelongue
Details | Diff
Build log from failed build with the new patch (1249596613-install-gnome-extra_gnome-user-docs-2.26.2:0::myoverlay.out,33.88 KB, text/plain)
2009-08-06 22:14 UTC, Jose daLuz
Details
gnome-user-docs-2.26.2-MAKEOPTS.patch (gnome-user-docs-2.26.2-MAKEOPTS.patch,726 bytes, patch)
2009-11-29 20:22 UTC, David Abbott
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Priit Laes (IRC: plaes) 2009-03-02 07:42:48 UTC
....
>>> Install gnome-user-docs-2.24.2-r1 into /home/portage/portage/gnome-extra/gnome-user-docs-2.24.2-r1/image/ category gnome-extra
make -j3 DESTDIR=/home/portage/portage/gnome-extra/gnome-user-docs-2.24.2-r1/image/ 'scrollkeeper_localstate_dir=/home/portage/portage/gnome-extra/gnome-user-docs-2.24.2-r1/image//var/lib/scrollkeeper ' install 
Making install in gnome2-user-guide
make[1]: Entering directory `/home/portage/portage/gnome-extra/gnome-user-docs-2.24.2-r1/work/gnome-user-docs-2.24.2/gnome2-user-guide'
make[2]: Entering directory `/home/portage/portage/gnome-extra/gnome-user-docs-2.24.2-r1/work/gnome-user-docs-2.24.2/gnome2-user-guide'
make[2]: Nothing to be done for `install-exec-am'.
make  install-data-hook
make[3]: Entering directory `/home/portage/portage/gnome-extra/gnome-user-docs-2.24.2-r1/work/gnome-user-docs-2.24.2/gnome2-user-guide'
/bin/sh /home/portage/portage/gnome-extra/gnome-user-docs-2.24.2-r1/work/gnome-user-docs-2.24.2/install-sh -d /home/portage/portage/gnome-extra/gnome-user-docs-2.24.2-r1/image//usr/share/gnome/help/user-guide/C
/bin/sh /home/portage/portage/gnome-extra/gnome-user-docs-2.24.2-r1/work/gnome-user-docs-2.24.2/install-sh -d /home/portage/portage/gnome-extra/gnome-user-docs-2.24.2-r1/image//usr/share/omf/user-guide
/bin/sh /home/portage/portage/gnome-extra/gnome-user-docs-2.24.2-r1/work/gnome-user-docs-2.24.2/install-sh -d /home/portage/portage/gnome-extra/gnome-user-docs-2.24.2-r1/image//usr/share/gnome/help/user-guide/C/figures/
/usr/bin/install -c -m 644 user-guide-C.omf /home/portage/portage/gnome-extra/gnome-user-docs-2.24.2-r1/image//usr/share/omf/user-guide/user-guide-C.omf
for lc in C ar bg de el es fi fr hu it ja ko oc pa pt pt_BR ru sv th zh_CN; do \
	  pdf="$lc/user-guide.pdf"; \
	  if [ -f "$pdf" ]; then spdf="$pdf"; else spdf="./$pdf"; fi; \
	  if [ -f "$spdf" ]; then \
	    /bin/sh /home/portage/portage/gnome-extra/gnome-user-docs-2.24.2-r1/work/gnome-user-docs-2.24.2/install-sh -d "/home/portage/portage/gnome-extra/gnome-user-docs-2.24.2-r1/image//usr/share/gnome/help/user-guide/$lc"; \
	    /usr/bin/install -c -m 644 "$spdf" "/home/portage/portage/gnome-extra/gnome-user-docs-2.24.2-r1/image//usr/share/gnome/help/user-guide/$pdf"; \
	  fi; \
	done
mkdir: cannot create directory `/home/portage/portage/gnome-extra/gnome-user-docs-2.24.2-r1/image//usr/share/gnome/help/user-guide/C': File exists
/usr/bin/install -c -m 644 C/figures/ask_pointer.png /home/portage/portage/gnome-extra/gnome-user-docs-2.24.2-r1/image//usr/share/gnome/help/user-guide/C/figures/ask_pointer.png
/usr/bin/install -c -m 644 C/figures/busy_pointer.png /home/portage/portage/gnome-extra/gnome-user-docs-2.24.2-r1/image//usr/share/gnome/help/user-guide/C/figures/busy_pointer.png
make[3]: *** [install-doc-docs] Error 1
make[3]: *** Waiting for unfinished jobs....
/usr/bin/install -c -m 644 C/figures/com_file_manager_menu.png /home/portage/portage/gnome-extra/gnome-user-docs-2.24.2-r1/image//usr/share/gnome/help/user-guide/C/figures/com_file_manager_menu.png
....
/usr/bin/install -c -m 644 C/figures/yelp_window.png /home/portage/portage/gnome-extra/gnome-user-docs-2.24.2-r1/image//usr/share/gnome/help/user-guide/C/figures/yelp_window.png
make[3]: Leaving directory `/home/portage/portage/gnome-extra/gnome-user-docs-2.24.2-r1/work/gnome-user-docs-2.24.2/gnome2-user-guide'
make[2]: *** [install-data-am] Error 2
make[2]: Leaving directory `/home/portage/portage/gnome-extra/gnome-user-docs-2.24.2-r1/work/gnome-user-docs-2.24.2/gnome2-user-guide'
make[1]: *** [install-am] Error 2
make[1]: Leaving directory `/home/portage/portage/gnome-extra/gnome-user-docs-2.24.2-r1/work/gnome-user-docs-2.24.2/gnome2-user-guide'
make: *** [install-recursive] Error 1
Comment 1 Priit Laes (IRC: plaes) 2009-03-02 07:43:19 UTC
plaes@sol ~ $ emerge --info
Portage 2.2_rc23 (default/linux/amd64/2008.0/no-multilib, gcc-4.3.3, glibc-2.9_p20081201-r2, 2.6.29-rc6 x86_64)
=================================================================
System uname: Linux-2.6.29-rc6-x86_64-Intel-R-_Core-TM-2_CPU_6320_@_1.86GHz-with-glibc2.2.5
Timestamp of tree: Mon, 02 Mar 2009 07:00:01 +0000
app-shells/bash:     3.2_p48-r1
dev-java/java-config: 2.1.7
dev-lang/python:     2.5.4-r2
dev-util/cmake:      2.6.3
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.4.3-r1
sys-apps/sandbox:    1.3.8
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.19.1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   1.3.5, 2.2.6a
virtual/os-headers:  2.6.28-r1
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=nocona -O2 -ggdb -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=nocona -O2 -ggdb -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="collision-protect distlocks fixpackages multilib-strict parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LDFLAGS="-Wl,--as-needed"
LINGUAS="en et"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/home/portage"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/opt/overlay"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acpi alsa amd64 apache2 automount avahi berkdb bzip2 cairo cdr cli cracklib crypt cups curl daap dbus dga dri dvd dvdr eds encode exif ffmpeg fftw flac fontconfig fortran gdbm gif gimp git glib glitz gmp gnome gnome-keyring gphoto2 gsl gstreamer gtk hal havekernel hdf5 hdri iconv idn ipv6 isdnlog jpeg jpeg2k kpathsea kqemu kvm lapack laptop latex lcms libnotify live lua lzma mad midi mmx mp3 mpeg mudflap nautilus ncurses network-cron nls nptl nptlonly nsplugin ogg openexr opengl openmp pam pch pcre pdf perl plotutils png pppd python qemu qt3support quicktime raw readline reflection sdl server session smp spl sse sse2 ssl ssse3 startup-notification subversion svg sysfs tcpd tga theora threads tiff totem truetype unicode vim-syntax vorbis webdav x264 xcb xinerama xml xmp xorg xulrunner xv xvid xvmc zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en et" USERLAND="GNU" VIDEO_CARDS="intel"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 2 Gilles Dartiguelongue gentoo-dev 2009-03-03 09:33:24 UTC
gdu strikes again :)

This phase:
make  install-data-hook

isn't supposed to be called anymore. I'll take a look asap.
Comment 3 Gilles Dartiguelongue gentoo-dev 2009-03-03 13:28:07 UTC
meh, I thought I assigned that to gnome.
Comment 4 Gilles Dartiguelongue gentoo-dev 2009-03-03 13:47:05 UTC
ok looks like I just failed at the sed...
Comment 5 Gilles Dartiguelongue gentoo-dev 2009-03-04 21:58:12 UTC
comment #2 is non-sense, the change is good after all. I don't know what's going on.
Comment 6 Martin von Gagern 2009-03-06 11:25:43 UTC
Created attachment 184121 [details, diff]
Updated parallel make patch

I tried to analyze this issue. To me, the cause of this bug seems to be the following:
* install-data-hooks depends on both install-doc-docs and install-doc-pdf.
* both these targets create their output subdirectories using mkinstalldirs.
* install-sh seems to have provisions for concurrent execution, but only
  when installing files, not when invoked to create directories.

The patch addresses the issue by having install-doc-pdf not create any
directories itself, but depend on install-doc-docs to do that.

As an alternative, it might be possible to drop the explicit directory
creation altogether, and rely on the implicit and concurrency-aware
directory creation of install-sh. The patch below is closer to original
behaviour, and thus may be more portable, even in cases where install-sh
would not be concurrency-aware.

The modifications touch the same locations in the code as the parallel make patch currently in portage. Therefore I integrated my modifications into that patch (quilt is great!) instead of providing a separate patch.

I must confess I haven't understood the current patch (CVS version 1.1). It might be trying to address the same issue that I do, and failing to do so. On the other hand, it might be fixing some different problem I haven't understood yet. In the former case, it might be better to replace that patch altogether. I will shortly attach a second patch, consisting only of my changes, and incompatible with the current parallel make patch. In the latter case, this integrated patch here might be a suitable solution to both issues, and the patch header should probably expanded to contain additional information about the issue the change from install-data-local to install-data-hooks is supposed to change.
Comment 7 Martin von Gagern 2009-03-06 11:27:55 UTC
Created attachment 184122 [details, diff]
Replacement parallel make patch

As I just wrote, I'm not sure if the parallel make patch currently in portage should be augmented or replaced. This patch here is intended as a replacement.

I should add that I haven't (yet) tested either of these two patches. Properly testing parallel build issues takes several builds in a loop with a high degree of parallelization, and I don't have the ressources for that just now.
Comment 8 Martin von Gagern 2009-03-06 11:39:24 UTC
Created attachment 184124 [details, diff]
Updated parallel make patch

(In reply to comment #6)
> Therefore I integrated my modifications into that patch (quilt is great!)
> instead of providing a separate patch.

Not so great after all... I forgot to refresh, so while the header of the patch was updated, its contents was not. This should be better.

By the way, as to how I found this issue:
1. "ebuild ... compile" in order to get the Makefile as configure writes it
2. Looked at "install-doc-docs" where the error is reported as well as
   "install-doc-pdf" as the target containing the command printed in the log
3. Noted the directory creation commands in both these targets
4. Traced those targets back to other targets depending on them
Comment 9 Reinis Danne 2009-03-11 13:30:05 UTC
Still an issue when upgrading Gnome. Worked around using:
MAKEOPTS="-j1" emerge ...
Comment 10 Michal Špondr 2009-03-11 22:42:19 UTC
I have the same problem.
Comment 11 Simonas Leleiva 2009-03-19 12:19:01 UTC
bump! Hope it hits the tree soon
Comment 12 John W Eckhart 2009-03-20 06:07:16 UTC
In the meantime, can we have parallel restricted for this ebuild (force -j1)?
Comment 13 Gilles Dartiguelongue gentoo-dev 2009-03-25 09:19:21 UTC
*** Bug 263653 has been marked as a duplicate of this bug. ***
Comment 14 Jose daLuz 2009-04-03 01:46:33 UTC
gnome-user-docs-2.26.0 needs a parallel make patch as well. It builds with -j1, not otherwise. Would you prefer I file a separate bug which blocks the Gnome 2.26.0 tracker?
Comment 15 Jose daLuz 2009-04-03 01:47:59 UTC
Created attachment 187151 [details]
Build log for gnome-user-docs-2.26.0
Comment 16 Gilles Dartiguelongue gentoo-dev 2009-04-11 09:12:07 UTC
*** Bug 265695 has been marked as a duplicate of this bug. ***
Comment 17 Jeroen Roovers gentoo-dev 2009-04-19 16:39:51 UTC
Portage 2.1.6.11 (default/linux/hppa/2008.0, gcc-4.3.2, glibc-2.8_p20080602-r1, 2.6.29.1-JeR parisc)
=================================================================
System uname: Linux-2.6.29.1-JeR-parisc-PA8700_-PCX-W2-with-glibc2.2
Timestamp of tree: Sun, 19 Apr 2009 15:15:02 +0000
distcc 3.0 hppa2.0-unknown-linux-gnu [enabled]
ccache version 2.4 [disabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 2.1.7
dev-lang/python:     2.5.4-r2
dev-python/pycrypto: 2.0.1-r8
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.6.3-r1
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.4.3-r1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="hppa"
CBUILD="hppa2.0-unknown-linux-gnu"
CFLAGS="-O2 -pipe -mschedule=8000 -march=2.0 -g -ggdb -Wall"
CHOST="hppa2.0-unknown-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib/fax /usr/share/config /var/bind /var/spool/fax/etc /var/spool/torque /var/www/localhost/htdocs/wordpress/wp-config.php"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -pipe -mschedule=8000 -march=2.0 -g -ggdb -Wall"
DISTDIR="/keeps/gentoo/distfiles"
FEATURES="autoaddcvs buildpkg cvs distcc distlocks fixpackages notitles parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict unmerge-orphans userfetch"
GENTOO_MIRRORS=" http://gentoo.tiscali.nl/ http://mirror.muntinternet.net/pub/gentoo/ http://mirror.cambrium.nl/pub/os/linux/gentoo/ http://ftp.snt.utwente.nl/pub/os/linux/gentoo/ "
LC_ALL="en_US.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="en nl he"
MAKEOPTS="-j5"
PKGDIR="/keeps/gentoo/packages/elmer"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/mnt/alt/portage-tmp"
PORTDIR="/keeps/gentoo/portage"
PORTDIR_OVERLAY="/keeps/gentoo/local"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="7zip X Xaw3d a52 aac aalib accessibility ads agg alsa amr amrnb amrwb ao aoss apache2 ares asf async asyncns audiofile audit automount avfs bash-completion berkdb bidi bittorrent bittorrent-external bl bluetooth bzip2 c++ cairo caps captury catalogs cblas cdb cddb cdparanoia cdr chardet cjk clarens cli cracklib crypt cups curl custom-cflags custom-cxxflags cxx dbi dbtool dbus designer designer-plugin device-mapper dga dia dirac directfb djbfft djvu domainkeys dri drm dts dv dvd dvdr dvdread dxr3 ebook edl elf emacs enca encode esd examples exif expat fame fastbuild fastcgi fbcon ffmpeg filter flac fluidsynth fontconfig fontforge foomaticdb fortran ftp gadu galago gcrypt gd gdbm geant4 geoip ggi gif gimp gimpprint glep glib glut gmp gnome gnutls google-gadgets gphoto2 gpm gps gs gsl gsm gtk gtk2 gtkhtml guidexml hal hepmc hesiod hppa ical icecast iconv icu idea idn imagemagick imlib immqt-bc inquisitio ipv6 isc isdnlog ithreads jack javascript jbig jingle jpeg jpeg2k judy kde kerberos kpathsea lapack latex lcms ldap leim libass libcaca libnotify libsamplerate libwww live lm_sensors logrotate logwatch lua lzo mad manhole matroska mbrola memcache metis mhash midi mikmod mmap mng modplug motif mozbranding mp3 mplayer mssql mudflap musepack mysql nas nautilus ncurses netpbm network-cron nfconntrack nfs nls nntp nptl nptlonly nsplugin ntlm offensive ogg openal openexr opengl openmp oss ots overlays pam pango pbs pcre pdf pdo-external perl php plasma plotutils plugins png portage portaudio postgres povray ppds pppd pulseaudio python pyzord qalculate qdbm qt3 qt3support qt4 quotas raw readline recode reflection rle rpc rrdtool rtc ruby samba sasl scanner schroedinger scim sdl seamonkey server session sid slang slp sms sndfile snmp soundex speex spell spl sqlite srt ssh ssl startup-notification subtitles subversion suhosin supernodal svg swat sysfs syslog talkfilters tcl tcpd test tftp tga theora threads thumbnail thunar-vfs tidy tiff timidity tk tools truetype tslib tunepimp twolame udev unicode unzip urandom usb userlocales utempter utf v4l v4l2 vanim vcd vidix vim-syntax vorbis wavpack webdav webinstall webkit winbind wlan wma wmf xanim xcb xchattext xcomposite xface xml xml2 xmp xmpi xorg xpm xrandr xscreensaver xsettings xulrunner xv xvid xvmc zip zip-external zlib" ALSA_CARDS="ad1889 usb-audio" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_ftp proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev joystick keyboard mouse acecad aiptek calcomp citron digitaledge dmc dynapro elo2300 elographics fpit hyperpen jamstudio magellan microtouch mutouch palmax penmount spaceorb summa synaptics tek4957 tslib ur98 virtualbox wacom void" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en nl he" USERLAND="GNU" VIDEO_CARDS="stifb fbdev matrox dummy"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 18 Harris Landgarten 2009-05-12 03:18:38 UTC
I have found that gnome-user-docs-2.26 fails when installing as sudo but succeeds when running as root
Comment 19 Rémi Cardona gentoo-dev 2009-05-12 09:23:20 UTC
Sigh, got this too with su, this clearly has nothing to do with how emerge is run, the gnome-doc-utils's makefiles just suck...

/me clones gnome-doc-utils to take a look
Comment 20 Radek Kubiak 2009-05-17 12:48:35 UTC
(In reply to comment #18)
> I have found that gnome-user-docs-2.26 fails when installing as sudo but
> succeeds when running as root
> 

not working for me
Comment 21 Priit Laes (IRC: plaes) 2009-05-19 05:27:28 UTC
Still fails with "mkdir: Unable to create directory `foo`: file exists"

[snip]
>>> Install gnome-user-docs-2.26.2 into /var/tmp/portage/gnome-extra/gnome-user-docs-2.26.2/image/ category gnome-extra
make -j3 DESTDIR=/var/tmp/portage/gnome-extra/gnome-user-docs-2.26.2/image/ 'scrollkeeper_localstate_dir=/var/tmp/portage/gnome-extra/gnome-user-docs-2.26.2/image//var/lib/scrollkeeper ' install 
Making install in gnome2-user-guide
make[1]: Entering directory `/var/tmp/portage/gnome-extra/gnome-user-docs-2.26.2/work/gnome-user-docs-2.26.2/gnome2-user-guide'
make[2]: Entering directory `/var/tmp/portage/gnome-extra/gnome-user-docs-2.26.2/work/gnome-user-docs-2.26.2/gnome2-user-guide'
make[2]: Nothing to be done for `install-exec-am'.
make  install-data-hook
make[3]: Entering directory `/var/tmp/portage/gnome-extra/gnome-user-docs-2.26.2/work/gnome-user-docs-2.26.2/gnome2-user-guide'
/bin/sh /var/tmp/portage/gnome-extra/gnome-user-docs-2.26.2/work/gnome-user-docs-2.26.2/install-sh -d /var/tmp/portage/gnome-extra/gnome-user-docs-2.26.2/image//usr/share/gnome/help/user-guide/C
/bin/sh /var/tmp/portage/gnome-extra/gnome-user-docs-2.26.2/work/gnome-user-docs-2.26.2/install-sh -d /var/tmp/portage/gnome-extra/gnome-user-docs-2.26.2/image//usr/share/omf/user-guide
/bin/sh /var/tmp/portage/gnome-extra/gnome-user-docs-2.26.2/work/gnome-user-docs-2.26.2/install-sh -d /var/tmp/portage/gnome-extra/gnome-user-docs-2.26.2/image//usr/share/gnome/help/user-guide/C/figures/
mkdir: kataloogi ``/var/tmp/portage/gnome-extra/gnome-user-docs-2.26.2/image//usr'' ei õnnestu luua: File exists
mkdir: kataloogi ``/var/tmp/portage/gnome-extra/gnome-user-docs-2.26.2/image//usr/share'' ei õnnestu luua: File exists
mkdir: kataloogi ``/var/tmp/portage/gnome-extra/gnome-user-docs-2.26.2/image//usr/share/gnome/help/user-guide'' ei õnnestu luua: File exists
mkdir: kataloogi ``/var/tmp/portage/gnome-extra/gnome-user-docs-2.26.2/image//usr/share/gnome/help/user-guide/C'' ei õnnestu luua: File exists
/usr/bin/install -c -m 644 user-guide-C.omf /var/tmp/portage/gnome-extra/gnome-user-docs-2.26.2/image//usr/share/omf/user-guide/user-guide-C.omf
make[3]: *** [install-doc-docs] Error 1
make[3]: *** Waiting for unfinished jobs....
[/snip]
Comment 22 Wilbur Pan 2009-05-19 17:52:47 UTC
I can confirm that 

MAKEOPTS="-j1" emerge --oneshot gnome-user-docs

was successful.
Comment 23 Wilbur Pan 2009-05-19 17:53:37 UTC
(In reply to comment #22)
> I can confirm that 
> 
> MAKEOPTS="-j1" emerge --oneshot gnome-user-docs
> 
> was successful.
> 

Forgot to add -- this is for gnome-user-docs-2.26.2
Comment 24 Oscar Florez 2009-06-06 04:41:38 UTC
Created attachment 193681 [details]
Failed to emerge gnome-extra/gnome-user-docs-2.26.2
Comment 25 Gilles Dartiguelongue gentoo-dev 2009-08-06 21:26:57 UTC
Created attachment 200433 [details, diff]
gnome-user-docs-2.26.2-parallel-make-install.patch

ok, let's try to fix this once and for all. Take another approach to described symptoms. Make directories if it doesn't exist and don't really on other targets to do it.
Comment 26 Gilles Dartiguelongue gentoo-dev 2009-08-06 21:28:01 UTC
Created attachment 200434 [details, diff]
gnome-user-docs-2.26.2.ebuild.patch

ebuild patch to test. Please everyone try this combo and tell me how it goes.
Comment 27 Jose daLuz 2009-08-06 22:12:44 UTC
(In reply to comment #26)
> Created an attachment (id=200434) [edit]
> gnome-user-docs-2.26.2.ebuild.patch
> 
> ebuild patch to test. Please everyone try this combo and tell me how it goes.
> 
It still fails for me. I will attach the build log.
Comment 28 Jose daLuz 2009-08-06 22:14:11 UTC
Created attachment 200436 [details]
Build log from failed build with the new patch
Comment 29 Paul Varner (RETIRED) gentoo-dev 2009-08-07 17:29:59 UTC
Worked for me on the following system

Portage 2.2_rc36 (default/linux/amd64/2008.0/desktop, gcc-4.3.2, glibc-2.9_p20081201-r2, 2.6.27-gentoo-r8 x86_64)
=================================================================
System uname: Linux-2.6.27-gentoo-r8-x86_64-Dual-Core_AMD_Opteron-tm-_Processor_2218-with-gentoo-2.0.1
Timestamp of tree: Fri, 07 Aug 2009 07:45:01 +0000
app-shells/bash:     4.0_p28
dev-java/java-config: 2.1.8-r1
dev-lang/python:     2.6.2-r1
dev-util/cmake:      2.6.4-r2
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.4.3-r3
sys-apps/sandbox:    2.0
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.7.9-r1, 1.9.6-r2, 1.10.2, 1.11
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=k8 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/chroot/dns /etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/bind"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=k8 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps=y"
FEATURES="assume-digests distlocks fixpackages parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LDFLAGS="-Wl,-O1"
LINGUAS="en en_US"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/sunrise /usr/local/portage/local"
SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"
USE="X acpi alsa amd64 arts berkdb branding bzip2 cairo cdr cli cracklib crypt cups dbus dri dvd dvdr eds emboss encode esd evo fam fortran gdbm gif gnome gpm gstreamer gtk hal iconv isdnlog java java6 jpeg kde libnotify mad mikmod mmx mp3 mpeg mudflap multilib ncurses nls nptl nptlonly ogg opengl pam pcre pdf perl png ppds pppd python qt3 qt3support qt4 quicktime readline reflection sdl session spell spl sse sse2 ssl startup-notification svg sysfs tcpd tiff truetype unicode usb vorbis xml xorg xscreensaver xulrunner xv zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_US" USERLAND="GNU" VIDEO_CARDS="nvidia nv vesa"
Unset:  CPPFLAGS, CTARGET, FFLAGS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 30 Olivier Crete (RETIRED) gentoo-dev 2009-09-19 21:13:04 UTC
Sounds like a case to add -j1 and be done with it
Comment 31 Roman Martynov 2009-10-09 20:16:00 UTC
already had that problem.
MAKEOPTS="-j1" emerge -1 gnome-user-docs doesnt gave a result, but emerge -j1 -1 gnome-users-docs does!
Comment 32 Sebastian Luther (few) 2009-10-21 13:58:27 UTC
*** Bug 290005 has been marked as a duplicate of this bug. ***
Comment 33 Emil Wojak 2009-10-26 14:56:26 UTC
This worked for me:
MAKEOPTS="-j1" emerge -1 gnome-extra/gnome-user-docs
Comment 34 Kevin Parent 2009-11-29 17:09:17 UTC
Just bitten by this bug.  Why not just change "MAKEOPTS" to "-j1" ?  Seems to do the trick.  It's a short install anyway so parallel make doens't really add all that much time savings.  The patch fails to resolve the problem.

I haven't worked on any ebuilds for some time, but I thought it is possible to override a users make.conf options using ebuild variables.  If this is the case just be done with it and override any parallel building with -j1.
Comment 35 David Abbott gentoo-dev 2009-11-29 20:22:22 UTC
Created attachment 211537 [details, diff]
gnome-user-docs-2.26.2-MAKEOPTS.patch

It did install here.
Comment 36 Gilles Dartiguelongue gentoo-dev 2009-12-09 21:42:15 UTC
+*gnome-user-docs-2.28.0 (09 Dec 2009)
+
+  09 Dec 2009; Gilles Dartiguelongue <eva@gentoo.org>
+  -gnome-user-docs-2.26.1.ebuild, +gnome-user-docs-2.28.0.ebuild:
+  New version for Gnome 2.28.0, closes: #293006. Restrict job for
+  src_install, bug #260827.
+
Sick of fighting with this. If anyone has a real solution, please chime in.
Comment 37 bungernut 2010-01-13 17:50:21 UTC
This item is NOT fixed, I am running a current snapshot (2010 Jan 12) and this bug prevented a lot of program installing that should have happened overnight for me. 

I can confirm that makeopts j1 worked as well but I repeat, apparently this is NOT fixed
Comment 38 Daniel Santos 2010-01-18 19:32:59 UTC
Reopen this bug.  It is definitely still broken and gnome fails to install (or at least the meta wont record to world file) as a result of this bug.
Comment 39 Daniel Santos 2010-01-18 19:35:41 UTC
If this helps at all:
mkdir: cannot create directory `/tmp/portage/gnome-extra/gnome-user-docs-2.26.2/image//usr/share/gnome/help': File exists
mkdir: cannot create directory `/tmp/portage/gnome-extra/gnome-user-docs-2.26.2/image//usr/share/gnome/help/user-guide': File exists
.
.
.
mkdir: cannot create directory `/tmp/portage/gnome-extra/gnome-user-docs-2.26.2/image//usr/share/gnome/help/gnome-access-guide/C': File exists



Portage 2.1.6.13 (default/linux/amd64/10.0/desktop, gcc-4.3.4, glibc-2.10.1-r1, 2.6.31-gentoo-r6 x86_64)
=================================================================                                       
System uname: Linux-2.6.31-gentoo-r6-x86_64-AMD_Phenom-tm-_9850_Quad-Core_Processor-with-gentoo-1.12.13 
Timestamp of tree: Mon, 18 Jan 2010 12:30:21 +0000
distcc 3.1 x86_64-pc-linux-gnu [disabled]
ccache version 2.4 [enabled]
app-shells/bash:     4.0_p35
dev-java/java-config: 2.1.9-r2
dev-lang/python:     2.6.4
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.6.4-r3
sys-apps/baselayout: 1.12.13
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=amdfam10 -O2 -ggdb"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=amdfam10 -O2 -ggdb"
DISTDIR="/usr/portage/distfiles"
FEATURES="buildpkg ccache distlocks fixpackages installsources parallel-fetch protect-owned sandbox sfperms splitdebug strict unmerge-orphans userfetch userpriv usersandbox"
GENTOO_MIRRORS="http://mirrors.cs.wmich.edu/gentoo http://mirror.mcs.anl.gov/pub/gentoo/ http://osmirrors.cerias.purdue.edu/pub/gentoo/"
LDFLAGS="-Wl,-O1"
LINGUAS="en_US en"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_COMPRESS="bzip2"
PORTAGE_COMPRESS_FLAGS="-9"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude '/lost+found'"
PORTAGE_TMPDIR="/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/sunrise /usr/local/portage/layman/kde-sunset"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext 3ds 64bit 7zip X Xaw3d a52 aac aalib acl acpi aim aio akode alsa amd64 amr ao aotuv apache2 applet ares arts async audacious audiofile authdaemond authfile autoipd automount bash-completion berkdb binfilter bittorrent bl bluetooth bonjour boost branding bsf bzip2 c3p0 cairo calendar cdaudio cdb cdda cddb cdparanoia cdr cegui cg cgi chm cjk cli commons-digester console consolekit cpufreq cpulimit cracklib crypt cscope css cups curl curlwrappers custom-optimization cvs cxx dbus dedicated devil dga dirac directfb divx djbfft djvu dmx dns dolby-record-switch dri dtmf dts dv dvb dvd dvdr editor eds emboss emoticon encode enscript evo excel exif expat extraicons faac faad fam fasttrack fax fbcon ffmpeg fftw firefox fits flac flash fltk fluidsynth fmod font-server fontconfig fontforge foomaticdb fortran fping fpx ftp fuse fusion gadu gcj gd gdbm geos ggi gif ginac git glib glitz glut gmedia gmp gmtfull gnokii gnome gnutella gnutls gphoto2 gpm gps graphviz gs gsl gsm gstreamer gtk gzip h323 hal hddtemp html htmlhandbook hwmixer icecast iceweasel iconv icq icu id3 id3tag idn ieee1394 ilbc imagemagick imap imlib inifile irc irda irrlicht jabber jadetex java java5 java6 javascript jbig jce jingle jmx joystick jpeg jpeg2k kde kdrive kpathsea lame latex lcms ldap libcaca libnotify libsamplerate libvisual libwww lirc live lm_sensors log4j logitech-mouse lua lzma lzo mad maildir maps math md5sum meanwhile mikmod mime mjpeg mmap mmkeys mmx mmxext mng modperl modplug modules motif mouse mozdevelop mozilla mp2 mp3 mp4 mp4live mpeg mpeg2 mplayer msn mtp mudflap multicall multilib multislot multitarget musepack music musicbrainz mysql mysqli mythtv nas ncurses net netjack network njb nls nntp nptl nptlonly nsplugin nss nvidia nvtv ode odk offensive ogg openal openexr opengl openmp oscar otr pam pango pch pcntl pcre pda pdf perl php player plotutils png posix postproc ppds pppd profile python qq qt3support qt4 quicktime radio rar raw readline reflection rrdcgi rss rtc ruby samba sametime sasl scanner schroedinger sdl sdl-image sdl-sound sensord session sharedext silc sip slp smp smtp sndfile snmp soap sockets sound speex spell spl sql sqlite sqlite3 sse sse2 sse3 ssl startup-notification stream subtitles subversion suexec svg sysfs syslog sysvipc t1lib tagwriting tcl tcpd test tga theora threads thumbnail thunar tidy tiff timidity tk tokenizer tools transcode translator trayicon truetype tse3 twolame unicode upnp urandom usb userlocales v4l v4l2 vcd vdpau vdr vhosts videos vim-syntax vim-with-x visualization vorbis vorbis-psy vxml wav wavpack webdav wifi wma wmf wxwidgets wxwindows x264 xanim xattr xcb xcomposite xface xforms xft xine xinerama xinetd xml xmlreader xmlrpc xmlwriter xorg xpm xprint xscreensaver xsl xulrunner xv xvid xvmc yaepg yahoo yv12 zeroconf zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_alias authn_dbd authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache dumpio env expires ext_filter file_cache filter headers ident imagemap include info log_config log_forensic logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias substitute" ELIBC="glibc" FOO2ZJS_DEVICES="hpp1006" INPUT_DEVICES="keyboard mouse joystick evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_US en" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_RSYNC_EXTRA_OPTS
Comment 40 Doug Goldstein gentoo-dev 2010-02-12 21:45:35 UTC
This is definitely still occurring on 2.26.2.
Comment 41 Gilles Dartiguelongue gentoo-dev 2010-03-08 23:52:37 UTC
we do not keep open bugs for bugs solved in ~arch. If you want to fix to hit stable, then please fill a stabilization request.
Comment 42 Gilles Dartiguelongue gentoo-dev 2010-04-13 23:11:32 UTC
*** Bug 315125 has been marked as a duplicate of this bug. ***