Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 260474 - New version: xfce-base/xfce-4.6
Summary: New version: xfce-base/xfce-4.6
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: XFCE Team
URL: http://www.xfce.org/about/news?id=21
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-02-27 08:21 UTC by Antonio Quartulli
Modified: 2015-11-25 18:46 UTC (History)
32 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Antonio Quartulli 2009-02-27 08:21:41 UTC
A new version of xfce is available!

Reproducible: Always
Comment 1 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-02-27 20:14:28 UTC
yes, we know. ;)

Main xfce maintainer is on vacation, so hopefully we can get to it soon-ish. I can't wait, myself..
Comment 2 Guillaume Romanczyk 2009-03-04 19:37:28 UTC
(In reply to comment #1)
I'm writing somes ebuilds to install this new version of xfce.
If you want, when I would have a set of ebuilds which could install this version I can post it. (In this case should I open one bug report by ebuild ?)

And if I could give you some help ... I'll be happy ;)
best regards.

Comment 3 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-03-04 19:41:56 UTC
(In reply to comment #2)
> (In reply to comment #1)
> I'm writing somes ebuilds to install this new version of xfce.
> If you want, when I would have a set of ebuilds which could install this
> version I can post it. (In this case should I open one bug report by ebuild ?)
> 
> And if I could give you some help ... I'll be happy ;)
> best regards.
> 

Although we appreciate it, there isn't a strong need for that. Most of the ebuilds just need a name change and moved from the xfce overlay[1] to the tree. But, like I said, the cordination for that needs to wait until angelos gets back from vacation (poor timing!). We are also trying to cordinate some name changes.

[1]: http://git.overlays.gentoo.org/gitweb/?p=proj/xfce.git;a=summary
Comment 4 Lev Panov 2009-03-09 18:51:33 UTC
I have some ebuilds for xfce-4.6 (actually renamed older ones).
You can get them from this overlay: http://github.com/l29ah/booboo/
There are also some tips for layman/paludis in wiki.

> Although we appreciate it, there isn't a strong need for that. Most of the
> ebuilds just need a name change and moved from the xfce overlay[1] to the tree.
> But, like I said, the cordination for that needs to wait until angelos gets
> back from vacation (poor timing!). We are also trying to cordinate some name
> changes.
> 
> [1]: http://git.overlays.gentoo.org/gitweb/?p=proj/xfce.git;a=summary
> 

Comment 5 Chris Hall 2009-03-09 19:59:00 UTC
awesome. thanks alot!

(In reply to comment #4)
> I have some ebuilds for xfce-4.6 (actually renamed older ones).
> You can get them from this overlay: http://github.com/l29ah/booboo/
> There are also some tips for layman/paludis in wiki.
> 
> > Although we appreciate it, there isn't a strong need for that. Most of the
> > ebuilds just need a name change and moved from the xfce overlay[1] to the tree.
> > But, like I said, the cordination for that needs to wait until angelos gets
> > back from vacation (poor timing!). We are also trying to cordinate some name
> > changes.
> > 
> > [1]: http://git.overlays.gentoo.org/gitweb/?p=proj/xfce.git;a=summary
> > 
> 

Comment 6 Christoph Mende (RETIRED) gentoo-dev 2009-03-10 14:14:08 UTC
everything in tree, as Jeremy said, a simple rename of the ebuilds in the overlay would've done it for those who can't wait
Comment 7 Liviu Andronic 2009-03-10 15:07:32 UTC
(In reply to comment #6)
> everything in tree, as Jeremy said, a simple rename of the ebuilds in the
> overlay would've done it for those who can't wait
> 
Xfce4-power-manager is still missing from Portage.
Comment 8 Christoph Mende (RETIRED) gentoo-dev 2009-03-10 15:18:00 UTC
no, it's not: http://sources.gentoo.org/viewcvs.py/gentoo-x86/xfce-extra/xfce4-power-manager/
Comment 9 Pablo Hess 2009-03-13 04:40:45 UTC
The thing is still pretty messy for me (amd64 with all xfce4-4.6.0 ebuilds & friends in package.keywords):

# emerge -vup xfce4

These are the packages that would be merged, in order:

Calculating dependencies -

!!! Invalid or corrupt dependency specification: 

invalid atom: '>=xfce-base/libxfce4util-'

('ebuild', '/', 'xfce-extra/xfce4-mixer-4.6.0', 'merge')

>=dev-libs/glib-2.12:2 >=media-libs/gst-plugins-base-0.10.2 >=x11-libs/gtk+-2.10:2 >=xfce-base/libxfce4util- >=xfce-base/libxfcegui4- >=xfce-base/xfce4-panel- >=xfce-base/xfconf- alsa? ( media-plugins/gst-plugins-alsa ) oss? ( media-plugins/gst-plugins-oss ) dev-util/intltool >=x11-libs/gtk+-2.2 dev-libs/libxml2 x11-libs/startup-notification >=dev-libs/dbh-1.0.20 >=x11-themes/gtk-engines-xfce-2.2.5 dev-util/pkgconfig

This package can not be installed. Please notify the 'xfce-
extra/xfce4-mixer-4.6.0' package maintainer about this problem.
... done!


###########################################
This message:
invalid atom: '>=xfce-base/libxfce4util-'

refers to this RDEPEND line in the ebuild:
>=xfce-base/libxfce4util-${XFCE_VERSION}

Looks like the ebuild lines:
inherit xfce4
xfce4_core

are not actually being executed. I already tried commenting those two lines out and hardcoding the needed variables (e.g. XFCE_VERSION="4.6.0") into the ebuild, but it doesn't seem to work.

Thanks for any suggestion.
###########################################

# emerge --info

Portage 2.1.6.7 (default/linux/amd64/2008.0/desktop, gcc-4.1.2, glibc-2.8_p20080602-r1, 2.6.28.6-efi x86_64)
=================================================================
System uname: Linux-2.6.28.6-efi-x86_64-Intel-R-_Core-TM-2_CPU_T7200_@_2.00GHz-with-glibc2.2.5
Timestamp of tree: Fri, 13 Mar 2009 00:45:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7, 2.1.6-r1
dev-lang/python:     2.4.4-r14, 2.5.2-r7
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.6.2-r1
sys-apps/baselayout: 2.0.0-r2
sys-apps/openrc:     0.4.2
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=nocona -O2 -fomit-frame-pointer -pipe -mfpmath=sse -msse -msse2 -msse3"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=nocona -O2 -fomit-frame-pointer -pipe -mfpmath=sse -msse -msse2 -msse3"
DISTDIR="/distfiles"
FEATURES="ccache distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch userpriv usersandbox"
GENTOO_MIRRORS="ftp://ftp.las.ic.unicamp.br/pub/gentoo/ http://mirror.datapipe.net/gentoo http://www.las.ic.unicamp.br/pub/gentoo/"
LANG="pt_BR.utf8"
LDFLAGS="-Wl,-O1"
LINGUAS="pt_BR"
MAKEOPTS=" -j2 -s "
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp/portage"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage /usr/portage /usr/portage/local/layman/roslin /usr/local/funtoo/portage"
SYNC="rsync://rsync.samerica.gentoo.org/gentoo-portage"
USE="X a52 aac aalib acl acpi additions alsa amd64 applet automount bash-completion battery bluetooth branding bzip2 cairo cdda cdparanoia cdr chroot cli composite cpufreq cracklib crypt css cups d dbus dia dirac divx dri dts dv dvb dvd dvdr dvdread dvdrw dvi emboss encode evo exif fam fbcon ffmpeg firefox flac fortran ftp fuse gcj gdbm gif glib glitz gnome-keyring gnustep gphoto2 gpm gstreamer gtk hal havekernel hddtemp iconv id3tag imagemagick ipw3945 isdnlog jabber java jpeg kde laptop latex libcaca libnotify lua lzma lzo mad md5sum midi mikmod mjpeg mmx mmxext mng mp3 mpeg multilib ncurses nls nptl nptlonly nsplugin objc objc++ offensive ogg opengl openmp pam pcre pdf perl png postscript ppds pppd python qt4 quicktime readline reflection samba sdl session smp spell spl sqlite sqlite3 sse sse2 ssl ssse3 startup-notification svg swat sysfs syslog t1lib tagwriting tcpd theora threads tiff tracker truetype unicode usb utils vcd vim-syntax vorbis webkit wifi wma wmf x264 xattr xcomposite xfce xine xinetd xml xorg xprint xulrunner xv xvid zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="canon fuji samsung" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="pt_BR" USERLAND="GNU" VIDEO_CARDS="intel"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


#############################################
This
Comment 10 Samuli Suominen gentoo-dev 2009-10-04 20:03:15 UTC
emerge --sync
emerge -C xfce4
emerge -av xfce4-meta

?

not entirely sure why the package move doesn't work for you.