Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 260283 - x11-base/xorg-server-1.5.3-r2 should depend on x11-drivers/xf86-video-ati-6.10.0
Summary: x11-base/xorg-server-1.5.3-r2 should depend on x11-drivers/xf86-video-ati-6.10.0
Status: VERIFIED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-02-25 18:41 UTC by Toralf Förster
Modified: 2009-02-26 13:44 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2009-02-25 18:41:41 UTC
if VIDEO_CARDS="ati" is set in /etc/make.conf.


Reproducible: Always




tfoerste@n22 ~ $ emerge --info
Portage 2.1.6.7 (default/linux/x86/2008.0/desktop, gcc-4.1.2, glibc-2.6.1-r0, 2.6.27-gentoo-r9 i686)
=================================================================
System uname: Linux-2.6.27-gentoo-r9-i686-Intel-R-_Pentium-R-_M_processor_1700MHz-with-glibc2.0
Timestamp of tree: Wed, 25 Feb 2009 15:45:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 2.1.6-r1
dev-lang/python:     2.5.2-r7
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=pentium-m -fomit-frame-pointer -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=pentium-m -fomit-frame-pointer -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://mirror.muntinternet.net/pub/gentoo/ http://ftp.snt.utwente.nl/pub/os/linux/gentoo http://gentoo.mneisen.org/ http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/"
LDFLAGS="-Wl,-O1"
LINGUAS="de en"
MAKEOPTS="-j 1"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.de.gentoo.org/gentoo-portage"
USE="X aac acl acpi alsa apache2 berkdb bluetooth branding bzip2 cairo cdda cddb cdr cli cracklib crypt cups dbus dri dvd dvdr dvdread eds emboss encode evo exif fam fastbuild firefox fortran gdbm gif gpm gstreamer gtk hyphenation iconv ipv6 isdnlog java jpeg kde kdeprefix libnotify mad mbox midi mikmod mmap mmx mmxext mp3 mp4 mpeg mudflap mysql ncurses nls nptl nptlonly nsplugin ogg opengl openmp pam pcre pdf perl png ppds pppd python qt3 qt3support qt4 quicktime readline reflection session spl sse sse2 ssl startup-notification svg sysfs tcpd tiff tk truetype unicode usb vorbis win32codecs wmf x86 xml xorg xpm xulrunner xv zlib" ALSA_CARDS="intel8x0" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de en" USERLAND="GNU" VIDEO_CARDS="ati"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Rémi Cardona gentoo-dev 2009-02-25 20:31:46 UTC
VIDEO_CARDS="radeon" already does this.

Thanks
Comment 2 Mart Raudsepp gentoo-dev 2009-02-26 01:09:03 UTC
Note that xf86-video-ati-6.10.0 is mentioned here, while VIDEO_CARDS="radeon" ensures only 6.9.0, not 6.10.0
Comment 3 Rémi Cardona gentoo-dev 2009-02-26 07:19:02 UTC
I know and this is intentional for now. The dep probably won't change in in the server, but will most likely be upped in the xorg-x11 meta.

Thanks
Comment 4 Toralf Förster gentoo-dev 2009-02-26 09:37:22 UTC
I run yesterday evening into this while upgrading xorg from 1.3 to 1.5. Within the file make.conf I had defined "ati" (for years I think) and assumed that this should be ok for 1.5 too. But b/c "ati" doesn't have any effect while "radeon" obviously brought me back my X11 probably I overlooked an ewarn, or ?
Comment 5 Rémi Cardona gentoo-dev 2009-02-26 10:33:08 UTC
I think putting an ewarn/elog message for such little changes is giving too much information. I think most of us devs are using elog too much already.

Sorry you got bit by this, but I don't see the point of changing it back. And portage now has a very nice way of showing which USE flags have changed.

Thanks
Comment 6 Mart Raudsepp gentoo-dev 2009-02-26 13:44:45 UTC
Maybe it's possible to have something like
if use video_cards_ati; then
  ewarn "Your VIDEO_CARDS contains ati but it's called radeon now"
fi

or something similar? And perhaps it'd be a good idea?

Not sure if it works with ati not being in profiles/desc/video_cards.desc anymore -- depends on how package managers do the conversion - if a USE_EXPAND variable is noticed in env, or it filters it based on desc; probably former?