Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 260257 - volume keys events dropped when context menu is open in e.g. Firefox
Summary: volume keys events dropped when context menu is open in e.g. Firefox
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Mozilla Gentoo Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-02-25 15:19 UTC by Florian Streibelt
Modified: 2009-02-25 16:41 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Streibelt 2009-02-25 15:19:44 UTC
My Thinkpad T61 has three extra keys to control the Volume. When I press them gnome handles them correctly and displays a OSD with the volume etc.

But when I open a Submenu like 'File'. 'Edit' etc in an Application like Firefox it seems the keypresses are somehow routed to the Application and not longer handled by gnome.

I personally would consider this a bug because I can't always mute the sound.

In addition when the screensaver locks my display it also disables the keys.
So nobody in the room can switch off my speakers when I forget it before I leave, it would be great if there would be a way to configure this.


Reproducible: Always

Steps to Reproduce:
1. start an application
2. open a menu and leave it open
3. try to change the volume via special keys

Actual Results:  
nothing happens

Expected Results:  
volume changed
Comment 1 Florian Streibelt 2009-02-25 15:22:25 UTC
gnome-desktop is 2.24.3

emerge --info:

Portage 2.1.6.7 (default/linux/amd64/2008.0, gcc-4.3.3, glibc-2.9_p20081201-r2, 2.6.28-gentoo-r2 x86_64)
=================================================================
System uname: Linux-2.6.28-gentoo-r2-x86_64-Intel-R-_Core-TM-2_Duo_CPU_T8300_@_2.40GHz-with-glibc2.2.5
Timestamp of tree: Fri, 20 Feb 2009 08:15:01 +0000
app-shells/bash:     3.2_p48-r1
dev-java/java-config: 1.3.7-r1, 2.1.7
dev-lang/python:     2.4.4-r13, 2.5.4-r2
dev-python/pycrypto: 2.0.1-r6
dev-util/cmake:      2.6.2-r1
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.4.3-r1
sys-apps/sandbox:    1.3.8
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.19.1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.28-r1
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=core2 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch userpriv"
GENTOO_MIRRORS="http://de-mirror.org/distro/gentoo/"
LANG="de_DE.UTF8"
LC_ALL="de_DE.UTF8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en de"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/poverlay"
SYNC="rsync://ftp.spline.de/gentoo-portage"
USE="X acl acpi alsa amd64 avahi bash-completion berkdb bluetooth bzip2 cairo cli cracklib crypt cups dbus dri esd fuse gdbm gif gnome gpm gtk hal iconv iproute2 ipv6 isdnlog jpeg midi mmx mppe-mppc mudflap multilib nautilus ncurses nls nptl nptlonly obex opengl openmp pam pcre perl png pppd python qt3 qt4 readline reflection session spl sse sse2 ssl sysfs tcpd threads tiff truetype unicode vorbis xinerama xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="alias asis auth_basic auth_digest authn_alias authn_anon authn_default authn_file authz_default authz_groupfile authz_host authz_owner authz_user dav dav_fs dav_lock dir env expires headers include info log_config logio mime mime_magic negotiation rewrite setenvif unique_id vhost_alias  autoindex  proxy proxy_http proxy_ajp  status userdir" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse synaptics joystick wacom" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en de" USERLAND="GNU" VIDEO_CARDS="nv svga"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

Comment 2 Gilles Dartiguelongue gentoo-dev 2009-02-25 15:23:14 UTC
those kind of buttons are not handled by gnome itself (or not directly that is) so firefox might get in the way.

Reassigning to mozilla and x11 herds.
Comment 3 Rémi Cardona gentoo-dev 2009-02-25 15:26:14 UTC
Unfortunately, that's not a bug, that's how X11 works. Not much we can do about
it. All the toolkits (gtk, qt, xul, motif, ...) would have to be fixed to allow
what you want and I don't really see that happening as it would likely break
other things.

Sorry
Comment 4 Florian Streibelt 2009-02-25 16:06:57 UTC
(In reply to comment #3)
> Unfortunately, that's not a bug, that's how X11 works. Not much we can do about
> it. All the toolkits (gtk, qt, xul, motif, ...) would have to be fixed to allow
> what you want and I don't really see that happening as it would likely break
> other things.

So whenever any application has some context menu these keys are dropped?
I thought These keys generate events via evdev or acpi?

Also all the additional blue keys like next song, magnifier etc. share this beaviour, but the brightness-keys are handled correctly.

As far as I understand these keys do not neccessarily generate keyboard events.


Comment 5 Rémi Cardona gentoo-dev 2009-02-25 16:41:35 UTC
(In reply to comment #4)
> So whenever any application has some context menu these keys are dropped?
> I thought These keys generate events via evdev or acpi?

They do, but then they are picked up by the X servers, and multimedia apps pick them up using the X protocol.

> Also all the additional blue keys like next song, magnifier etc. share this
> beaviour, but the brightness-keys are handled correctly.
> 
> As far as I understand these keys do not neccessarily generate keyboard events.

Brightness keys might be handled without X being even aware of their existence. It really depends on your hardware...

Thanks