Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 260192 - notifications in Kopete don't work with kdelibs-4.2.0-r3
Summary: notifications in Kopete don't work with kdelibs-4.2.0-r3
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo KDE team
Depends on:
Reported: 2009-02-25 00:21 UTC by Danil Zagoskin
Modified: 2009-04-15 08:02 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Danil Zagoskin 2009-02-25 00:21:12 UTC
After update to kdelibs-4.2.0-r3 Kopete stopped showing massage notifications.
I tried to recompile some KDE and DBUS-related packages but nothing helped.
Tried to switch on more notifications in configuration dialogs, even «log to a file» one, nothing worked.
Finally rolled back to kdelibs-4.2.0-r2 and voila! Notifications are working again.

Reproducible: Always

Steps to Reproduce:
1. Update to kdelibs-4.2.0-r3
Actual Results:  
No notifications are invoked on events like incoming message.

Expected Results:  
pop-up, log entry, etc.
Comment 1 Lamarque V. Souza 2009-03-22 01:52:04 UTC
There is a bug entry upstream about this problem: I made a patch that solves the problem but I do not know if it really is the best solution. Anyway the patch is very simple, two words change.
Comment 2 Tomáš Chvátal (RETIRED) gentoo-dev 2009-04-14 22:50:00 UTC
Hi, it looks nice, but we should wait to somebody from upstream actualy says it is a good approach.
When they do so just apply the patch here as attachment (due to our lazyness :D) or give us commit id for upstream and we will patch our kopete :]
Comment 3 Danil Zagoskin 2009-04-15 08:01:47 UTC
As it works with 4.2.1 and 4.2.2 there is no reason to do anythibg with 4.2.0 bug.