Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 259783 - When suspension resumes, X is frozen and computer reboots.
Summary: When suspension resumes, X is frozen and computer reboots.
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High minor (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-02-21 03:35 UTC by Steven DuBois
Modified: 2009-03-17 10:26 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Steven DuBois 2009-02-21 03:35:22 UTC
When I suspend with s2ram -f -p -m inside of X with the intel driver and I resume, X is frozen and then the computer reboots. It works fine if i use the vesa driver. 

Reproducible: Always

Steps to Reproduce:
1.s2ram -f -p -m with intel driver (I am on a thinkpad r400)
2.resume
3.X is frozen, and computer will reboot in about 1 minute



Expected Results:  
It should have resumed back to X.
Comment 1 Daniel V. 2009-02-21 11:28:17 UTC
I don't know the cause, but i've been getting the same sympthons since xf86-video-intel-2.6.1.

I'm suspending my machine simply by "echo mem > /sys/power/state".

Maybe it's already known upstream?
Comment 2 Steven DuBois 2009-02-21 14:21:26 UTC
(In reply to comment #1)
> I don't know the cause, but i've been getting the same sympthons since
> xf86-video-intel-2.6.1.
> 
> I'm suspending my machine simply by "echo mem > /sys/power/state".
> 
> Maybe it's already known upstream?
> 

I just tried that, and when it resumes. The screen is black and then it reboots.
Comment 3 Steven DuBois 2009-02-21 15:46:15 UTC
FIXED: Upgraded to xf86-video-intel-2.6.1, and it works fine
Comment 4 Steven DuBois 2009-02-24 18:10:32 UTC
It was working fine for a day or so, and now it just stopped working for no apparent reason. Same problem as before.
Comment 5 Rémi Cardona gentoo-dev 2009-02-25 09:11:40 UTC
Hum, there's not much I can do to help you here.

Please read this document : http://intellinuxgraphics.org/how_to_report_bug.html and open a bug on FreeDesktop's bugzilla. Please paste the url here so we can keep track of it.

Thanks
Comment 6 Rémi Cardona gentoo-dev 2009-03-17 10:26:46 UTC
Please get back to us once you've opened a bug in FreeDesktop's bugzilla.

Thanks