Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 259741 - Stabilise =dev-util/cmake-2.6.2-r1
Summary: Stabilise =dev-util/cmake-2.6.2-r1
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on:
Blocks: 245293 250329
  Show dependency tree
 
Reported: 2009-02-20 17:12 UTC by Tomáš Chvátal (RETIRED)
Modified: 2009-03-14 15:38 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Tests ouptut on x86 and amd64 (cmake-tests.txt,5.05 KB, text/plain)
2009-02-20 18:55 UTC, Tomáš Chvátal (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tomáš Chvátal (RETIRED) gentoo-dev 2009-02-20 17:12:13 UTC
Howdy.
Could you please start working on this cmake version stabilisation? ;]
It works much better than current stable and dont have any obvious regressions with comparsion to 2.4 series.

Thankies
Comment 1 Ferris McCormick (RETIRED) gentoo-dev 2009-02-20 18:37:08 UTC
I see one test failure on sparc:

56/ 92 Testing SimpleInstall-Stage2          ***Failed

Is this expected, a show stopper, or what?  The other 91 tests all pass.  Also, I verified that this version of cmake works with media-libs/openal and dev-cpp/gccxml.  (I have been using this version of cmake thus:
Mon Jan  5 20:49:11 2009 >>> dev-util/cmake-2.6.2-r1
but I rebuilt it for this test cycle.  In the wild it does not get much use, unfortunately.)
Comment 2 Tomáš Chvátal (RETIRED) gentoo-dev 2009-02-20 18:42:35 UTC
The cmake-2.6.X is used by every kde4 user, so i hope it is tested a lot :]
about the test suite i am not sure :(
Comment 3 Tomáš Chvátal (RETIRED) gentoo-dev 2009-02-20 18:55:40 UTC
Created attachment 182679 [details]
Tests ouptut on x86 and amd64

That test failiture looks like some sparc issue :((
Comment 4 Ferris McCormick (RETIRED) gentoo-dev 2009-02-20 20:03:39 UTC
I don't see how it can be sparc specific, but it is specific to the system I used for testing.  On other sparc systems, it's fine so there must be something interesting about that one particular configuration. If I run the tests by hand with ARGS="-VV", here's what that test complains about:
===========
 56/ 92 Testing SimpleInstall-Stage2          
Test command: /var/tmp/portage/dev-util/cmake-2.6.2-r1/work/cmake-2.6.2/bin/ctest --build-and-test /var/tmp/portage/dev-util/cmake-2.6.2-r1/work/cmake-2.6.2/Tests/SimpleInstallS2 /var/tmp/portage/dev-util/cmake-2.6.2-r1/work/cmake-2.6.2/Tests/SimpleInstallS2 --build-generator Unix\ Makefiles --build-project TestSimpleInstall --build-makeprogram /usr/bin/gmake --build-two-config --build-options -DCMAKE_INSTALL_PREFIX:PATH=/var/tmp/portage/dev-util/cmake-2.6.2-r1/work/cmake-2.6.2/Tests/SimpleInstall/InstallDirectory -DSTAGE2:BOOL=1 --test-command /var/tmp/portage/dev-util/cmake-2.6.2-r1/work/cmake-2.6.2/Tests/SimpleInstall/InstallDirectory/MyTest/bin/SimpleInstExeS2
Test timeout computed to be: 1500
Internal cmake changing into directory: /var/tmp/portage/dev-util/cmake-2.6.2-r1/work/cmake-2.6.2/Tests/SimpleInstallS2
Error: cmake execution failed
Extra install: 
Stage 1 did run install script 2.
Search for library in: /var/tmp/portage/dev-util/cmake-2.6.2-r1/work/cmake-2.6.2/Tests/SimpleInstall/InstallDirectory/MyTest/lib/static;/var/tmp/portage/dev-util/cmake-2.6.2-r1/work/cmake-2.6.2/Tests/SimpleInstall/InstallDirectory/MyTest/lib
CMake Error at CMakeLists.txt:81 (MESSAGE):
  test1 not found in lib/static!


Configuring
Configuring incomplete, errors occurred!

-- Process completed
***Failed 
========================

I believe that cmake is fine, but I'd like to know what can trigger that failure.
Comment 5 Ferris McCormick (RETIRED) gentoo-dev 2009-02-20 21:08:06 UTC
Hm.  Same failure on that specific sparc system with cmake-2.4.8:
 33/ 67 Testing SimpleInstall-Stage2          ***Failed
so this is not a regression.  But I'd really like to know what that failure means is going wrong (the verbose output displayed above does not mean anything to me, so I can't pursue it to see what is going wrong.)

There is no problem for me on other sparc systems or on amd64 (all system use gcc-4.1.2).  The only interesting thing about the failing SB1000 is that it is an asymmetric multiprocessor (1x900, 1x750) running CPUs with different speeds.
Comment 6 Jeroen Roovers gentoo-dev 2009-02-20 23:26:31 UTC
Stable for HPPA.
Comment 7 Tobias Klausmann gentoo-dev 2009-02-22 15:04:56 UTC
Stable on alpha.
Comment 8 nixnut (RETIRED) gentoo-dev 2009-03-01 14:46:24 UTC
ppc stable
Comment 9 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-03-07 05:06:22 UTC
amd64 stable, all tests passed and chromium built fine.
Comment 10 Markus Meier gentoo-dev 2009-03-08 21:16:44 UTC
x86 stable
Comment 11 Brent Baude (RETIRED) gentoo-dev 2009-03-11 15:19:54 UTC
ppc64 done
Comment 12 Raúl Porcel (RETIRED) gentoo-dev 2009-03-14 15:38:05 UTC
arm/ia64/s390/sh/sparc stable, closing