Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 259680 - CLUCENE crashes creating hs_err.log appear into home
Summary: CLUCENE crashes creating hs_err.log appear into home
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Tomáš Chvátal (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-02-20 08:56 UTC by renato gallo
Modified: 2011-01-12 20:36 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---
tampakrap: Bugday+


Attachments
some of those misterious logs (hs_err_pid.tar.gz,276.12 KB, multipart/application)
2009-02-20 08:57 UTC, renato gallo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description renato gallo 2009-02-20 08:56:20 UTC
what the hell are those ? how can I fix the error those logs signal ?
Comment 1 renato gallo 2009-02-20 08:57:07 UTC
Created attachment 182626 [details]
some of those misterious logs
Comment 2 Serkan Kaba (RETIRED) gentoo-dev 2009-02-20 09:33:06 UTC
they're dumped from java crashes. If you suspect any bugs please file them per package basis.
Comment 3 renato gallo 2009-02-20 09:37:11 UTC
(In reply to comment #2)
> they're dumped from java crashes. If you suspect any bugs please file them per
> package basis.
> 

Comment 4 renato gallo 2009-02-20 09:37:47 UTC
(In reply to comment #3)
> (In reply to comment #2)
> > they're dumped from java crashes. If you suspect any bugs please file them per
> > package basis.
> > 
> 
if someone that knows java can read them and tell me which package is involved I would be glad to

Comment 5 renato gallo 2009-02-20 09:38:30 UTC
emerge --info
Portage 2.1.6.7 (default/linux/amd64/2008.0, gcc-4.3.3, glibc-2.9_p20081201-r2, 2.6.28.6 x86_64)                                                                                          
=================================================================                            
System uname: Linux-2.6.28.6-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q6600_@_2.40GHz-with-glibc2.2.5                                                                                           
Timestamp of tree: Thu, 19 Feb 2009 20:20:01 +0000                                           
app-shells/bash:     3.2_p48-r1                                                              
dev-java/java-config: 1.3.7-r1, 2.1.7                                                        
dev-lang/python:     2.4.4-r13, 2.5.4-r2                                                     
dev-python/pycrypto: 2.0.1-r6                                                                
dev-util/cmake:      2.6.2-r1                                                                
sys-apps/baselayout: 2.0.0                                                                   
sys-apps/openrc:     0.4.3-r1                                                                
sys-apps/sandbox:    1.3.7                                                                   
sys-devel/autoconf:  2.13, 2.63                                                              
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2                               
sys-devel/binutils:  2.19.1                                                                  
sys-devel/gcc-config: 1.4.1                                                                  
sys-devel/libtool:   2.2.6a                                                                  
virtual/os-headers:  2.6.28-r1                                                               
ACCEPT_KEYWORDS="amd64 ~amd64"                                                               
CBUILD="x86_64-pc-linux-gnu"                                                                 
CFLAGS="-march=nocona -O2 -pipe"                                                             
CHOST="x86_64-pc-linux-gnu"                                                                  
CONFIG_PROTECT="/etc /opt/openjms/config /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"                                                              
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"                                                   
CXXFLAGS="-march=nocona -O2 -pipe"                                                           
DISTDIR="/usr/portage/distfiles"                                                             
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"                                                                            
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"                                                                                     
LANG="it_IT.UTF-8"                                                                           
LDFLAGS="-Wl,-O1"                                                                            
LINGUAS="it en"                                                                              
MAKEOPTS="-j5"                                                                               
PKGDIR="/usr/portage/packages"                                                               
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"                                                                                         
PORTAGE_TMPDIR="/var/tmp"                                                                    
PORTDIR="/usr/portage"                                                                       
PORTDIR_OVERLAY="/usr/local/portage/layman/wschlich-testing /usr/local/portage/layman/sunrise"                                                                                            
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"                                        
USE="2dnow 3dnowext 7zip X Xaw3d a52 aac aalib accessibility acl acpi ada addbookmarks akode alias alsa amd64 amr amrb applet aqua_theme ares arts artswrappersuid artworkextra athena autoipd automount autoreplace avahi bash-completion beagle belagle berkdb bidi bl bluetooth bookmarks branding bzip2 cairo carbone_theme cdda cddb cdio cdparanoia cdr chm cisco clamavfontconfig cli connectionstatus contactnotes cpudetection cracklib crypt cscope cups cupsddk curl dbus debug device-mapper dga directfb disk-partition diskio djvu dmx dnd doc dri dts dv dvb dvd dvdr dvi eds elf emacs emacx enca encode eolconv epiphany esd exif expat extensible fam fasttrack fax fbcon fbcondecor ffmpeg filepicker firefox flac fltk foomaticdb fortran freetts freewnn ftp gadu galago gd gdbm gedit ggi gif gimp glib glitz gnokii gnome gnome-keyring gnomecd gnutella gnutls google-gadgets gpg gphoto2 gpm graphwiz groupwise gsf gstreamer gtk gtkhtml guile gz gzip-el hal hdri hesiod hfs highlight history hotplug howl-compat hybrid-auth iceweasel iconv ieee1394 imagemagick imlib inotify inquisitio iproute2 ipv6 irc irda irmc isdnlog jack jadetex jai java java5 javamail javascript jbig jce jingle jmf jms jmx joystick jpeg jpeg2k kde kdrive kerberos ladspa lame laptop latex lcms ldap legacyssl libcaca libffi libnotify libsamplerate lirc live lm_sensors logitech-mouse lua lzma lzo mad mbrola md5sum mdnsresponder-compat mfd-rewrites midi mmap mmx mng mono motif mozdevelop mp2 mp3 mpeg mudflap mule multilib musepack mysql mythtv nas nautilus ncurses neXt nemesi netmeeting network networking networkmanager new-login nls nntp nowlistening npp nptl nptlonly nsplugin odbc odk offensive ogg openal openexr openft opengl openmp opensslcrypt oracle pam passwordsave pch pcre pda pdf perl phonon php pink pkcs11 png pnm pop portage povray ppds pppd pulseaudio python python-bindings q32 q8 qa qt3 qt3support qt4 quicktime radio rar rdesktop readline reflection remote resolvconf rpm rtc ruby ruby-bindings samba sametime sasl savedconfig scanner schedule script sdl seamonkey sendmail session slang slp smp sms smux snmp socks5 sound speex spell spl srt ssesse2 ssl ssse3 startup-notification statistics suid svg swat sysfs syslog t1lib tcl tcpd teletext test tetex texteffect tga theora tiff tk toolkit-scroll-bars tools tracker translator truetype tseng unicode usb v4l v4l2 vcd vim-pager vim-syntax vim-with-x visibility vorbis wavpack webinterface webkit webpresence wifi winpopup wlm wmf x264 xanim xattr xcb xcomposite xemacs xext xface xforms xft xim xine xinerama xinetd xml xorg xscreensaver xulrunner xv xvid xvmc yahoo zeroconf zlib zoran zsh-completion zvbi" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear metermmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions aliasauth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_defaultauthz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="adc65 agfa_cl20 aox barbie canon casio_qv clicksmart310 digigr8digita dimagev dimera3500 directory enigma13 fuji gsmart300 hp215 iclick jamcam jd11 kodak_dc120 kodak_dc210 kodak_dc240 kodak_dc3200 kodak_ez200 konica konica_qm150 largan lg_gsm mars mustek panasonic_coolshot panasonic_dc1000 panasonic_dc1580 panasonic_l859 pccam300 pccam600 polaroid_pdc320 polaroid_pdc640 polaroid_pdc700 ptp2 ricoh ricoh_g3 samsung sierra sipix_blink sipix_blink2 sipix_web2 smal sonix sony_dscf1 sony_dscf55 soundvision spca50x sq905 stv0674stv0680 sx330z template toshiba_pdrm11" DVB_CARDS="tda1004x" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse acecad aiptek digitaledge elographics fpit hyperpen jamstudio joystick magellan mutouch palmax spaceorb summa synaptics tek4957 ur98 vmmouse void wacom" KERNEL="linux"LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="it en" LIRC_DEVICES="mceusb2 mceusb devinput" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 6 Tomáš Chvátal (RETIRED) gentoo-dev 2009-02-21 12:02:42 UTC
Ok i have no clue what java stuff causes this, clucene runs fine on my computer.
Comment 7 Alistair Bush (RETIRED) gentoo-dev 2009-02-21 12:53:26 UTC
(In reply to comment #0)
> what the hell are those ? how can I fix the error those logs signal ?
> 

I wonder whether re-emerging clucene with debug compiler flags would shed some light on this.

Are there any kde bugs similar to this?  Do you have /proc mounted?

Where is java within the dep tree of this?  does strigi or nepomuk depend on java in someway.
Comment 8 renato gallo 2009-02-21 16:41:19 UTC
proc is mounted
clucene has something to do with java


mount
rootfs on / type rootfs (rw)
/dev/sda1 on / type reiserfs (rw,noatime)
proc on /proc type proc (rw,nosuid,nodev,noexec)
rc-svcdir on /lib64/rc/init.d type tmpfs (rw,nosuid,nodev,noexec,size=1024k,mode=755)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec)
udev on /dev type tmpfs (rw,nosuid,size=10240k,mode=755)
devpts on /dev/pts type devpts (rw,nosuid,noexec,gid=5,mode=620)
shm on /dev/shm type tmpfs (rw,nosuid,nodev,noexec)
cachedir on /lib64/splash/cache type tmpfs (rw,size=4096k,mode=644)
usbfs on /proc/bus/usb type usbfs (rw,noexec,nosuid,devmode=0664,devgid=85)
nfsd on /proc/fs/nfsd type nfsd (rw,noexec,nosuid,nodev)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
none on /proc/fs/vmblock/mountPoint type vmblock (rw)





(In reply to comment #7)
> (In reply to comment #0)
> > what the hell are those ? how can I fix the error those logs signal ?
> > 
> 
> I wonder whether re-emerging clucene with debug compiler flags would shed some
> light on this.
> 
> Are there any kde bugs similar to this?  Do you have /proc mounted?
> 
> Where is java within the dep tree of this?  does strigi or nepomuk depend on
> java in someway.
> 

Comment 9 Alistair Bush (RETIRED) gentoo-dev 2009-02-21 20:26:26 UTC
Im hoping this is tracing down where the cause of the issue is.

sesame2 definitely does some jni stuff.  Could clucene be causing the SIGSEGV and java catching and logging it?  Otherwise will need to look into the code more (${PORTAGE_TMP_BLAH}/work/soprano-2.2.1/backends/sesame2)


# equery d clucene
[ Searching for packages depending on clucene... ]
app-misc/strigi-0.6.4 (!clucene & !hyperestraier? >=dev-cpp/clucene-0.9.19[-debug])
                      (clucene? >=dev-cpp/clucene-0.9.19[-debug])                  
dev-libs/soprano-2.2.1 (clucene? dev-cpp/clucene)

# equery d soprano
[ Searching for packages depending on soprano... ]
kde-base/kdelibs-4.2.0-r3 (semantic-desktop? >=dev-libs/soprano-2.1.64)
kde-base/nepomuk-4.2.0 (dev-libs/soprano[clucene])
media-sound/amarok-2.0.1.1 (semantic-desktop? dev-libs/soprano[sesame2])
Comment 10 Alistair Bush (RETIRED) gentoo-dev 2009-02-21 20:27:28 UTC
renato gallo

java-config -L please
Comment 11 renato gallo 2009-02-21 22:06:44 UTC
(In reply to comment #10)
> renato gallo
> 
> java-config -L please
> 

java-config -L
The following VMs are available for generation-2:
1)      Sun JDK 1.5.0.16 [sun-jdk-1.5]
*)      Sun JDK 1.6.0.12 [sun-jdk-1.6]
Comment 12 renato gallo 2009-03-02 05:50:57 UTC
any news ?
(In reply to comment #10)
> renato gallo
> 
> java-config -L please
> 

Comment 13 Serkan Kaba (RETIRED) gentoo-dev 2009-03-03 07:08:02 UTC
The logs hint that soprano bundles a copy of sesame2 (I don't know if that's binary or built from source) which probably needs to be packaged separately.
Comment 14 renato gallo 2009-03-03 07:11:54 UTC
(In reply to comment #13)
> The logs hint that soprano bundles a copy of sesame2 (I don't know if that's
> binary or built from source) which probably needs to be packaged separately.
> 
ebuilds... patches... anyone ?

Comment 15 Alistair Bush (RETIRED) gentoo-dev 2009-03-05 10:09:34 UTC
(In reply to comment #14)
> (In reply to comment #13)
> > The logs hint that soprano bundles a copy of sesame2 (I don't know if that's
> > binary or built from source) which probably needs to be packaged separately.
> > 
> ebuilds... patches... anyone ?
> 

This is rather complex, so it will take a while to solve.  as a workaround please try compiling

dev-libs/soprano with redland use flag enabled.

Does this solve the issue?
Comment 16 Alistair Bush (RETIRED) gentoo-dev 2009-03-08 21:43:31 UTC
Ok I believe I may have found a solution.

Firstly do you have a file /etc/env.d/20java.

If so mv that to some backup location. (aka ~ )  ( note this breaks java generation 1, which isn't such a big deal ).

After this, reboot or otherwise make sure you environment is completely regenerated.

retest
Comment 17 renato gallo 2009-03-09 07:34:25 UTC
compiled soprano with redland. I believe that solved the issue but cannot be certain since those crashes were very random.

(In reply to comment #15)
> (In reply to comment #14)
> > (In reply to comment #13)
> > > The logs hint that soprano bundles a copy of sesame2 (I don't know if that's
> > > binary or built from source) which probably needs to be packaged separately.
> > > 
> > ebuilds... patches... anyone ?
> > 
> 
> This is rather complex, so it will take a while to solve.  as a workaround
> please try compiling
> 
> dev-libs/soprano with redland use flag enabled.
> 
> Does this solve the issue?
> 

Comment 18 Alistair Bush (RETIRED) gentoo-dev 2009-03-09 09:54:16 UTC
Reopening. Lets not close this until we have actually solved the issue.
Comment 19 renato gallo 2009-04-19 16:06:03 UTC
it happens less but it still happens

(In reply to comment #18)
> Reopening. Lets not close this until we have actually solved the issue.
> 

Comment 20 Andreas K. Hüttel gentoo-dev 2010-08-18 20:26:04 UTC
any news here?
Comment 21 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2011-01-05 15:12:20 UTC
with soprano 2.5.2 i wasn't able to switch to sesame2 backend. I tried the following:
s/virtuosobackend/sesame2 in .kde4/share/config/nepomukserverrc (but after restarting nepomuk, it reverted my change
USE="-virtuoso -redland" emerge -av1 soprano
I got the following error:
"Nepomuk Semantic Desktop needs the Virtuoso RDF server to store its data. Installing the Virtuoso Soprano plugin is mandatory for using Nepomuk"
So, does anyone know if redland/sesame2 are officially dead?
Comment 22 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2011-01-05 15:27:28 UTC
Got an answer in #nepomuk-kde
<tampakrap> are sesame2/redland officially dead?
<s-trueg> tampakrap: as backends for Nepomuk: yes
I'll proceed in removing them
Comment 23 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2011-01-05 15:34:24 UTC
actually i have two questions:
1) $(cmake-utils_use !redland SOPRANO_DISABLE_RAPTOR_SERIALIZER)
why not !raptor instead of !redland?
2) what should i do with the stable?
Comment 24 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2011-01-12 20:36:11 UTC
java support removed from >=soprano-2.5.2