Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 259542 - Please stabilize app-text/aspell-0.60.6
Summary: Please stabilize app-text/aspell-0.60.6
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Highest enhancement (vote)
Assignee: Spell checking utilities and dictionaries -- related bugs (OBSOLETE)
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on: 226873
Blocks: gcc-4.3-stable
  Show dependency tree
 
Reported: 2009-02-18 23:56 UTC by Jorge Peixoto de Morais Neto
Modified: 2010-03-18 05:01 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jorge Peixoto de Morais Neto 2009-02-18 23:56:55 UTC
It was added to Portage in 2008-04-27. It has only these three open bugs [1]:
1. #226873, "app-text/aspell: append-ldflags is used to pass libraries"
2. #254883, "app-text/aspell-0.60.6 fails with libtool-1.5(?)"
3. #257769, "app-text/aspell-0.60.6 fails to build on IRIX"
The first bug, #226873, does not mention version and seems to also affect the stable version. The two other bugs seem to be prefix-specific. A search for all bugs (including closed ones) modified since 2009-01-01 shows [2] these three bugs plus two others: #245399, closed 2009-01-10, and #258326, closed on 2009-02-10 as a duplicate of #245399.
Aspell 0.60.6 is included in Debian stable [3].
It seems Debian has patched the package [4], but I have not investigated the patch enough to see which part has bug fixes relevant to Gentoo, which part has bug fixes already included in Gentoo and which part is just Debian-specific.

The aspell changelog lists these enhancements over 0.60.5:

Compile fixes for Gcc 4.3.
Updated to Libtool 2.2.2 and Automake 1.10.1
Minor tweak to suggestion code which improved suggestion results in certain cases.
Always line buffer stdout and stderr in the Aspell utility when there is the potential for it to be used interactively through a pipe.
Removed debug output in aspell munch-list.
Other minor updates and bug fixes.

I don't know how libtool works and don't know the implications of this "Updated to Libtool 2.2.2" bit; my system which is generally stable and has sys-devel/libtool-1.5.26 has built aspell-0.60.6 without errors and aspell has been working fine since I emerged it in 2008-04-28

[1] http://bugs.gentoo.org/buglist.cgi?quicksearch=app-text%2Faspell
[2] http://bugs.gentoo.org/buglist.cgi?query_format=advanced&short_desc_type=allwordssubstr&short_desc=app-text%2Faspell&long_desc_type=substring&long_desc=&bug_file_loc_type=allwordssubstr&bug_file_loc=&status_whiteboard_type=allwordssubstr&status_whiteboard=&keywords_type=allwords&keywords=&bug_status=UNCONFIRMED&bug_status=NEW&bug_status=ASSIGNED&bug_status=REOPENED&bug_status=RESOLVED&bug_status=VERIFIED&bug_status=CLOSED&emailassigned_to1=1&emailtype1=substring&email1=&emailassigned_to2=1&emailreporter2=1&emailcc2=1&emailtype2=substring&email2=&bugidtype=include&bug_id=&votes=&chfieldfrom=2009-01-01&chfieldto=Now&chfieldvalue=&cmdtype=doit&order=Reuse+same+sort+as+last+time&field0-0-0=noop&type0-0-0=noop&value0-0-0=
[3] http://packages.debian.org/stable/text/aspell
[4] http://ftp.de.debian.org/debian/pool/main/a/aspell/aspell_0.60.6-1.diff.gz

And going somewhat off-topic, what is the procedure for filing stabilization bugs? Have I got it right? Should I have added the STABLEREQ keyword instead of leaving it to the developer? And did I do something useful or just annoyed you?
Thank you for your time and contribution


Reproducible: Always

Steps to Reproduce:
Comment 1 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-02-19 01:43:15 UTC
(In reply to comment #0)
> Compile fixes for Gcc 4.3.

This is reason enough to request stabilization. (Because we are trying to get gcc-4.3 stable soon)

> And going somewhat off-topic, what is the procedure for filing stabilization
> bugs? Have I got it right? Should I have added the STABLEREQ keyword instead of
> leaving it to the developer? And did I do something useful or just annoyed you?

Nope, its fine. We just now wait for the maintainer to ACK and add arches.
Comment 2 Ryan Hill (RETIRED) gentoo-dev 2009-03-02 20:33:41 UTC
this is a blocker on major arches.
Comment 3 Ryan Hill (RETIRED) gentoo-dev 2009-03-02 20:40:29 UTC
Please stabilize app-text/aspell-0.60.6 ASAP.  Thanks.
Comment 4 Ferris McCormick (RETIRED) gentoo-dev 2009-03-02 23:02:18 UTC
Sparc stable, it works fine.
Comment 5 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-03-03 06:00:28 UTC
 * Appending a library link instruction (-lgpm); libraries to link to should not be passed through LDFLAGS

amd64 stable
Comment 6 Jeroen Roovers gentoo-dev 2009-03-06 02:28:09 UTC
Stable for HPPA.
Comment 7 Christian Faulhammer (RETIRED) gentoo-dev 2009-03-07 21:04:25 UTC
x86 stable
Comment 8 Tobias Klausmann gentoo-dev 2009-03-08 19:00:22 UTC
Stable on alpha.
Comment 9 Brent Baude (RETIRED) gentoo-dev 2009-03-12 14:23:19 UTC
ppc64 done
Comment 10 Raúl Porcel (RETIRED) gentoo-dev 2009-03-14 20:32:06 UTC
arm/ia64/s390/sh stable
Comment 11 Joe Jezak (RETIRED) gentoo-dev 2009-03-18 07:35:07 UTC
Marked ppc stable.
Comment 12 Peter Volkov (RETIRED) gentoo-dev 2010-03-18 05:01:23 UTC
@m68k, please proceed with bug 310015.