Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 259408 - app-editors/xmlcopyeditor - Could not open catalog: XercesMessages_en_US.cat
Summary: app-editors/xmlcopyeditor - Could not open catalog: XercesMessages_en_US.cat
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Jose Luis Rivero (yoswink) (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-02-17 20:42 UTC by Christof Baur
Modified: 2011-04-14 23:11 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christof Baur 2009-02-17 20:42:50 UTC
After loading a file the xmlcopyeditor will exit sooner or later.
The following message is displayed (shell):

Could not open catalog:
 XercesMessages_en_US.cat
 or XercesMessages_en_US.cat

On my Gentoo system the file located in the directory:
/usr/share/xerces-c/msg




Reproducible: Always

Steps to Reproduce:
1.Open xmlcopyeditor from console
2.Load XML file
3.Perform some action (e.g. typing)

Actual Results:  
Could not open catalog:
 XercesMessages_en_US.cat
 or XercesMessages_en_US.cat


Expected Results:  
no output to the console 

Used strace, but could not find, in which directory xmlcopyeditor tries to find
XercesMessages_en_US.cat

Is this a library problem ?
Comment 1 Jeroen Roovers gentoo-dev 2009-02-18 23:28:16 UTC
Please post your `emerge --info' too.
Comment 2 Christof Baur 2009-02-19 18:19:20 UTC
emerge --info xmlcopyeditor
Portage 2.1.6.7 (default/linux/x86/2008.0, gcc-4.1.2, glibc-2.6.1-r0, 2.6.27-gentoo-r8 i686)
=================================================================
                        System Settings
=================================================================
System uname: Linux-2.6.27-gentoo-r8-i686-AMD_Athlon-tm-_Dual_Core_Processor_5050e-with-glibc2.0
Timestamp of tree: Thu, 19 Feb 2009 17:15:02 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7-r1, 2.1.6-r1
dev-lang/python:     2.4.4-r13, 2.5.2-r7
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.6.2-r1
sys-apps/baselayout: 1.12.12
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=athlon-xp -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=athlon-xp -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://mirror.muntinternet.net/pub/gentoo/ ftp://ftp.snt.utwente.nl/pub/os/linux/gentoo http://mirror.cambrium.nl/pub/os/linux/gentoo/ http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ http://212.219.56.133/sites/www.ibiblio.org/gentoo/"
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="acl alsa berkdb bzip2 cli cracklib crypt cups dri gdbm gpm iconv isdnlog lm_sensors midi mudflap ncurses nls nptl nptlonly opengl openmp pam pcre perl pppd python readline reflection session spl ssl sysfs tcpd unicode x86 xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="fbdev glint i810 intel mach64 mga neomagic nv r128 radeon savage sis tdfx trident vesa vga via vmware voodoo"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================
>>> Attempting to run pkg_info() for 'app-editors/xmlcopyeditor-1.2.0.2-r1'
 * Adjusting permissions for FEATURES=ccache: '/tmp/tmpIiEJO1/ccache'
 * pkg_info() is not defined: 'xmlcopyeditor-1.2.0.2-r1.ebuild'
Comment 3 Christof Baur 2009-02-19 22:07:00 UTC
I also did this:

emerge -v --unmerge xmlcopyeditor
emerge -v --unmerge xerces
emerge -v --unmerge xereces-c

emerge -v xerces-c
emerge -v xmlcopyeditor

==> the problem ist fixed

Comment 4 Jose Luis Rivero (yoswink) (RETIRED) gentoo-dev 2009-02-21 12:06:05 UTC
Hello Cristof:

(In reply to comment #3)
> I also did this:
> 
> emerge -v --unmerge xmlcopyeditor
> emerge -v --unmerge xerces
> emerge -v --unmerge xereces-c
> 
> emerge -v xerces-c
> emerge -v xmlcopyeditor
> 

What xerces-c version do you have now?
Did you unmerge xerces java package and don't back to emerge it?
Did the emege of xerces-c make an upgrade from version -2.* to -3.*? 

> ==> the problem ist fixed

"ist" is not clear enough to me. "ist" means "is now fixed" or means "is NOT now fixed". 

Thanks!
Comment 5 Christof Baur 2009-02-22 11:17:06 UTC
I am sorry for the typo.

xmlcopyeditor is working without any problems, now

Comment 6 Jose Luis Rivero (yoswink) (RETIRED) gentoo-dev 2009-04-26 09:35:01 UTC
I'm closing the bug, feel free to reopen if new info appears.
Comment 7 Wim Muskee 2009-05-09 04:37:17 UTC
(In reply to comment #6)
> I'm closing the bug, feel free to reopen if new info appears.
> 

Got the same error as Christof for:
- xerces-c-3.0.0-r1 curl iconv threads
- xmlcopyeditor-1.2.0.2-r1 guidexml

When compiling xerces-c without iconv support, the error disappeared.
Comment 8 Jose Luis Rivero (yoswink) (RETIRED) gentoo-dev 2009-05-11 14:19:06 UTC
Thanks Wim, verified, if xerces-c is used with iconv USE flag enabled, xmlcopyeditor closes with message: 

   Could not open catalog:
      XercesMessages_en_US.cat
      or XercesMessages_en_US.cat

Reopen the bug.
Comment 9 Sascha Cunz 2009-05-20 22:37:09 UTC
http://xerces.apache.org/xerces-c/samples-3.html states:

    On both Windows and UNIX platforms, if the parser is built with the
    ICU message loader or message catalog loader, then you may need to set
    another environment variable, XERCESC_NLS_HOME, to point to the xerces-
    c-3.0.1/msg directory, which is where the message files reside.

And in fact this is true for iconv, too (i just verified it)

So after emerging xmlcopyeditor + xerces-c[iconv] one has to run env-update && source /etc/profile and all will work fine.
Comment 10 Jose Luis Rivero (yoswink) (RETIRED) gentoo-dev 2009-05-23 14:18:09 UTC
(In reply to comment #9)
> http://xerces.apache.org/xerces-c/samples-3.html states:
> 
>     On both Windows and UNIX platforms, if the parser is built with the
>     ICU message loader or message catalog loader, then you may need to set
>     another environment variable, XERCESC_NLS_HOME, to point to the xerces-
>     c-3.0.1/msg directory, which is where the message files reside.
> 
> And in fact this is true for iconv, too (i just verified it)
> 
> So after emerging xmlcopyeditor + xerces-c[iconv] one has to run env-update &&
> source /etc/profile and all will work fine.
> 

Indeed. Thanks Sascha.

xerces-c installs a env.d/ file which has to be part of environment variables. First time you install it, you need to run the env-update tool in all your open terminals.

If xmlcopyeditor installation brings xerces-c to your system, it will fail the first time you run it.

The problem has to be fixed in xerces-c ebuild, so other applications don't suffer the same. 

I close this as CANTFIX and will fill a bug against xerces-c.

Thanks.