Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 259403 - dev-lang/icc-10.X and dev-lang/ifc-10.X problems with libstdc++.so.5 after sys-libs/libstdc++-v3-3.3.6 recompile
Summary: dev-lang/icc-10.X and dev-lang/ifc-10.X problems with libstdc++.so.5 after sy...
Status: RESOLVED DUPLICATE of bug 304239
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Sébastien Fabbro (RETIRED)
URL:
Whiteboard:
Keywords:
: 262501 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-02-17 20:12 UTC by Diogo Tridapalli
Modified: 2011-06-09 05:39 UTC (History)
10 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
same problem here as OP (ifc only; icc not installed), emerge --info and revdep-rebuild attached (ifc,5.61 KB, text/plain)
2009-02-17 20:38 UTC, Rolf S. Arvidson
Details
same result as previous poster (comment,1.60 KB, text/plain)
2009-09-15 14:31 UTC, Rolf S. Arvidson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Diogo Tridapalli 2009-02-17 20:12:58 UTC
After the recompile the sys-libs/libstdc++-v3-3.3.6 (first line of the Changelog: 
 $Header: /var/cvsroot/gentoo-x86/sys-libs/libstdc++-v3/ChangeLog,v 1.60 2009/02/17 03:28:06 vapier Exp $), some programs of icc and ifc are giving errors like:

 prelink: /usr/lib32/libstdc++.so.5: no version information available (required by prelink)

And the revdep-rebuild keep trying to rebuild this packages:

*   broken /opt/intel/cce/10.1.018/bin/codecov (no version information available)
 *   broken /opt/intel/cce/10.1.018/bin/mcpcom (no version information available)
 *   broken /opt/intel/cce/10.1.018/bin/prelink (no version information available)
 *   broken /opt/intel/cce/10.1.018/bin/profrun.bin (no version information available)
 *   broken /opt/intel/cce/10.1.018/bin/pronto_tool (no version information available)
 *   broken /opt/intel/cce/10.1.018/bin/tselect (no version information available)
 *   broken /opt/intel/fce/10.1.018/bin/codecov (no version information available)
 *   broken /opt/intel/fce/10.1.018/bin/fortcom (no version information available)
 *   broken /opt/intel/fce/10.1.018/bin/profrun.bin (no version information available)
 *   broken /opt/intel/fce/10.1.018/bin/pronto_tool (no version information available)
 *   broken /opt/intel/fce/10.1.018/bin/tselect (no version information available)

The behavior are the same for icc-10.0.026 and ifc-10.0.026-r1.

Reproducible: Always

Steps to Reproduce:
1. # /opt/intel/cce/10.1.018/bin/prelink



Actual Results:  
prelink: /usr/lib32/libstdc++.so.5: no version information available (required by prelink)

Expected Results:  
no error

Portage 2.1.6.4 (default/linux/amd64/2008.0, gcc-4.1.2, glibc-2.8_p20080602-r1, 
2.6.27-gentoo-r8 x86_64)
=================================================================
System uname: Linux-2.6.27-gentoo-r8-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q6600_@_
2.40GHz-with-glibc2.2.5
Timestamp of tree: Tue, 17 Feb 2009 06:00:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 2.1.6-r1
dev-lang/python:     2.5.2-r7
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.4.8
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ABI="amd64"
ACCEPT_KEYWORDS="amd64"
ALSA_CARDS="hda-intel"
ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hoo
ks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate
 route share shm softvol"
ANT_HOME="/usr/share/ant"
ARCH="amd64"
ASFLAGS_x86="--32"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CCACHE_DIR="/var/tmp/ccache/"
CCACHE_SIZE="2G"
CDEFINE_amd64="__x86_64__"
CDEFINE_x86="__i386__"
CFLAGS="-march=nocona -O2 -pipe"
CFLAGS_x86="-m32"
CHOST="x86_64-pc-linux-gnu"
CHOST_amd64="x86_64-pc-linux-gnu"
CHOST_x86="i686-pc-linux-gnu"
CLEAN_DELAY="5"
COLLISION_IGNORE="/lib/modules"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shu
tdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/
fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/
ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/splash /etc/t
erminfo /etc/texmf/web2c /etc/udev/rules.d"
CVS_RSH="ssh"
CXXFLAGS="-march=nocona -O2 -pipe"
DEFAULT_ABI="amd64"
DISPLAY=":0.0"
DISTDIR="/usr/portage/distfiles"
EDITOR="/usr/bin/vim"
ELIBC="glibc"
EMERGE_DEFAULT_OPTS="--verbose"
EMERGE_WARNING_DELAY="10"
FEATURES="ccache distlocks fixpackages parallel-fetch protect-owned sandbox sfpe
rms strict unmerge-orphans userfetch"
FETCHCOMMAND="/usr/bin/wget -t 5 -T 60 --passive-ftp -O "${DISTDIR}/${FILE}" "${
URI}""
GCC_SPECS=""
GDK_USE_XFT="1"
GENERATION="2"
HOME="/root"
INFOPATH="/usr/share/info:/usr/share/binutils-data/x86_64-pc-linux-gnu/2.18/info
:/usr/share/gcc-data/x86_64-pc-linux-gnu/4.1.2/info:/usr/share/info/emacs-22"
INPUT_DEVICES="keyboard mouse evdev"
JAVAC="/etc/java-config-2/current-system-vm/bin/javac"
JAVA_HOME="/etc/java-config-2/current-system-vm"
JDK_HOME="/etc/java-config-2/current-system-vm"
KDEDIRS="/usr:/usr/local:/usr/kde/3.5"
KERNEL="linux"
LDFLAGS="-Wl,-O1"
LDFLAGS_x86="-m elf_i386"
LESS="-R -M --shift 5"
LESSOPEN="|lesspipe.sh %s"
LIBDIR_amd64="lib64"
LIBDIR_ppc="lib32"
LIBDIR_ppc64="lib64"
LIBDIR_sparc32="lib32"
LIBDIR_sparc64="lib64"
LIBDIR_x86="lib32"
LOGNAME="root"
MAKEOPTS="-j5"
MANPATH="/etc/java-config-2/current-system-vm/man:/usr/local/share/man:/usr/shar
e/man:/usr/share/binutils-data/x86_64-pc-linux-gnu/2.18/man:/usr/share/gcc-data/
x86_64-pc-linux-gnu/4.1.2/man:/opt/intel/cce/10.1.018/man:/opt/intel/fce/10.1.01
8/man:/opt/blackdown-jdk-1.4.2.03/man:/etc/java-config/system-vm/man/:/usr/lib64
/php5/man/:/usr/kde/3.5/share/man:/usr/qt/3/doc/man:/opt/vmware/server/man"
MULTILIB_ABIS="amd64 x86"
MULTILIB_STRICT_DENY="64-bit.*shared object"
MULTILIB_STRICT_DIRS="/lib32 /lib /usr/lib32 /usr/lib /usr/kde/*/lib32 /usr/kde/
*/lib /usr/qt/*/lib32 /usr/qt/*/lib /usr/X11R6/lib32 /usr/X11R6/lib"
MULTILIB_STRICT_EXEMPT="(perl5|gcc|gcc-lib|binutils|eclipse-3|debug|portage)"
NETBEANS="apisupport cnd groovy gsf harness ide identity j2ee java mobility nb p
hp profiler soa visualweb webcommon websvccommon xml"
NOCOLOR="true"
OPENGL_PROFILE="nvidia"
PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/opt/bin:/usr
/x86_64-pc-linux-gnu/gcc-bin/4.1.2:/opt/intel/cce/10.1.018/bin:/opt/intel/fce/10
.1.018/bin:/opt/blackdown-jdk-1.4.2.03/bin:/opt/blackdown-jdk-1.4.2.03/jre/bin:/
usr/kde/3.5/sbin:/usr/kde/3.5/bin:/usr/qt/3/bin:/opt/vmware/server/bin"
PKGDIR="/usr/portage/packages"
PKG_CONFIG_PATH="/usr/qt/3/lib64/pkgconfig"
PORTAGE_ARCHLIST="ppc s390 amd64 x86 ppc64 x86-fbsd m68k arm sparc sh mips ia64
alpha hppa sparc-fbsd"
PORTAGE_BINHOST_CHUNKSIZE="3000"
PORTAGE_BIN_PATH="/usr/lib64/portage/bin"
PORTAGE_COMPRESS_EXCLUDE_SUFFIXES="css gif htm[l]? jp[e]?g js pdf png"
PORTAGE_CONFIGROOT="/"
PORTAGE_COUNTER_HASH="f037cb8351105d26754686c45d6c6746"
PORTAGE_DEBUG="0"
PORTAGE_DEPCACHEDIR="/var/cache/edb/dep"
PORTAGE_ELOG_CLASSES="log warn error"
PORTAGE_ELOG_MAILFROM="portage@localhost"
PORTAGE_ELOG_MAILSUBJECT="[portage] ebuild log for ${PACKAGE} on ${HOST}"
PORTAGE_ELOG_MAILURI="root"
PORTAGE_ELOG_SYSTEM="save_summary echo"
PORTAGE_FETCH_CHECKSUM_TRY_MIRRORS="5"
PORTAGE_FETCH_RESUME_MIN_SIZE="350K"
PORTAGE_GID="250"
PORTAGE_INST_GID="0"
PORTAGE_INST_UID="0"
PORTAGE_PYM_PATH="/usr/lib64/portage/pym"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress 
--force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclu
de=/local --exclude=/packages"
PORTAGE_RSYNC_RETRIES="3"
PORTAGE_TMPDIR="/var/tmp"
PORTAGE_VERBOSE="1"
PORTAGE_WORKDIR_MODE="0700"
PORTDIR="/usr/portage"
PRELINK_PATH_MASK="/usr/lib64/klibc"
PROFILE_ONLY_VARIABLES="ARCH ELIBC KERNEL USERLAND"
PWD="/root"
QMAKESPEC="linux-g++"
QTDIR="/usr/qt/3"
RESUMECOMMAND="/usr/bin/wget -c -t 5 -T 60 --passive-ftp -O "${DISTDIR}/${FILE}"
 "${URI}""
ROOT="/"
ROOTPATH="/opt/bin:/usr/x86_64-pc-linux-gnu/gcc-bin/4.1.2:/opt/intel/cce/10.1.01
8/bin:/opt/intel/fce/10.1.018/bin:/opt/blackdown-jdk-1.4.2.03/bin:/opt/blackdown
-jdk-1.4.2.03/jre/bin:/usr/kde/3.5/sbin:/usr/kde/3.5/bin:/usr/qt/3/bin:/opt/vmwa
re/server/bin"
RPMDIR="/usr/portage/rpm"
SANE_CONFIG_DIR="/etc/sane.d"
SHELL="/bin/bash"
SHLVL="1"
STAGE1_USE="multilib nptl nptlonly unicode"
SYMLINK_LIB="yes"
TERM="xterm"
TEXINPUTS="/usr/lib64/ocaml/ocamldoc:"
USB_DEVFS_PATH="/dev/bus/usb"
USE="X a52 aac aalib acl acpi alsa amd64 apache2 apm asf audiofile bash-completi
on berkdb bitmap-fonts bluetooth bzip2 cddb cdparanoia cdr cli cracklib crypt cu
ps dbus dga divx4linux djvu dlloader dri dts dvd dvdr dvdread emacs encode ffmpe
g firefox foomaticdb fortran gdbm gif gimpprint gnome gpm gtk gtk2 hal i8x0 icon
v ieee1394 isdnlog java jpeg jpeg2k latex libcaca lirc live lm_sensors mad midi 
mjpeg mmx mmxext mp3 mpeg mudflap multilib ncurses network nls nptl nptlonly nsp
lugin nvidia ogg openal opengl openmp oss pam pcre pdf pdflib perl pic png ppds 
pppd python qt4 quicktime readline reflection sdl session speex spell spl sse ss
e2 ssl ssse3 svg sysfs tcpd tetex theora tiff truetype truetype-fonts type1-font
s unicode usb vcd videos vim-syntax vorbis wmf x264 xml xorg xprint xulrunner xv
 xvid xvmc zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy d
mix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear me
ter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULE
S="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_def
ault authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner a
uthz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env exp
ires ext_filter file_cache filter headers ident imagemap include info log_config
 logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer prox
y_connect proxy_http rewrite setenvif so speling status unique_id userdir usertr
ack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linu
x" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses
 text" LIRC_DEVICES="asusdh" USERLAND="GNU" VIDEO_CARDS="nvidia"
USER="root"
USERLAND="GNU"
USE_EXPAND="ALSA_CARDS ALSA_PCM_PLUGINS APACHE2_MODULES APACHE2_MPMS CAMERAS CRO
SSCOMPILE_OPTS DVB_CARDS ELIBC FCDSL_CARDS FOO2ZJS_DEVICES FRITZCAPI_CARDS INPUT
_DEVICES KERNEL LCD_DEVICES LINGUAS LIRC_DEVICES MISDN_CARDS NETBEANS_MODULES US
ERLAND VIDEO_CARDS"
USE_EXPAND_HIDDEN="CROSSCOMPILE_OPTS ELIBC KERNEL USERLAND"
USE_ORDER="env:pkg:conf:defaults:pkginternal:env.d"
VIDEO_CARDS="nvidia"
VMHANDLE="blackdown-jdk-1.4.2"
XAUTHORITY="/root/.xauthK9YJIs"
XDG_DATA_DIRS="/usr/share:/usr/kde/3.5/share:/usr/local/share"
XERCESC_NLS_HOME="/usr/share/xerces-c/msg"
_="/usr/bin/emerge"
Comment 1 Rolf S. Arvidson 2009-02-17 20:38:50 UTC
Created attachment 182370 [details]
same problem here as OP (ifc only; icc not installed), emerge --info and revdep-rebuild attached
Comment 2 Nikos Chantziaras 2009-02-19 02:30:37 UTC
Same here on AMD64.

/opt/intel/cce/10.1.018/bin/mcpcom: /usr/lib32/libstdc++.so.5: no version information available (required by /opt/intel/cce/10.1.018/bin/mcpcom)

/opt/intel/cce/10.1.018/bin/tselect: /usr/lib32/libstdc++.so.5: no version information available (required by /opt/intel/cce/10.1.018/bin/tselect)

/opt/intel/cce/10.1.018/bin/pronto_tool: /usr/lib32/libstdc++.so.5: no version information available (required by /opt/intel/cce/10.1.018/bin/pronto_tool)

/opt/intel/cce/10.1.018/bin/prelink: /usr/lib32/libstdc++.so.5: no version information available (required by /opt/intel/cce/10.1.018/bin/prelink)

/opt/intel/cce/10.1.018/bin/profrun.bin: /usr/lib32/libstdc++.so.5: no version information available (required by /opt/intel/cce/10.1.018/bin/profrun.bin)

/opt/intel/cce/10.1.018/bin/codecov: /usr/lib32/libstdc++.so.5: no version information available (required by /opt/intel/cce/10.1.018/bin/codecov)
Comment 3 emerald 2009-02-20 08:50:53 UTC
As a workaround it is possible to use gcc:3.3 as provider for libstdc++-v3 and 
deinstall the (broken) lib.
With gcc:3.3 it's just a few more files, compile time is quite similar i think.
Comment 4 Diogo Tridapalli 2009-02-20 11:25:22 UTC
The workaround works here, thanks emerald, but the bug still not resolved ;-)
Comment 5 Sébastien Fabbro (RETIRED) gentoo-dev 2009-03-16 14:41:19 UTC
*** Bug 262501 has been marked as a duplicate of this bug. ***
Comment 6 Jakob Schiotz 2009-03-26 12:39:41 UTC
If you have app-emulation/emul-linux-x86-compat installed, there is an easy workaround: Just delete the files /usr/lib32/libstdc++.so.5*

icc/icpc/ifc will then use the similar (but working!) files from app-emulation/emul-linux-x86-compat, installed in /usr/lib32/libstdc++-v3/

/Jakob
Comment 7 Alexander Bezrukov 2009-03-26 15:27:29 UTC
Jakob,

thank you for your input, it works at mine.
Comment 8 Rolf S. Arvidson 2009-03-26 21:06:46 UTC
Jakob,
Thanks! - your fix works for me as well.
Cheers 
Comment 9 bugzilla-gentoo 2009-03-29 16:51:44 UTC
After removing libstdc++-v3, adding libstdc++-v3 to the package.provided file and reemerging icc, revdep-rebuild still reports libomp_db.so as broken:

broken /opt/intel/cce/10.0.026/lib/libomp_db.so (requires libstdc++.so.5)

Any ideas?
Comment 10 Jakob Schiotz 2009-03-29 17:57:47 UTC
Do you have app-emulation/emul-linux-x86-compat installed?  You should have the file /usr/lib32/libstdc++-v3/libstdc++.so.5

Probably you also need to run update-env to update the cache.

/Jakob
Comment 11 bugzilla-gentoo 2009-03-29 18:18:07 UTC
I do have emul-linux-x86-compat installed and the library is in place. Unfortunately update-env didn't help. ldd reports the following.

# ldd -v /opt/intel/cce/10.0.026/lib/libomp_db.so 
	linux-vdso.so.1 =>  (0x00007fff9b3ff000)
	libm.so.6 => /lib/libm.so.6 (0x00007f0f92f6a000)
	libstdc++.so.5 => not found
	libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x00007f0f92d5b000)
	libc.so.6 => /lib/libc.so.6 (0x00007f0f92a13000)
	libdl.so.2 => /lib/libdl.so.2 (0x00007f0f9280f000)
	/lib64/ld-linux-x86-64.so.2 (0x00007f0f9332f000)

	Version information:
	/opt/intel/cce/10.0.026/lib/libomp_db.so:
		libgcc_s.so.1 (GCC_3.0) => /lib/libgcc_s.so.1
		libc.so.6 (GLIBC_2.2.5) => /lib/libc.so.6
		libstdc++.so.5 (GLIBCPP_3.2) => not found
		libstdc++.so.5 (CXXABI_1.2) => not found
	/lib/libm.so.6:
		libc.so.6 (GLIBC_2.2.5) => /lib/libc.so.6
	/lib/libgcc_s.so.1:
		libc.so.6 (GLIBC_2.2.5) => /lib/libc.so.6
	/lib/libc.so.6:
		ld-linux-x86-64.so.2 (GLIBC_PRIVATE) => /lib64/ld-linux-x86-64.so.2
		ld-linux-x86-64.so.2 (GLIBC_2.3) => /lib64/ld-linux-x86-64.so.2
	/lib/libdl.so.2:
		ld-linux-x86-64.so.2 (GLIBC_PRIVATE) => /lib64/ld-linux-x86-64.so.2
		libc.so.6 (GLIBC_PRIVATE) => /lib/libc.so.6
		libc.so.6 (GLIBC_2.2.5) => /lib/libc.so.
Comment 12 bugzilla-gentoo 2009-03-29 19:02:09 UTC
The problem is that now since I deinstalled libstdc++-v3, the 64-bit version /usr/lib64/libstdc++.so.5 is missing which is needed by libomp_db.so. Reinstalling libstdc++-v3 fixes this but brings us back to the "no version information available" issue.
Comment 13 Jakob Schiotz 2009-03-29 20:28:49 UTC
Do not uninstall anything, just delete the files /usr/lib32/libstdc++.so.5*

Of course they will come back if the package is upgraded, but hopefully any upgrade fixes this bug anyway :-)

/Jakob

Comment 14 Stephan Friedrichs 2009-09-15 11:59:00 UTC
I don't know if this is related, I came here via bug #262501 (icc always gets rebuilt by revdep-rebuild). I also have the revdep-rebuild problem, but with dev-lang/icc-11.1.046-r3 (no 10.X) on ~amd64:


> reconcilio -p # reconcilio is paludis' revdep-prebuild
Searching for broken packages... 

Broken packages:

* dev-lang/icc-11.1.046-r3:0::installed
    /opt/intel/Compiler/11.1/046/bin/intel64/iidb (requires libDebuggerData.so libDebuggerServices.so libPostOffice.so libScheduler.so libxerces-c.so.27)

Building dependency list: ... 296 steps 

These packages will be installed:

* dev-lang/icc::science [R 11.1.046-r3] <target>
    idb ipp mkl build_options: -optional_tests -trace

Total: 1 package (1 rebuild)

Checking for possible errors......

 * No unread news items found


Executing /opt/intel/Compiler/11.1/046/bin/intel64/prelink works.
Comment 15 Rolf S. Arvidson 2009-09-15 14:31:12 UTC
Created attachment 204197 [details]
same result as previous poster

Also on ~amd64, I now also have same result from dev-lang/icc-11.1.046-r3 as Stephan Friedrichs above (but not using paludis), revdep-rebuild always wants to rebuild icc
Comment 16 Sébastien Fabbro (RETIRED) gentoo-dev 2009-10-09 01:58:24 UTC
The problem seems to be gone on my boxes after updates to icc and ifc 11.1.056 and with a re-emerge of libstdc++-v3. Could someone confirm this?
Comment 17 Rolf S. Arvidson 2009-10-09 07:45:52 UTC
(In reply to comment #16)
> The problem seems to be gone on my boxes after updates to icc and ifc 11.1.056
> and with a re-emerge of libstdc++-v3. Could someone confirm this?
> 

I can confirm on my system that this bug is fixed with icc and ifc 11.1.056
Comment 18 Stephan Friedrichs 2009-10-09 10:39:52 UTC
(In reply to comment #16)
> The problem seems to be gone on my boxes after updates to icc and ifc 11.1.056
> and with a re-emerge of libstdc++-v3. Could someone confirm this?
> 

That doesn't fix the problem for me (on ~amd64).
Comment 19 Diogo Tridapalli 2009-10-14 22:04:50 UTC
(In reply to comment #16)
> The problem seems to be gone on my boxes after updates to icc and ifc 11.1.056
> and with a re-emerge of libstdc++-v3. Could someone confirm this?
> 

Look to be gone here too!
Comment 20 AstroFloyd 2009-10-22 20:57:39 UTC
> (In reply to comment #16)
> > The problem seems to be gone on my boxes after updates to icc and ifc 11.1.056
> > and with a re-emerge of libstdc++-v3. Could someone confirm this?
> That doesn't fix the problem for me (on ~amd64).

It doesn't fix it for me either.  I'm on amd64 (w/o ~, except for some packages like ifc,icc).  When I use USE=idb and emerge ifc and icc, everything works.  However, revdep-rebuild will remerge either ifc or icc (whichever I emerged first, and only once - it won't keep doing it every time I run revdep-rebuild) and this breaks things (many files disappear, e.g. causing ld not to find -limf).

The problem in my case seems to be the combination of ifc and icc, with the idb USE flag enabled.  I actually have to *actively* disable it for icc (USE=-idb, I don't quite understand where the automatic support for idb comes from, it's not there for ifc).  Anyway, ifc and icc seem to provide the same files in the same directories and that may well be the culprit here.

After USEing -idb for both icc and ifc (+idb *only* on icc gives the same problem),
# emerge -C ifc icc && emerge ifc icc 
did the trick for me.
Comment 21 Sébastien Fabbro (RETIRED) gentoo-dev 2009-10-23 21:04:03 UTC
(In reply to comment #20)

> However, revdep-rebuild will remerge either ifc or icc (whichever I emerged
> first, and only once - it won't keep doing it every time I run revdep-rebuild)
> and this breaks things (many files disappear, e.g. causing ld not to find
> -limf).

Yes, there are problems with the current 11.1.056 icc and idb ebuilds, such that re-emerging them will dismiss some required libraries (removing the rpm parts). The only way I found is to split the core common libraries for icc and ifc into new ebuilds. I'm trying to see with upstream if we are allowed to re-distribute the devlibs rpm at least.
 
Comment 22 Horst Prote 2010-10-08 11:54:20 UTC
(In reply to comment #4)
> The workaround works here, thanks emerald, but the bug still not resolved ;-)

For the "/usr/lib32/libstdc++.so.5: no version information available" part of this bug please see bug 335733.
Comment 23 Vadik 2010-11-12 15:34:04 UTC
(In reply to comment #21)

There are also problems with the 11.1.072 icc and ifc ebuilds.
Comment 24 Justin Lecher gentoo-dev 2010-11-12 17:01:25 UTC
(In reply to comment #23)
> (In reply to comment #21)
> 
> There are also problems with the 11.1.072 icc and ifc ebuilds.
> 

comments like this doesn't help much. What is wrong and how could it be fixed?
Comment 25 Justin Lecher gentoo-dev 2011-05-25 08:16:32 UTC
Please test new version in sci overlay
Comment 26 Nikos Chantziaras 2011-05-25 10:00:06 UTC
(In reply to comment #25)
> Please test new version in sci overlay

Would it be possible to remove packages from the overlay that are already in portage? I added the overlay to test icc, but I'm getting a conflict with openmpi. Or is this intended somehow?
Comment 27 Justin Lecher gentoo-dev 2011-05-25 11:42:33 UTC
No we can't. The versions in the overlay are the same version numbers, but the implementation in the ebuild differs.
Comment 28 Nikos Chantziaras 2011-05-25 12:33:35 UTC
Shouldn't the changes be put in portage?
Comment 29 Justin Lecher gentoo-dev 2011-05-25 12:40:16 UTC
Everything is new. Completely new scheme and an additional eclass. Lets test it a little and then it will be moved.
Comment 30 Nikos Chantziaras 2011-05-27 17:50:15 UTC
Finally found some time to try this out. Unfortunately, emerging abort with a sandbox access violation:

 * Tagging intel-common
ACCESS DENIED  mkdir:        /opt/intel
mkdir: cannot create directory `/opt/intel': Permission denied

VERSION 1.0
FORMAT: F - Function called
FORMAT: S - Access Status
FORMAT: P - Path as passed to function
FORMAT: A - Absolute Path (not canonical)
FORMAT: R - Canonical Path
FORMAT: C - Command Line

F: mkdir
S: deny
P: intel
A: /opt/intel
R: /opt/intel
C: mkdir -p /opt/intel composerxe-2011.2.137/licenses
Comment 31 Justin Lecher gentoo-dev 2011-05-28 07:32:33 UTC
Please at the complete build.log
Comment 32 Justin Lecher gentoo-dev 2011-05-28 07:49:59 UTC
My fault, it is fixed now.
Comment 33 Nikos Chantziaras 2011-05-28 09:12:22 UTC
Thanks. It emerged fine now. I've successfully built my projects with it, and everything runs fine. Some (probably naive) benchmarking reveals that this compiler is still ahead of GCC in producing faster binaries.

Btw, there's now a newer version available (2011 update2).
Comment 34 SpanKY gentoo-dev 2011-06-09 05:39:31 UTC

*** This bug has been marked as a duplicate of bug 304239 ***