Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 258724 - sys-devel/gcc-4.3.3 (-DFORTIFY_SOURCE=2) fails to build sys-devel/gcc-3.3.6-r1 - /usr/include/bits/fcntl2.h:51: error: call to '__open_missing_mode' declared with attribute error: open with O_CREAT in second argument needs 3 arguments
Summary: sys-devel/gcc-4.3.3 (-DFORTIFY_SOURCE=2) fails to build sys-devel/gcc-3.3.6-r...
Status: RESOLVED DUPLICATE of bug 256638
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-02-12 12:53 UTC by Vincent Le Ligeour
Modified: 2009-02-17 22:00 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vincent Le Ligeour 2009-02-12 12:53:07 UTC
sys-devel/gcc-3.3.6-r1 failed to build with newer gcc (probably because of the -DFORTIFY_SOURCE=2 flag)

Error is:
/usr/include/bits/fcntl2.h:51: error: call to '__open_missing_mode' declared with attribute error: open with O_CREAT in second argument needs 3 arguments

Reproducible: Always
Comment 1 Marijn Schouten (RETIRED) gentoo-dev 2009-02-12 13:21:59 UTC
Try gcc-3.4.6-r2
Comment 2 Vincent Le Ligeour 2009-02-12 15:22:59 UTC
sys-devel/gcc-3.4.6-r2 fails the same way (warning I tried to install dev-db/oracle-instantclient-basic-10.2.0.3-r1 that depend on sys-devel/gcc-3.3*)
Comment 3 Jeroen Roovers (RETIRED) gentoo-dev 2009-02-12 17:38:47 UTC
Please post your `emerge --info' in a comment and attach the entire build log.
Comment 4 Peter Alfredsen (RETIRED) gentoo-dev 2009-02-12 22:31:05 UTC

*** This bug has been marked as a duplicate of bug 256638 ***