Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 258448 - version bump for nVidia drivers 180.29
Summary: version bump for nVidia drivers 180.29
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Ricardo Mendoza (RETIRED)
URL: ftp://download.nvidia.com/XFree86/Lin...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-02-10 14:30 UTC by Sumit Khanna
Modified: 2009-03-10 22:57 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sumit Khanna 2009-02-10 14:30:30 UTC
nVidia just released the 180.29 drivers last night. This drive should fix a couple of the VDPAU issues. 

Reproducible: Always
Comment 1 Jose daLuz 2009-02-11 03:48:02 UTC
Renaming the 180.27 ebuild to 180.29 works. No issues with the driver itself so far.
Comment 2 Sumit Khanna 2009-02-11 16:10:13 UTC
I renamed the ebuild to 180.29 last night and put it in my local overlay, emerged it and reloaded the module/restarted X. It seems to work fine with no stability issues on ~amd64 so far.
Comment 3 Fred Krogh 2009-02-12 05:33:26 UTC
It fails to start X for me on an Opteron system.  I'm using gdm-2.20.9.  The last nvidia-drivers that works for me is 177.82.  I have heard that gdm-2.24? works, but is is not yet in portage using amd~.

============ emerge --info ====================

Portage 2.1.6.7 (default/linux/amd64/2008.0, gcc-4.3.3, glibc-2.9_p20081201-r1, 2.6.28-gentoo-r1 x86_64)
=================================================================
System uname: Linux-2.6.28-gentoo-r1-x86_64-AMD_Opteron-tm-_Processor_242-with-glibc2.2.5
Timestamp of tree: Thu, 12 Feb 2009 00:10:01 +0000
app-shells/bash:     3.2_p48-r1
dev-java/java-config: 1.3.7-r1, 2.1.7
dev-lang/python:     2.5.4-r2
dev-util/cmake:      2.6.2-r1
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.4.3
sys-apps/sandbox:    1.3.6
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.7.9-r1, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.19.1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.28-r1
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=opteron -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=opteron -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sfperms strict unmerge-orphans"
GENTOO_MIRRORS="http://gentoo.osuosl.org http://ftp.ucsb.edu/pub/mirrors/linux/gentoo  http://cudlug.cudenver.edu/gentoo http://gentoo.binarycompass.org"
LANG="en_us"
LC_ALL="C"
LDFLAGS="-Wl,-O1"
LINGUAS="en"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac acl administrator aiglx alsa amd64 apache2 auctex audiofile bash-completion bcmath berkdb blas bonobo bzip2 cairo calendar cdrom clamav clamd cli clisp colordiff cracklib crypt ctype cups dbus debugger deprecated dga discouraged divx-linux dri dvd dvdr dvdread emacs emul-linux86 esd fam fastcgi fbcon ffmpeg flac fortran ftp gd gdbm glut gmail gnome gnome-keyring gphoto2 gpm gstreamer gtk hal iconv imagemagick ipv6 isdnlog java javascript jpeg kerberos kpathsea latex latin1 leim lesstif libclamav libnotify libwww logrotate mad maildir mbox mcal midi mime mmx mmxext mng mouse mozcalendar mozilla mpeg2 mpi mudflap multilib mysql mysqli nat ncurses nls nocd nosendmail nptl nptlonly nsplugin nvidia objc offensive ogg opengl openmp osc oscar pam pcre pdf perl png policykit pop pop3d portaudio posix ppds pppd preview-latex python query-browser readline reflection regex replytolist rtc samba sasl session sharedmem sockets sound source sox speex spl sse sse2 ssl svg symlink sysfs tcltk tcpd tetex thunderbird truetype unicode vhosts vorbis wxwindows xcomposite xine xmail xorg xulrunner xvid" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" USERLAND="GNU" VIDEO_CARDS="nvidia vesa fbdev"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 4 Fred Krogh 2009-02-16 22:54:15 UTC
I just tried gdm-2.20.9-r1 with nvidia-drivers-180.29, and X still fails to start for me.
Comment 5 Doug Goldstein gentoo-dev 2009-03-08 18:02:00 UTC
Already in the tree.
Comment 6 Fred Krogh 2009-03-10 19:23:24 UTC
(In reply to comment #5)
> Already in the tree.
> 

I am puzzled.  What is in the tree and what tree are we talking about?
If there is something later than gdm-2.20.9-r1, I'd be happy to try it.  Likewise for nvidia-drivers after 180.35.  Neither is showing up for me on recent synchs.
Comment 7 Ricardo Mendoza (RETIRED) gentoo-dev 2009-03-10 19:32:02 UTC
180.37 is now in the tree thanks to Cardoe. If stuff keeps breaking for you then do a separate bug report and attach the logs.
Comment 8 Fred Krogh 2009-03-10 19:37:25 UTC
(In reply to comment #7)
> 180.37 is now in the tree thanks to Cardoe. If stuff keeps breaking for you
> then do a separate bug report and attach the logs.
>
This didn't show up for me when I synced yesterday.  When it does, I'll give it a try and report the results.  I suspect the problem is in gdm because of this message when I try to start x.

** Message: Could not connect to session manager: Could not get owner of name 'org.gnome.SessionManager': no such name

But perhaps that is just noise?

Comment 9 Doug Goldstein gentoo-dev 2009-03-10 20:03:55 UTC
Totally outside the scope of this bug... but you've installed ConsoleKit, which gdm will attempt to use but did not follow the instructions after installing ConsoleKit to add it to your default runlevel with:

rc-update add consolekit default

The following will work to remedy the situation for your current boot after running the above:

/etc/init.d/consolekit start && /etc/init.d/xdm restart

Then logging back in as your user in GDM.

But again.. this is all outside of the scope of bumping nvidia-drivers-180.29
Comment 10 Fred Krogh 2009-03-10 22:06:25 UTC
My problems have disappeared with 180.37.  Thanks for the help.