Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 258403 - Unable to compile x11-base/xorg-server-1.5.3-r2 on amd64
Summary: Unable to compile x11-base/xorg-server-1.5.3-r2 on amd64
Status: VERIFIED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High major (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-02-10 05:04 UTC by Mishael Sibiryakov
Modified: 2009-02-11 11:50 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mishael Sibiryakov 2009-02-10 05:04:34 UTC
compilation fail with:

linuxPci.c:288: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'static'
linuxPci.c: In function 'linuxOpenLegacy':
linuxPci.c:471: warning: implicit declaration of function 'get_parent_bridge'
linuxPci.c:471: warning: nested extern declaration of 'get_parent_bridge'
linuxPci.c:471: warning: assignment makes pointer from integer without a cast
linuxPci.c: In function 'xf86MapLegacyIO':
linuxPci.c:529: warning: initialization makes pointer from integer without a cast
linuxPci.c:544: warning: cast to pointer from integer of different size
linuxPci.c: At top level:
linuxPci.c:553: warning: no previous prototype for 'xf86AccResFromOS'
make[5]: *** [linuxPci.lo] Error 1
make[5]: Leaving directory `/var/tmp/portage/x11-base/xorg-server-1.5.3-r2/work/xorg-server-1.5.3/hw/xfree86/os-support/bus'
make[4]: *** [all-recursive] Error 1
make[4]: Leaving directory `/var/tmp/portage/x11-base/xorg-server-1.5.3-r2/work/xorg-server-1.5.3/hw/xfree86/os-support'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/var/tmp/portage/x11-base/xorg-server-1.5.3-r2/work/xorg-server-1.5.3/hw/xfree86'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/var/tmp/portage/x11-base/xorg-server-1.5.3-r2/work/xorg-server-1.5.3/hw/xfree86'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/x11-base/xorg-server-1.5.3-r2/work/xorg-server-1.5.3/hw'
make: *** [all-recursive] Error 1



Reproducible: Always

Steps to Reproduce:




Portage 2.1.6.7 (default/linux/amd64/2008.0/desktop, gcc-4.1.2, glibc-2.9_p20081201-r1, 2.6.27-gentoo-r7 x86_64)
=================================================================
System uname: Linux-2.6.27-gentoo-r7-x86_64-Intel-R-_Core-TM-2_Duo_CPU_T9500_@_2.60GHz-with-glibc2.2.5
Timestamp of tree: Mon, 09 Feb 2009 21:30:01 +0000
app-shells/bash:     3.2_p48-r1
dev-java/java-config: 1.3.7-r1, 2.1.7
dev-lang/python:     2.4.4-r6, 2.5.4-r2
dev-python/pycrypto: 2.0.1-r6
dev-util/cmake:      2.6.2
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.4.2
sys-apps/sandbox:    1.3.5
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.19.1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.28-r1
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=nocona"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -pipe -march=nocona"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/desktop-effects /usr/local/portage/layman/java-overlay"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X accessability acl acpi alsa amd64 apache2 audiofile avahi avi berkdb bluetooth branding bzip2 cairo cdr cgi cli cracklib crypt ctags ctype cups cxx dba dbus dga dri dts dvd dvdr dvdread eds emboss encode evo fam firefox flac gd gdbm gif glitz gnome gnome-games gpm gstreamer gtk guile hal iconv ipv6 isdnlog jpeg kde ldap libnotify mad matroska midi mikmod mmx mozdevelop mp3 mpeg mudflap multilib multitarget ncurses nls nptl nptlonly nsplugin ogg opengl pam pcre pda pdf perl png ppds pppd python qt qt3 qt3support qt4 quicktime readline reflection samba sdl session slang spell spl sse sse2 sse3 ssl ssp startup-notification svg sysfs tcpd threads tiff truetype unicode usb vorbis xcb xml xorg xprint xulrunner xv zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="fbdev glint i810 intel mach64 mga neomagic nv r128 radeon savage sis tdfx trident vesa vga via vmware voodoo"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Mishael Sibiryakov 2009-02-10 05:12:49 UTC
Looks like problem in the headers:

/usr/include/linux # grep -rnw pci_device *
/usr/include/linux # 

Compilation fail on:

static struct pci_device *                    <--- HERE
get_parent_bridge(struct pci_device *dev)

Is this is my personal problem or not ?
Comment 2 Mishael Sibiryakov 2009-02-10 05:17:51 UTC
Latest versions of the linux-headers and current version.


     Mon Jun  9 15:17:53 2008 >>> sys-kernel/linux-headers-2.6.25-r4
       merge time: 9 seconds.

     Thu Aug 21 03:12:54 2008 >>> sys-kernel/linux-headers-2.6.26
       merge time: 14 seconds.

     Mon Oct 27 02:35:37 2008 >>> sys-kernel/linux-headers-2.6.27-r1
       merge time: 19 seconds.

     Mon Oct 27 09:33:58 2008 >>> sys-kernel/linux-headers-2.6.27-r2
       merge time: 13 seconds.

     Sun Dec 28 02:53:38 2008 >>> sys-kernel/linux-headers-2.6.28
       merge time: 26 seconds.

     Tue Dec 30 00:34:21 2008 >>> sys-kernel/linux-headers-2.6.28-r1
       merge time: 15 seconds.
Comment 3 Shunichi Fuji 2009-02-10 09:16:58 UTC
Do you have x11-libs/libpciaccess?
`struct pci_device` is defined in /usr/include/pciaccess.h.
Comment 4 Mishael Sibiryakov 2009-02-10 09:24:26 UTC
Yep, x11-libs/libpciaccess-0.10.5

And previous version of xorg-server are installed without any problems.

Sat Jan 17 11:45:06 2009 >>> x11-base/xorg-server-1.5.3-r1

I can send you complete list of installed/updated packages between previous versions of the xorg-server and current state.
Comment 5 Shunichi Fuji 2009-02-10 11:49:46 UTC
Hmm ...
Difference between xorg-server-1.5.3 -r1 and -r2 is very small (patch 57 to 60),
and it looks not contained changes around for linuxPci.c.

Are you still able to build -r1 with current machine state?
Comment 6 Mishael Sibiryakov 2009-02-10 12:21:51 UTC
Aha, i reviewed patchset and changes between ebuilds too. And found nothing about linuxPci or something else around.

x11-base/xorg-server-1.5.3-r1 merged successfully.

I can compare extracted and patched sources from r1 and r2. I can't invent something else at this moment. Need this ?
Comment 7 Mishael Sibiryakov 2009-02-11 03:34:37 UTC
    Wow, after another sync it merged successfully.

    Timestamp of tree: Tue, 10 Feb 2009 20:10:01 +0000

         Tue Feb 10 15:16:11 2009 >>> x11-base/xorg-server-1.5.3-r1 <-- Yesterday
    test
         Wed Feb 11 00:37:04 2009 >>> media-libs/openjpeg-1.3-r2
         Wed Feb 11 00:37:42 2009 >>> sys-apps/util-linux-2.14.2
         Wed Feb 11 00:38:01 2009 >>> sys-apps/grep-2.5.4
         Wed Feb 11 00:38:10 2009 >>> perl-core/PodParser-1.38
         Wed Feb 11 00:38:36 2009 >>> app-text/iso-codes-3.6
         Wed Feb 11 00:38:51 2009 >>> x11-apps/xinit-1.0.8-r4
         Wed Feb 11 00:42:51 2009 >>> x11-base/xorg-server-1.5.3-r2 <-- Success
Comment 8 Rémi Cardona gentoo-dev 2009-02-11 08:19:56 UTC
Not really a bug then :)

Thanks for the follow up.
Comment 9 Mishael Sibiryakov 2009-02-11 11:50:45 UTC
Ok :)