Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 258344 - mark media-gfx/gimp-2.6.4 stable?
Summary: mark media-gfx/gimp-2.6.4 stable?
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Hanno Böck
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on: 246816 260063
Blocks:
  Show dependency tree
 
Reported: 2009-02-09 17:11 UTC by Peter Alfredsen (RETIRED)
Modified: 2009-08-14 20:00 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Alfredsen (RETIRED) gentoo-dev 2009-02-09 17:11:24 UTC
It's been working for me, the post-2.6 annoyances I noticed have been smoothed out. Time for another stable?
Comment 1 Hanno Böck gentoo-dev 2009-02-09 17:20:43 UTC
I'm fine with it. Archs please go ahead
Comment 2 Tobias Klausmann gentoo-dev 2009-02-09 20:02:38 UTC
Sorry, but this pulls in a rather big lot of dependencies for stabilization:

dev-util/intltool-0.40.5 (which I've tested & stabilized)
dev-libs/glib-2.18.1 (ditto)

Plus those:
>=media-libs/gegl-0.0.22
 >=x11-libs/gtk+-2.14.0 
 >=media-libs/babl-0.0.20
net-libs/webkit-gtk

Please check with the mainatiners of those (especially gtk+) if all of them should be stabilized. I'd rather not annoy them just to stabilize gimp.
Comment 3 Peter Alfredsen (RETIRED) gentoo-dev 2009-02-09 20:52:26 UTC
Hanno is babl and gegl, so assuming he's good with stabbing those. Now we just need to wait for gtk+, glib and webkit-gtk. *sigh* :-)
Comment 4 Tobias Klausmann gentoo-dev 2009-03-11 21:50:10 UTC
Stabilized babl and webkit, Now just gegl and the stuff from bug 260063 (which I added as a dep since 253934 has been called a dupe of that) is what keeps gimp form stabling. Since gegl depends on >=dev-libs/glib-2.18.0 and >=x11-libs/gtk+-2.14.0, it'll have to wait.
Comment 5 Markus Meier gentoo-dev 2009-03-20 23:35:52 UTC
amd64/x86 stable
Comment 6 Tobias Klausmann gentoo-dev 2009-03-22 16:36:39 UTC
Stable on alpha.
Comment 7 Raúl Porcel (RETIRED) gentoo-dev 2009-03-31 14:17:26 UTC
ia64/sparc stable
Comment 8 Brent Baude (RETIRED) gentoo-dev 2009-04-06 14:15:04 UTC
ppc done
Comment 9 Jeroen Roovers (RETIRED) gentoo-dev 2009-07-07 14:10:31 UTC
I went for 2.6.6 instead.
Comment 10 Gilles Dartiguelongue gentoo-dev 2009-08-14 11:54:16 UTC
all arches done, I guess this can be closed ?
Comment 11 Hanno Böck gentoo-dev 2009-08-14 20:00:59 UTC
done