Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 258269 - Please stabilise net-misc/openvpn-2.1_rc15 ?
Summary: Please stabilise net-misc/openvpn-2.1_rc15 ?
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Cédric Krier
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on:
Blocks: glibc-2.8-stable
  Show dependency tree
 
Reported: 2009-02-09 01:43 UTC by Christian Faulhammer (RETIRED)
Modified: 2009-07-09 10:09 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Faulhammer (RETIRED) gentoo-dev 2009-02-09 01:43:05 UTC
This is for Glibc 2.8 stabilisation...I am not sure if a RC should be stabilised.
Comment 1 Cédric Krier gentoo-dev 2009-02-11 19:08:37 UTC
I prefer to not stabilize 2.1* version because upstream consider it as a beta version for testing.
Comment 2 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-02-12 02:19:51 UTC
Ok, then this should be masked because it won't compile in the stable tree after bug 247553 is done. just fyi.
Comment 3 Raúl Porcel (RETIRED) gentoo-dev 2009-03-07 11:19:26 UTC
(In reply to comment #1)
> I prefer to not stabilize 2.1* version because upstream consider it as a beta
> version for testing.
> 

Debian are using rc's on lenny.
Comment 4 dongxu li 2009-03-27 00:09:21 UTC
the gentoo stable version 2.0.7-r2 fails for me for no apparent reason.

tcpdump -i tun0 shows proper traffics, but I couldn't use any service over vpn.

the the same configuration simply works with 2.1_rc15.

hope stablizing 2.1* would save more time for other users
Comment 5 Cédric Krier gentoo-dev 2009-03-27 00:27:34 UTC
Is 2.0.9 works for you?
Comment 6 CPUShare 2009-07-07 14:27:14 UTC
to me it looks like PEER_DNS in /etc/conf.d/openvpn is ignored because that file isn't sourced at the top of /etc/openvpn/{up,down}.sh
Comment 7 Christian Faulhammer (RETIRED) gentoo-dev 2009-07-09 10:09:25 UTC
Not needed for Glibc 2.8 anymore.