Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 257909 - media-video/vlc-0.9.8a - configure: error: Could not find freetype (required for skins2)
Summary: media-video/vlc-0.9.8a - configure: error: Could not find freetype (required ...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
Depends on:
Reported: 2009-02-06 17:03 UTC by Stephan
Modified: 2009-06-23 23:01 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

config.log (config.log,383.34 KB, text/plain)
2009-06-23 22:04 UTC, Shane Williams

Note You need to log in before you can comment on or make changes to this bug.
Description Stephan 2009-02-06 17:03:33 UTC
I can't find a place to attach files in here and I don't want to copy and paste /var/tmp/portage/media-video/vlc-0.9.8a/work/vlc-0.9.8a/config.log because it is quite large.

Problem is that vlc can't find freetype although it is installed on my system:

emerge -av freetype

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] media-libs/freetype-2.3.7-r1  USE="X -bindist -debug -doc -utils" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB

Here the error message:
checking deschutes/libraries/hdmachinex225/PCMAudioPlayer.h usability... no
checking deschutes/libraries/hdmachinex225/PCMAudioPlayer.h presence... no
checking for deschutes/libraries/hdmachinex225/PCMAudioPlayer.h... no
configure: error: Could not find freetype (required for skins2)

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/media-video/vlc-0.9.8a/work/vlc-0.9.8a/config.log
 * ERROR: media-video/vlc-0.9.8a failed.
 * Call stack:
 *     , line   49:  Called src_compile
 *             environment, line 3601:  Called econf '--enable-a52' '--disable-aa' '--enable-faad' '--enable-alsa' '--disable-altivec' '--disable-arts' '--disable-asademux' '--disable-atmo' '--disable-bonjour' '--enable-fribidi' '--enable-cdda' '--enable-cddax' '--disable-libcddb' '--enable-libcdio' '--disable-csri' '--enable-dbus' '--enable-dbus-control' '--disable-dirac' '--disable-directfb' '--disable-dc1394' '--disable-debug' '--enable-dca' '--disable-dv' '--enable-dvb' '--enable-dvdread' '--enable-dvdnav' '--disable-esd' '--enable-fb' '--enable-avcodec' '--enable-avformat' '--enable-swscale' '--disable-imgresample' '--enable-postproc' '--enable-flac' '--disable-fluidsynth' '--disable-fontconfig' '--disable-ggi' '--disable-gnomevfs' '--enable-gnutls' '--disable-hal' '--enable-httpd' '--disable-id3tag' '--disable-jack' '--disable-kate' '--disable-libass' '--disable-caca' '--enable-libgcrypt' '--disable-notify' '--disable-libproxy' '--disable-libtar' '--disable-libsysfs' '--disable-libv4l2' '--disable-lirc' '--enable-live555' '--disable-lua' '--enable-mkv' '--disable-mmx' '--disable-mod' '--enable-mad' '--enable-libmpeg2' '--disable-mpc' '--enable-ncurses' '--enable-mozilla' '--with-mozilla-pkg=libxul' '--enable-ogg' '--enable-glx' '--enable-opengl' '--enable-galaktos' '--disable-optimize-memory' '--disable-oss' '--disable-pda' '--enable-png' '--disable-portaudio' '--disable-pulse' '--disable-pvr' '--enable-qt4' '--enable-realrtsp' '--disable-run-as-root' '--enable-smb' '--disable-schroedinger' '--enable-sdl' '--disable-sdl-image' '--disable-shout' '--enable-skins2' '--disable-speex' '--enable-sse' '--enable-sout' '--disable-svg' '--enable-svgalib' '--disable-taglib' '--enable-theora' '--disable-freetype' '--disable-twolame' '--disable-upnp' '--enable-v4l' '--disable-v4l2' '--enable-vcd' '--disable-vcdinfo' '--disable-vcdx' '--enable-vorbis' '--enable-loader' '--enable-x11' '--enable-screen' '--disable-x264' '--disable-xinerama' '--disable-libxml2' '--disable-xosd' '--enable-xvideo' '--disable-xvmc' '--disable-zvbi' '--disable-snapshot' '--disable-growl' '--disable-optimizations' '--enable-fast-install' '--enable-vlm' '--enable-sout' '--enable-skins2' '--enable-qt4' '--disable-remoteosd'
 *     , line  529:  Called die
 * The specific snippet of code:
 *                      die "econf failed"
 *  The die message:
 *   econf failed

Reproducible: Always

emerge --info
Portage (default/linux/x86/2008.0, gcc-4.1.2, glibc-2.6.1-r0, 2.6.24-gentoo-r3 i686)
System uname: Linux-2.6.24-gentoo-r3-i686-Intel-R-_Pentium-R-_M_processor_1300MHz-with-glibc2.0
Timestamp of tree: Wed, 04 Feb 2009 22:45:01 +0000
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7-r1, 2.1.6-r1
dev-lang/python:     2.4.4-r9, 2.5.2-r7
dev-python/pycrypto: 2.0.1-r6
dev-util/cmake:      2.4.8
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.4_p6, 1.7.9-r1, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
CFLAGS="-O2 -march=i686 -pipe"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=i686 -pipe"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X a52 aac acl alsa bash-completion berkdb bidi bzip2 cdda cdio cdr cli cracklib crypt css cups dbus dri dts dv dvb dvd dvdr dvdread encode fbcon ffmpeg firefox flac fortran freetype ftp gdbm gif gimp gnutls gphoto2 gpm gsm gtk httpd iconv imap ipv6 isdnlog java javascript jpeg lame live mad madwifi matroska midi mp3 mpeg mplayer mudflap nas ncurses nls nptl nptlonly nsplugin ogg oggvorbis opengl openmp pam pcmcia pcre perl png ppds pppd python qt-static qt3 quicktime raw rdesktop readline reflection rtsp samba sdl session skins sockets spl sse ssl startup-notification stream svga sysfs syslog tcpd theora tiff unicode usb v4l vcd vd videos vim-syntax vlm vnc vorbis wavpack wifi win32codecs wxwindows x86 xine xorg xscreensaver xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="radeon"
Comment 1 Rafał Mużyło 2009-02-06 19:09:33 UTC
I think that 'Create a New Attachment' link on bug page is a rather obvious place.
Without that log, or at least the error within, this bug is unlikely to be fixed.
Comment 2 Stephan 2009-02-07 09:33:28 UTC
Sorry, was in a hurry, didn't see that link. This is my first time here.

emerge worked in the mean time, I had to add the USE flag "truetype" then do a "emerge --update --deep --newuse --ask --verbose world" then it worked fine. The log file got deleted by the successful merge, sorry.

I just left this bug in state "new" so that you can have a look if there are some missing dependencies or something, maybe you can replicate with my USE flags.
Comment 3 Jeroen Roovers (RETIRED) gentoo-dev 2009-02-07 17:50:34 UTC
!!! Please attach the following file when seeking support:

!!! /var/tmp/portage/media-video/vlc-0.9.8a/work/vlc-0.9.8a/config.log
Comment 4 Stephan 2009-02-07 23:56:40 UTC
(In reply to comment #3)
> !!! Please attach the following file when seeking support:

I wasn't seeking support, I filed a bug since I thought that's the sensible and social thing to do since gentoo isn't working as it is supposed to, so who are YOU to spam this bug if I may ask?
Comment 5 Shane Williams 2009-06-23 22:04:54 UTC
Created attachment 195612 [details]

From a failed emerge
Comment 6 Shane Williams 2009-06-23 23:01:27 UTC
(In reply to comment #5)
> Created an attachment (id=195612) [edit]
> config.log
> From a failed emerge

I've attached the config.log, but really I think the problem shows up even in the call stack in the initial report where it says "disable-freetype".  I'm not an ebuild expert, but the vlc ebuild contains a couple of functions that show warnings about altering use flags based on other use flags (vlc_use_needs and vlc_use_force), but I don't see that it actually alters anything.  For instance, it warns the user that skins is going to be turned off because the truetype flag isn't on, but the config.log still contains enable-skins2.  Conversely, changing that line to be "vlc_use_force skins truetype", the config.log still shows disable-freetype.

So, the workaround is to add the truetype USE flag, as Stephan figured out, but this doesn't change the fact that there's a bug in the ebuild.