Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 257830 - www-client/mozilla-firefox-bin-3.0.5 + X11 killed by URL
Summary: www-client/mozilla-firefox-bin-3.0.5 + X11 killed by URL
Status: RESOLVED DUPLICATE of bug 253062
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Mozilla Gentoo Team
URL: http://wiki.zimbra.com/index.php?titl...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-02-05 22:02 UTC by Dmitry S. Makovey
Modified: 2010-09-06 13:08 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dmitry S. Makovey 2009-02-05 22:02:59 UTC
Every time I try to open http://wiki.zimbra.com/index.php?title=Ajcody-Notes in firefox-bin-3.0.5 it crashes my entire X11 session. 

Reproducible: Always

Steps to Reproduce:
1. open Firefox
2. either type in URL or navigate to it from other pages

Actual Results:  
entire X11 crashes logging me out

Expected Results:  
page should render normally

$ emerge --info
Portage 2.2_rc16 (default/linux/x86/2008.0/desktop, gcc-4.1.2, glibc-2.6.1-r0, 2.6.22-gentoo-r9 i686)
=================================================================
System uname: Linux-2.6.22-gentoo-r9-i686-Genuine_Intel-R-_CPU_U1300_@_1.06GHz-with-glibc2.0
Timestamp of tree: Tue, 20 Jan 2009 00:10:01 +0000
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7-r1, 2.1.6-r1
dev-lang/python:     2.3.6-r4, 2.4.4-r13, 2.5.2-r7
dev-python/pycrypto: 2.0.1-r6
dev-util/cmake:      2.4.6-r1
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -fomit-frame-pointer -march=prescott -msse3 -pipe -mno-tls-direct-seg-refs"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -fomit-frame-pointer -march=prescott -msse3 -pipe -mno-tls-direct-seg-refs"
DISTDIR="/usr/portage/distfiles"
FEATURES="buildpkg ccache collision-protect distlocks parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch userpriv usersandbox"
GENTOO_MIRRORS="http://gentoo.mirrors.tera-byte.com/ http://gentoo.chem.wisc.edu/gentoo/ http://gentoo.arcticnetwork.ca/ ftp://mirrors.tera-byte.com/pub/gentoo"
LANG="en_US.UTF-8"
LC_ALL="en_US.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="en ru pl"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/sunrise /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X Xaw3d a52 aac acl acpi acpi4linux aiglx alias alsa aoss artworkextra audiofile authdaemond avantgo ba-completion bcmath berkdb bindist bluetooth bootsplash branding bzip2 cairo caps cdparanoia cdr chroot cli codecs contactnotes cracklib crypt css cups cvs dbus dga dia divx divx4linux djvu dmi dmx dnd doc dri dv dvb dvd dvdr dvdread emboss emovix encode esd evo exif fam fame fbcon fbdev ffmpeg firefox flac fortran gamma gdbm gif gimp gimpprint glep glgd glut gnutls gpm graphviz gs gstreamer gvim hal hdri history hvm i8x0 iconv icq idea ieee1394 imagekits imap imlib2 innodb ipv6 irda irmc isdnlog j2ee jabber jpeg jpeg2k kde koffice-plugin lame laptop lcd ldap libgd libnotify live lynxkeymap lzo lzw lzw-tiff mad mdnsresponder-compat midi mikmod mime mimencode ming mjpeg mmx mmx2 mng monkey mozcalendar mozdevelop mozsha1 mozsvg mozxmlterm mp2 mp3 mp4 mp4live mpeg mpeg2 mplayer msn mudflap musicbrainz ncurses network nls nojython nptl nptlonly nsplugin ogg openexr opengl openmp opens oscar pam pcmcia pcre pda pdf pdfkit perl png pnp postgresql ppds pppd pygrub python q32 q8 qt3 qt3support qt4 quicktime rdesktop readline realmedia reflection reiserfs restrict-javascript samba sametime screen sdl serial session slang smartcard smime sms sndfile snmp soap speedo speex spell spl sql sse sse2 ssl startup-notification subtitles subversion svg svgz sysfs tcpd tga theora threads tidy tiff transcode truetype type1 unicode usb v4l2 vcd videos vidix vim vim-pager vim-syntax vim-with-x visualization vnc vorbis webdav webpresence wifi win32codecs winpopup x264 x86 xanim xcomposite xext xinerama xml xml2 xmlrpc xorg xosd xpm xscreensaver xulrunner xv xvid xvmc xvnc yahoo zeo zlib" ALSA_CARDS="als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x fm801 hda-intel intel8x0 intel8x0m usb-audio" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="synaptics keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en ru pl" USERLAND="GNU" VIDEO_CARDS="i810 i830 i915 intel vesa vga"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Jeroen Roovers (RETIRED) gentoo-dev 2009-02-06 02:22:12 UTC
Can't confirm that. Works fine here on a mostly similar system.

Looks like X is getting killed because of high memory usage - how much RAM does your system have?
What does dmesg say afterward?
What does /var/log/Xorg.*.log say?
Comment 2 Gene Seto 2009-02-17 05:40:54 UTC
I'm guessing this page fro this bug causes a crash too?
http://bugs.gentoo.org/show_bug.cgi?id=253062
Comment 3 Dmitry S. Makovey 2009-02-18 05:15:22 UTC
I'm going to try opening link from comment #2 on my office machine and see if it'll crash it. However reading through bug #253062 it looks awefully like my experience. And I know I should not be running out of memory - nothing hoggs the memory that fast. it's a 1.5G machine with 2G swap. It should spend some time thrashing the swap first, no? In my experience - it's instanteneous: click-DEAD. Looks like a crash in X11 libs someplace as it crashes Xorg and everything else naturally goes with it (KDE/FF/etc.). I'll reproduce problem and see what I can gather from logs.
Comment 4 Dmitry S. Makovey 2009-02-18 15:37:47 UTC
Backtrace:
0: /usr/bin/X(xf86SigHandler+0x85) [0x80cec63]

Fatal server error:
Caught signal 11.  Server aborting

(II) AIGLX: Suspending AIGLX clients for VT switch
(II) intel(0): xf86UnbindGARTMemory: unbind key 0
(II) intel(0): xf86UnbindGARTMemory: unbind key 1
(II) intel(0): xf86UnbindGARTMemory: unbind key 2
(II) intel(0): xf86UnbindGARTMemory: unbind key 3
(II) intel(0): xf86UnbindGARTMemory: unbind key 4

from what I gather sig11 is related to "out of boundary" access stuff:

"""Signal 11, or officially know as "segmentation fault", means that the program accessed a memory location that was not assigned. That's usually a bug in the program. So if you're writing your own program, that's the most likely cause. """

Comment 5 Dmitry S. Makovey 2009-02-18 15:41:34 UTC
feel free to mark it as a duplicate of bug #253062 - URLs there crash my X11 session in the very same fashion.
Comment 6 Jory A. Pratt gentoo-dev 2010-09-06 13:08:53 UTC

*** This bug has been marked as a duplicate of bug 253062 ***