Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 25756 - domenu command, required for global menu system (#18638)
Summary: domenu command, required for global menu system (#18638)
Status: RESOLVED FIXED
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Unclassified (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
: 27605 27779 27802 28051 28688 56552 66076 89374 (view as bug list)
Depends on:
Blocks: 31333
  Show dependency tree
 
Reported: 2003-08-02 07:25 UTC by Heinrich Wendel (RETIRED)
Modified: 2011-10-30 22:21 UTC (History)
14 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
domenu (domenu.,1.21 KB, text/plain)
2003-08-02 07:25 UTC, Heinrich Wendel (RETIRED)
Details
domenu (domenu.,1.36 KB, text/plain)
2003-08-02 07:31 UTC, Heinrich Wendel (RETIRED)
Details
domenu (domenu.,1.36 KB, text/plain)
2003-08-02 07:33 UTC, Heinrich Wendel (RETIRED)
Details
domenu (domenu,1.67 KB, text/plain)
2003-09-08 23:39 UTC, Heinrich Wendel (RETIRED)
Details
domenu (domenu,2.01 KB, text/plain)
2003-09-16 13:55 UTC, Heinrich Wendel (RETIRED)
Details
domenu (domenu,2.01 KB, text/plain)
2003-09-25 07:28 UTC, Heinrich Wendel (RETIRED)
Details
domenu (domenu,1.27 KB, text/plain)
2004-05-01 03:27 UTC, Heinrich Wendel (RETIRED)
Details
domenu (domenu,1.19 KB, text/plain)
2004-10-25 14:16 UTC, Heinrich Wendel (RETIRED)
Details
doicon (doicon,946 bytes, text/plain)
2004-10-25 14:17 UTC, Heinrich Wendel (RETIRED)
Details
domenuicon.diff (domenuicon.diff,1.05 KB, text/plain)
2004-11-11 12:01 UTC, Stefan Schweizer (RETIRED)
Details
domenuicon.diff (domenuicon.diff,885 bytes, patch)
2004-11-12 04:45 UTC, Stefan Schweizer (RETIRED)
Details | Diff
domenuicon.diff (domenuicon.diff,709 bytes, patch)
2004-11-14 12:19 UTC, Stefan Schweizer (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Heinrich Wendel (RETIRED) gentoo-dev 2003-08-02 07:25:19 UTC
Please add this file, it will install the .desktop entries in a directory where 
the menu system will find it. The menu system is not yet finished, but so the 
ebuilds can begin to support it as it will take a long time though. For more 
information on the menu system take a look at bug #16638.
Comment 1 Heinrich Wendel (RETIRED) gentoo-dev 2003-08-02 07:25:37 UTC
Created attachment 15360 [details]
domenu
Comment 2 Heinrich Wendel (RETIRED) gentoo-dev 2003-08-02 07:31:31 UTC
Created attachment 15361 [details]
domenu

fixed if xdg module not available
Comment 3 Heinrich Wendel (RETIRED) gentoo-dev 2003-08-02 07:33:20 UTC
Created attachment 15362 [details]
domenu

sorry, now it should work ;)
Comment 4 SpanKY gentoo-dev 2003-09-02 09:53:22 UTC
*** Bug 27605 has been marked as a duplicate of this bug. ***
Comment 5 SpanKY gentoo-dev 2003-09-02 09:53:25 UTC
*** Bug 27779 has been marked as a duplicate of this bug. ***
Comment 6 SpanKY gentoo-dev 2003-09-02 15:44:17 UTC
*** Bug 27802 has been marked as a duplicate of this bug. ***
Comment 7 Roderick Goessen 2003-09-03 10:23:20 UTC
Well, emm SpanKY, it's nice of you that you mark my requests for several programs to have menu entries as duplicated, but I don't think that's valid. As long 'domenu' isn't even in Portage yet, there has to be another way to put the programs in the menu. 

I think my requests are up to the maintainers of the ebuilds if they decide to wait for 'domenu' (howlong that could ever take from now) or that they want to have their ebuild right, right now, and modify it when this domenu is finished.

So, I don't know how long we have to wait for domenu, but in the maintime I think ebuild maintainers should have the chance to add a menu entry if it's wanted.

Ebuild maintainers of Unreal Tournament, UT2003 (&demo) amongst another one did accept the request kindly.
Comment 8 SpanKY gentoo-dev 2003-09-06 14:17:19 UTC
*** Bug 28051 has been marked as a duplicate of this bug. ***
Comment 9 SpanKY gentoo-dev 2003-09-07 15:47:09 UTC
do to the load that Gentoo puts on developers as is, if you want a menu added to a package then you'll have to personally talk to a developer/team to get it added ...

i'm not going to reassign menu requests to a developer, i'm going to mark them as dups of this
Comment 10 Heinrich Wendel (RETIRED) gentoo-dev 2003-09-08 23:39:26 UTC
Created attachment 17313 [details]
domenu

new version...
Comment 11 Heinrich Wendel (RETIRED) gentoo-dev 2003-09-15 12:09:56 UTC
*** Bug 28688 has been marked as a duplicate of this bug. ***
Comment 12 Heinrich Wendel (RETIRED) gentoo-dev 2003-09-16 13:55:07 UTC
Created attachment 17826 [details]
domenu

hopefully the last version ...
Comment 13 Heinrich Wendel (RETIRED) gentoo-dev 2003-09-25 07:28:11 UTC
Created attachment 18315 [details]
domenu

little fix, when will it be included?
Comment 14 Nicholas Jones (RETIRED) gentoo-dev 2003-10-05 16:12:59 UTC
Included for 2.0.49-r8
Comment 15 Heinrich Wendel (RETIRED) gentoo-dev 2003-10-06 03:34:48 UTC
can you please remove domenu again from portage, some 
people wanted a glep for the menu system and it has not been 
accepted yet
Comment 16 Nicholas Jones (RETIRED) gentoo-dev 2003-10-08 03:11:26 UTC
removed
Comment 17 Heinrich Wendel (RETIRED) gentoo-dev 2003-12-16 07:10:26 UTC
don't know if we will need it at all now, mark it as later for now, for more information on this topic see the current glep: http://www.gentoo.org/proj/en/glep/glep-0016.html
Comment 18 Steven Wagner 2004-03-24 23:54:15 UTC
Okay, so now we have a glep as requested...but the project is dead, so maybe this patch which seems to be a working solution should be applied?
Comment 19 Heinrich Wendel (RETIRED) gentoo-dev 2004-05-01 03:27:05 UTC
Created attachment 30438 [details]
domenu
Comment 20 Heinrich Wendel (RETIRED) gentoo-dev 2004-05-01 03:27:35 UTC
this one should be included now, maybe for portage 2.0.51?
Comment 21 SpanKY gentoo-dev 2004-05-01 23:39:17 UTC
i think it should be included / finished soon

i hate having to deal with bug reports about creating menu entries ... i think they're cruft and i'd love to have someone else handle it :)
Comment 22 Graeme Humphries 2004-05-04 19:49:04 UTC
Is this script supposed to throw this error:

Traceback (most recent call last):
  File "./domenu.sh", line 43, in ?
    os.system("install -d " + os.path.join(D, "usr/share/applications"))
  File "/usr/lib/python2.2/posixpath.py", line 50, in join
    elif path == '' or path[-1:] == '/':
TypeError: unsubscriptable object

? :)
Comment 23 SpanKY gentoo-dev 2004-07-09 18:46:54 UTC
*** Bug 56552 has been marked as a duplicate of this bug. ***
Comment 24 SpanKY gentoo-dev 2004-08-15 00:03:16 UTC
*** Bug 58924 has been marked as a duplicate of this bug. ***
Comment 25 SpanKY gentoo-dev 2004-08-15 00:03:26 UTC
*** Bug 58925 has been marked as a duplicate of this bug. ***
Comment 26 SpanKY gentoo-dev 2004-08-15 00:03:28 UTC
*** Bug 58926 has been marked as a duplicate of this bug. ***
Comment 27 SpanKY gentoo-dev 2004-08-15 00:11:04 UTC
*** Bug 49579 has been marked as a duplicate of this bug. ***
Comment 28 Mr. Bones. (RETIRED) gentoo-dev 2004-08-16 17:30:33 UTC
*** Bug 57203 has been marked as a duplicate of this bug. ***
Comment 29 SpanKY gentoo-dev 2004-10-01 18:25:38 UTC
*** Bug 66076 has been marked as a duplicate of this bug. ***
Comment 30 Stefan Schweizer (RETIRED) gentoo-dev 2004-10-25 11:40:01 UTC
Any progress on this? Is help needed?
Comment 31 Heinrich Wendel (RETIRED) gentoo-dev 2004-10-25 14:16:15 UTC
Created attachment 42578 [details]
domenu
Comment 32 Heinrich Wendel (RETIRED) gentoo-dev 2004-10-25 14:17:04 UTC
Created attachment 42579 [details]
doicon
Comment 33 Heinrich Wendel (RETIRED) gentoo-dev 2004-10-25 14:18:59 UTC
i can also impelement it as eclass, if you won't add it ;)
Comment 34 Aron Griffis (RETIRED) gentoo-dev 2004-10-25 14:36:00 UTC
Lanius, that would be better anyway... don't put this in portage, 'cause then you're tied to their release schedule for something that isn't base portage functionality.  Please put it in an eclass.
Comment 35 SpanKY gentoo-dev 2004-10-25 16:01:04 UTC
i'd say for now, integrate it into eutils.eclass and when portage starts splitting up portage into sep packages, we can merge it into the broken up portage packages
Comment 36 Jason Stubbs (RETIRED) gentoo-dev 2004-10-26 04:44:25 UTC
I second, err, third this.
Comment 37 Stefan Schweizer (RETIRED) gentoo-dev 2004-11-08 06:51:25 UTC
Where is the problem with this? Why is it not yet applied?
Comment 38 Chris Gianelloni (RETIRED) gentoo-dev 2004-11-08 12:28:22 UTC
...because you haven't written it as a patch to eutils.eclass yet?
Comment 39 Stefan Schweizer (RETIRED) gentoo-dev 2004-11-11 12:01:43 UTC
Created attachment 43733 [details]
domenuicon.diff

diff for eutils.eclass


Please review it, as I am not quite sure if I have respected all gentoo
policies.
Comment 40 Mr. Bones. (RETIRED) gentoo-dev 2004-11-12 01:01:02 UTC
needs local variables
probably should use "$@" instead of $*
shouldn't call ls, grep, echo in $()
should be quiet
should insinto once per function.
Comment 41 Stefan Schweizer (RETIRED) gentoo-dev 2004-11-12 04:45:21 UTC
Created attachment 43775 [details, diff]
domenuicon.diff

Is this ok?
Comment 42 Stefan Schweizer (RETIRED) gentoo-dev 2004-11-14 12:19:56 UTC
Created attachment 43948 [details, diff]
domenuicon.diff

Here is a smaller implementation that is also quiet.
Comment 43 Heinrich Wendel (RETIRED) gentoo-dev 2004-11-17 12:42:50 UTC
i propose to move that and make_desktop_entry to a new menu.eclass, because eutils.eclass is already full of stuff
Comment 44 Chris Gianelloni (RETIRED) gentoo-dev 2004-11-17 13:10:51 UTC
Well, these should supercede the make_desktop_entry, and if you move make_desktop_entry to a new eclass, then you would need to edit every ebuild that uses it.  If you're editing every ebuild that uses it already, then why not just move to the new do* commands in those ebuilds instead?
Comment 45 Chris Gianelloni (RETIRED) gentoo-dev 2004-11-17 13:14:50 UTC
Stefan: that looks good, but it would really need to create the entire .desktop entry.  Also, the domenu command would need to support non-freedesktop.org compliant window managers, such as windowmaker, *step, and *box.
Comment 46 Heinrich Wendel (RETIRED) gentoo-dev 2004-11-17 13:44:28 UTC
1.) for creating .desktop entries we have make_desktop_entry
2.) non-freedesktop compliant windowmanagers need to be patched to support freedesktop standards, we more or less decided that a long time ago
Comment 47 SpanKY gentoo-dev 2004-11-17 18:12:37 UTC
what's the difference between 'domenu' and 'make_desktop_entry' ?

they both result in the same thing, an entry in the menu system of a WM/DE

like wolf said, i think we should punt make_desktop_entry and move to using domenu, meaning no 'new' eclass is needed
Comment 48 Heinrich Wendel (RETIRED) gentoo-dev 2004-11-18 02:10:23 UTC
domenu only installs a already existing desktop entry in the correct location. make_desktop_entry creates a new desktop entry
Comment 49 Stefan Schweizer (RETIRED) gentoo-dev 2004-11-20 11:51:44 UTC
I think we should keep it in eutils.eclass, so no extra eclass needs to be inherited, and no ebuild needs to be changed.
Comment 50 Stefan Schweizer (RETIRED) gentoo-dev 2004-11-27 04:19:19 UTC
Can we add this now?

I think we should additionally provide a make_session_desktop(command, title) to make gdm 2.6 happy, so that all window managers can easily place their session files in /usr/share/xsession. (See bug 72613, among others)
Comment 51 Heinrich Wendel (RETIRED) gentoo-dev 2004-12-29 10:19:59 UTC
finally in portage, also included a make_session_desktop
Comment 52 SpanKY gentoo-dev 2005-04-16 22:47:17 UTC
*** Bug 89374 has been marked as a duplicate of this bug. ***