Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 257506 - app-pda/pilot-link-0.12.3 fails to build with gcc-4.3.3 (DFORTIFY_SOURCE=2 related)
Summary: app-pda/pilot-link-0.12.3 fails to build with gcc-4.3.3 (DFORTIFY_SOURCE=2 re...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal with 1 vote (vote)
Assignee: Gentoo PDA Herd
URL:
Whiteboard:
Keywords:
: 258581 258845 265728 266322 (view as bug list)
Depends on:
Blocks: fortify-source
  Show dependency tree
 
Reported: 2009-02-03 17:10 UTC by Maciej Mrozowski
Modified: 2010-06-04 12:48 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
proposed patch (pilot-link-0.12.3-fix-O_CREAT-missing-param.patch,506 bytes, patch)
2009-02-03 17:37 UTC, Maciej Mrozowski
Details | Diff
Updated patch (pilot-link-0.12.3-glibc-open.patch,578 bytes, patch)
2009-02-17 13:23 UTC, CFuga
Details | Diff
Build log of pilot-link-0.12.3-r1 (app-pda_pilot-link-0.12.3-r1.log,76.22 KB, text/plain)
2009-02-23 23:05 UTC, Magnus Granberg
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Maciej Mrozowski gentoo-dev 2009-02-03 17:10:30 UTC
Build log (short):
x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I.. -I/usr/include -I../include  -I/usr/include      -march=nocona -O2 -pipe -msse3 -ftree-vectorize -MT pilot-schlep.o -MD -MP -MF .deps/pilot-schlep.Tpo -c -o pilot-schlep.o pilot-schlep.c                                                                                
In function 'open',                                                                                      
    inlined from 'Fetch' at pilot-schlep.c:41,                                                           
    inlined from 'main' at pilot-schlep.c:218:                                                           
/usr/include/bits/fcntl2.h:51: error: call to '__open_missing_mode' declared with attribute error: open with O_CREAT in second argument needs 3 arguments                                                         
make[3]: *** [pilot-schlep.o] Error 1                                                                    
make[3]: Leaving directory `/var/tmp/portage/app-pda/pilot-link-0.12.3/work/pilot-link-0.12.3/src'       
make[2]: *** [all-recursive] Error 1                                                                     
make[2]: Leaving directory `/var/tmp/portage/app-pda/pilot-link-0.12.3/work/pilot-link-0.12.3/src'       
make[1]: *** [all-recursive] Error 1                                                                     
make[1]: Leaving directory `/var/tmp/portage/app-pda/pilot-link-0.12.3/work/pilot-link-0.12.3'           
make: *** [all] Error 2

Use flags used:
[ebuild  N    ] app-pda/pilot-link-0.12.3  USE="png readline threads usb (-bluetooth) -debug -java -perl-python" 0 kB
Comment 1 Maciej Mrozowski gentoo-dev 2009-02-03 17:37:45 UTC
Created attachment 180824 [details, diff]
proposed patch
Comment 2 Maciej Mrozowski gentoo-dev 2009-02-03 17:40:24 UTC
It should be noted that this issue is on box with emerge --info:

Portage 2.2_rc23 (default/linux/amd64/2008.0/no-multilib, gcc-4.3.3, glibc-2.9_p20081201-r1, 2.6.27-gentoo-r8 x86_64)                                                                                             
=================================================================                                        
System uname: Linux-2.6.27-gentoo-r8-x86_64-Intel-R-_Pentium-R-_4_CPU_3.20GHz-with-glibc2.2.5            
Timestamp of tree: Tue, 03 Feb 2009 14:15:01 +0000                                                       
ccache version 2.4 [enabled]                                                                             
app-shells/bash:     3.2_p48                                                                             
dev-java/java-config: 1.3.7-r1, 2.1.7                                                                    
dev-lang/python:     2.5.4-r2                                                                            
dev-util/ccache:     2.4-r8                                                                              
dev-util/cmake:      2.6.2-r1                                                                            
sys-apps/baselayout: 2.0.0                                                                               
sys-apps/openrc:     0.4.2                                                                               
sys-apps/sandbox:    1.3.3                                                                               
sys-devel/autoconf:  2.13, 2.63                                                                          
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2                                           
sys-devel/binutils:  2.19                                                                                
sys-devel/gcc-config: 1.4.1                                                                              
sys-devel/libtool:   2.2.6a                                                                              
virtual/os-headers:  2.6.28-r1                                                                           
ACCEPT_KEYWORDS="amd64 ~amd64"                                                                           
CBUILD="x86_64-pc-linux-gnu"                                                                             
CFLAGS="-march=nocona -O2 -pipe -msse3 -ftree-vectorize"                                                 
CHOST="x86_64-pc-linux-gnu"                                                                              
CONFIG_PROTECT="/etc /usr/share/config"                                                                  
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"                                                                                          
CXXFLAGS="-march=nocona -O2 -pipe -msse3 -ftree-vectorize"                                               
DISTDIR="/usr/portage/distfiles"                                                                         
FEATURES="ccache collision-protect distlocks fixpackages parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch userpriv usersandbox"                                        
GENTOO_MIRRORS="http://ftp.vectranet.pl/gentoo http://distro.ibiblio.org/pub/linux/distributions/gentoo" 
LANG="pl_PL.utf8"                                                                                        
LC_ALL="pl_PL.utf8"                                                                                      
LDFLAGS="-Wl,--as-needed"                                                                                
MAKEOPTS="-j3"                                                                                           
PKGDIR="/usr/portage/packages"                                                                           
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"                    
PORTAGE_TMPDIR="/var/tmp"                                                                                
PORTDIR="/usr/portage"                                                                                   
PORTDIR_OVERLAY="/usr/local/portage/layman/java-overlay /usr/local/portage/kde-testing /usr/local/portage/reavertm"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="7zip X a52 aac accessibility ace acpi additions alsa amd64 archive autoipd bash-completion bittorrent branding bzip2 cdaudio cddb chm cli clucene colordiff cracklib crypt cups curl dbus designer-plugin dirac divx dri dv dvd dvdr dvdread dynamic exif exiv2 ffmpeg flac fontconfig ftp gadu gd gif glibc-omitfp gnokii gphoto2 hal history iconv inotify isdnlog java6 javascript jpeg kde kdeenablefinal kdehiddenvisibility kdexdeltas kickoff libgadu lm_sensors lzma lzo mad mbox midi mng mp3 mplayer mudflap ncurses no-net2 nolvm1 nonfsv4 nptl nptlonly nsplugin ogg openmp pam pch pcre pdf pg-intdatetime plasma png pppd quicktime rar rdesktop readline reiserfs rtc session sha512 sms sndfile sockets spell spl srt sse sse2 ssl svg symlink sysfs theora threads threadsonly tiff toolkit-scroll-bars truetype unicode urandom usb utempter vhosts vnc vorbis webkit x264 xattr xcomposite xorg xpm xv xvid xvmc zeroconf zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd     authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile     authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd     deflate dir disk_cache env expires ext_filter file_cache filter headers ident     imagemap include info log_config logio mem_cache mime mime_magic negotiation     proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so   speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 3 Steve Kutnar 2009-02-08 01:54:34 UTC
Can the author please fix the title?  The application reference should be app-pda/pilot-link-0.12.3.
Comment 4 Peter Alfredsen (RETIRED) gentoo-dev 2009-02-11 18:31:00 UTC
*** Bug 258581 has been marked as a duplicate of this bug. ***
Comment 5 Markus Ullmann (RETIRED) gentoo-dev 2009-02-16 15:40:19 UTC
*** Bug 258845 has been marked as a duplicate of this bug. ***
Comment 6 Markus Ullmann (RETIRED) gentoo-dev 2009-02-16 15:41:20 UTC
patch added to cvs, thanks :)
Comment 7 CFuga 2009-02-17 13:23:12 UTC
Created attachment 182328 [details, diff]
Updated patch

Updated patch for glibc-2.6.1
Comment 8 CFuga 2009-02-17 13:28:43 UTC
In my current x86 stable system (glibc-2.6.1), the original patch fails, because S_IRUSR and S_IWUSR are defined in /usr/include/sys/types.h, which it's not included. My patch adds the missing header and it compiles just fine.

Comment 9 Maciej Mrozowski gentoo-dev 2009-02-17 14:27:06 UTC
Ah yes, missing headers.
Thanks
Comment 10 hirakendu 2009-02-20 09:08:21 UTC
I am on glibc-2.9 (20081201), and for me the missing header is <sys/stat.h> instead of <sys/types.h> as in the patch above. Anyways, after fixing it, it emerges fine.

Also, please do something about bluez :). (Make bluetooth enabled either with new bluez-4.2X or old bluez-utils/libs.)
Comment 11 Gergely POLONKAI 2009-02-20 10:12:13 UTC
I have glibc-2.9_p20081201-r2 emerged, which still has this bug.
Comment 12 Magnus Granberg gentoo-dev 2009-02-23 23:05:37 UTC
Created attachment 182969 [details]
Build log of pilot-link-0.12.3-r1

It still fail gcc 4.3.3 and glibc >=2.8
pilot-schlep.c: In function 'Fetch':
pilot-schlep.c:41: error: 'S_IRUSR' undeclared (first use in this function)
pilot-schlep.c:41: error: (Each undeclared identifier is reported only once
pilot-schlep.c:41: error: for each function it appears in.)
pilot-schlep.c:41: error: 'S_IWUSR' undeclared (first use in this function)
make[3]: *** [pilot-schlep.o] Error 1
Comment 13 Samuli Suominen gentoo-dev 2010-06-04 12:47:09 UTC
*** Bug 265728 has been marked as a duplicate of this bug. ***
Comment 14 Samuli Suominen gentoo-dev 2010-06-04 12:48:16 UTC
*** Bug 266322 has been marked as a duplicate of this bug. ***