Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 257445 - kde-base/kdm-4.3 fails to start on system start
Summary: kde-base/kdm-4.3 fails to start on system start
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-02-02 23:12 UTC by Morozov Alexandr
Modified: 2010-04-09 03:38 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---
tampakrap: Bugday+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Morozov Alexandr 2009-02-02 23:12:17 UTC
On system start kdm don`t work, with this messages: 
kdm[3169]: X server startup timeout, terminating
kdm[3169]: X server for display :0 cannot be started, session disabled
After /etc/init.d/xdm restart it starting normally.
I`m trying to set ServerTimeout in /usr/share/config/kdm/kdmrc even 240, but it`s not help.

Reproducible: Always

Steps to Reproduce:
1.start the system
2.wait until kdm starts

Actual Results:  
black screen with a blinking dash

Expected Results:  
starting kdm normally 

Portage 2.2_rc23 (default/linux/amd64/2008.0/desktop, gcc-4.3.3, glibc-2.9_p20081201-r1, 2.6.28-gentoo x86_64)                             
=================================================================                                                                          
System uname: Linux-2.6.28-gentoo-x86_64-Intel-R-_Core-TM-2_Duo_CPU_E8400_@_3.00GHz-with-glibc2.2.5                                        
Timestamp of tree: Mon, 02 Feb 2009 21:30:01 +0000                                                                                         
ccache version 2.4 [enabled]                                                                                                               
app-shells/bash:     3.2_p48                                                                                                               
dev-java/java-config: 1.3.7-r1, 2.1.7                                                                                                      
dev-lang/python:     2.5.4-r2                                                                                                              
dev-util/ccache:     2.4-r8                                                                                                                
dev-util/cmake:      2.6.2-r1                                                                                                              
sys-apps/baselayout: 2.0.0                                                                                                                 
sys-apps/openrc:     0.4.2                                                                                                                 
sys-apps/sandbox:    1.3.3                                                                                                                 
sys-devel/autoconf:  2.13, 2.63                                                                                                            
sys-devel/automake:  1.5, 1.7.9-r1, 1.9.6-r2, 1.10.2                                                                                       
sys-devel/binutils:  2.19                                                                                                                  
sys-devel/gcc-config: 1.4.1                                                                                                                
sys-devel/libtool:   2.2.6a                                                                                                                
virtual/os-headers:  2.6.28-r1                                                                                                             
ACCEPT_KEYWORDS="amd64 ~amd64"                                                                                                             
CBUILD="x86_64-pc-linux-gnu"                                                                                                               
CFLAGS="-O3 -march=native -pipe"                                                                                                           
CHOST="x86_64-pc-linux-gnu"                                                                                                                
CONFIG_PROTECT="/etc /usr/share/config"                                                                                                    
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"                                                                                                                                        
CXXFLAGS="-O3 -march=native -pipe"                                                                                                          
DISTDIR="/usr/portage/distfiles"                                                                                                            
FEATURES="ccache distlocks fixpackages parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch"         
GENTOO_MIRRORS="http://mirror.yandex.ru/gentoo-distfiles/ ftp://mirror.yandex.ru/gentoo-distfiles/ "                                        
LANG="ru_RU.UTF-8"                                                                                                                          
LC_ALL=""                                                                                                                                   
LDFLAGS="-Wl,-O1"                                                                                                                           
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/kde-testing /usr/local/portage/layman/mozilla /usr/local/portage/layman/science /usr/local/portage/layman/java-overlay /usr/local/portage/myoverlay"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X acl acpi alsa amd64 berkdb branding bzip2 cairo cdr cli cracklib crypt dbus dri dvd dvdr dvdread emboss encode evo fam firefox fortran gdbm gif gpm hal iconv isdnlog jpeg kde libnotify logitech-mouse mad midi mikmod mmx mp3 mpeg mudflap multilib ncurses nls nptl nptlonly nvidia ogg opengl openmp pam pcre pdf perl png ppds pppd python qt3support qt4 quicktime readline reflection reiser4 samba sdl session smp spl sse sse2 sse3 ssl ssse3 startup-notification svg sysfs tcpd threads tiff truetype unicode usb vorbis xml xorg xulrunner xv zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Casey Jones 2009-02-20 23:26:28 UTC
Check /var/log/Xorg.0.log after kdm fails.

I've experienced this problem too, and for me Xorg fails when trying to initialize the Nvidia GLX extension.  And you're using Nvidia, just like me.

I haven't tried /etc/init.d/xdm restart though.
Comment 2 Casey Jones 2009-02-21 18:43:16 UTC
Okay, I restarted xdm, and it does work like you said.  I'm using AMD64 like you, could anyone confirm if it works with nvidia-drivers on x86?
Comment 3 Jochen Schalanda 2009-04-04 10:13:14 UTC
I've experienced a similar problem here with kdm-3.5.10, also having an amd64 system and a nVidia graphics card. It seems that some drivers (or maybe device files in /dev?) are not fully initialized when booting the system.

When the boot process is complete, I can log into the system in text mode and run `/etc/init.d/xdm restart`. Putting a short pause into the xdm init script solved the problem.
Comment 4 Sven Müller 2009-04-19 06:39:23 UTC
Same problem here for a long time. Error message: 

Apr 19 08:24:54 faultier acpid: client connected from 2667[0:0]
Apr 19 08:24:54 faultier acpid: 1 client rule loaded
Apr 19 08:24:55 faultier IRQ 16/nvidia: IRQF_DISABLED is not guaranteed on shared IRQs
Apr 19 08:24:56 faultier acpid: client connected from 2667[0:0]
Apr 19 08:24:56 faultier acpid: 1 client rule loaded
Apr 19 08:25:02 faultier kdm: :0[2719]: Abnormal termination of greeter for display :0, code 1, signal 0
Apr 19 08:25:28 faultier login[2685]: ROOT LOGIN  on 'tty1'
Apr 19 08:25:35 faultier acpid: client connected from 2804[0:0]
Apr 19 08:25:35 faultier acpid: 1 client rule loaded
Apr 19 08:25:35 faultier IRQ 16/nvidia: IRQF_DISABLED is not guaranteed on shared IRQs
Apr 19 08:25:36 faultier acpid: client connected from 2804[0:0]
Apr 19 08:25:36 faultier acpid: 1 client rule loaded
Apr 19 08:25:38 faultier kdm: :0[2811]: Abnormal termination of greeter for display :0, code 1, signal 0
Apr 19 08:25:42 faultier acpid: client connected from 2882[0:0]
Apr 19 08:25:42 faultier acpid: 1 client rule loaded
Apr 19 08:25:42 faultier IRQ 16/nvidia: IRQF_DISABLED is not guaranteed on shared IRQs
Apr 19 08:25:44 faultier acpid: client connected from 2882[0:0]
Apr 19 08:25:44 faultier acpid: 1 client rule loaded

After a root-Login on the console I have to restart xdm several times. If the computer has a good day, then one time is enough. On other days I have to restart xdm 3 or 4 times to get the login screen. 

This behaviour occures for me since upgrading to 4.2.2. including the versions of the testings overlay (e.g. 4.1.85). 

System: amd64
Graphics card: nvidia
Comment 5 Tomáš Chvátal (RETIRED) gentoo-dev 2009-06-14 13:25:01 UTC
Driver issue, try different one it should start working.
Comment 6 Alex Alexander (RETIRED) gentoo-dev 2009-08-20 23:39:46 UTC
Any updates on this? Is this still happening for you with kde 4.3 and latest nvidia driver?

Thanks :)
Comment 7 Klaas Decanniere 2009-08-26 20:05:58 UTC
(In reply to comment #6)
> Any updates on this? Is this still happening for you with kde 4.3 and latest
> nvidia driver?
> 
> Thanks :)
> 

Still happening for me in a setup with KDE 4.3.0, nvidia-drivers 185.18.31, two GeForce9500GT cards in an SLI setup

logfile says
[kdm] X server startup timeout, terminating
[kdm] X server for display :0 cannot be started, session disabled

restarting xdm works. At least the desktop looks much nicer than before.

Klaas
Comment 8 Paramonov Valeriy 2009-09-18 13:11:05 UTC
(In reply to comment #7)
> (In reply to comment #6)
> > Any updates on this? Is this still happening for you with kde 4.3 and latest
> > nvidia driver?
> > 
> > Thanks :)
> > 
> 
> Still happening for me in a setup with KDE 4.3.0, nvidia-drivers 185.18.31, two
> GeForce9500GT cards in an SLI setup
> 
> logfile says
> [kdm] X server startup timeout, terminating
> [kdm] X server for display :0 cannot be started, session disabled
> 
> restarting xdm works. At least the desktop looks much nicer than before.
> 
> Klaas
> 

+1

GeForce9200M GS card

logfile says
[kdm] X server startup timeout, terminating
[kdm] X server for display :0 cannot be started, session disabled

This troube become same time ago after update world at begining of september 2009.
Comment 9 Tomáš Chvátal (RETIRED) gentoo-dev 2009-09-18 19:01:59 UTC
reopen based on comment 7 and comment 8
Comment 10 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2009-09-19 12:31:28 UTC
Could this be related to the timeout set on kdm startup? Check OpenTimeout in /usr/share/config/kdm/kdmrc - try increasing the value and see if that fixes kdm startup.
Comment 11 Patrick ALLAERT 2009-10-01 07:01:25 UTC
Same here.

nvidia-drivers-185.18.31 + kde-meta-4.3.1
card: nVidia Corporation GeForce 9600M GS [10de:0648] (rev a1)

I don't have any *Timeout* config in /usr/share/config/kdm/kdmrc
Comment 12 Marat Radchenko 2009-10-15 17:29:23 UTC
Same problem here (kdm-4.3.2, nvidia-drivers-180.60, xorg-server-1.6.3.901-r2).

Workarounded by increasing ServerTimeout from 15 to 30 in /usr/share/config/kdm/kdmrc
Comment 13 Eugene Volchek 2009-10-21 06:36:11 UTC
Same here (kdm-4.3.1-r2, nvidia-drivers-180.60, xorg-server-1.6.3.901-r2).

ServerTimeout helped too
Comment 14 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2009-10-30 13:59:17 UTC
Looking at my kdmrc, I see the following:

# How long to wait before timing out a display connection attempt.
# Default is 120
#OpenTimeout=120

I'll check the original file in the tarball later and will uncomment it to see if we get this fixed.
Comment 15 John 2010-03-01 08:40:13 UTC
Confirming problem but with Intel Corporation 4 Series Chipset Integrated Graphics Controller, kdm-4.3.5, xf86-video-intel-2.9.2 and xorg-server-1.6.5-r1.

Workaround for me was setting ServerTimeout=30 (default ServerTimeout=15) in /usr/share/config/kdm/kdmrc.

Comment 16 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2010-04-09 03:38:34 UTC
ServerTimeout is set to 30 now (in 4.4.2 and live ebuilds in overlay), thanks for the report and all the feedback