Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 257339 - kde-base/kdm-4.2.0 crashes on root login with a segfault
Summary: kde-base/kdm-4.2.0 crashes on root login with a segfault
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
: 239672 (view as bug list)
Depends on:
Blocks: 300393 313999
  Show dependency tree
 
Reported: 2009-02-02 06:49 UTC by Robert Holzknecht
Modified: 2010-07-12 18:24 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---
tampakrap: Bugday+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Holzknecht 2009-02-02 06:49:00 UTC
Every time i try to login as root, kdm crashes with a segfault.
This Problem doesn't appear if i use kdm-3.5.9 or 3.5.10.

Seems to be a similar error like in http://bugs.gentoo.org/show_bug.cgi?id=239672
just that i get it with the new version.

Reproducible: Always

Steps to Reproduce:
1. Install KDE 4.2 (USE: -prefix)
2. Use kdm 4.2
3. Try to login as root, AlloRootLogin=true in /usr/share/config/kdm/kdmrc

Actual Results:  
Root Login not possible, segfault occurs.

Expected Results:  
Login should be possible for root.

########### emerge --info ##########
Portage 2.2_rc23 (default/linux/x86/2008.0/desktop, gcc-4.1.2, glibc-2.6.1-r0, 2.6.27-gentoo-r7 i686)
=================================================================
System uname: Linux-2.6.27-gentoo-r7-i686-Genuine_Intel-R-_CPU_T2400_@_1.83GHz-with-glibc2.0
Timestamp of tree: Sat, 31 Jan 2009 18:30:17 +0000
distcc 3.0 i686-pc-linux-gnu [disabled]
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7-r1, 2.1.6-r1
dev-lang/python:     2.4.4-r13, 2.5.2-r7
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.6.2-r1
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.28-r1
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=prescott -O2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=prescott -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks fixpackages parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://ftp.uni-erlangen.de/pub/mirrors/gentoo http://mirror.bytemark.co.uk/gentoo/ http://gd.tuwien.ac.at/opsys/linux/gentoo/ http://mirror.jamit.de/gentoo/ http://gentoo.ynet.sk/pub"
LANG="de_DE.utf8"
LC_ALL="de_DE.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="de en en_GB en_US"
MAKEOPTS="-j7"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/sunrise /usr/local/portage/layman/desktop-effects /usr/local/portage/my_ebuilds"
SYNC="rsync://10.0.1.7/gentoo-portage"
USE="16bit 3ds 7zip X Xaw3d a52 aac aalib accessibility acl acpi addbookmarks adns adplug afs aio alias alisp alsa amd amr amrnb amrr amrwb ao apache2 apm ares arts async audiofile automount autoreplace avahi badval bash-completion bcmath berkdb bidi big-tables binfilter bittorrent bl bluetooth boehm-gc branding bzip2 cairo calendar caps carbone_theme cardbus catalogs ccache cdb cdda cddb cdf cdparanoia cdr cdrom cdsound cgi chardet chipcard chroot cjk clearcase cli cmdsubmenu connectionstatus contactnotes corba courier cpio cpudetection cracklib crypt css ctype cups curl curlwrappers cvs daap dbase dbus dc1394 de_tvtoday deprecated designer-plugin device-mapper dga dhcp directfb disk-partition diskio divx djbfft djvu dmi dri dts dv dvb dvbplayer dvd dvdr dvdread dvi dynamic eap-tls eds ee elf emboss emerald enca encode escreen evo exif expat fam fame fastbuild fat fax fbcon fbcondecor fbdev fbsplash ffmpeg fftw filter firefox flac flash flatfile fltk font-server fontconfig foomaticdb fortran fping fpx freetds ftp gadu gd gdbm geoip ggi gif gimp glade glib glitz glut gmedia gmp gnokii gnutls gphoto2 gpm gps graphviz groupwise gs gsl gsm gstreamer gtk gtkhtml gtkspell guile h323 hal hash haskell hbci hddtemp hfs highlight history howl-compat htmlhandbook ical iconv id3 idea idn ieee1394 ifp ilbc imagemagick imap imlib inifile iodbc ipod ipsec ipv6 ipw3945 irc irda irmc isdnlog it jack jack-tmpfs jad jai java java5 javacomm javascript jbig jce jfs jikes jingle john joystick jpeg jpeg2k json kde kde4 kdepim kdm kerberos kipi krb4 ladspa lame laptop lcd lcms ldap libcaca libgda libnotify libsamplerate libssh2 linux-smp-stats lirc live lm_sensors lua lzo math matroska matrox max-idx-128 mbox mbrola mcve md5sum mdb mdnsresponder-compat meanwhile memlimit metalink mfd-rewrites mhash midi mikmod mjpeg mmap mmkeys mmx mmxext mng modplug mono motif mouse mp2 mp3 mp3rtp mp3tunes mp4 mp4live mpeg mpeg2 mpi mpi_njtree mplayer msn mssql mtp mudflap multiprocess multiuser musepack music musicbrainz mysql mysqli nas nautilus ncurses nemesi net netjack netmeeting network networking nis njb nls nowlistening nptl nptlonly nsplugin nss ntfs ntlm ntp nvidia obex objc objc++ objc-gc ocaml odbc odk ofx ogg old-daemons openal openexr opengl openmp openntpd openssh optimisememory pam parse-clocks pascal pci pcmcia pcntl pcre pda pdf pdo perforce perl php physfs plasma player pmu png portaudio postgres povray ppds pppd print pulseaudio python qt3 qt3support qt4 quicktime radio rar readline realmedia reflection reiser4 reiserfs replytolist rle rpm rrdtool rss rtc rtsp ruby samba sametime sasl scanner screen script sdl sdl-image sensord serial server session sftp sharedext shout sid skins slp smartcard smp sms sndfile snmp soap sockets softfax sound soundex sounds soundtouch speedo speex spell spl sql srp srt sse sse2 sse3 ssl ssse3 startup-notification statistics stats stream submenu subtitles subversion suhosin svg svga svgz swig sysfs szip tcl tcp tcpd teletext templates test-programs texteffect textures tga themes theora threads thumbnail thunderbird tiff timidity tivo tk tokenizer tools trace transcode translator transmitter truetype tta tv_check tv_combiner tv_pick_cgi type1 unicode unzip upnp ups urandom usb userlocales utempter utils v4l v4l2 vcd vdr videos vidix vim vim-pager vim-syntax vim-with-x visualization vlm vnc vorbis vorbis-psy wavpack webdav webkit webpresence wifi win32codecs winbind winpopup wireshark wma wmf wmp x264 x86 x86emu xanim xattr xcb xchatdccserver xcomposite xext xforms xfs xft xine xinerama xml xmldoclet xmlreader xmlrpc xmlwriter xorg xosd xpm xprint xrandr xscreensaver xsettings xsl xslt xterm xulrunner xv xvid xvmc yahoo yaz yv12 zip zlib zoran zvbi" ALSA_CARDS="hda-intel usb-audio" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse synaptics evdev joystick void" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de en en_GB en_US" LIRC_DEVICES="serial" USERLAND="GNU" VIDEO_CARDS="nv nvidia vesa vga fbdev"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Robert Holzknecht 2009-02-02 07:19:35 UTC
Here are the segfault from /var/log/messages:
---------------------------------------------
kdm[10783]: segfault at 0 ip 08051f26 sp bf8d1ce0 error 4 in kdm[8048000+22000]
kdm[10808]: segfault at 0 ip 08051f26 sp bf8d1ce0 error 4 in kdm[8048000+22000]

Comment 2 Maciej Mrozowski gentoo-dev 2009-06-19 17:42:15 UTC
Please try with newest kdm from portage (4.2.4)
Comment 3 Andriy Baranskyy 2009-06-20 18:41:10 UTC
Unfortunately, the problem still remains with 4.2.4.
Comment 4 Maciej Mrozowski gentoo-dev 2009-07-01 00:53:19 UTC
Hmm, do you happen to have qt-gui emerged with gtkstyle USE flag enabled?
Also does this crash happen when you try to log into newly created user account?
Comment 5 Andriy Baranskyy 2009-07-01 01:00:12 UTC
Czesc  Maciej,

This only happens for the root account logins (and not only on my machine) and, yes, gtk use flag is enabled. Would you like me to recompile the package without the flag? I will try to do that later in the week - won't be able to do it earlier. Note that root logins work fine when I use kdm from the 3.5 branch.

andriy
Comment 6 Andriy Baranskyy 2009-07-01 01:00:55 UTC
*** Bug 239672 has been marked as a duplicate of this bug. ***
Comment 7 Maciej Mrozowski gentoo-dev 2009-07-01 14:17:42 UTC
I may be wrong, but it may be related to Qt4 Gtk style (Qt4 style using Gtk2 and its plugins for rendering)
It may appear when one used gtk-engines-qt (the other way around - Gtk2 style using Qt4 style for rendering) - applications will crash.
See bug 250504

You could try the following:
- make sure you have
export GTK2_RC_FILES=~/.gtkrc-2.0
in ~/.kde4/env/gtk-style.sh (remove any other conflicting files from there)
- install >=x11-themes/gtk-chtheme-0.3.1-r2
- choose some Gtk theme (for accounts that kdm crashes with, so for root, you need to run it in any X session that works for you)
- relogin, crashes should be gone for that account - if so, run systemsettings and for KDE4 apps set Qt4 style you want (it supposedly crashes because this style is set to Gtk - using qt-gui[gtkstyle] but still having remnants of gtk-engines-qt).
Comment 8 Andriy Baranskyy 2009-07-02 02:43:00 UTC
Thanks! I will try it on the weekend or early next week and will let you know.
Comment 9 Andriy Baranskyy 2009-07-11 03:38:05 UTC
Hi and sorry for not replying earlier.
This is strange, but I do not seem to have any gtk-style.sh files on my system at all (and in the directory you mentioned in particular). I tried creating one and following the steps but the crashes remain. I am guessing, I need to figure out why I do not have the file in the first place before proceding further. Alas, I was not able to find much online regarding this.
Comment 10 Maciej Mrozowski gentoo-dev 2009-07-11 16:28:04 UTC
It's fine that you don't have such file - as it's just example file where you can set GTK2_RC_FILES for your kde session. The point is - in the same location there could have been either some other similar (remnants of gtk-engines-qt) that combined with Gtk2 Qt style (provided by qt-gui[gtkstyle]) could render your qt4 apps unusable and require manual gtk theme switch (to sth other than gtk theme using qt engine) while having qt theme using gtk engine enabled.
At least that was the case of kdm segfaults I encountered.
Comment 11 Maciej Mrozowski gentoo-dev 2009-08-27 15:31:53 UTC
Any feedback? Andriy, if you want attention (like in bug 244720), you need to provide one as well, and report whether issue is still reproducible for you. Besides we all are yet to see any meaningful backtrace attached.
Comment 12 Andriy Baranskyy 2009-08-27 21:04:21 UTC
(In reply to comment #11)
> Any feedback? Andriy, if you want attention (like in bug 244720), you need to
> provide one as well, and report whether issue is still reproducible for you.
> Besides we all are yet to see any meaningful backtrace attached.
> 
Hi Maciej,

Sorry about the delay. Unfortunately, even with the upgrade to the latest kde (and kdm 4.3.0-r1) and gcc 4.4.1 I still run into the issue. I was trying to look for the files you've mentioned but could not find anything. Could you recommend other files where I can look for inconsistencies? 

With regards to backtrace, I would be happy to provide you with it, but not sure how to do this. The only thing that I can give you so far is the output in dmesg:

kdm[14386]: segfault at 0 ip 0805339f sp bfa07df0 error 4 in kdm[8048000+23000]

So far, this is not a big issue as I can either use kdm from the 3.5 series or gdm, but it would be great to figure out what is going on. Please let me know what else I can do...
Comment 13 Maciej Mrozowski gentoo-dev 2009-08-27 23:14:02 UTC
Hmm, to get coredumps, you could:

1. Enable core dumps
In /etc/profile.d/ create shell script with line 'ulimit -c 65536' (should be big enough for just backtraces)

2. Issue storing core dumps in some common place, for example this way:
In /etc/conf.d/local in local_start() add lines:

mkdir -p /tmp/core && chmod 1777 /tmp/core
echo "/tmp/core/%u:%g-%e.core" > /proc/sys/kernel/core_pattern

This will make coredumps created in /tmp/core/

3. Get kdm + kdelibs built with debug symbols
This can be achieved using /etc/portage/env hack.

In files /etc/portage/env/kde-base/kdelibs and /etc/portage/env/kde-base/kdm add lines:
CFLAGS="-O0 -ggdb"
CXXFLAGS="${CFLAGS}"
FEATURES="${FEATURES} splitdebug"

after that reemerge kdelibs and kdm, /etc/init.d/local restart and relogin

(remove those files in /etc/portage/env/kde-base when issue is solved as you don't need them built this way permanently I suppose)
Comment 14 Andreas K. Hüttel gentoo-dev 2010-03-12 23:09:25 UTC
Any news on this? Situation with 4.3.5 or 4.4.1?
Comment 15 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2010-04-09 14:20:47 UTC
I couldn't reproduce with 4.4.2, you could try also, so I'm marking this as fixed for 4.4.2. If the problem persists for you, attach the backtrace here and please open an upstream bug with the backtrace and paste the link here (comment 13 has the info you want for this). Feel fre to reopen. Thanks
Comment 16 Richard F. Ostrow Jr. 2010-07-12 18:24:07 UTC
Same problem here, with kdm-4.4.4-r1. Not currently in a position to do a backtrace, but it's apparently still an issue.