Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 257139 - net-misc/dhcdbd-3.0 - /usr/include/bits/fcntl2.h:51: error: call to '__open_missing_mode' declared with attribute error: open with O_CREAT in second argument needs 3 arguments
Summary: net-misc/dhcdbd-3.0 - /usr/include/bits/fcntl2.h:51: error: call to '__open_m...
Status: RESOLVED DUPLICATE of bug 232084
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Steev Klimaszewski
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: fortify-source
  Show dependency tree
 
Reported: 2009-01-31 21:05 UTC by Juergen Rose
Modified: 2009-02-17 23:26 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
fixed dhcdbd-3.0-daemon.patch (dhcdbd-3.0-daemon.patch,1.72 KB, patch)
2009-02-01 23:44 UTC, Tom Voss
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Juergen Rose 2009-01-31 21:05:53 UTC
'emerge dhcdbd' fails with:
cc -march=nocona -O2 -pipe  -DDBUS_API_SUBJECT_TO_CHANGE -D_GNU_SOURCE -I../include -c dhcdbd.c
cc -march=nocona -O2 -pipe  -DDBUS_API_SUBJECT_TO_CHANGE -D_GNU_SOURCE -I../include -I/usr/include/dbus-1.0 -I/usr/lib64/dbus-1.0/include   -DDHC_DEFINE_OP
TION_TABLES -c dhcp_options.c
dbus_service.c: In function 'set_watch_fds':
dbus_service.c:1030: warning: 'dbus_watch_get_fd' is deprecated (declared at /usr/include/dbus-1.0/dbus/dbus-connection.h:373)
dbus_service.c: In function 'add_watch':
dbus_service.c:1067: warning: 'dbus_watch_get_fd' is deprecated (declared at /usr/include/dbus-1.0/dbus/dbus-connection.h:373)
dbus_service.c: In function 'remove_watch':
dbus_service.c:1088: warning: 'dbus_watch_get_fd' is deprecated (declared at /usr/include/dbus-1.0/dbus/dbus-connection.h:373)
dbus_service.c:1099: warning: 'dbus_watch_get_fd' is deprecated (declared at /usr/include/dbus-1.0/dbus/dbus-connection.h:373)
dbus_service.c: In function 'toggle_watch':
dbus_service.c:1114: warning: 'dbus_watch_get_fd' is deprecated (declared at /usr/include/dbus-1.0/dbus/dbus-connection.h:373)
dbus_service.c: In function 'process_watch':
dbus_service.c:1140: warning: 'dbus_watch_get_fd' is deprecated (declared at /usr/include/dbus-1.0/dbus/dbus-connection.h:373)
dbus_service.c:1148: warning: 'dbus_watch_get_fd' is deprecated (declared at /usr/include/dbus-1.0/dbus/dbus-connection.h:373)
cc -march=nocona -O2 -pipe  -DDBUS_API_SUBJECT_TO_CHANGE -D_GNU_SOURCE -I../include -c main.c
In function 'open',
    inlined from 'dhcdbd_run' at dhcdbd.c:2816:
/usr/include/bits/fcntl2.h:51: error: call to '__open_missing_mode' declared with attribute error: open with O_CREAT in second argument needs 3 arguments
make[1]: *** [dhcdbd.o] Error 1
make[1]: Leaving directory `/var/tmp/portage/net-misc/dhcdbd-3.0/work/dhcdbd-3.0/src'
make: *** [dhcdbd] Error 2
 * 
 * ERROR: net-misc/dhcdbd-3.0 failed.

It fails on x86_64 and i686 systems.

Reproducible: Always




root@condor:/root(52)# emerge --info 
Portage 2.1.6.7 (default/linux/amd64/2008.0/desktop, gcc-4.3.3, glibc-2.9_p20081201-r1, 2.6.28.2 x86_64)
=================================================================
System uname: Linux-2.6.28.2-x86_64-Intel-R-_Core-TM-2_CPU_6600_@_2.40GHz-with-glibc2.2.5
Timestamp of tree: Sat, 31 Jan 2009 05:40:01 +0000
distcc 3.1 x86_64-pc-linux-gnu [disabled]
app-shells/bash:     3.2_p48
dev-java/java-config: 1.3.7-r1, 2.1.7
dev-lang/python:     2.4.4-r15, 2.5.4-r2
dev-python/pycrypto: 2.0.1-r6
dev-util/cmake:      2.6.2-r1
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.4.2
sys-apps/sandbox:    1.3.3
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.19
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.28-r1
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=nocona -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/4.1/env /usr/kde/4.1/share/config /usr/kde/4.1/shutdown /usr/kde/4.2/env /usr/kde/4.2/share/config /usr/kde/4.2/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=nocona -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
FFLAGS="-march=nocona -O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LDFLAGS="-Wl,-O1"
LINGUAS="de fr"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/java-overlay /usr/local/portage/layman/zugaina /usr/local/portage/layman/dotnet /usr/local/portage/layman/science /usr/local/portage/layman/jokey /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X Xaw3d a52 aac acl acpi administrator afs aiglx alsa amd64 amrr ao aotuv apache2 asf atlas auctex audacious audiofile automount bash-completion beagle berkdb bjam blas bluetooth bonobo boo boost branding bzip2 c++ cairo cdda cddb cdf cdio cdparanoia cdr cgi chm cli corba cracklib cran crypt cups curl cxx daap dbus device-mapper dga dia divx djvu dlloader dmi doc dri ds3490 dv dvb dvd dvdr dvdread dvi dxr3 dynagraph eds effects elf emacs emboss encode epiphany esd evo examples exif expat extra fam fame ffmpeg fftw firefox fits flac fltk foomaticdb fortran fpx galago gd gdal gdbm geos gif gimp gimpprint ginac glade glib glitz gml gmp gnokii gnome gnuplot gnutls gphoto2 gpm graphics graphviz gs gsl gsm gstreamer gtk guile hal hardened harness hddtemp hdf hdf5 hlapi http hvm iconv icq icu id3 ide imagemagick imap innodb ipv6 irda irmc isdnlog ithreads jabber java jbig john jpeg jpeg2k kde kde4 kdeprefix kerberos kexi keyring ladspa lame lapack latex lcms ldap libffi libgda libnotify libsamplerate lirc lm_sensors lua lzo lzw mad maildir math matroska midi mikmod mmx mmxext mng mod mono motif mozdevelop mozilla mozsvg mozxmlterm mp3 mp4 mp4live mpeg mpeg2 mplayer mudflap multilib musicbrainz mysql mysqli nautilus ncurses neXt netcdf netpbm network networkmanager nfs nls nntp nptl nptlonly nsplugin ntfs numarray numeric nvidia obex ocaml octave odbc ogdi ogg ole opengl openmp pae pam pcre pda pdf perl plotutils plugins png posix postgres postscript ppds pppd preview-latex proj projectx pstricks python qhull qt3 qt3support qt4 quicktime readline reflection reiserfs rhythmbox rle rpc rrdcgi rrdtool samba sasl science sdl session slang slp smp sndfile snmp soup sox speex spell spl sqlite sse sse2 ssl startup-notification stlport subtitles subversion suexec svg sysfs t1lib tcl tcpd tex theora threads thunderbird tidy tiff tk truetype unicode usb userlocales utempter v4l2 vorbis webkit wmf wxwindows xattr xcb xemacs xext xine xml xmlreader xmlrpc xorg xpm xulrunner xv xvid xvmc zlib zvbi" ALSA_CARDS="intel8x0" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" DVB_CARDS="cx8800 cx88xx tda1004x saa713" ELIBC="glibc" INPUT_DEVICES="keyboard mouse                " KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de fr" NETBEANS_MODULES="ide websvccommon nb harness apisupport groovy gsf j2ee java xml" USERLAND="GNU" VIDEO_CARDS="nv nvidia vesa"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Tom Voss 2009-02-01 21:27:57 UTC
I get this bug also.  Compiles with CFLAGS="-O0" as a temporary workaround.
Comment 2 Tom Voss 2009-02-01 23:44:42 UTC
Created attachment 180631 [details, diff]
fixed dhcdbd-3.0-daemon.patch
Comment 3 Tom Voss 2009-02-01 23:49:45 UTC
Nevermind about CFLAGS="-O0", this seems to break stuff at runtime.

line 22 of dhcdbd-3.0-daemon.patch was the issue it should be:
+        if ((fd = open (DHCDBD_PID_FILE, O_WRONLY | O_CREAT, 0644)) == -1)
instead of
+        if ((fd = open (DHCDBD_PID_FILE, O_WRONLY | O_CREAT)) == -1)

dhcdbd-2.8-daemon.patch should also be fixed in a similar way
Comment 4 Juergen Rose 2009-02-02 08:46:04 UTC
Replacing 
        if ((fd = open (DHCDBD_PID_FILE, O_WRONLY | O_CREAT)) == -1)
with
        if ((fd = open (DHCDBD_PID_FILE, O_WRONLY | O_CREAT, 0644)) == -1)
in dhcdbd-2.8-daemon.patch solved the problem.
Comment 5 Peter Alfredsen (RETIRED) gentoo-dev 2009-02-17 23:26:34 UTC

*** This bug has been marked as a duplicate of bug 232084 ***