Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 256949 - no 2d accel on radeon X1650 whith ati-drivers
Summary: no 2d accel on radeon X1650 whith ati-drivers
Status: VERIFIED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
: 256945 256951 256957 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-01-30 15:28 UTC by leonik
Modified: 2009-02-01 13:22 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description leonik 2009-01-30 15:28:04 UTC
seems that 2d accel does not work on my X1650
trying x11perf to see real digits:
x11perf -copypixpix500
x11perf - X11 performance program, version 1.5
The X.Org Foundation server version 10502000 on :0.0
from mad375
Fri Jan 16 02:45:12 2009

Sync time adjustment is 0.0374 msecs.

3600 reps @ 1.4707 msec ( 680.0/sec): Copy 500x500 from pixmap to pixmap
3600 reps @ 1.4362 msec ( 696.0/sec): Copy 500x500 from pixmap to pixmap
3600 reps @ 1.4411 msec ( 694.0/sec): Copy 500x500 from pixmap to pixmap
3600 reps @ 1.4382 msec ( 695.0/sec): Copy 500x500 from pixmap to pixmap
3600 reps @ 1.4385 msec ( 695.0/sec): Copy 500x500 from pixmap to pixmap
18000 trep @ 1.4449 msec ( 692.0/sec): Copy 500x500 from pixmap to pixmap


Reproducible: Always
Comment 1 Tomáš Chvátal (RETIRED) gentoo-dev 2009-01-30 16:18:28 UTC
*** Bug 256951 has been marked as a duplicate of this bug. ***
Comment 2 Tomáš Chvátal (RETIRED) gentoo-dev 2009-01-30 16:20:20 UTC
Hi,
we in gentoo have no chance about changing ati binary driver.
2D acceleration is working only with OpenSource drivers so if you use them (xf86-video-ati) you might get it working.
For working 2d accel with fglrx driver you have to bug amd on their bugzilla.

Hope i explained every aspect of your question.
Comment 3 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-01-30 16:29:47 UTC
*** Bug 256957 has been marked as a duplicate of this bug. ***
Comment 4 Tomáš Chvátal (RETIRED) gentoo-dev 2009-01-30 16:59:15 UTC
*** Bug 256945 has been marked as a duplicate of this bug. ***