Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 256777 - [patch] sys-libs/libsmbios-2.0.3 Fails build with GCC-4.4 alphas
Summary: [patch] sys-libs/libsmbios-2.0.3 Fails build with GCC-4.4 alphas
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GCC Porting (show other bugs)
Hardware: All Linux
: High minor (vote)
Assignee: Cédric Krier
URL: http://bugs.debian.org/cgi-bin/bugrep...
Whiteboard:
Keywords:
Depends on:
Blocks: gcc-4.4
  Show dependency tree
 
Reported: 2009-01-29 12:09 UTC by Kent Fredric (IRC: kent\n)
Modified: 2009-04-11 16:46 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
files/gcc4.4.patch (gcc4.4.patch,1.53 KB, patch)
2009-01-29 12:10 UTC, Kent Fredric (IRC: kent\n)
Details | Diff
libsmbios-2.0.3.ebuild (libsmbios-2.0.3.ebuild,1.10 KB, text/plain)
2009-01-29 12:11 UTC, Kent Fredric (IRC: kent\n)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kent Fredric (IRC: kent\n) gentoo-dev 2009-01-29 12:09:22 UTC
Due to some increased strictures, there needs to be explicit including of various files. The original debian bug shows more detail. 

Have created adapted patch and ebuild vs 2.0.3 

Reproducible: Always
Comment 1 Kent Fredric (IRC: kent\n) gentoo-dev 2009-01-29 12:10:16 UTC
Created attachment 180089 [details, diff]
files/gcc4.4.patch
Comment 2 Kent Fredric (IRC: kent\n) gentoo-dev 2009-01-29 12:11:04 UTC
Created attachment 180090 [details]
libsmbios-2.0.3.ebuild
Comment 3 Erik 2009-03-30 08:01:34 UTC
Just wondering why the patch adds sometimes stdio.h and sometimes cstdio. I thought that it should always be cstdio in cpp-files?
Comment 4 Ryan Hill (RETIRED) gentoo-dev 2009-04-01 04:51:10 UTC
when using the .h versions, their functions are considered to be in the global namespace and don't need to be explicitly prefixed with std::.  it sometimes doesn't matter and sometimes does.

http://www.comeaucomputing.com/techtalk/#cname
Comment 5 Peter Alfredsen (RETIRED) gentoo-dev 2009-04-11 16:46:21 UTC
+  11 Apr 2009; Peter Alfredsen <loki_val@gentoo.org>
+  +files/libsmbios-2.0.3-gcc44.patch, libsmbios-2.0.3.ebuild:
+  Fix bug 256777, failure with gcc-4.4. Thanks to Kent Fredric
+  <kentfredric@gmail.com> for the patch.
+