Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 256271 - net-wireless/iwl3945-ucode-15.28.2.8 error loading code in dmesg and network down
Summary: net-wireless/iwl3945-ucode-15.28.2.8 error loading code in dmesg and network ...
Status: VERIFIED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-01-25 04:02 UTC by arctic
Modified: 2009-01-27 04:26 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description arctic 2009-01-25 04:02:14 UTC
I am using a 2.6.28.1 kernel and when i upgrade to this version , network is down .The net-wireless/iwl3945-ucode-15.28.1.8 works perfect for this kernel.

iwl3945 0000:06:00.0: irq 376 for MSI/MSI-X                                       
[  392.039714] iwl3945 0000:06:00.0: firmware: requesting iwlwifi-3945-1.ucode                   
[  392.042564] iwl3945: iwlwifi-3945-1.ucode firmware file req failed: Reason -2                 
[  392.042567] iwl3945: Could not read microcode: -2                                             
[  392.042677] iwl3945 0000:06:00.0: PCI INT A disabled                                          
[  392.049251] iwl3945 0000:06:00.0: PCI INT A -> GSI 18 (level, low) -> IRQ 18                  
[  392.049420] iwl3945 0000:06:00.0: restoring config space at offset 0x1 (was 0x100102, writing 0x100106)                                                                                        
[  392.049604] iwl3945 0000:06:00.0: irq 376 for MSI/MSI-X                                       
[  392.049695] iwl3945 0000:06:00.0: firmware: requesting iwlwifi-3945-1.ucode                   
[  392.053082] iwl3945: iwlwifi-3945-1.ucode firmware file req failed: Reason -2                 
[  392.053085] iwl3945: Could not read microcode: -2                                             
[  392.053196] iwl3945 0000:06:00.0: PCI INT A disabled  

Reproducible: Always
Comment 1 Lawrence Ong 2009-01-25 14:55:37 UTC
Need to manually do a symbolic link from iwlwifi-3945-2.ucode to iwlwifi-3945-1.ucode. That solves the problem.
Comment 2 Tony Vroon gentoo-dev 2009-01-26 15:12:10 UTC
You need to keep both versions of the microcode installed. That's why they are slotted, and why portage did not delete the old ebuild. If you deleted it yourself, that's why you're having problems.
Comment 3 Andrew Brouwers 2009-01-26 15:55:50 UTC
(In reply to comment #2)
> You need to keep both versions of the microcode installed. That's why they are
> slotted, and why portage did not delete the old ebuild. If you deleted it
> yourself, that's why you're having problems.
> 

I hit this last night too.  I loaded a fresh ~amd64 install on my lappy, and installed the wireless driver.  If both are needed (using 2.6.28.2), shouldn't portage pull in both sets?  By default, only 2.8 got installed, and resulted in a non-functioning wireless card.
Comment 4 arctic 2009-01-27 04:26:05 UTC
Yes , i needed to emerge as slot.

Work now ;)