Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 255874 - media-sound/aqualung: automake called by maintainer-mode
Summary: media-sound/aqualung: automake called by maintainer-mode
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High QA (vote)
Assignee: Gentoo Sound Team
URL: http://blog.flameeyes.eu/2008/06/13/m...
Whiteboard:
Keywords:
Depends on:
Blocks: bad-autotools
  Show dependency tree
 
Reported: 2009-01-22 00:43 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2009-05-12 16:30 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (aqualung-0.9_beta9_p1:20081120-203550.log,89.05 KB, text/plain)
2009-01-22 00:43 UTC, Diego Elio Pettenò (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2009-01-22 00:43:26 UTC
Hello,

You're receiving this canned (template-based) bug report because I found a problem with a package during my tinderbox run.

The package in question is running automake (and most likely other autotools) during compile phase by maintainer-mode. You can see in my blog post in the URL field why that's a problem, and how to address the issue, but in general, you don't want maintainer-mode rebuild during compile phase, especially since it can cause multiple run of econf.

The causes of maintainer-mode rebuild are various, but most likely it's because of a patch that changes Makefile.am or configure.ac/in and don't rebuild autotools properly. The way to fix this is almost always to inherit autotools eclass and run eautomake/eautoreconf (as needed; eautoconf should only be used when automake is not involved, which is not the case here) during src_unpack phase.

Thanks,
Diego
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-01-22 00:43:39 UTC
Created attachment 179255 [details]
Build log
Comment 2 Samuli Suominen gentoo-dev 2009-05-12 16:30:39 UTC
+  12 May 2009; Samuli Suominen <ssuominen@gentoo.org>
+  aqualung-0.9_beta10-r1.ebuild:
+  Run eautoreconf to avoid maintainer-mode wrt #255874 and remove unused
+  use_enable taglib metadata since it's been removed by upstream.