Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 255800 - app-cdr/xcdroast: automake called by maintainer-mode
Summary: app-cdr/xcdroast: automake called by maintainer-mode
Status: RESOLVED DUPLICATE of bug 226443
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High QA (vote)
Assignee: optical media herd
URL: http://blog.flameeyes.eu/2008/06/13/m...
Whiteboard:
Keywords:
Depends on:
Blocks: bad-autotools
  Show dependency tree
 
Reported: 2009-01-21 22:02 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2009-02-09 04:04 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (xcdroast-0.98_alpha15-r5:20081114-212551.log,50.15 KB, text/plain)
2009-01-21 22:03 UTC, Diego Elio Pettenò (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2009-01-21 22:02:53 UTC
Hello,

You're receiving this canned (template-based) bug report because I found a problem with a package during my tinderbox run.

The package in question is running automake (and most likely other autotools) during compile phase by maintainer-mode. You can see in my blog post in the URL field why that's a problem, and how to address the issue, but in general, you don't want maintainer-mode rebuild during compile phase, especially since it can cause multiple run of econf.

The causes of maintainer-mode rebuild are various, but most likely it's because of a patch that changes Makefile.am or configure.ac/in and don't rebuild autotools properly. The way to fix this is almost always to inherit autotools eclass and run eautomake/eautoreconf (as needed; eautoconf should only be used when automake is not involved, which is not the case here) during src_unpack phase.

Thanks,
Diego
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-01-21 22:03:09 UTC
Created attachment 179216 [details]
Build log
Comment 2 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-02-09 04:04:25 UTC

*** This bug has been marked as a duplicate of bug 226443 ***