Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 255664 - games-simulation/kfreeflight: automake called by maintainer-mode
Summary: games-simulation/kfreeflight: automake called by maintainer-mode
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Games (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Games
URL: http://blog.flameeyes.eu/2008/06/13/m...
Whiteboard:
Keywords:
Depends on:
Blocks: bad-autotools
  Show dependency tree
 
Reported: 2009-01-20 18:00 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2010-01-09 09:47 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (kfreeflight-0.2.1_rc1:20090119-131238.log,35.88 KB, text/plain)
2009-01-20 18:00 UTC, Diego Elio Pettenò (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2009-01-20 18:00:03 UTC
Hello,

You're receiving this canned (template-based) bug report because I found a problem with a package during my tinderbox run.

The package in question is running automake (and most likely other autotools) during compile phase by maintainer-mode. You can see in my blog post in the URL field why that's a problem, and how to address the issue, but in general, you don't want maintainer-mode rebuild during compile phase, especially since it can cause multiple run of econf.

The causes of maintainer-mode rebuild are various, but most likely it's because of a patch that changes Makefile.am or configure.ac/in and don't rebuild autotools properly. The way to fix this is almost always to inherit autotools eclass and run eautomake/eautoreconf (as needed; eautoconf should only be used when automake is not involved, which is not the case here) during src_unpack phase.

Thanks,
Diego
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-01-20 18:00:21 UTC
Created attachment 179099 [details]
Build log
Comment 2 Samuli Suominen gentoo-dev 2010-01-09 09:47:48 UTC
Removed from Portage with kde-base/kdelibs:3.5.