Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 255371 - dev-util/kbuild-0.1.4 emerge fails with error "gcc: argument to '-o' is missing"
Summary: dev-util/kbuild-0.1.4 emerge fails with error "gcc: argument to '-o' is missing"
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: x86 Linux
: High normal with 3 votes (vote)
Assignee: Lars Wendler (Polynomial-C)
URL:
Whiteboard:
Keywords:
: 272391 415329 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-01-18 11:56 UTC by Wai Ling
Modified: 2019-04-20 13:51 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Wai Ling 2009-01-18 11:56:45 UTC
kbuild-0.1.4 emerge failed with error "gcc: argument to '-o' is missing".  Please find attached for emerge log.

Reproducible: Always

Steps to Reproduce:
1. emerge kbuild
2.
3.




Here's my emerge -info

Portage 2.2_rc20 (default/linux/x86/2008.0, gcc-4.1.2, glibc-2.6.1-r0, 2.6.27-hardened-r3 i686)
=================================================================                              
System uname: Linux-2.6.27-hardened-r3-i686-Intel-R-_Pentium-R-_4_CPU_2.40GHz-with-glibc2.0    
Timestamp of tree: Fri, 09 Jan 2009 10:30:02 +0000                                             
distcc[3875] (dcc_set_trace_from_env) ERROR: failed to open logfile /var/log/distcc/distcc.log: Permission denied [enabled]                                                                                                         
ccache version 2.4 [enabled]                                                                                      
app-shells/bash:     3.2_p39                                                                                      
dev-java/java-config: 1.3.7-r1, 2.1.6-r1                                                                          
dev-lang/python:     2.4.4-r13, 2.5.2-r7                                                                          
dev-python/pycrypto: 2.0.1-r6                                                                                     
dev-util/ccache:     2.4-r7                                                                                       
dev-util/cmake:      2.6.2-r1                                                                                     
sys-apps/baselayout: 1.12.11.1                                                                                    
sys-apps/sandbox:    1.2.18.1-r2                                                                                  
sys-devel/autoconf:  2.13, 2.63                                                                                   
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2                                                         
sys-devel/binutils:  2.18-r3                                                                                      
sys-devel/gcc-config: 1.4.0-r4                                                                                    
sys-devel/libtool:   1.5.26                                                                                       
virtual/os-headers:  2.6.27-r2                                                                                    
ACCEPT_KEYWORDS="x86"                                                                                             
CBUILD="i686-pc-linux-gnu"                                                                                        
CFLAGS="-march=pentium4 -O2 -pipe"                                                                                
CHOST="i686-pc-linux-gnu"                                                                                         
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"          
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=pentium4 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distcc distlocks fixpackages parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="POSIX"
LDFLAGS="-Wl,-O1"
LINGUAS="en zh_CN zh_TW zh ja"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/local"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X acl acpi alsa apache2 berkdb bzip2 cjk cli cracklib crypt cups dbus dri flac fortran gdbm gif git gpm hal iconv imlib isdnlog java jpeg kde laptop latex lm_sensors midi mmx mp3 mudflap mysql ncurses nls nptl nptlonly oggopengl openmp pam pcre pdf perl png pppd python qt4 readline redland reflection ruby sdl session spell spl sse sse2 ssl subversion svg sysfs tcpd theora tiff truetype unicode usb vhosts vidix vorbis win32codecs x264 x86 xcb xcomposite xinerama xorg xv xvid xvmc zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse wacom" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en zh_CN zh_TW zh ja" USERLAND="GNU" VIDEO_CARDS="ati radeon vesa vga"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Wai Ling 2009-01-18 12:02:07 UTC
It looks like bugzilla have internal error that prevent me for creating attachment.  So I am pasting the last few lines from the emerge.

...
Making all in doc                                                                                                 
make[3]: Entering directory `/var/tmp/portage/dev-util/kbuild-0.1.4/work/kBuild-0.1.4/out/linux.x86/release/bootstrap/sed/doc'                                                                                                      
Updating /var/tmp/portage/dev-util/kbuild-0.1.4/work/kBuild-0.1.4/src/sed/doc/version.texi                        
restore=: && backupdir=".am$$" && \                                                                               
        am__cwd=`pwd` && cd /var/tmp/portage/dev-util/kbuild-0.1.4/work/kBuild-0.1.4/src/sed/doc && \             
        rm -rf $backupdir && mkdir $backupdir && \                                                                
        if (/bin/sh /var/tmp/portage/dev-util/kbuild-0.1.4/work/kBuild-0.1.4/src/sed/config/missing --run makeinfo --version) >/dev/null 2>&1; then \                                                                               
          for f in /var/tmp/portage/dev-util/kbuild-0.1.4/work/kBuild-0.1.4/src/sed/doc/sed.info /var/tmp/portage/dev-util/kbuild-0.1.4/work/kBuild-0.1.4/src/sed/doc/sed.info-[0-9] /var/tmp/portage/dev-util/kbuild-0.1.4/work/kBuild-0.1.4/src/sed/doc/sed.info-[0-9][0-9] /var/tmp/portage/dev-util/kbuild-0.1.4/work/kBuild-0.1.4/src/sed/doc/sed.i[0-9] /var/tmp/portage/dev-util/kbuild-0.1.4/work/kBuild-0.1.4/src/sed/doc/sed.i[0-9][0-9]; do \                
            if test -f $f; then mv $f $backupdir; restore=mv; else :; fi; \                                       
          done; \                                                                                                 
        else :; fi && \                                                                                           
        cd "$am__cwd"; \                                                                                          
        if /bin/sh /var/tmp/portage/dev-util/kbuild-0.1.4/work/kBuild-0.1.4/src/sed/config/missing --run makeinfo   -I /var/tmp/portage/dev-util/kbuild-0.1.4/work/kBuild-0.1.4/src/sed/doc \                                       
         -o /var/tmp/portage/dev-util/kbuild-0.1.4/work/kBuild-0.1.4/src/sed/doc/sed.info /var/tmp/portage/dev-util/kbuild-0.1.4/work/kBuild-0.1.4/src/sed/doc/sed.texi; \                                                          
        then \                                                                                                    
          rc=0; \                                                                                                 
          cd /var/tmp/portage/dev-util/kbuild-0.1.4/work/kBuild-0.1.4/src/sed/doc; \                              
        else \                                                                                                    
          rc=$?; \                                                                                                
          cd /var/tmp/portage/dev-util/kbuild-0.1.4/work/kBuild-0.1.4/src/sed/doc && \                            
          $restore $backupdir/* `echo ".//var/tmp/portage/dev-util/kbuild-0.1.4/work/kBuild-0.1.4/src/sed/doc/sed.info" | sed 's|[^/]*$||'`; \                                                                                      
        fi; \                                                                                                     
        rm -rf $backupdir; exit $rc                                                                               
/var/tmp/portage/dev-util/kbuild-0.1.4/work/kBuild-0.1.4/src/sed/config/help2man --name "stream editor for filtering and transforming text" \                                                                                       
          -p sed --include /var/tmp/portage/dev-util/kbuild-0.1.4/work/kBuild-0.1.4/src/sed/doc/sed.x ../sed/sed > /var/tmp/portage/dev-util/kbuild-0.1.4/work/kBuild-0.1.4/src/sed/doc/sed.1                                       
make[3]: Leaving directory `/var/tmp/portage/dev-util/kbuild-0.1.4/work/kBuild-0.1.4/out/linux.x86/release/bootstrap/sed/doc'                                                                                                       
Making all in testsuite                                                                                           
make[3]: Entering directory `/var/tmp/portage/dev-util/kbuild-0.1.4/work/kBuild-0.1.4/out/linux.x86/release/bootstrap/sed/testsuite'                                                                                                
make[3]: Nothing to be done for `all'.                                                                            
make[3]: Leaving directory `/var/tmp/portage/dev-util/kbuild-0.1.4/work/kBuild-0.1.4/out/linux.x86/release/bootstrap/sed/testsuite'                                                                                                 
make[3]: Entering directory `/var/tmp/portage/dev-util/kbuild-0.1.4/work/kBuild-0.1.4/out/linux.x86/release/bootstrap/sed'                                                                                                          
make[3]: Nothing to be done for `all-am'.                                                                         
make[3]: Leaving directory `/var/tmp/portage/dev-util/kbuild-0.1.4/work/kBuild-0.1.4/out/linux.x86/release/bootstrap/sed'                                                                                                           
make[2]: Leaving directory `/var/tmp/portage/dev-util/kbuild-0.1.4/work/kBuild-0.1.4/out/linux.x86/release/bootstrap/sed'                                                                                                           
make[1]: Leaving directory `/var/tmp/portage/dev-util/kbuild-0.1.4/work/kBuild-0.1.4/out/linux.x86/release/bootstrap/sed'                                                                                                           
cp -f /var/tmp/portage/dev-util/kbuild-0.1.4/work/kBuild-0.1.4/out/linux.x86/release/bootstrap/sed/sed/sed /var/tmp/portage/dev-util/kbuild-0.1.4/work/kBuild-0.1.4/out/linux.x86/release/bootstrap/kmk/kmk_sed                     
cp -f /var/tmp/portage/dev-util/kbuild-0.1.4/work/kBuild-0.1.4/out/linux.x86/release/bootstrap/kmk/config.h /var/tmp/portage/dev-util/kbuild-0.1.4/work/kBuild-0.1.4/src/kmk/config.h.linux                                         
cp -f /var/tmp/portage/dev-util/kbuild-0.1.4/work/kBuild-0.1.4/out/linux.x86/release/bootstrap/sed/config.h /var/tmp/portage/dev-util/kbuild-0.1.4/work/kBuild-0.1.4/src/sed/config.h.linux                                         
/var/tmp/portage/dev-util/kbuild-0.1.4/work/kBuild-0.1.4/out/linux.x86/release/bootstrap/kmk/kmk -C /var/tmp/portage/dev-util/kbuild-0.1.4/work/kBuild-0.1.4                                                                        
kmk: Entering directory `/var/tmp/portage/dev-util/kbuild-0.1.4/work/kBuild-0.1.4'                                
kBuild: Pass - Build Programs                                                                                     
kBuild: Pass - Libraries                                                                                          
kBuild: Compiling kDep - /var/tmp/portage/dev-util/kbuild-0.1.4/work/kBuild-0.1.4/src/lib/kDep.c                  
gcc: argument to '-o' is missing                                                                                  
kmk: *** [/var/tmp/portage/dev-util/kbuild-0.1.4/work/kBuild-0.1.4/out/linux.x86/release/obj/kDep/kDep.o] Error 1 
The failing command:                                                                                              
        @gcc -c -O2 -g  -O3 -I/var/tmp/portage/dev-util/kbuild-0.1.4/work/kBuild-0.1.4/src/lib -DKBUILD_VERSION_MAJOR=0 -DKBUILD_VERSION_MINOR=1 -DKBUILD_VERSION_PATCH=4 -DKBUILD_OS_LINUX -DKBUILD_ARCH_X86 -Wp,-MD,/var/tmp/portage/dev-util/kbuild-0.1.4/work/kBuild-0.1.4/out/linux.x86/release/obj/kDep/kDep.o.dep -Wp,-MT,/var/tmp/portage/dev-util/kbuild-0.1.4/work/kBuild-0.1.4/out/linux.x86/release/obj/kDep/kDep.o -Wp,-MP -o /var/tmp/portage/dev-util/kbuild-0.1.4/work/kBuild-0.1.4/out/linux.x86/release/obj/kDep/kDep.o /var/tmp/portage/dev-util/kbuild-0.1.4/work/kBuild-0.1.4/src/lib/kDep.c                                                                                           
kmk: Leaving directory `/var/tmp/portage/dev-util/kbuild-0.1.4/work/kBuild-0.1.4'                                 
make: *** [/var/tmp/portage/dev-util/kbuild-0.1.4/work/kBuild-0.1.4/out/linux.x86/release/bootstrap/ts-stage2-build] Error 2                                                                                                        
kBuild/env.sh: info: rc=2: make -f bootstrap.gmk                                                                  
 *                                                                                                                
 * ERROR: dev-util/kbuild-0.1.4 failed.                                                                           
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 2525:  Called die
 * The specific snippet of code:
 *       kBuild/env.sh --full make -f bootstrap.gmk || die "bootstrap failed"
 *  The die message:
 *   bootstrap failed
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/dev-util/kbuild-0.1.4/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-util/kbuild-0.1.4/temp/environment'.
Comment 2 Martin Volf 2009-01-19 18:12:59 UTC
Hello,

I experienced the same problem and I was also using distcc and ccache. When I removed distcc and cache from FEATURES in /etc/make.conf, emerge -av1 kbuild succeeded.

Martin Volf
Comment 3 Wai Ling 2009-01-22 06:56:47 UTC
Thanks.  It works after I disabled ccache and distcc.
Comment 4 Markus Ullmann (RETIRED) gentoo-dev 2009-03-11 09:31:40 UTC
Sadly this app is known to it to hickup sometimes with ccache/distcc, though there are cases where it works fine. Can't do something useful here
Comment 5 Ioannis Aslanidis (RETIRED) gentoo-dev 2010-05-04 20:24:30 UTC
This is still happening. Force disable of FEATURES -distcc -ccache in the ebuild.
Comment 6 Jesse Adelman 2011-08-03 22:42:23 UTC
dev-util/kbuild-0.1.5-r1 same error, same cause (distcc alone in my case). When meerged with 'FEATURES="-distcc" emerge -1v kbuild', it compiles and installs.
Comment 7 destroyedlolo 2011-12-02 15:18:55 UTC
I have the same problem with VBox client companions, and seems it's related to kbuild.

Bye

Laurent
Comment 8 Pacho Ramos gentoo-dev 2012-03-18 18:55:54 UTC
*** Bug 272391 has been marked as a duplicate of this bug. ***
Comment 9 Ben Kohler gentoo-dev 2013-03-11 15:00:09 UTC
*** Bug 415329 has been marked as a duplicate of this bug. ***
Comment 10 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2014-04-26 13:30:38 UTC
Does this still happen with the snapshots in the Portage tree?
Comment 11 Patrick McMunn 2014-04-28 06:39:50 UTC
I tested dev-util/kbuild-0.1.9998_pre20131130 on two different machines. On my 64-bit laptop with gcc-4.9.0_alpha20140423 on which I do not use distcc, the only problem I had was undefined references errors with LTO enabled. It built fine once I disabled LTO. On my 32-bit desktop with gcc-4.9.0_alpha20140416 on which I do use distcc, I went ahead and disabled LTO. The compilation failed, although it was with a different error than the title of this bug. Aside from the march parameter, the CFLAGS/CXXFLAGS and LDFLAGS were the same on both machines. The only significant difference was the use of distcc on the machine where kbuild failed. I checked the kbuild trunk, and it was updated as recently as 6 weeks ago, so I don't know if this has been addressed upstream by now, but this really may just be a conflict between kbuild and distcc.
Comment 12 Marc Lecuyer 2015-11-20 08:08:25 UTC
It just happened to me on a fresh install.
Disabling distcc made kbuild build without issue.
dev-util/kbuild-0.1.9998_pre20131130
Comment 13 Bodo Graumann 2017-11-02 15:57:36 UTC
I just encountered this bug with the latest stable version 0.1.9998_pre20131130-r1. Why was distcc not forcefully disabled for the ebuild?
Comment 14 Larry the Git Cow gentoo-dev 2019-04-20 13:51:25 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=d1b515c88db3255d192e5d469f90405eb2bd33b9

commit d1b515c88db3255d192e5d469f90405eb2bd33b9
Author:     Lars Wendler <polynomial-c@gentoo.org>
AuthorDate: 2019-04-20 13:51:09 +0000
Commit:     Lars Wendler <polynomial-c@gentoo.org>
CommitDate: 2019-04-20 13:51:09 +0000

    dev-util/kbuild: Don't build with distcc
    
    Closes: https://bugs.gentoo.org/255371
    Package-Manager: Portage-2.3.64, Repoman-2.3.12
    Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>

 dev-util/kbuild/kbuild-0.1.9998.3149.ebuild | 7 ++++++-
 dev-util/kbuild/kbuild-9999.ebuild          | 7 ++++++-
 2 files changed, 12 insertions(+), 2 deletions(-)