Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 25423 - drupal-4.1.0.ebuild (new package)
Summary: drupal-4.1.0.ebuild (new package)
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: web-apps Herd
URL:
Whiteboard:
Keywords: EBUILD
: 46014 (view as bug list)
Depends on:
Blocks:
 
Reported: 2003-07-28 06:10 UTC by Al Maw
Modified: 2004-12-01 08:00 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
drupal-4.1.0.ebuild (drupal-4.1.0.ebuild,2.01 KB, text/plain)
2003-07-28 06:12 UTC, Al Maw
Details
drupal-4.1.0.ebuild (drupal-4.1.0.ebuild,2.01 KB, text/plain)
2003-07-28 06:13 UTC, Al Maw
Details
4.2.0rc ebuild (drupal-4.2.0_rc.ebuild,2.03 KB, text/plain)
2003-07-28 07:29 UTC, Al Maw
Details
drupal-4.1.0.ebuild (drupal-4.1.0.ebuild,2.04 KB, text/plain)
2003-07-28 08:47 UTC, Al Maw
Details
drupal-4.2.0_rc.ebuild (drupal-4.2.0_rc.ebuild,2.07 KB, text/plain)
2003-07-28 08:49 UTC, Al Maw
Details
drupal 4.4.1 ebuild that uses webapp.eclass (drupal-4.4.1.ebuild,1.97 KB, text/plain)
2004-06-10 13:45 UTC, Peter Westwood
Details
postinstall-en.txt required by ebuild (postinstall-en.txt,2.52 KB, text/plain)
2004-06-10 13:46 UTC, Peter Westwood
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Al Maw 2003-07-28 06:10:20 UTC
Attached is an ebuild for Drupal 4.1.0.

Drupal is an open-source platform and content management system for building
dynamic web sites offering a broad range of features and services including user
administration, publishing workflow, discussion capabilities, news aggregation,
metadata functionalities using controlled vocabularies and XML publishing for
content sharing purposes. Equipped with a powerful blend of features and
configurability, Drupal can support a diverse range of web projects ranging from
personal weblogs to large community-driven sites.

Please see http://drupal.org for more information.

This ebuild depends on virtual/php.
Comment 1 Al Maw 2003-07-28 06:12:16 UTC
Created attachment 15125 [details]
drupal-4.1.0.ebuild
Comment 2 Al Maw 2003-07-28 06:13:09 UTC
Created attachment 15126 [details]
drupal-4.1.0.ebuild
Comment 3 Al Maw 2003-07-28 07:29:51 UTC
Created attachment 15130 [details]
4.2.0rc ebuild

I also attach a Drupal 4.2.0 rc ebuild.
The Drupal package should go into net-www/
Comment 4 Al Maw 2003-07-28 08:47:05 UTC
Created attachment 15131 [details]
drupal-4.1.0.ebuild

Fixing .htaccess file not copied bug.
Comment 5 Al Maw 2003-07-28 08:49:00 UTC
Created attachment 15132 [details]
drupal-4.2.0_rc.ebuild

Fixing .htaccess issue.
Comment 6 Stuart Herbert (RETIRED) gentoo-dev 2003-10-04 08:13:48 UTC
Looks interesting ;-)

The web-apps herd is currently working on delivering some important changes
to the way that web-based applications are installed and managed on Gentoo
Linux.  Until this work is complete, we're not commiting ebuilds for new
web-based packages.

I've marked this bug as 'LATER'.  As soon as we are able to, we will come
back to this bug and help you convert your ebuild to our new approach.

Many thanks for your patience,
Stu
Comment 7 Stuart Herbert (RETIRED) gentoo-dev 2004-04-23 01:14:12 UTC
Hi,

Sorry for the delay in replying.  We've been very busy putting a new
framework in place for ebuilds for web-based applications.  This has
now been added to Portage.

We need you to update your ebuild to use the new framework before we
can accept your ebuild.

Please emerge net-www/webapp-config (make sure you get version 1.2 or
later), and update your ebuild to work with this new tool.  You can
use 'man 5 webapp.eclass', 'man 5 webapp-config' and 'man 8 webapp-config'
to learn more about how your ebuild needs to work.

You can find an example ebuild, for phpmyadmin, in

	/usr/share/doc/webapp-config-1.2/
	
If you encounter any difficulties with the new framework (and we
apologise, but there are sure to be a few at first), please let us know
and we'll do our best to help you.

Best regards,
Stu
Comment 8 Peter Westwood 2004-06-10 13:45:56 UTC
Created attachment 33045 [details]
drupal 4.4.1 ebuild that uses webapp.eclass

I've converted the previous ebuild over to webapp.eclass

I'm not sure how to handle the sql dumps provided so they currently end up as
part of the install :(
Comment 9 Peter Westwood 2004-06-10 13:46:52 UTC
Created attachment 33046 [details]
postinstall-en.txt required by ebuild

Nice verbose postinstall info - a slightly cut down version of the install
instructuions!
Comment 10 Peter Westwood 2004-06-10 13:47:13 UTC
add self as cc
Comment 11 Stuart Herbert (RETIRED) gentoo-dev 2004-07-11 03:31:10 UTC
I've just added an ebuild for Drupal 4.4.2 to Portage, based on Pete's ebuild (which was based on Al's).

Please test, and let me know if I've broken anything or not.

Best regards,
Stu
Comment 12 Stuart Herbert (RETIRED) gentoo-dev 2004-07-11 03:32:09 UTC
*** Bug 46014 has been marked as a duplicate of this bug. ***
Comment 13 Guttorm Flatabø 2004-07-18 07:03:38 UTC
Just did an install the other day with apache 2.0.50 and mod_php 4.3.8. Had no problems.

The only thing I noticed was that the theme did not seem to work before I had logged in for the first time, it was just very plain without colours, images, and special formatting. Haven't tested it extensivly since I found out that it doesn't cover my needs (but eZ Publish does).

Just wanted to let you know that it seems to work fine on a simple ARCH system.

--Guttorm
Comment 14 mythdraug 2004-12-01 08:00:24 UTC
Anyone up for doing a ebuild for drupal 4.5?