Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 254030 - net-misc/ntp-4.2.4_p5 fails to compile on uclibc due to missing __adjtimex()
Summary: net-misc/ntp-4.2.4_p5 fails to compile on uclibc due to missing __adjtimex()
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Server (show other bugs)
Hardware: PPC Linux
: High normal (vote)
Assignee: Gentoo's Team for Core System packages
Depends on:
Reported: 2009-01-07 01:08 UTC by Tom Lloyd
Modified: 2015-04-08 21:03 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

Unabridged build.log, for your viewing pleasure (build.log,124.67 KB, text/plain)
2009-01-07 01:11 UTC, Tom Lloyd

Note You need to log in before you can comment on or make changes to this bug.
Description Tom Lloyd 2009-01-07 01:08:50 UTC
net-misc/ntp is failing to compile on my machine.  I use uClibc, so it's probably something to do with that.  It usually is.  I used to have 0.9.28, but I recently upgraded to 0.9.30 - and then this happened.  Go figure.

I'm pasting the end of the build process (with the errors) here.  I'll attach the full build log too, in case that helps.

Reproducible: Always

Steps to Reproduce:
1. emerge =net-misc/ntp-4.2.4_p5
Actual Results:  
<--- SNIP --->
Making all in util
make[2]: Entering directory `/var/tmp/portage/net-misc/ntp-4.2.4_p5/work/ntp-4.2.4p5/util'
make  all-am
make[3]: Entering directory `/var/tmp/portage/net-misc/ntp-4.2.4_p5/work/ntp-4.2.4p5/util'
if powerpc-gentoo-linux-uclibc-gcc -DHAVE_CONFIG_H -I. -I. -I..  -I../include -I../libopts -I/usr/include  -O2 -mcpu=603e -pipe  -Wall -Wcast-qual -Wmissing-prototypes -Wpointer-arith -Wshadow -Wstrict-prototypes -MT tickadj.o -MD -MP -MF ".deps/tickadj.Tpo" -c -o tickadj.o tickadj.c; \
        then mv -f ".deps/tickadj.Tpo" ".deps/tickadj.Po"; else rm -f ".deps/tickadj.Tpo"; exit 1; fi
if powerpc-gentoo-linux-uclibc-gcc -DHAVE_CONFIG_H -I. -I. -I..  -I../include -I../libopts -I/usr/include  -O2 -mcpu=603e -pipe  -Wall -Wcast-qual -Wmissing-prototypes -Wpointer-arith -Wshadow -Wstrict-prototypes -MT ntp-keygen.o -MD -MP -MF ".deps/ntp-keygen.Tpo" -c -o ntp-keygen.o ntp-keygen.c; \
        then mv -f ".deps/ntp-keygen.Tpo" ".deps/ntp-keygen.Po"; else rm -f ".deps/ntp-keygen.Tpo"; exit 1; fi
if powerpc-gentoo-linux-uclibc-gcc -DHAVE_CONFIG_H -I. -I. -I..  -I../include -I../libopts -I/usr/include  -O2 -mcpu=603e -pipe  -Wall -Wcast-qual -Wmissing-prototypes -Wpointer-arith -Wshadow -Wstrict-prototypes -MT ntp-keygen-opts.o -MD -MP -MF ".deps/ntp-keygen-opts.Tpo" -c -o ntp-keygen-opts.o ntp-keygen-opts.c; \
        then mv -f ".deps/ntp-keygen-opts.Tpo" ".deps/ntp-keygen-opts.Po"; else rm -f ".deps/ntp-keygen-opts.Tpo"; exit 1; fi
tickadj.c:183:22: sys/var.h: No such file or directory
tickadj.c: In function `main':
tickadj.c:436: error: `txc' undeclared (first use in this function)
tickadj.c:436: error: (Each undeclared identifier is reported only once
tickadj.c:436: error: for each function it appears in.)
make[3]: *** [tickadj.o] Error 1
make[3]: *** Waiting for unfinished jobs....
ntp-keygen.c: In function `main':
ntp-keygen.c:318: warning: assignment discards qualifiers from pointer target type
ntp-keygen.c:332: warning: assignment discards qualifiers from pointer target type
ntp-keygen.c:335: warning: assignment discards qualifiers from pointer target type
ntp-keygen.c:338: warning: assignment discards qualifiers from pointer target type
ntp-keygen.c:341: warning: assignment discards qualifiers from pointer target type
make[3]: Leaving directory `/var/tmp/portage/net-misc/ntp-4.2.4_p5/work/ntp-4.2.4p5/util'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/var/tmp/portage/net-misc/ntp-4.2.4_p5/work/ntp-4.2.4p5/util'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/net-misc/ntp-4.2.4_p5/work/ntp-4.2.4p5'
make: *** [all] Error 2
 * ERROR: net-misc/ntp-4.2.4_p5 failed.

Portage (uclibc/ppc/hardened, gcc-3.4.6, uclibc-0.9.30-r0, 2.6.26-hardened-r7-muttley-1-misc ppc)
System uname: Linux-2.6.26-hardened-r7-muttley-1-misc-ppc-G2_LE-with-libc0
Timestamp of tree: Sun, 04 Jan 2009 18:15:01 +0000
distcc 3.0 powerpc-gentoo-linux-uclibc [enabled]
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p33
dev-lang/python:     2.4.4-r14, 2.5.2-r7
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-devel/autoconf:  2.63
sys-devel/automake:  1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.23-r3
CFLAGS="-O2 -mcpu=603e -pipe"
CONFIG_PROTECT="/etc /var/bind"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -mcpu=603e -pipe"
FEATURES="autoconfig ccache distcc distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="alsa apache2 bzip2 cgi cli cracklib crypt dri embedded fastcgi hardened ipv6 mudflap mysql ncurses offensive openmp pcre perl php pic ppc python quotas readline reflection samba session sni spl sqlite ssl ssp suhosin syslog tcpd uclibc uclibc-compat unicode xorg zlib" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="alias auth_basic authn_alias authn_anon authn_default authn_file authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias proxy proxy_http" APACHE2_MPMS="prefork" CAMERAS="sq905" ELIBC="uclibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="dummy fbdev v4l"
Comment 1 Tom Lloyd 2009-01-07 01:11:56 UTC
Created attachment 177626 [details]
Unabridged build.log, for your viewing pleasure
Comment 2 Patrick Lauer gentoo-dev 2009-01-07 20:10:13 UTC
tickadj.c:183:22: sys/var.h: No such file or directory
I don't have that file on my system. Missing dependency? 
Comment 3 Tom Lloyd 2009-01-07 20:37:17 UTC
Heh, nor do I!  I wonder what it's supposed to do? =P
Comment 4 Tom Lloyd 2009-01-07 20:44:11 UTC
Hmm, Google throws up this:
Apparently it was a bug in 4.1, and should now be fixed.  Obviously not...  There's various other stuff in mailing list archives from about the same time (2003).  Could this be a really, really old regression?
Comment 5 Robert Lewis 2009-01-07 22:21:21 UTC
I think sys/var.h is specific to AIX. There is an IFDEF for NLIST which is included on most systems, else it will choose alternate header files (one being var.h)

NLIST might be specific to elf binary systems. You are running PPC, is it using the a.out binary format?

I think it is a mistake in the code for PPC systems. I tried looking other headers to use instead of var.h but no dice..
Comment 6 Tom Lloyd 2009-01-07 23:00:32 UTC
I think I'm using ELF...  I just tried throwing a couple of random binaries at readelf and it didn't complain.  Is there a more definitive way of telling?
Comment 7 SpanKY gentoo-dev 2009-01-08 05:55:21 UTC
no Gentoo system uses a.out ... uClibc certainly does not
Comment 8 SpanKY gentoo-dev 2009-01-10 13:03:21 UTC
i fixed this for Blackfin quite a while ago ... and now ive committed that patch to the gentoo tree