Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 253802 - Portage 2.2 is masked despite 2.1.6 being marked stable.
Summary: Portage 2.2 is masked despite 2.1.6 being marked stable.
Status: RESOLVED FIXED
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core (show other bugs)
Hardware: All Linux
: High normal with 1 vote (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
: 344517 (view as bug list)
Depends on: force-rebuild
Blocks: 364275 472632
  Show dependency tree
 
Reported: 2009-01-05 05:25 UTC by James Gilliland
Modified: 2013-08-12 23:52 UTC (History)
8 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description James Gilliland 2009-01-05 05:25:36 UTC
The mask for >=sys-apps/portage-2.2_pre says it will be masked until 2.1.6 is marked stable. It has been marked stable so the mask should probably be removed.
Comment 1 Serkan Kaba (RETIRED) gentoo-dev 2009-01-05 06:51:20 UTC
It's not for all arches. Adding a blocker.
Comment 2 Zac Medico gentoo-dev 2009-01-06 02:45:56 UTC
There are a number of known bugs in the package sets and preserve-libs features. I plan to have a lot of these bugs fixed before I unmask it. I've updated the message in package.mask to reflect this.
Comment 3 Wolfram Schlich (RETIRED) gentoo-dev 2009-02-13 14:43:24 UTC
(In reply to comment #2)
> There are a number of known bugs in the package sets and preserve-libs
> features. I plan to have a lot of these bugs fixed before I unmask it. I've
> updated the message in package.mask to reflect this.

Zac, what bugs are you referring to?
Any bug numbers instead of or in addition to the following tracker bugs?

bug #210077: [TRACKER] sys-apps/portage-2.2
bug #144480: [TRACKER] portage package set support
bug #240323: [TRACKER] portage preserve-libs and @preserved-rebuild
Comment 4 Zac Medico gentoo-dev 2009-02-13 21:30:05 UTC
There are some bugs that block bug 144480 and bug 240323, but there are some other issues that don't have bugs filed. Here are some that come to mind:

1) For preserve-libs, there is no protection against building packages which depend on packages for which libs are still preserved. This issue is briefly discussed here: http://blog.flameeyes.eu/2008/06/30/a-few-risks-i-see-related-to-the-new-portage-2-2-preserve-libs-behaviour

2) Package set operators currently operate on atoms, but what users really need is for them to operate on the packages themselves. This will allow one set to add or subtract packages from another even though the sets to not use the exact same atoms to refer to the given packages.

3) The dependency resolver currently expands all the sets nested within a given set, and in the process discards the nesting relationship. Instead, it should keep the sets separate so that when a given nested set dependency is unsatisfied it's possible to indicate precisely which set is at fault.
Comment 5 Zac Medico gentoo-dev 2009-07-04 21:35:21 UTC
(In reply to comment #4
> 2) Package set operators currently operate on atoms, but what users really need
> is for them to operate on the packages themselves. This will allow one set to
> add or subtract packages from another even though the sets to not use the exact
> same atoms to refer to the given packages.

I imagine the way this should be done is to create a mapping of atom -> package for each set, perform the intersection using the packages, and then map the package intersection back into a set of atoms.
Comment 6 Zac Medico gentoo-dev 2009-07-05 09:36:59 UTC
(In reply to comment #4)
> 2) Package set operators currently operate on atoms, but what users really need
> is for them to operate on the packages themselves. This will allow one set to
> add or subtract packages from another even though the sets to not use the exact
> same atoms to refer to the given packages.

In svn r13787 I've removed set operator support, since the current implementation will not meet user expectations. We can consider adding support for it again later, but the implementation will have to be entirely different.
Comment 7 Zac Medico gentoo-dev 2009-10-18 21:11:57 UTC
In svn r14679 I've removed support for 'extend', 'remove', and 'intersect' sets.conf section attributes, for the same reasons as in comment #6.
Comment 8 Samuli Suominen gentoo-dev 2010-11-07 14:10:09 UTC
*** Bug 344517 has been marked as a duplicate of this bug. ***
Comment 9 Zac Medico gentoo-dev 2013-08-12 23:52:24 UTC
This is fixed with portage-2.2.0.