Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 252855 - scanelf: Sorry, long names not yet supported; output will be incomplete for ...
Summary: scanelf: Sorry, long names not yet supported; output will be incomplete for ...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: SpanKY
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-12-28 21:19 UTC by Matteo Modesti
Modified: 2008-12-30 16:29 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
libgcov.a (libgcov.a,40.09 KB, application/octet-stream)
2008-12-30 08:10 UTC, Ryan Hill (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matteo Modesti 2008-12-28 21:19:47 UTC
Hi, I just upgraded from sys-devel/gcc from 4.3.2 to 4.3.2-r1.
It compiled and installed correctly, but right after installation it printed this out:


>>> Completed installing gcc-4.3.2-r1 into /var/tmp/portage/sys-devel/gcc-4.3.2-r1/image/

ecompressdir: bzip2 -9 /usr/share/gcc-data/x86_64-pc-linux-gnu/4.3.2/man
ecompressdir: bzip2 -9 /usr/share/gcc-data/x86_64-pc-linux-gnu/4.3.2/info
scanelf: Sorry, long names not yet supported; output will be incomplete for /var/tmp/portage/sys-devel/gcc-4.3.2-r1/image/usr/lib/gcc/x86_64-pc-linux-gnu/4.3.2/libgcc.a
scanelf: Sorry, long names not yet supported; output will be incomplete for /var/tmp/portage/sys-devel/gcc-4.3.2-r1/image/usr/lib/gcc/x86_64-pc-linux-gnu/4.3.2/libgfortran.a
scanelf: Sorry, long names not yet supported; output will be incomplete for /var/tmp/portage/sys-devel/gcc-4.3.2-r1/image/usr/lib/gcc/x86_64-pc-linux-gnu/4.3.2/libgcc_eh.a  
scanelf: Sorry, long names not yet supported; output will be incomplete for /var/tmp/portage/sys-devel/gcc-4.3.2-r1/image/usr/lib/gcc/x86_64-pc-linux-gnu/4.3.2/32/libgcc.a  
scanelf: Sorry, long names not yet supported; output will be incomplete for /var/tmp/portage/sys-devel/gcc-4.3.2-r1/image/usr/lib/gcc/x86_64-pc-linux-gnu/4.3.2/32/libgfortran.a
scanelf: Sorry, long names not yet supported; output will be incomplete for /var/tmp/portage/sys-devel/gcc-4.3.2-r1/image/usr/lib/gcc/x86_64-pc-linux-gnu/4.3.2/32/libgcc_eh.a  
scanelf: Sorry, long names not yet supported; output will be incomplete for /var/tmp/portage/sys-devel/gcc-4.3.2-r1/image/usr/lib/gcc/x86_64-pc-linux-gnu/4.3.2/32/libstdc++_pic.a
scanelf: Sorry, long names not yet supported; output will be incomplete for /var/tmp/portage/sys-devel/gcc-4.3.2-r1/image/usr/lib/gcc/x86_64-pc-linux-gnu/4.3.2/32/libsupc++.a    
scanelf: Sorry, long names not yet supported; output will be incomplete for /var/tmp/portage/sys-devel/gcc-4.3.2-r1/image/usr/lib/gcc/x86_64-pc-linux-gnu/4.3.2/32/libgcov.a      
scanelf: Sorry, long names not yet supported; output will be incomplete for /var/tmp/portage/sys-devel/gcc-4.3.2-r1/image/usr/lib/gcc/x86_64-pc-linux-gnu/4.3.2/32/libstdc++.a    
scanelf: Sorry, long names not yet supported; output will be incomplete for /var/tmp/portage/sys-devel/gcc-4.3.2-r1/image/usr/lib/gcc/x86_64-pc-linux-gnu/4.3.2/32/libmudflapth.a 
scanelf: Sorry, long names not yet supported; output will be incomplete for /var/tmp/portage/sys-devel/gcc-4.3.2-r1/image/usr/lib/gcc/x86_64-pc-linux-gnu/4.3.2/libstdc++_pic.a   
scanelf: Sorry, long names not yet supported; output will be incomplete for /var/tmp/portage/sys-devel/gcc-4.3.2-r1/image/usr/lib/gcc/x86_64-pc-linux-gnu/4.3.2/libsupc++.a       
scanelf: Sorry, long names not yet supported; output will be incomplete for /var/tmp/portage/sys-devel/gcc-4.3.2-r1/image/usr/lib/gcc/x86_64-pc-linux-gnu/4.3.2/libgcov.a         
scanelf: Sorry, long names not yet supported; output will be incomplete for /var/tmp/portage/sys-devel/gcc-4.3.2-r1/image/usr/lib/gcc/x86_64-pc-linux-gnu/4.3.2/libstdc++.a       
scanelf: Sorry, long names not yet supported; output will be incomplete for /var/tmp/portage/sys-devel/gcc-4.3.2-r1/image/usr/lib/gcc/x86_64-pc-linux-gnu/4.3.2/libmudflapth.a


Sorry if this isn't a valid bug report, but reading "output will be incomplete" I think it is, so I post it.

Reproducible: Always

Steps to Reproduce:




# emerge --info

Portage 2.2_rc20 (default/linux/amd64/2008.0, gcc-4.3.2, glibc-2.7-r2, 2.6.26-gentoo-r4 x86_64)
=================================================================
System uname: Linux-2.6.26-gentoo-r4-x86_64-AMD_Phenom-tm-_9850_Quad-Core_Processor-with-glibc2.2.5
Timestamp of tree: Sun, 28 Dec 2008 18:15:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p33
dev-java/java-config: 1.3.7-r1, 2.1.6-r1
dev-lang/python:     2.5.2-r7
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.4.8
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r2
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.28
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps y"
FEATURES="ccache distlocks fixpackages parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://ftp.belnet.be/mirror/rsync.gentoo.org/gentoo/"
LANG="it_IT.UTF-8"
LC_ALL="it_IT.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="it en"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext 3ds 64bit 7zip X Xaw3d a52 aac ace acl acpi additions aio akode alsa amd64 ao apache2 audacious audiofile autoreplace bash-completion berkdb branding bzip2 cairo cal3d caps ccache cdda cddb cdio cdparanoia cdr chardet chroot cli cpudetection cracklib crypt css cups curl dbus dga dirac directfb divx dmi double-precision dri dts dv dvb dvd dvdr dvdread ecc emovix enca encode exif expat fam fame fbcon fbdev ffmpeg fftw firefox flac flash fontconfig fortran fpx ftp gd gdbm ggi gif gimp glib glitz glut gmedia gmp gnutls gpm graphviz gs gtk gtkhtml guile gzip hal hdri history iconv id3 id3tag idea imagemagick imlib isdnlog jabber java5 java6 javascript jbig jingle jpeg jpeg2k justify kde kdrive ladspa lame lcms libcaca libffi libnotify libsamplerate lm_sensors loop-aes lzo mad matroska md5sum messenger midi mikmod mime mjpeg mmap mmx mmxext mng modplug mono motif mozdom mp2 mp3 mp4 mpeg mpeg2 mplayer msn mudflap multilib musepack musicbrainz mysql ncurses networking nls nokia6600 nptl nptlonly nsplugin ntlm nuv oav objc objc++ objc-gc offensive ogg openal openexr opengl openmp openssl pam paste64 pch pcre pdf perl physfs png ppds pppd pth python qt3 qt3support qt4 quicktime radio rar readline realmedia reflection replytolist rtc rtsp samba schroedinger scrobbler sdl sdl-image sdl-sound sdlaudio sensord session shout slang slp smp sms sndfile sockets speex spell spl sql srp srt sse sse2 sse3 ssl statistics stream svg sysfs syslog szip t1lib tcpd tetex tga theora threads tidy tiff toolbar truetype tta type1 unicode unzip usb utempter v4l v4l2 vcd vdr vorbis wav wavpack wifi winbind wma wmf wmp x264 xanim xcomposite xforms xine xml xorg xpm xprint xsl xulrunner xv xvid xvmc zip zlib" ALSA_CARDS="ca0106" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif speling status unique_id userdir usertrack vhost_alias" DVB_CARDS="usb-dib0700" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="it en" USERLAND="GNU" VIDEO_CARDS="fglrx radeon vesa vga fbdev"
Unset:  CPPFLAGS, CTARGET, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 1 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2008-12-29 02:48:35 UTC
What version of scanelf are you using? (scanelf --version)
Comment 2 Matteo Modesti 2008-12-29 05:47:10 UTC
$ scanelf --version
pax-utils-0.1.17: scanelf.c compiled Oct 12 2008
$Id: scanelf.c,v 1.189 2008/01/17 04:37:19 solar Exp $
scanelf written for Gentoo by <solar and vapier @ gentoo.org>


Should I try to upgrade pax-utils to 0.1.19?
Comment 3 SpanKY gentoo-dev 2008-12-29 09:24:10 UTC
no, i doubt it'll make a difference since i havent touched the archive code in a while, but maybe i'm wrong

try upgrading to latest pax-utils and if you still get the warning, post one of the archives as an attachment (compress it first if need be)
Comment 4 Ryan Hill (RETIRED) gentoo-dev 2008-12-30 08:10:54 UTC
Created attachment 176844 [details]
libgcov.a

this is from 0.1.17
Comment 5 SpanKY gentoo-dev 2008-12-30 08:22:14 UTC
can you try pax-utils 0.1.19 and see if that fixes the warning ?  that attachment doesnt throw any warnings when i run `scanelf -aA` on it
Comment 6 Bailey Kong 2008-12-30 10:48:07 UTC
I was also suffering from the same message, and I can confirm that upgrading pax-utils from 0.1.17 to 0.1.19 made those messages go away.

pax-utils-0.1.17:
scanelf -aA libgcov.a 
scanelf: Sorry, long names not yet supported; output will be incomplete for libgcov.a
 TYPE    PAX   PERM ENDIAN STK/REL/PTL TEXTREL RPATH BIND FILE 
ET_REL PeMRxS  LE --- --- ---    -      -    libgcov.a:_gcov.o 
ET_REL PeMRxS  LE --- --- ---    -      -    libgcov.a: 
ET_REL PeMRxS  LE --- --- ---    -      -    libgcov.a: 
ET_REL PeMRxS  LE --- --- ---    -      -    libgcov.a: 
ET_REL PeMRxS  LE --- --- ---    -      -    libgcov.a:_gcov_fork.o 
ET_REL PeMRxS  LE --- --- ---    -      -    libgcov.a:_gcov_execl.o 
ET_REL PeMRxS  LE --- --- ---    -      -    libgcov.a:_gcov_execlp.o 
ET_REL PeMRxS  LE --- --- ---    -      -    libgcov.a:_gcov_execle.o 
ET_REL PeMRxS  LE --- --- ---    -      -    libgcov.a:_gcov_execv.o 
ET_REL PeMRxS  LE --- --- ---    -      -    libgcov.a:_gcov_execvp.o 
ET_REL PeMRxS  LE --- --- ---    -      -    libgcov.a:_gcov_execve.o 
ET_REL PeMRxS  LE --- --- ---    -      -    libgcov.a: 
ET_REL PeMRxS  LE --- --- ---    -      -    libgcov.a: 
ET_REL PeMRxS  LE --- --- ---    -      -    libgcov.a: 
ET_REL PeMRxS  LE --- --- ---    -      -    libgcov.a: 
ET_REL PeMRxS  LE --- --- ---    -      -    libgcov.a: 
ET_REL PeMRxS  LE --- --- ---    -      -    libgcov.a: 
ET_REL PeMRxS  LE --- --- ---    -      -    libgcov.a:

pax-utils-0.1.19:
scanelf -aA libgcov.a 
 TYPE    PAX   PERM ENDIAN STK/REL/PTL TEXTREL RPATH BIND FILE 
ET_REL PeMRxS  LE --- --- ---    -      -    libgcov.a:_gcov.o 
ET_REL PeMRxS  LE --- --- ---    -      -    libgcov.a:_gcov_merge_add.o 
ET_REL PeMRxS  LE --- --- ---    -      -    libgcov.a:_gcov_merge_single.o 
ET_REL PeMRxS  LE --- --- ---    -      -    libgcov.a:_gcov_merge_delta.o 
ET_REL PeMRxS  LE --- --- ---    -      -    libgcov.a:_gcov_fork.o 
ET_REL PeMRxS  LE --- --- ---    -      -    libgcov.a:_gcov_execl.o 
ET_REL PeMRxS  LE --- --- ---    -      -    libgcov.a:_gcov_execlp.o 
ET_REL PeMRxS  LE --- --- ---    -      -    libgcov.a:_gcov_execle.o 
ET_REL PeMRxS  LE --- --- ---    -      -    libgcov.a:_gcov_execv.o 
ET_REL PeMRxS  LE --- --- ---    -      -    libgcov.a:_gcov_execvp.o 
ET_REL PeMRxS  LE --- --- ---    -      -    libgcov.a:_gcov_execve.o 
ET_REL PeMRxS  LE --- --- ---    -      -    libgcov.a:_gcov_interval_profiler.o 
ET_REL PeMRxS  LE --- --- ---    -      -    libgcov.a:_gcov_pow2_profiler.o 
ET_REL PeMRxS  LE --- --- ---    -      -    libgcov.a:_gcov_one_value_profiler.o 
ET_REL PeMRxS  LE --- --- ---    -      -    libgcov.a:_gcov_indirect_call_profiler.o 
ET_REL PeMRxS  LE --- --- ---    -      -    libgcov.a:_gcov_average_profiler.o 
ET_REL PeMRxS  LE --- --- ---    -      -    libgcov.a:_gcov_ior_profiler.o 
ET_REL PeMRxS  LE --- --- ---    -      -    libgcov.a:_gcov_merge_ior.o
Comment 7 SpanKY gentoo-dev 2008-12-30 11:46:27 UTC
then the issue is fixed in 0.1.19 ... it'll go stable
Comment 8 SpanKY gentoo-dev 2008-12-30 12:06:12 UTC
looking at the history, grobian implemented extended name support in november.  so you can thank him.
Comment 9 Matteo Modesti 2008-12-30 16:29:32 UTC
I can confirm that upgrading to pax-utils 0.1.19 solved the issue: I hope it'll go stable soon.
Thanks