Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 252721 (linux-headers-2.6.28) - Many packages don't compile with linux-headers-2.6.28: /usr/include/linux/serial.h:164: error: expected specifier-qualifier-list before ‘__u32’
Summary: Many packages don't compile with linux-headers-2.6.28: /usr/include/linux/ser...
Status: RESOLVED FIXED
Alias: linux-headers-2.6.28
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Toolchain Maintainers
URL:
Whiteboard:
Keywords:
: 252758 252759 252789 252796 252803 252804 252805 252968 252969 253019 253047 255726 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-12-27 18:05 UTC by giovanni.bobbio
Modified: 2009-02-02 18:39 UTC (History)
13 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description giovanni.bobbio 2008-12-27 18:05:32 UTC
i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I..  -DDATADIR=\"/usr/share\" -DLOCALEDIR=\"/usr/share/locale\"   -O2 -march=native -pipe -MT fgconsole.o -MD -MP -MF .deps/fgconsole.Tpo -c -o fgconsole.o fgconsole.c                                                                                 
In file included from fgconsole.c:9:                                                             
/usr/include/linux/serial.h:164: error: expected specifier-qualifier-list before ‘__u32’         
make[2]: *** [fgconsole.o] Error 1                                                               
make[2]: *** Waiting for unfinished jobs....                                                     
mv -f .deps/kbdrate.Tpo .deps/kbdrate.Po                                                         
mv -f .deps/psfxtable.Tpo .deps/psfxtable.Po                                                     
make[2]: Leaving directory `/var/tmp/portage/sys-apps/kbd-1.15/work/kbd-1.15/src'                
make[1]: *** [all-recursive] Error 1                                                             
make[1]: Leaving directory `/var/tmp/portage/sys-apps/kbd-1.15/work/kbd-1.15'                    
make: *** [all] Error 2
 *
 * ERROR: sys-apps/kbd-1.15 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 2041:  Called die
 * The specific snippet of code:
 *       emake || die
 *  The die message:
 *   (no error message)
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/sys-apps/kbd-1.15/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-apps/kbd-1.15/temp/environment'.
 *


Reproducible: Always




kien ~ # emerge --info                                       
Portage 2.1.6.3 (default/linux/x86/2008.0/desktop, gcc-4.3.2, glibc-2.9_p20081201-r1, 2.6.28-gentoo i686)                                                                                         
=================================================================                                
System uname: Linux-2.6.28-gentoo-i686-Intel-R-_Core-TM-2_Duo_CPU_T7700_@_2.40GHz-with-glibc2.0  
Timestamp of tree: Sat, 27 Dec 2008 11:35:01 +0000                                               
app-shells/bash:     3.2_p48                                                                     
dev-java/java-config: 1.3.7-r1, 2.1.6-r1                                                         
dev-lang/python:     2.5.2-r8                                                                    
dev-util/cmake:      2.6.2                                                                       
sys-apps/baselayout: 2.0.0                                                                       
sys-apps/openrc:     0.4.1                                                                       
sys-apps/sandbox:    1.3.2                                                                       
sys-devel/autoconf:  2.13, 2.63                                                                  
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2                                   
sys-devel/binutils:  2.19                                                                        
sys-devel/gcc-config: 1.4.0-r4                                                                   
sys-devel/libtool:   2.2.6a                                                                      
virtual/os-headers:  2.6.28                                                                      
ACCEPT_KEYWORDS="x86 ~x86"                                                                       
CBUILD="i686-pc-linux-gnu"                                                                       
CFLAGS="-O2 -march=native -pipe"                                                                 
CHOST="i686-pc-linux-gnu"                                                                        
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"                                                                          
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"                                                                                                
CXXFLAGS="-O2 -march=native -pipe"                                                               
DISTDIR="/usr/portage/distfiles"                                                                 
EMERGE_DEFAULT_OPTS="--with-bdeps y --reinstall changed-use --keep-going --jobs=2"               
FEATURES="ccache distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"                                                                             
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"                                                                                             
LANG="en_US.utf8"                                                                                
LDFLAGS="-Wl,-O1"                                                                                
LINGUAS="en it"                                                                                  
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X aac acl acpi alsa amarok bash-completion berkdb bluetooth branding bzip2 cairo cddb cdparanoia cdr cli cracklib crypt cups dbus dri dvd dvdr dvdread embedded emboss encode esd fam firefox gd gdbm gif git gnokii gpm hal hddtemp history iconv id3tag idn imap imlib ipod irc isdnlog java javascript jpeg kde kdepim libnotify live lm_sensors mad matroska midi mikmod mmx mmxext mp3 mpeg mudflap musicbrainz ncurses nls nowlistening nptl nptlonly nsplugin nvidia obex offensive ogg opengl openmp pam pcre pda pdf perl plasma png ppds pppd psyco python qt3 qt3support qt4 quicktime rdesktop readline reflection sdl sensord session sms spell spl srt sse sse2 ssl ssse3 startup-notification subversion svg symlink sysfs texteffect tiff truetype type1 unicode usb userlocales vcd vorbis webpresence wifi win32codecs x86 xcomposite xine xml xorg xosd xrandr xulrunner xv xvidyahoo zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="*" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en it" USERLAND="GNU" VIDEO_CARDS="nvidia vesa"
Unset:  CPPFLAGS, CTARGET, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 1 giovanni.bobbio 2008-12-27 18:26:58 UTC
The same issue affects hal-0.5.11-r4
Comment 2 Rafał Mużyło 2008-12-27 23:15:13 UTC
In linux-headers 2.6.28, linux/serial.h is broken.
It should include <linux/types.h>,
but does that only during kernel build.
Comment 3 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2008-12-28 00:59:03 UTC
*** Bug 252758 has been marked as a duplicate of this bug. ***
Comment 4 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2008-12-28 00:59:49 UTC
*** Bug 252759 has been marked as a duplicate of this bug. ***
Comment 5 Rafał Mużyło 2008-12-28 15:40:40 UTC
*** Bug 252796 has been marked as a duplicate of this bug. ***
Comment 6 Rafał Mużyło 2008-12-28 15:44:19 UTC
*** Bug 252805 has been marked as a duplicate of this bug. ***
Comment 7 Diego Elio Pettenò (RETIRED) gentoo-dev 2008-12-28 15:44:21 UTC
*** Bug 252789 has been marked as a duplicate of this bug. ***
Comment 8 Diego Elio Pettenò (RETIRED) gentoo-dev 2008-12-28 15:44:25 UTC
*** Bug 252803 has been marked as a duplicate of this bug. ***
Comment 9 Diego Elio Pettenò (RETIRED) gentoo-dev 2008-12-28 15:44:29 UTC
*** Bug 252804 has been marked as a duplicate of this bug. ***
Comment 10 Ryan Stevenson 2008-12-28 18:30:43 UTC
Editing /usr/include/linux/serial.h worked fine to enable the emerge of any packages that refered to it.

edited the top of serial.h to this:

#ifndef _LINUX_SERIAL_H
#define _LINUX_SERIAL_H

#include <linux/types.h>

everything below was left as normal.  Will be doing the same on another machine to test results. Not a true fix, but a good workaround.
Comment 11 Oschtan 2008-12-28 23:26:31 UTC
Similarly
~Amd64
Also, x11-libs/gtk+:2, dev-python/pygobject, dev-lang/php, dev-libs/glib...
And nonremovable error configure for all packages:
 checking command to parse /usr/bin/nm -B output from x86_64-pc-linux-gnu-gcc object...failed
Comment 12 Azamat H. Hackimov 2008-12-29 05:47:58 UTC
(In reply to comment #10)
> Editing /usr/include/linux/serial.h worked fine to enable the emerge of any
> packages that refered to it.

Here also patch from Ubuntu team:

http://launchpadlibrarian.net/20136526/0001-serial-RS485-ioctl-structure-uses-__u32-include-lin.patch
Comment 14 Rafał Mużyło 2008-12-29 10:17:29 UTC
*** Bug 252969 has been marked as a duplicate of this bug. ***
Comment 15 Rafał Mużyło 2008-12-29 10:18:11 UTC
*** Bug 252968 has been marked as a duplicate of this bug. ***
Comment 16 Lars Wendler (Polynomial-C) gentoo-dev 2008-12-29 20:23:04 UTC
*** Bug 253019 has been marked as a duplicate of this bug. ***
Comment 17 Rafał Mużyło 2008-12-29 21:08:10 UTC
*** Bug 253047 has been marked as a duplicate of this bug. ***
Comment 18 SpanKY gentoo-dev 2009-01-21 08:40:22 UTC
*** Bug 255726 has been marked as a duplicate of this bug. ***
Comment 19 Ramin 2009-02-02 18:39:12 UTC
Would anyone mind hard-masking
linux-headers-2.6.28
?