Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 252603 - media-video/xfmedia-0.9.2-r2 - Does not display avi video formats
Summary: media-video/xfmedia-0.9.2-r2 - Does not display avi video formats
Status: VERIFIED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High minor (vote)
Assignee: XFCE Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-12-26 14:36 UTC by Bruno
Modified: 2009-10-15 09:16 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bruno 2008-12-26 14:36:02 UTC
Every time I try to play a avi file the xfmedia only displays a white rectangle with a black line on the middle. After running that on terminal, I got the following lines:

[mpeg4 @ 0x15b4e90]Invalid and inefficient vfw-avi packed B frames detected
[mpeg4 @ 0x15b4e90]Invalid and inefficient vfw-avi packed B frames detected
[mpeg4 @ 0x15b4e90]Invalid and inefficient vfw-avi packed B frames detected

And so goes. I got perfect audio, but no video display.

Reproducible: Always

Steps to Reproduce:
1.emerge xine-lib
2.emerge xfmedia
3.execute xfmedia

Actual Results:  
No video

Expected Results:  
Video display

bruno@bruno ~ $ emerge --info
Portage 2.1.6.1 (default/linux/amd64/2008.0/desktop, gcc-4.1.2, glibc-2.6.1-r0, 2.6.27-gentoo-r3 x86_64)
=================================================================
System uname: Linux-2.6.27-gentoo-r3-x86_64-AMD_Athlon-tm-_64_X2_Dual_Core_Processor_4200+-with-glibc2.2.5
Timestamp of tree: Sat, 20 Dec 2008 20:15:02 +0000
app-shells/bash:     3.2_p33
dev-java/java-config: 1.3.7-r1, 2.1.6-r1
dev-lang/python:     2.5.2-r7
dev-python/pycrypto: 2.0.1-r6
dev-util/cmake:      2.6.2
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r2
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=k8 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=k8 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://ftp.las.ic.unicamp.br/pub/gentoo ftp://mirrors.localhost.net.ar/pub/mirrors/gentoo ftp://ftp.las.ic.unicamp.br/pub/gentoo/ http://www.las.ic.unicamp.br/pub/gentoo/"
LANG="pt_BR.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="en pt_BR"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.samerica.gentoo.org/gentoo-portage"
USE="3dnow X a52 aac acl acpi alsa amd64 ao apache2 berkdb bluetooth branding bzip2 cairo cdr cli cracklib crypt cups dbus dvd dvdr dvdread eds emboss encode esd evo fam ffmpeg firefox flac fontconfig fortran gdbm gif gpm gstreamer gtk hal iconv ipv6 isdnlog java java6 javascript jpeg ldap libnotify mad midi mikmod mmx mozilla mp3 mpeg mplayer mudflap multilib mysql ncurses nls nptl nptlonly nsplugin opengl openmp pam pcre pdf perl php png ppds pppd python qt3support quicktime readline reflection sdl session spell spl sse sse2 ssl startup-notification svg sysfs tcpd tiff truetype unicode usb vorbis x264 xcb xfce xml xorg xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en pt_BR" USERLAND="GNU" VIDEO_CARDS="fbdev glint i810 intel mach64 mga neomagic nv r128 radeon savage sis tdfx trident vesa vga via vmware voodoo"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Jeroen Roovers (RETIRED) gentoo-dev 2008-12-26 17:04:11 UTC
(In reply to comment #0)
> Every time I try to play a avi file the xfmedia only displays a white rectangle
> with a black line on the middle. After running that on terminal, I got the
> following lines:
> 
> [mpeg4 @ 0x15b4e90]Invalid and inefficient vfw-avi packed B frames detected
> [mpeg4 @ 0x15b4e90]Invalid and inefficient vfw-avi packed B frames detected
> [mpeg4 @ 0x15b4e90]Invalid and inefficient vfw-avi packed B frames detected

These are harmless media-video/ffmpeg warnings. Nothing to do with your missing video output.
Comment 2 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2008-12-28 16:39:19 UTC
Hm, can you play an avi with other applications? Try mplayer.
Comment 3 Bruno 2008-12-28 21:15:43 UTC
(In reply to comment #2)
> Hm, can you play an avi with other applications? Try mplayer.
> 

Yes I can play with another players, but I want to full tweak my desktop to XFCE, and I know that everyone can run AVI with xfmedia but me...
Comment 4 Sasha Medvedev 2009-05-01 08:42:50 UTC
I resolve this problem and other video relayted from bugs.xfce.org by using -O0 in CFLAGS insted of -02. So PLEASE add warning messege or change CFLAGS in xfmedia ebuild. 
Comment 5 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-05-09 05:22:44 UTC
(In reply to comment #4)
> I resolve this problem and other video relayted from bugs.xfce.org by using -O0
> in CFLAGS insted of -02. So PLEASE add warning messege or change CFLAGS in
> xfmedia ebuild. 
> 

Wow..that is....odd. Got a reference from bugzilla.xfce.org to show us? Thanks for tracking this down!!
Comment 6 Bruno 2009-05-09 20:06:57 UTC
(In reply to comment #4)
> I resolve this problem and other video relayted from bugs.xfce.org by using -O0
> in CFLAGS insted of -02. So PLEASE add warning messege or change CFLAGS in
> xfmedia ebuild. 
> 

Not Really... I just recompiled, and stil... The problem persists...
Comment 7 Sasha Medvedev 2009-05-12 09:21:01 UTC
Strange. My CFLAGS ,CHOST and USE variable is
CFLAGS="-O0 -march=pentium3 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
USE="dbus startup-notification -debug -taglib"
Comment 8 David BRIWA 2009-07-01 19:15:36 UTC
in first sorry i'm very very bad in english,

i have find a workaround for the crash of xfmedia for the video window too wide or the crash for avi format...

i have compiled xfmedia with 

USE="-dbus -startup-notification" emerge -av xfmedia

and now xfmedia play avi in a normal window and not crash

cheer 

Davidou2a
Comment 9 Samuli Suominen (RETIRED) gentoo-dev 2009-08-08 17:13:05 UTC
xfmedia has been broken with video files for years. only use it as sound player, thanks.
Comment 10 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-08-21 18:23:52 UTC
(In reply to comment #9)
> xfmedia has been broken with video files for years. only use it as sound
> player, thanks.
> 

Ah, it looks like this is a known issue even.

	elog "${PN} is known to crash when playing video files, please report"
	elog "bugs directly to http://bugs.xfce.org, under ${PN} product."
Comment 11 Dmitry Kustov 2009-10-15 08:19:52 UTC
(In reply to comment #8)
> i have compiled xfmedia with 
> 
> USE="-dbus -startup-notification" emerge -av xfmedia
> 
> and now xfmedia play avi in a normal window and not crash
> 
Have the same problem: I don't see any video. Recompiled ffmpeg and xine - no effect.
Tried
emerge xfmedia
USE="-dbus -startup-notification" emerge xfmedia
USE="-startup-notification" emerge xfmedia
USE="-dbus" emerge xfmedia
no help.
Comment 12 Samuli Suominen (RETIRED) gentoo-dev 2009-10-15 09:16:12 UTC
(In reply to comment #11)
> Have the same problem: I don't see any video. Recompiled ffmpeg and xine - no
> effect.

Don't even waste your time with xfmedia, it's not maintained by upstream anymore. Unless you have patches.

The new Xfce4's media player is media-video/parole