Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 252486 - x11-drivers/xf86-video-intel-2.5.1-r1: (EE) intel(0): Failed to pin back buffer: Cannot allocate memory
Summary: x11-drivers/xf86-video-intel-2.5.1-r1: (EE) intel(0): Failed to pin back buff...
Status: RESOLVED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High major (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-12-25 15:48 UTC by Andrey Batyiev
Modified: 2009-01-27 21:28 UTC (History)
8 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
xorg.conf (xorg.conf,15.12 KB, text/plain)
2008-12-25 15:52 UTC, Andrey Batyiev
Details
Xorg.0.log (Xorg.0.log,16.35 KB, text/plain)
2008-12-25 16:22 UTC, Andrey Batyiev
Details
Xorg.log (Xorg.0.log,15.68 KB, text/plain)
2008-12-26 16:22 UTC, Andy Gebauer
Details
LIBGL_DEBUG=1 glxinfo (glxinfo,7.18 KB, text/plain)
2009-01-13 10:10 UTC, Andrey Batyiev
Details
Xorg.0.log containing error message(s) (Xorg.0.log,15.48 KB, text/plain)
2009-01-23 21:03 UTC, Konstantin Münning
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Batyiev 2008-12-25 15:48:00 UTC
I updated xorg-server to 1.5.3 and xf86-video-intel to 2.5.1-r1. Now I get in /var/log/Xorg.0.log:

(==) intel(0): Backing store disabled
(==) intel(0): Silken mouse enabled
(II) intel(0): Initializing HW Cursor
(II) intel(0): [DRI] installation complete
(II) intel(0): xf86BindGARTMemory: bind key 0 at 0x05072000 (pgoffset 20594)
(II) intel(0): xf86BindGARTMemory: bind key 1 at 0x0e000000 (pgoffset 57344)
(EE) intel(0): Failed to pin back buffer: Cannot allocate memory

Fatal server error:
Couldn't bind memory for BO back buffer

(II) intel(0): xf86UnbindGARTMemory: unbind key 0
(II) intel(0): xf86UnbindGARTMemory: unbind key 1

Backtrace:
0: /usr/bin/X(xorg_backtrace+0x33) [0x8100c8b]
1: /usr/bin/X(xf86SigHandler+0x75) [0x80ac515]
2: [0xb7fcc400]
3: /usr/lib/xorg/modules/drivers//intel_drv.so [0xb7b24f22]
4: /usr/bin/X(AbortDDX+0x75) [0x80987c7]
5: /usr/bin/X(AbortServer+0x2b) [0x8108f3a]
6: /usr/bin/X(FatalError+0x6f) [0x81093a2]
7: /usr/lib/xorg/modules/drivers//intel_drv.so(i830_bind_all_memory+0xdf) [0xb7b2a162]
8: /usr/lib/xorg/modules/drivers//intel_drv.so [0xb7b2565e]
9: /usr/lib/xorg/modules/drivers//intel_drv.so [0xb7b26c02]
10: /usr/bin/X(AddScreen+0x151) [0x806df43]
11: /usr/bin/X(InitOutput+0xd30) [0x8099c31]
12: /usr/bin/X(main+0x2e3) [0x806e668]
13: /lib/libc.so.6(__libc_start_main+0xe3) [0xb7bf0fd3]

FatalError re-entered, aborting
Caught signal 11.  Server aborting


Installed:
x11-base/xorg-server-1.5.3
media-libs/mesa-7.2
x11-drivers/xf86-video-intel-2.5.1-r1
x11-libs/libdrm-2.4.1


Reproducible: Always

Steps to Reproduce:
1. Unmask and emerge =xorg-server-1.5.3
2. Reemerge =xf86-video-intel-2.5.1-r1 (due to bug 243252)
3. Restart X

Actual Results:  
System locked and not respond to keyboard input. Only way to communicate is ssh.

Expected Results:  
Get Xorg working.

Portage 2.2_rc16 (default/linux/x86/2008.0, gcc-4.1.2, glibc-2.6.1-r0, 2.6.28 i686)
=================================================================
System uname: Linux-2.6.28-i686-Intel-R-_Core-TM-2_Duo_CPU_T5670_@_1.80GHz-with-glibc2.0
Timestamp of tree: Thu, 25 Dec 2008 13:30:01 +0000
app-shells/bash:     3.2_p33
dev-java/java-config: 1.3.7-r1, 2.1.6
dev-lang/python:     2.5.2-r7
dev-util/cmake:      2.6.2
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.3.0-r1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r2
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.25-r4
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-Os -mtune=prescott -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/4.1/env /usr/kde/4.1/share/config /usr/kde/4.1/shutdown /usr/share/config /var/bind"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-Os -mtune=prescott -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks noinfo parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="ru_RU.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="ru"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X acpi alsa bash-completion berkdb bluetooth bzip2 cli cracklib crypt cups custom-optimization dbus dri dvd gdbm gif glibc-omitfp gpm hal iconv isdnlog jpeg kde kdeprefix latex mesa midi mmx mudflap ncurses nls nptl nptlonly ogg openal opengl openmp pam pcmcia pcre perl png pppd python qt3 qt4 readline reflection samba session spl sse sse2 ssl ssse3 startup-notification svg sysfs syslog tcpd theora truetype unicode vim-syntax vorbis wifi x86 xcb xcomposite xft xinerama xorg xv zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="ru" USERLAND="GNU" VIDEO_CARDS="intel"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Andrey Batyiev 2008-12-25 15:52:28 UTC
Created attachment 176355 [details]
xorg.conf
Comment 2 Andrey Batyiev 2008-12-25 16:22:45 UTC
Created attachment 176357 [details]
Xorg.0.log
Comment 3 Andy Gebauer 2008-12-26 16:22:39 UTC
Created attachment 176442 [details]
Xorg.log

Same problem here: Intel 855GM.
No xorg.conf, only hal based system.

xorg-server: 1.5.3
xf86-video-intel: 2.5.1-r1
media-libs/mesa: 7.2
x11-libs/libdrm: 2.4.1
gentoo-sources: 2.6.28

System is complete new builded with emere --emptytree world
Comment 4 Andy Gebauer 2008-12-26 16:26:30 UTC
Bug is also known by Xorg devs: https://bugs.freedesktop.org/show_bug.cgi?id=18974
Comment 5 Andy Gebauer 2008-12-26 16:30:32 UTC
Possible solutions from https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/304871

- Downgrade to kernel to 2.6.27
- Add NoAccel to your xorg.com

As I have no accel with 2.6.27 also, I think this is only a help to use the system, not to solve this issue
Comment 6 Harris Landgarten 2009-01-10 04:42:15 UTC
I ran into a similar problem. I found that intelfb.ko was no loading automatically. After modprobing it Xorg starts normally. 
Comment 7 Andy Gebauer 2009-01-10 10:36:56 UTC
(In reply to comment #6)
> I ran into a similar problem. I found that intelfb.ko was no loading
> automatically. After modprobing it Xorg starts normally. 
> 

I'm not completly sure, but in my knowledge intelfb is the module for the intel framebuffer. But most people will use the stable vesa framebuffer as far as I know.

Can you check, if you have hardware accelerated opengl?
Comment 8 Rémi Cardona gentoo-dev 2009-01-10 10:48:13 UTC
Please don't use intelfb. For the moment, it competes with the intel driver. In future kernel, it will be fixed to use the DRM driver if available.

vesafb or uvesafb should be safer to use as they only bang on "standard" VGA registers.

But for now, it's best not to use any if you don't need a framebuffer console. Please try to disable all framebuffer drivers (at least temporarily).

Thanks
Comment 9 Andrey Batyiev 2009-01-12 21:02:23 UTC
I have upgraded kernel to lastest git (nearly 2.6.29-rc1). Now X server works, glxinfo says "direct rendering: Yes", but glxgears shows 280 fps, 4 times slower than default (1100 fps).
Comment 10 Rémi Cardona gentoo-dev 2009-01-12 23:14:14 UTC
glxgears is *not* a benchmarking tool. Its *only* use is to see if direct rendering works or not, no more, no less.

Please test with *real* applications to compare frame rates.

Closing fixed then.

Thanks
Comment 11 Andrey Batyiev 2009-01-12 23:44:08 UTC
(In reply to comment #10)
> Please test with *real* applications to compare frame rates.

Ok, I tried to run Tremulous game and got huge fps drop: from 90 to 1, even game's menu moves sharply.
Comment 12 Rémi Cardona gentoo-dev 2009-01-13 07:34:46 UTC
Could you please attach the full output of `LIBGL_DEBUG=1 glxinfo`?

Thanks
Comment 13 R Stephan 2009-01-13 08:26:35 UTC
To clear this up:

I guess this bug is still about the intel issue where the
only solution would be to add Option "NoAccel" "true" to
the Driver section.

So, please open a new bug for any frame buffer issue.
Comment 14 Andy Gebauer 2009-01-13 08:56:20 UTC
(In reply to comment #13)
> To clear this up:
> 
> I guess this bug is still about the intel issue where the
> only solution would be to add Option "NoAccel" "true" to
> the Driver section.
> 
> So, please open a new bug for any frame buffer issue.
> 
To disable the direct rendering is no solution.
In kernel 2.6.29 the graphics infrastructur is improved. Therefore, let us wait for tests with the git kernel.
Comment 15 Rémi Cardona gentoo-dev 2009-01-13 09:23:05 UTC
You might want to try set the "Legacy3D" option to "false" in your Device section.

Please don't try 2.6.29-rc* yet, if there's a bug with 2.6.28, it needs to be identified and fixed.

Thanks
Comment 16 Andy Gebauer 2009-01-13 09:27:25 UTC
> if there's a bug with 2.6.28, it needs to be
> identified and fixed.

Problem may be, that the infrastructur, mainly the memory manager and kernel mode line settings are not implemented completly in 2.6.28.
I'm not sure if it's worth the effort to backport these patches.
Comment 17 Rémi Cardona gentoo-dev 2009-01-13 09:36:54 UTC
(In reply to comment #16)
> > if there's a bug with 2.6.28, it needs to be
> > identified and fixed.
> 
> Problem may be, that the infrastructur, mainly the memory manager and kernel
> mode line settings are not implemented completly in 2.6.28.

The memory manager is complete and should work on all supported chips. KMS is a whole other issue, one that is far from being ready. Let's stick with the bug at hand before fixing the rest of the world.

Thanks
Comment 18 Andrey Batyiev 2009-01-13 10:10:07 UTC
Created attachment 178335 [details]
LIBGL_DEBUG=1 glxinfo

(In reply to comment #12)
> Could you please attach the full output of `LIBGL_DEBUG=1 glxinfo`?
Comment 19 Andrey Batyiev 2009-01-13 10:11:39 UTC
(In reply to comment #15)
> You might want to try set the "Legacy3D" option to "false" in your Device
> section.
> 
> Please don't try 2.6.29-rc* yet, if there's a bug with 2.6.28, it needs to be
> identified and fixed.

Setting "Legacy3D" option to "false" doesn't help on 2.6.28.
Comment 20 Rémi Cardona gentoo-dev 2009-01-13 10:15:42 UTC
"Doesn't help", guys, I'm lost. I have no idea what bug you guys are having.

Please explain again what bug you guys are having.

Thanks
Comment 21 Andrey Batyiev 2009-01-13 10:29:09 UTC
(In reply to comment #20)
> Please explain again what bug you guys are having.

Ok, it's bug in connection between xf86-video-intel and kernel. x11-drivers/xf86-video-intel-2.5.1-r1 (lastest stable) simply doesn't work with 2.6.28 kernel (also lastest stable).

Lastest git kernel sources (2.6.29-rc1) can be used as workaround for this bug, but there is huge performance loss either.
Comment 22 Rémi Cardona gentoo-dev 2009-01-13 11:57:35 UTC
(In reply to comment #21)
> (In reply to comment #20)
> > Please explain again what bug you guys are having.
> 
> Ok, it's bug in connection between xf86-video-intel and kernel.
> x11-drivers/xf86-video-intel-2.5.1-r1 (lastest stable) simply doesn't work with
> 2.6.28 kernel (also lastest stable).

It should, have you tried the Legacy3D option like I suggested earlier? If you do use it, mesa 7.2 won't be able to do any sort of acceleration (it's a known limitation, I should have pointed that out)

> Lastest git kernel sources (2.6.29-rc1) can be used as workaround for this bug,
> but there is huge performance loss either.

Again, if you somehow end up using the software renderer (even if glxinfo says you're using direct rendering), then it'll be of course very slow.

Now, if you want/need opengl acceleration, you should use the x11 overlay (available through layman).

With this overlay, you'll get release candidates for -intel 2.6 and mesa 7.4 which have been tested and fixed for GEM operation. Those packages will hit portage within the next couple of weeks, but the sooner you test them, the sooner you can report bugs.

Phew :)

Thanks
Comment 23 Andrey Batyiev 2009-01-13 12:09:09 UTC
(In reply to comment #22)
> (In reply to comment #21)
> > (In reply to comment #20)
> > > Please explain again what bug you guys are having.
> > 
> > Ok, it's bug in connection between xf86-video-intel and kernel.
> > x11-drivers/xf86-video-intel-2.5.1-r1 (lastest stable) simply doesn't work with
> > 2.6.28 kernel (also lastest stable).
> 
> It should, have you tried the Legacy3D option like I suggested earlier? If you
> do use it, mesa 7.2 won't be able to do any sort of acceleration (it's a known
> limitation, I should have pointed that out)

        Option      "Legacy3D" "false"

> > Lastest git kernel sources (2.6.29-rc1) can be used as workaround for this bug,
> > but there is huge performance loss either.
> 
> Again, if you somehow end up using the software renderer (even if glxinfo says
> you're using direct rendering), then it'll be of course very slow.
> 
> Now, if you want/need opengl acceleration, you should use the x11 overlay
> (available through layman).
> 
> With this overlay, you'll get release candidates for -intel 2.6 and mesa 7.4
> which have been tested and fixed for GEM operation. Those packages will hit
> portage within the next couple of weeks, but the sooner you test them, the
> sooner you can report bugs.

Ok, should i update mesa too?

> Phew :)

:)
Comment 24 Rémi Cardona gentoo-dev 2009-01-13 13:08:14 UTC
(In reply to comment #23)
> Ok, should i update mesa too?

Yes, please update all unmasked packages provided by the x11 overlay.

Thanks
Comment 25 Nick Hadaway 2009-01-16 01:25:19 UTC
http://intellinuxgraphics.org/2008Q4.html

After adding ebuilds for the mesa, libdrm, and xf86-video-intel packages referenced on this page, my 855GM started working much better.  I can play doom3 (albeit slowly) on this laptop for the first time ever.  It seems to be that the display problems in 2D mode and 3D mode have been addressed in a very positive way and the display anomalies that I had noticed before seem to be gone.
Comment 26 Rémi Cardona gentoo-dev 2009-01-16 10:16:41 UTC
(In reply to comment #25)
> After adding ebuilds for the mesa, libdrm, and xf86-video-intel packages
> referenced on this page,

Could you please try the ebuilds we provide in the x11 overlay instead?

Thanks
Comment 27 R Stephan 2009-01-17 17:38:29 UTC
> Could you please try the ebuilds we provide in the x11 overlay instead?

I'm not the person you asked but I want to report that your ebuilds solve
the problems with my 855GM card (Centrino mainboard). I've tested DOOM2, other games, Firefox with flash and videos using xine, and no crash so far. Needless to say it's faster than with NoAccel. And this is all with a 2.6.22 kernel, so I'm looking forward to my first GEM kernel, with further speed gains, I guess.

Finally, this old but fine hardware is used optimally. A shame otherwise. Thanks!

PS: you said get mesa-7.4 but the overlay shows only 7.3_rc2 which was what I tested
Comment 28 Nick Hadaway 2009-01-19 17:13:14 UTC
I went to making my own ebuilds and following the suggested package versions mentioned on intellinuxgraphics.org for the 2008Q4 driver package because I could not get a working xserver from the x11 overlay.

I was utilizing the git builds to attempt to get a working configuration out of my 855GM.  After trying for a day or 2 with various combinations of git builds and point releases I got frustrated and made my own.  Nothing special needed to be done, just account for different file names/versions as suggested on the web intel web page.

I will happily test x11 overlay builds if you need verification.  I need to know what builds of what packages you specifically would like me to use as git builds crash my system with no logging output at all.
Comment 29 Rémi Cardona gentoo-dev 2009-01-19 17:50:21 UTC
Don't use any of the -9999 ebuilds. Just add the x11 overlay and emerge -DuN @world.

Thanks
Comment 30 Konstantin Münning 2009-01-23 21:03:17 UTC
Created attachment 179476 [details]
Xorg.0.log containing error message(s)

Just tried x11 overlay and it does not work with vanilla-sources-2.6.28.1. With 2.6.27.8 X starts and glxgears works the same as with xf86-video-intel-2.5.1-r1. The needed/installed packages out of the overlay were only these:

x11-drivers/xf86-video-intel-2.6.1
x11-libs/libdrm-2.4.4
x11-proto/dri2proto-1.99.3

Do I need to take some more out of the overlay or to re-emerge something?
Comment 31 Rémi Cardona gentoo-dev 2009-01-25 16:36:05 UTC
@all,

1) please add the x11 overlay using "layman"
2) please emerge or reemerge _in_that_order_
 - dri2proto
 - libdrm
 - mesa
 - xorg-server
 - xf86-video-intel

The order *really* matters.

If you still have issues with all that and a stable kernel, please use this kernel instead :
 - cd /usr/src
 - git clone git://git.kernel.org/pub/scm/linux/kernel/git/anholt/drm-intel
 - cd drm-intel
 - git checkout -t origin/drm-intel-2.6.28 -b drm-intel-2.6.28

And if with that kernel, you still have issues, please read this document (http://intellinuxgraphics.org/how_to_report_bug.html) on how to file a bug over at FreeDesktop to Intel devs.

If you do open bugs there, please add "remi@gentoo.org" as a CC on them so I can keep track of the problems.

Thanks
Comment 32 Andrey Batyiev 2009-01-25 20:52:05 UTC
(In reply to comment #31)
> 1) please add the x11 overlay using "layman"
> 2) please emerge or reemerge _in_that_order_

wow, it's not perfect (nearly 30fps in Tremulous, was 90fps), but it's at least starting up and hardware 3D is online.
Comment 33 Konstantin Münning 2009-01-25 22:29:34 UTC
(In reply to comment #31)

Here my status report. This made no difference. The resulting Xorg.0.log was (almost) identical to the one I already uploaded.

> 2) please emerge or reemerge _in_that_order_
>  - dri2proto
>  - libdrm
>  - mesa
>  - xorg-server
>  - xf86-video-intel
> 
> The order *really* matters.

The versions I now have are:

x11-proto/dri2proto-1.99.3
x11-libs/libdrm-2.4.4
media-libs/mesa-7.3
x11-base/xorg-server-1.5.3-r1
x11-drivers/xf86-video-intel-2.6.1

where only mesa and xf86-video-intel are out of the overlay. The others (like dri2proto were the masked 9999-versions as said in comment #31) are out of regular portage. They were reemerged (mesa-7.3 was an upgrade) exactly in the specified order.

> If you still have issues with all that and a stable kernel, please use this
> kernel instead :
>  - cd /usr/src
>  - git clone git://git.kernel.org/pub/scm/linux/kernel/git/anholt/drm-intel
>  - cd drm-intel
>  - git checkout -t origin/drm-intel-2.6.28 -b drm-intel-2.6.28

I'll try this kernel sometime later and will report the results. 

Again the remaining details in short, I tried vanilla kernel 2.6.28.1, it's working with 2.6.27.8, am using no framebuffer and the error message is:

(EE) intel(0): Failed to pin front buffer: Cannot allocate memory

Fatal server error:
Couldn't bind memory for BO front buffer
Comment 34 Andrey Batyiev 2009-01-25 22:48:32 UTC
(In reply to comment #33)
> The versions I now have are:
> 
> x11-proto/dri2proto-1.99.3
> x11-libs/libdrm-2.4.4
> media-libs/mesa-7.3
> x11-base/xorg-server-1.5.3-r1
> x11-drivers/xf86-video-intel-2.6.1
> 

My case differs from yours only in x11-libs/libdrm-2.4.3 and x11-base/xorg-server-1.5.99.901. Try to upgrade xorg-server.
Comment 35 Franz Glauber Vanderlinde 2009-01-26 20:17:13 UTC
I followed comment #31 (http://bugs.gentoo.org/show_bug.cgi?id=252486#c31) as well, but I only had a major diference in performance (according to glxgears) after using the different kernel. I have a 945GM, it was around 170fps and now it's ~340fps.

However, this is still far from what is expected from this card, I think. Anyone got any more ideas?
Comment 36 Konstantin Münning 2009-01-26 23:49:35 UTC
(In reply to comment #34)

> My case differs from yours only in x11-libs/libdrm-2.4.3 and
> x11-base/xorg-server-1.5.99.901. Try to upgrade xorg-server.

Upgrading xorg-server did not make a difference. But I think I found the reason for the failure. Kernel module i915 has some problem, as seen in kernel messages:

[drm:i915_gem_object_bind_to_gtt] *ERROR* GTT full, but LRU list empty

and later but I think unrelated to the primary faulure of X:
[drm:i915_gem_object_pin] *ERROR* Failure to bind: -12

I tried the git-kernel but there was no difference - same error message.

So something is wrong with the i915 kernel module on my hardware. Where to report this bug?
Comment 37 Rémi Cardona gentoo-dev 2009-01-27 07:14:59 UTC
(In reply to comment #36)
> So something is wrong with the i915 kernel module on my hardware. Where to
> report this bug?

I've explained that bit back in comment #31

Thanks
Comment 38 Konstantin Münning 2009-01-27 09:12:48 UTC
(In reply to comment #37)

I think the bug I encounter is this one:

http://bugs.freedesktop.org/show_bug.cgi?id=18974

I will post there. Rémi, should I add "remi@gentoo.org" to the Cc list or are you going to do this yourself?
Comment 39 Franz Glauber Vanderlinde 2009-01-27 12:31:05 UTC
For some odd reason, I issued again the glxgears last night and it was back to the poorest performance (~180fps). I haven't changed anything, so I found it very weird.

I recompiled the packages in the order after activating the new kernel, but had no success either.

Lastly, I tried to use EXA instead of UXA. Then I found the fps count growing a bit unstable (floating between 180 - 270). Then I looked at dmesg:

------------[ cut here ]-----------                                                      
WARNING: at drivers/gpu/drm/i915/i915_gem.c:2475 i915_gem_idle+0x15e/0x305 [i915]()                                            
Modules linked in: coretemp i915 drm rfcomm bnep l2cap snd_hda_intel rt73 i2c_i801 hci_usb                                     
Pid: 9602, comm: X Not tainted 2.6.28-00006-ge1a6fce #1                                                                        
Call Trace:                                                                                                                    
 [<c011fa9f>] warn_on_slowpath+0x40/0x59
 [<c0126e00>] lock_timer_base+0xa/0x35
 [<c0126e6f>] try_to_del_timer_sync+0x44/0x4a
 [<c0126e7f>] del_timer_sync+0xa/0x14
 [<c0447f76>] schedule_timeout+0x72/0x86
 [<f82b6e3b>] i915_gem_retire_requests+0xe9/0x100 [i915]
 [<f82b74a9>] i915_gem_idle+0x15e/0x305 [i915]
 [<f82b7676>] i915_gem_leavevt_ioctl+0x9/0x17 [i915]
 [<f8291714>] drm_ioctl+0x1a6/0x21e [drm]
 [<f82b766d>] i915_gem_leavevt_ioctl+0x0/0x17 [i915]
 [<c016f4b0>] vfs_ioctl+0x47/0x5d
 [<c016f929>] do_vfs_ioctl+0x38b/0x3c1
 [<c01268ab>] run_timer_softirq+0x30/0x18d
 [<c0123574>] __do_softirq+0x83/0x11e
 [<c016f98b>] sys_ioctl+0x2c/0x42
 [<c0102ce9>] sysenter_do_call+0x12/0x25
---[ end trace 3f8ce497d15f4da7 ]---

After examining the Xorg log, I realize I couldn't use DRI2 with EXA. Anyways, I got the warnings:

(WW) intel(0): libpciaccess reported 0 rom size, guessing 64kB
(WW) intel(0): Register 0x61200 (PP_STATUS) changed from 0xc0000008 to 0xd0000009
(WW) intel(0): PP_STATUS before: on, ready, sequencing idle
(WW) intel(0): PP_STATUS after: on, ready, sequencing on
(WW) intel(0): Register 0x70024 (PIPEASTAT) changed from 0x00000000 to 0x00000203
(WW) intel(0): PIPEASTAT before: status:
(WW) intel(0): PIPEASTAT after: status: VSYNC_INT_STATUS VBLANK_INT_STATUS OREG_UPDATE_STATUS
(WW) intel(0): Register 0x71024 (PIPEBSTAT) changed from 0x00000202 to 0x80000202
(WW) intel(0): PIPEBSTAT before: status: VSYNC_INT_STATUS VBLANK_INT_STATUS
(WW) intel(0): PIPEBSTAT after: status: FIFO_UNDERRUN VSYNC_INT_STATUS VBLANK_INT_STATUS
(WW) intel(0): DRI2 requires UXA
(WW) intel(0): ESR is 0x00000001, instruction error
(WW) intel(0): Existing errors found in hardware state.

Comment 40 Rémi Cardona gentoo-dev 2009-01-27 14:09:51 UTC
(In reply to comment #38)
> I will post there. Rémi, should I add "remi@gentoo.org" to the Cc list or are
> you going to do this yourself?

I've added myself directly. Thanks.

(In reply to comment #39)
> Lastly, I tried to use EXA instead of UXA. Then I found the fps count growing a
> bit unstable (floating between 180 - 270). Then I looked at dmesg:

Please file another bug at FreeDesktop, this is beyond my current knowledge.

To the rest of you, if you still have issues after rebuilding the packages in the correct order, please file bugs over at FreeDesktop too.

There's little else I can do.

Thanks