Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 252288 - After system update udev faild to start
Summary: After system update udev faild to start
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: udev maintainers
URL:
Whiteboard:
Keywords:
: 252305 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-12-23 16:28 UTC by lexx
Modified: 2009-03-08 10:54 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description lexx 2008-12-23 16:28:51 UTC
After changing make.profile (from 2007.0 to 2008.0) and system update (emerge -uDN world) system faild to start.
In interactive boot menu qestion about starting udev service failed with message
"
    udev uses addon code which is deprecated 
    and may not be available in the future
  Mounting /dev
/lib/rcscript/addons/udev-start.sh: line 26: _start: command not found
ERROR: udev failed to start
"
After that system boots without /dev, and even haven't root fs.

Reproducible: Always

Steps to Reproduce:




Portage 2.1.6_rc2 (default-linux/x86/2007.0/desktop, gcc-4.3.2,
glibc-2.8_p20080602-r0, 2.6.26-gentoo i686)
=================================================================
System uname: Linux-2.6.26-gentoo-i686-AMD_K7_processo-with-glibc2.0
Timestamp of tree: Tue, 02 Dec 2008 17:45:01 +0000
app-shells/bash:     3.2_p48
dev-java/java-config: 1.3.7-r1, 2.1.6-r1
dev-lang/python:     2.5.2-r8
dev-util/cmake:      2.6.2
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.3.0-r1
sys-apps/sandbox:    1.2.18.1-r3
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.19
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=athlon-xp -O3 -pipe -fomit-frame-pointer -funroll-all-loops
-fpeel-loops -funswitch-loops -funit-at-a-time"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config
/usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/
/etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release
/etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/
/etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo
/etc/udev/rules.d"
CXXFLAGS="-march=athlon-xp -O3 -pipe -fomit-frame-pointer -funroll-all-loops
-fpeel-loops -funswitch-loops -funit-at-a-time"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks parallel-fetch protect-owned sandbox sfperms strict
unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.bg/
http://mirror.yandex.ru/gentoo-distfiles/
ftp://mirror.yandex.ru/gentoo-distfiles/ http://distfiles.gentoo.bg/
http://ftp.gentoo.bg/ http://ftp.fi.muni.cz/pub/linux/gentoo/
ftp://ftp.fi.muni.cz/pub/linux/gentoo/ http://gentoo.mirror.web4u.cz/
ftp://gentoo.mirror.web4u.cz/ http://ftp.linux.ee/pub/gentoo/distfiles/
ftp://ftp.linux.ee/pub/gentoo/distfiles/
http://mirror.ovh.net/gentoo-distfiles/ ftp://mirror.ovh.net/gentoo-distfiles/
ftp://gentoo.imj.fr/pub/gentoo/ ftp://ftp.free.fr/mirrors/ftp.gentoo.org/
ftp://ftp.tu-clausthal.de/pub/linux/gentoo/
ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo
http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/
ftp://linux.rz.ruhr-uni-bochum.de/gentoo-mirror/
http://ftp.uni-erlangen.de/pub/mirrors/gentoo
ftp://ftp.uni-erlangen.de/pub/mirrors/gentoo
ftp://ftp.join.uni-muenster.de/pub/linux/distributions/gentoo
ftp://ftp.wh2.tu-dresden.de/pub/mirrors/gentoo
ftp://ftp.join.uni-muenster.de/pub/linux/distributions/gentoo
http://mirrors.sec.informatik.tu-darmstadt.de/gentoo/
http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/
ftp://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/
ftp://ftp.gentoo.mesh-solutions.com/gentoo/
ftp://pandemonium.tiscali.de/pub/gentoo/ http://gentoo.mneisen.org/
http://de-mirror.org/distro/gentoo/ ftp://de-mirror.org/distro/gentoo/"
LANG="ru_RU.UTF-8"
LC_ALL=""
LDFLAGS=""
LINGUAS="ru en"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress
--force --whole-file --delete --stats --timeout=180 --exclude=/distfiles
--exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp/portage"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext 7zip X X509 Xaw3d a52 aac accessibility acl acpi aim alias
alisp alsa amarok amr amrnb aotuv aspnet aspnet2 async audit authfile
auto-completion automount avahi bash-completion bind-mysql boost bzip2 c++
cairo caps ccache cdaudio cdb cdda cddb cdio cdparanoia cdr cdrom cdsound cg
cgi chroot compress consolekit cpio cracklib crypt cups curl cursors cxx
cyrillic dbm dbus demo device-mapper dga dhcp directfb directv divx djvu dmi
dnd dvbplayer dvd dvdarchive dvdchapjump dvdr dvdread emacs emboss encode esd
exif fame fastbuild fbdev ffmpeg filter flac floppy ftp gdb gdbm gif gimp glut
gmp gpm gstreamer hal hash http icons iconv icq ieee1394 ivtv java
java-external java-internal javascript jpeg jpeg2k kde kdm kdrive kerberos lame
libnotify lirc logitech-mouse mad maps midi mikmod mime mmx mono moonlight
mouse mp2 mp3 mp4 mp4live mpeg mpeg2 mplayer mpu401 mtp mudflap music mysql
nano-syntax nanoemacs ncurses nforce2 nls nocd nptl nvidia nvram odk ogg opengl
openmp openssl opensslcrypt opera oscar oss pam pcre pdf perl php player png
posix python qt3 qt3support qt4 quicktime radio rar rdesktop readline
reflection reiser4 reiserfs resolver rsync ruby samba scanner sdl search server
session slang sms sound soundex sounds spell spl srt sse ssl suexec svg svga
tcpd tga themes threads tiff tivo toolbar tools translator truetype tv unicode
usb v4l v4l2 vcd vga videos vim-syntax vmware vorbis wav web win32codecs
winbind winpopup wma wmf wmp x264 x86 xcomposite xine xinerama xml xmlwriter
xorg xscreensaver xv xvid xvmc zip zlib zoran" ALSA_CARDS="intel8x0"
ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file
hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug
rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic
authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm
authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache
dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache
filter headers include info log_config logio mem_cache mime mime_magic
negotiation rewrite setenvif speling status unique_id userdir usertrack
vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux"
LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses
text" LINGUAS="ru en" LIRC_DEVICES="avermedia avermedia98 pctv pixelview_bt878
avermedia_vdomate" USERLAND="GNU" VIDEO_CARDS="nvidia vesa"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK,
PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS,
PORTDIR_OVERLAY
Comment 1 Rafał Mużyło 2008-12-23 17:04:34 UTC
What were the udev/openrc/sysvinit versions when booting failed ?

Did you run etc-update after emerging ?
Comment 2 Lars Wendler (Polynomial-C) gentoo-dev 2008-12-23 19:42:14 UTC
*** Bug 252305 has been marked as a duplicate of this bug. ***
Comment 3 Panagiotis Christopoulos (RETIRED) gentoo-dev 2008-12-23 19:49:32 UTC
(In reply to comment #1)
> What were the udev/openrc/sysvinit versions when booting failed ?
> 
> Did you run etc-update after emerging ?
> 

Please verify if you have run etc-update or not. 

Comment 4 Panagiotis Christopoulos (RETIRED) gentoo-dev 2008-12-25 10:39:15 UTC
Any progress here? 
Comment 5 Harry Putnam 2008-12-25 23:53:45 UTC
(In reply to comment #4)
> Any progress here? 
> 

I'm not the OP but I can verify that I have updated incoming config files as asked in previous post.  In my case I used cfg-update but still there are no more files to update and on restart udev still fails to start.

should there be something uncommented in /etc/conf.d/udev?  In my case its only comments.
After bootup, with udev having failed to start... no cmdline tools are found, no PATHS are set etc so nothing can really be done short of booting off an install img or livecd and chrooting.   But what to do?
Attempting to start udev manually raises the original error reported by OP.



Comment 6 Matthias Schwarzott gentoo-dev 2008-12-26 07:51:02 UTC
Which udev version do you use? udev-135-r2 does not use addon code. So either you have an older version or did not update the cponfig-files/init-scripts properly.
Comment 7 Lucas 2008-12-29 21:58:04 UTC
After emerge udev run etc-update and update your config files in /etc/init.d/
Comment 8 Matthias Schwarzott gentoo-dev 2009-01-08 09:57:33 UTC
We cannot do anything here without further information.
Comment 9 Adam Nielsen 2009-03-08 10:54:40 UTC
Just came across this same issue, same error and symptoms.  Running etc-update and updating all the files related to udev fixed the problem.