Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 252287 - dev-libs/boost-1.35.0-r4 and 1.37-r1 won't build with GCC 4.4 (strict aliasing)
Summary: dev-libs/boost-1.35.0-r4 and 1.37-r1 won't build with GCC 4.4 (strict aliasing)
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GCC Porting (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Tiziano Müller
URL:
Whiteboard:
Keywords:
: 271242 273165 (view as bug list)
Depends on:
Blocks: gcc-4.4
  Show dependency tree
 
Reported: 2008-12-23 16:22 UTC by Daniel J.
Modified: 2009-11-20 14:37 UTC (History)
11 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
From upstream SVN revision 42435: adds #include needed by GCC 4.4 (boost-svn-r42435.patch,295 bytes, patch)
2008-12-23 16:23 UTC, Daniel J.
Details | Diff
From upstream SVN revision 49257: adjusts header files to be GCC-4.4 compliant (boost-svn-r49257.patch,5.02 KB, patch)
2008-12-23 16:24 UTC, Daniel J.
Details | Diff
build.log (dev-libs:boost-1.35.0-r4:20090301-234639.log,334.31 KB, text/plain)
2009-03-02 00:07 UTC, Ryan Hill (RETIRED)
Details
boost-1.37.0-gcc44-dynamic_bitset.patch (boost-1.37.0-gcc44-dynamic_bitset.patch,749 bytes, patch)
2009-04-05 04:41 UTC, Ryan Hill (RETIRED)
Details | Diff
build log for boost 1.37 (build.log,1.10 MB, text/plain)
2009-05-20 17:49 UTC, Alexey Shvetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel J. 2008-12-23 16:22:32 UTC
Because of issues in the Boost headers, neither boost nor any packages that depend on Boost will build with GCC 4.4.

Reproducible: Always

Steps to Reproduce:
Comment 1 Daniel J. 2008-12-23 16:23:41 UTC
Created attachment 176230 [details, diff]
From upstream SVN revision 42435: adds #include needed by GCC 4.4
Comment 2 Daniel J. 2008-12-23 16:24:25 UTC
Created attachment 176231 [details, diff]
From upstream SVN revision 49257: adjusts header files to be GCC-4.4 compliant
Comment 3 Wormo (RETIRED) gentoo-dev 2008-12-25 06:06:55 UTC
Thanks for submitting your patches; I see you're even adding them to the tracker bug.

Assigning to maintainers.
Comment 4 Tiziano Müller gentoo-dev 2009-01-06 15:13:49 UTC
Fixed in boost-1.35.0-r4. Thanks!
Comment 5 Daniel J. 2009-01-08 16:13:47 UTC
Shouldn't this be marked RESOLVED FIXED then?
Comment 6 Tiziano Müller gentoo-dev 2009-01-08 20:57:01 UTC
em, yes :-) thanks
Comment 7 Ryan Hill (RETIRED) gentoo-dev 2009-03-01 23:59:05 UTC
still fails for me without -fno-strict-aliasing.  i'm still trying to find the actual error message in the sea of unintelligible c++ warnings.

[ebuild     U ] dev-libs/boost-1.35.0-r4 [1.35.0-r2] USE="expat -debug -doc -icu -mpi -tools" 0 kB

dirtyepic@halo ~ $ gcc -v
Using built-in specs.
Target: x86_64-pc-linux-gnu
Configured with: /var/tmp/portage/sys-devel/gcc-4.4.0_pre9999/work/gcc-4.4.0-9999/configure --prefix=/usr --bindir=/usr/x86_64-pc-linux-gnu/gcc-bin/4.4.0-pre9999 --includedir=/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.0-pre9999/include --datadir=/usr/share/gcc-data/x86_64-pc-linux-gnu/4.4.0-pre9999 --mandir=/usr/share/gcc-data/x86_64-pc-linux-gnu/4.4.0-pre9999/man --infodir=/usr/share/gcc-data/x86_64-pc-linux-gnu/4.4.0-pre9999/info --with-gxx-include-dir=/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.0-pre9999/include/g++-v4 --host=x86_64-pc-linux-gnu --build=x86_64-pc-linux-gnu --disable-altivec --disable-fixed-point --disable-nls --with-system-zlib --disable-checking --disable-werror --enable-secureplt --enable-multilib --disable-libmudflap --disable-libssp --enable-libgomp --enable-cld --disable-libgcj --enable-languages=c,c++ --enable-shared --enable-threads=posix --enable-__cxa_atexit --enable-clocale=gnu --with-bugurl=http://bugs.gentoo.org/ --with-pkgversion='Gentoo SVN' --with-ppl --with-cloog
Thread model: posix
gcc version 4.4.0-pre9999 built 20090226 (experimental) rev. 144460 (Gentoo SVN)


dirtyepic@halo ~ $ emerge --info                                                                                                            
Portage 2.2_rc23 (default/linux/amd64/2008.0/developer, gcc-4.4.0-pre9999, glibc-2.9_p20081201-r2, 2.6.28-gentoo-r2 x86_64)                 
=================================================================                                                                           
System uname: Linux-2.6.28-gentoo-r2-x86_64-Intel-R-_Core-TM-2_Duo_CPU_T9300_@_2.50GHz-with-glibc2.2.5                                      
Timestamp of tree: Sat, 28 Feb 2009 20:00:01 +0000                                                                                          
ccache version 2.4 [enabled]                                                                                                                
app-shells/bash:     3.2_p48-r1                                                                                                             
dev-java/java-config: 1.3.7-r1, 2.1.7                                                                                                       
dev-lang/python:     2.5.4-r2                                                                                                               
dev-python/pycrypto: 2.0.1-r6                                                                                                               
dev-util/ccache:     2.4-r8                                                                                                                 
dev-util/cmake:      2.6.2-r1                                                                                                               
sys-apps/baselayout: 2.0.0                                                                                                                  
sys-apps/openrc:     0.4.3-r1                                                                                                               
sys-apps/sandbox:    1.3.8                                                                                                                  
sys-devel/autoconf:  2.13, 2.63                                                                                                             
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2                                                                              
sys-devel/binutils:  2.19.51.0.2                                                                                                            
sys-devel/gcc-config: 1.4.1                                                                                                                 
sys-devel/libtool:   2.2.6a                                                                                                                 
virtual/os-headers:  2.6.28-r1                                                                                                              
ACCEPT_KEYWORDS="amd64 ~amd64"                                                                                                              
CBUILD="x86_64-pc-linux-gnu"                                                                                                                
CFLAGS="-O2 -march=core2 -fno-strict-aliasing -fomit-frame-pointer -pipe"                                                                   
CHOST="x86_64-pc-linux-gnu"                                                                                                                 
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"                                    
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"                                                                                     
CXXFLAGS="-O2 -march=core2 -fno-strict-aliasing -fomit-frame-pointer -pipe"                                                                 
DISTDIR="/usr/portage/distfiles"                                                                                                            
FEATURES="ccache collision-protect cvs digest distlocks fixpackages multilib-strict parallel-fetch preserve-libs sandbox sfperms sign splitdebug strict test unmerge-orphans userfetch userpriv usersandbox"                                                                            
GENTOO_MIRRORS="http://gentoo.mirrors.tera-byte.com/ http://gentoo.osuosl.org http://distfiles.gentoo.org"                                  
LANG="en_US.utf8"                                                                                                                           
LDFLAGS="-Wl,--as-needed,--hash-style=gnu"                                                                                                  
LINGUAS="en en_US"                                                                                                                          
MAKEOPTS="-j4"                                                                                                                              
PKGDIR="/usr/portage/packages"                                                                                                              
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"                                                                                          
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/home/dirtyepic/overlay /home/dirtyepic/dev/svn/dirtyepic /home/dirtyepic/dev/svn/gcc-porting"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acpi akode alsa amd64 aspell audiofile avahi bash-completion berkdb bzip2 cairo cdaudio cdr chm cleartype cli consolekit cracklib crypt css cups curl cvs dbus dhcpcd divx dri dts dvd dvdr dvdread eds emboss encode evo exif expat fam ffmpeg fftw firefox3 flac fontconfig foomaticdb gdbm geos gif gimp git glib glw gmedia gmp gpgme gphoto2 gstreamer gtk hal hdaps hpn htmlhandbook iconv id3tag imap imlib inotify ipw4965 isdnlog javascript jpeg kde kdeenablefinal kdehiddenvisibility lame laptop libwww lzma mad mdnsresponder-compat midi mikmod mmap mmx mozilla mp3 mpeg multilib ncurses network-cron nntp nptl nptlonly nsplugin ogg opengl openmp pam pcre pdf phonon pic png pop ppds pppd pth qt3 qt3support qt4 quicktime readline reflection rtc sasl sesame2 session sha512 smapi smime smp smtp sndfile spell spl srt sse sse2 ssl ssse3 startup-notification subversion svg sysfs taglib tcpd theora threads threadsafe tiff truetype unicode urandom usb utempter vim-syntax vorbis wifi wmp wxwindows x264 xcb xcomposite xine xml xorg xpm xslt xulrunner xv xvid xvmc zeroconf zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="mouse keyboard synaptics evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_US" USERLAND="GNU" VIDEO_CARDS="intel"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 8 Ryan Hill (RETIRED) gentoo-dev 2009-03-02 00:07:29 UTC
Created attachment 183631 [details]
build.log

still can't find why, but i do see where:

1356     "x86_64-pc-linux-gnu-g++"  -ftemplate-depth-128 -O2 -march=core2 -fomit-frame-pointer -pipe -finline-functions -Wno-inline -Wall -f     PIC  -DBOOST_ALL_DYN_LINK=1 -DBOOST_ALL_NO_LIB=1 -DNDEBUG  -I"." -c -o "bin.v2/libs/wave/build/gcc-4.4/gentoorelease/instantiate_cpp_ex     prgrammar.o" "libs/wave/src/instantiate_cpp_exprgrammar.cpp"
1357
1358 ...failed gcc.compile.c++ bin.v2/libs/wave/build/gcc-4.4/gentoorelease/instantiate_cpp_exprgrammar.o...
1359 ...removing bin.v2/libs/wave/build/gcc-4.4/gentoorelease/instantiate_cpp_exprgrammar.o
1360 ...on 500th target...
Comment 9 Tiziano Müller gentoo-dev 2009-03-02 05:43:19 UTC
Just give me some time to bump to boost-1.38.0 and see whether that one builds...
Comment 10 Alexander Bezrukov 2009-03-11 16:39:31 UTC
I am also suffering from this problem (~amd64, sys-devel/gcc-4.3.3 and dev-util/boost-build-1.34.1). Some #includes are missing, functions are assumed to be implicitly declared, leading to errors reported by the compiler.

Interestingly enough, if built manually (by launching boost_1_34_1/tools/jam/src/build.sh) the source is built with no problem.

The root cause that makes the ebuild to fail (in my case, at least) is the '-combine' gcc compilation flag which causes the compiler to stop at error in the code which otherwise left undetected.

If that makes sense I can prepare a patch which would fix this problem.
Comment 11 Alexander Bezrukov 2009-03-11 18:47:39 UTC
The problem I am facing is actually different from the one described here. I opened a separate Bug #262174.
Comment 12 Ryan Hill (RETIRED) gentoo-dev 2009-03-24 06:09:36 UTC
i don't understand why this is failing.  there are a ton of strict-aliasing warnings when compiling libs/wave/src/instantiate_cpp_exprgrammar.cpp but it does succeed.

halo ~/portage/dev-libs/boost-1.35.0-r4/work/boost_1_35_0 # "x86_64-pc-linux-gnu-g++"  -ftemplate-depth-128 -O2 -march=core2 -fomit-frame-pointer -pipe -Wno-parentheses -finline-functions -Wno-inline -Wall -fPIC  -DBOOST_ALL_DYN_LINK=1 -DBOOST_ALL_NO_LIB=1 -DNDEBUG  -I"." -c -o "bin.v2/libs/wave/build/gcc-4.4/gentoorelease/instantiate_cpp_exprgrammar.o" "libs/wave/src/instantiate_cpp_exprgrammar.cpp" -Wno-strict-aliasing                                                                                                                                        
halo ~/portage/dev-libs/boost-1.35.0-r4/work/boost_1_35_0 # echo $?
0          


BTW, we will also need these patches added to the 1.36 patchset.
Comment 13 Ryan Hill (RETIRED) gentoo-dev 2009-04-05 04:41:54 UTC
Created attachment 187347 [details, diff]
boost-1.37.0-gcc44-dynamic_bitset.patch

we also need this patch for 1.37.0 to fix a public header that's breaking ardour.
Comment 14 Ivan Mironov 2009-04-13 06:18:42 UTC
Patches https://bugs.gentoo.org/attachment.cgi?id=176230 and https://bugs.gentoo.org/attachment.cgi?id=176231 fixes compilation of =dev-libs/boost-1.35.0-r2. Thanks =).
Comment 15 Kevin Bowling 2009-05-08 22:00:03 UTC
Still broken with current GCC 4.4 in tree, as well as current ~amd64 boost.
Comment 16 Florian GYS 2009-05-09 18:38:10 UTC
(In reply to comment #15)
> Still broken with current GCC 4.4 in tree, as well as current ~amd64 boost.
> 

Same here
Comment 17 Florian GYS 2009-05-09 18:55:29 UTC
(In reply to comment #16)
> (In reply to comment #15)
> > Still broken with current GCC 4.4 in tree, as well as current ~amd64 boost.
> > 
> 
> Same here
> 

Unmasking boost-1.35.0-r4 solved this.
Comment 18 Volker Hemmann 2009-05-11 05:49:07 UTC
1.35.0-r4 doesn't built here
Comment 19 Volker Hemmann 2009-05-11 06:38:07 UTC
emerge --info
WARNING: One or more repositories have missing repo_name entries:

        /usr/local/portage/profiles/repo_name

NOTE: Each repo_name entry should be a plain text file containing a
unique name for the repository on the first line.                  
Portage 2.2_rc33 (default/linux/amd64/2008.0/desktop, gcc-4.4.0, glibc-2.9_p20081201-r2, 2.6.28.9r4-tuxonice3.1 x86_64)
=================================================================                                                      
System uname: Linux-2.6.28.9r4-tuxonice3.1-x86_64-AMD_Athlon-tm-_64_X2_Dual_Core_Processor_6000+-with-gentoo-2.0.0     
Timestamp of tree: Mon, 11 May 2009 04:30:01 +0000                                                                     
ccache version 2.4 [enabled]                                                                                           
app-shells/bash:     4.0_p17-r1                                                                                        
dev-java/java-config: 1.3.7-r1, 2.1.7                                                                                  
dev-lang/python:     2.5.4-r2, 2.6.2                                                                                   
dev-python/pycrypto: 2.0.1-r8                                                                                          
dev-util/ccache:     2.4-r8                                                                                            
dev-util/cmake:      2.6.4                                                                                             
sys-apps/baselayout: 2.0.0                                                                                             
sys-apps/openrc:     0.4.3-r2                                                                                          
sys-apps/sandbox:    1.9                                                                                               
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.19.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.29
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=k8-sse3 -O2 -msse3 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/live/env /usr/kde/live/share/config /usr/kde/live/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=k8-sse3 -O2 -msse3 -pipe"
DISTDIR="/var/portage/distfiles"
FEATURES="autoconfig buildpkg candy ccache distlocks fixpackages metadata-transfer parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="C"
LC_ALL="C"
LDFLAGS="-Wl,-O1"
LINGUAS="de"
MAKEOPTS="-j3"
PKGDIR="/usr/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/var/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/qting-edge /usr/local/portage/layman/x11 /usr/local/portage/layman/kde-testing /usr/local/portage/layman/games /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="32bit 3dnow 3dnowext 7zip S3TC X Xaw3d a52 aac acpi addbookmarks aften aiglx aim aio akode alias alsa altenburgcards amarok amarok2 amd64 amr amrnb amrwb analogtv aotuv aqua_theme archive athena audio audiofile autoreplace bash-completion berkdb binary-drivers bittorrent bluetooth boost branding bzip2 cairo captury cdaudio cdda cddb cdinstall cdparanoia cdr cdrom cdsound cegui chm clamav cli clucene connectionstatus consolekit contactnotes cracklib crypt css cups curl dbus dhcp divx dnd double-precision downloadorder dpms dragonplayer dri dts dv dvb dvbplayer dvbsetup dvd dvdr dvdread editor eds emboss emerald emovix encode evo exif exiv2 expat extra-cardsets fame fasttrack fat ffmpeg fftw file firefox fits flac fontconfig foomaticdb fortran ftp gadu gd gdbm geoip gif gimp glibc-omitfp glitz glut glx gnutella google-gadgets gpgme gpm graphite grub hal hddtemp highlight history icons iconv icq icu id3 id3tag ieee1394 imagemagick inotify ipv6 irc irmc irrlicht isdnlog jabber java java6 javascript jce jingle joystick jpeg jpeg2k kate kcal kde kde4 kdecards kdeenablefinal kdehiddenvisibility kdepim kdeprefix kdm kexi kipi lame lapack lcms lesstif libnotify libsamplerate libssh2 libwww lirc lm_sensors logitech-mouse logviewer lzo mad magic mailbox maildir maps matroska mbox mdnsresponder-compat metric midi mikmod mime mixer mjpeg mmap mmx mmxext mng monolithic mp2 mp3 mp4 mpeg mpeg2 mplayer msn mtp mudflap mule multilib musepack music nano-syntax ncurses neXt nepomuk net network newspr ngui nls no-old-linux nocd nowin nowlistening npp nptl nptlonly nsplugin ntfs obex offensive ogg ogg123 ogm openexr opengl openmp oscar otr oxygen pam paste64 pch pcre pdf perl physfs pixmaps plasma player plugins png pnm posix ppds pppd ps python qt3 qt3support qt4 quicktime rar readline recode reflection reiser4 reiserfs remix resolvconf rogue rtc sametime sasl scanner scenarios schedule scsi sdl sdl-image sdl-sound sdlaudio search semantic-desktop server session slp smp sms sndfile sockets sound sounds spell spl sqlite sqlite3 sse sse-filters sse2 sse3 ssh ssl startup-notification statistics stats stroke subp subtitles svg sysfs sysvipc szip tcpd texteffect textures tga theora threads threadsafe thumbnail tiff timidity tk tomsfastmath toolbar tools transcode translator truetype tv tv_check tv_combiner tv_pick_cgi tvtime unicode unzip usb userlocales utempter v4l v4l2 vcd videos visualization vorbis webdav webkit webpresence wifi wireshark wlm wmf wmp wxwindows x264 xanim xcb xcomposite xemacs xext xface xft xine xml xorg xosd xpm xrandr xrender xscreensaver xskatcards xulrunner xv xvid xvmc yahoo yiff yv12 zip zlib zsh-completion zvbi" ALSA_CARDS="emu10k1" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de" LIRC_DEVICES="devinput" USERLAND="GNU" VIDEO_CARDS="vesa v4l fglrx radeon radeonhd"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

1.35.0-r4 fails
1.37.0-r1 fails
(should I open a new bug about 37?)
Comment 20 Łukasz Michalik 2009-05-11 09:14:59 UTC
(In reply to comment #18)
> 1.35.0-r4 doesn't built here
> 

Does it fail in the same fashion as for other people in this bug (strict aliasing errors)?  If not please open a new bug and attach full build log.
Comment 21 Rafał Mużyło 2009-05-14 17:33:22 UTC
My personal experience:
I was trying to upgrade from boost 1.35.0-r4 (built with gcc 4.3.3)
to boost 1.35.0-r5 (gcc 4.4.0).
It fails for me in the already mentioned instantiate_cpp_exprgrammar.cpp.
However, it fails on that file for every more recent boost version,
including 1.39.0.
Also, if I try to compile that file manually, it's fine.
If I simply run the reconstructed command in the workdir:
bjam-1_35 -q gentoorelease -sICULUDE=/usr/include -sEXPAT_LIBPATH=/usr/lib --without-mpi --user-config=/var/tmp/portage/dev-libs/boost-1.35.0-r5/work/boost_1_35_0/user-config.jam --boost-build=/usr/share/boost-build-1_35 --prefix=/var/tmp/portage/dev-libs/boost-1.35.0-r5/image//usr --layout=versioned

the build seems to complete correctly (well, aside of all those
strict aliasing warnings, including "does break" ones).
Can it be a problem with portage ?
Comment 22 Rafał Mużyło 2009-05-14 23:17:26 UTC
Funny, repeated invocation of 'ebuild <ebuild name> merge'
eventually gets around the problem.
Could either portage or bjam have a buffer overrun problem
or such ?
Comment 23 Rafał Mużyło 2009-05-14 23:19:50 UTC
I said repeated, cause a single one is not enough.
Comment 24 Alexey Shvetsov gentoo-dev 2009-05-20 17:49:48 UTC
Created attachment 191919 [details]
build log for boost 1.37
Comment 25 Alexey Shvetsov gentoo-dev 2009-05-20 17:50:27 UTC
Same bug for 1.37
Comment 26 Gregg Casillo 2009-05-25 00:22:02 UTC
I had a similar issue getting 1.37.0-r1 to compile using gcc-4.3.3. Masked boost-1.37.0-r1 and boost-build-1.37.0, tried emerging boost-1.36.0-r1 and boost-build 1.36.0, and I was unsuccessful. I tried every version of boost and boost-build in portage as of this afternoon, and none will compile. FWIW, I'm doing a fresh install where I'm trying to build a KDE4 desktop.

My emerge --info for reference:
Portage 2.2_rc33 (default/linux/x86/2008.0/desktop, gcc-4.3.3, glibc-2.10.1-r0, 2.6.28-gentoo-r5 i686)
=================================================================
System uname: Linux-2.6.28-gentoo-r5-i686-Intel-R-_Atom-TM-_CPU_N280_@_1.66GHz-with-gentoo-2.0.0
Timestamp of tree: Sat, 23 May 2009 22:30:01 +0000
distcc 3.1 i686-pc-linux-gnu [enabled]
ccache version 2.4 [enabled]
app-shells/bash:     4.0_p24
dev-lang/python:     2.5.4-r2, 2.6.2
dev-util/ccache:     2.4-r8
dev-util/cmake:      2.6.4
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.4.3-r2
sys-apps/sandbox:    1.9
sys-devel/autoconf:  2.63-r1
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.19.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.29
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=prescott -O2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/4.2/env /usr/kde/4.2/share/config /usr/kde/4.2/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=prescott -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distcc distlocks fixpackages parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://ftp.ussg.iu.edu/pub/linux/gentoo ftp://ftp.gtlib.gatech.edu/pub/gentoo http://www.gtlib.gatech.edu/pub/gentoo http://gentoo.mirrors.pair.com/ ftp://gentoo.mirrors.pair.com/ http://gentoo.mirrors.tds.net/gentoo ftp://gentoo.mirrors.tds.net/gentoo http://mirror.datapipe.net/gentoo ftp://mirror.datapipe.net/gentoo"
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j16"
PKGDIR="/usr/portage/packages"
PORTAGE_COMPRESS="gzip"
PORTAGE_COMPRESS_FLAGS="-9"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amarok asf audiofile avi bash-completion berkdb bluetooth branding bzip2 cdr cli cracklib crypt ctype cups dbus dirac dlloader dri dts encode faac faad fam ffmpeg firefox flac foomaticdb frontendonly ftp gdbm gif hal imap imlib innodb ip4100 isdnlog joystick jpeg kde kdehiddenvisibility kdeprefix lcms libg++ libwww live lm_sensors logrotate mad maildir matroska midi mikmod mime mmx mmxext mng mp3 mpeg mudflap mysql ncurses nls nptl nptlonly nsplugin ogg oggvorbis openal opengl openmp pcre pdf perl plasma png postgres ppds python qt3support qt4 quicktime readline reflection samba sasl scanner sdl semantic-desktop session smp speex spell spl sse sse2 ssl ssse3 startup-notification subversion svg sysfs syslog taglib tcpd theora tiff transcode truetype unicode usb vhosts vorbis webkit win32codecs x264 x86 xcomposite xine xml xml2 xorg xulrunner xv xvid zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="ptp2" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="intel"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 27 Gregg Casillo 2009-05-26 05:38:41 UTC
Well, late last night, I was somehow able to get the latest versions (boost-1.37.0-r1 and boost-build-1.37.0) to compile and emerge. I wish I could explain how or why it ultimately worked, but I'm just not sure.
Comment 28 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-06-08 10:41:16 UTC
*** Bug 273165 has been marked as a duplicate of this bug. ***
Comment 29 Peter Levine 2009-06-13 06:41:15 UTC
I finally got boost-1.37.0 to build with gcc-4.4 by adding -fno-strict-aliasing to the CXXFLAGS.
Comment 30 Oschtan 2009-06-13 09:26:30 UTC
(In reply to comment #29)
> I finally got boost-1.37.0 to build with gcc-4.4 by adding -fno-strict-aliasing
> to the CXXFLAGS.
> 

Yahoo! It's work! Thanks!
Comment 31 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-06-15 18:32:10 UTC
I've added a -fno-strict-aliasing append when building with gcc 4.4 to reduce the effect of the build failure; somebody should apply the proper fixes though.
Comment 32 Rafał Mużyło 2009-06-17 00:06:18 UTC
Does anyone have an idea what exactly goes wrong ?
As repeated invocations of ebuild eventually sidestep the problem
(yes, it may be build not quite correctly, but that's a different issue),
the build failure is caused by something else.
It's almost as if a buffer overrun in either bjam or portage
was triggered by all those warnings.
Comment 33 Ryan Hill (RETIRED) gentoo-dev 2009-07-02 02:52:41 UTC
not really, but it seems to be specific to Gentoo.  i'm also wondering if it's the sheer number of strict-aliasing warnings causing portage to abort.  has anyone tried with paludis (remember to remove -fno-strict-aliasing first).
Comment 34 Ryan Hill (RETIRED) gentoo-dev 2009-07-02 03:21:52 UTC
Whatever the root cause, I just did a couple test builds and it looks like we can just pass -Wno-strict-aliasing and dodge the performance hit.  Upstream has declared that these warnings are spurious (though others have disagreed), so they won't be fixed any time soon.
Comment 35 Ryan Hill (RETIRED) gentoo-dev 2009-07-02 04:13:36 UTC
applied to 1.35.0-r5, 1.36.0-r1, and 1.37.0-r1.
Comment 36 Rafał Mużyło 2009-07-02 08:15:21 UTC
I'd still say it would be nice to know whether it
was portage or bjam, that couldn't handle so many warnings.
Comment 37 Sebastian Luther (few) 2009-11-20 14:37:57 UTC
*** Bug 271242 has been marked as a duplicate of this bug. ***