Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 252276 - media-sound/listen-0.5-r1 fails to emerge.
Summary: media-sound/listen-0.5-r1 fails to emerge.
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: José Alberto Suárez López (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on: 268466
Blocks:
  Show dependency tree
 
Reported: 2008-12-23 15:24 UTC by Tijmen van Hoeckel
Modified: 2009-07-17 09:07 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
listen-0.5-r1.ebuild (listen-0.5-r1.ebuild,3.18 KB, text/plain)
2009-04-28 20:10 UTC, Geert Vanhaute
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tijmen van Hoeckel 2008-12-23 15:24:36 UTC
media-sound/listen-0.5-r1 fails to emerge with the following die message:
 * ERROR: media-sound/listen-0.5-r1 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called pkg_setup
 *    listen-0.5-r1.ebuild, line   68:  Called built_with_use 'dev-python/gnome-python-extras' 'firefox'
 *           eutils.eclass, line 1740:  Called die
 * The specific snippet of code:
 *                  die)   die "$PKG does not actually support the $1 USE flag!";;
 *  The die message:
 *   dev-python/gnome-python-extras-2.19.1-r3 does not actually support the firefox USE flag! 

I tried different ways of making sure the firefox USE-flag wasn't used (through make.conf, /etc/portage/package.use, USE="-firefox" emerge gnome-python-extras etc.) but somehow the Listen ebuild refuses to recognize gnome-python-extras is built without firefox USE-flag.
I discussed it on the Gentoo Forums here: http://forums.gentoo.org/viewtopic-p-5333543.html

Reproducible: Always

Steps to Reproduce:
1. emerge media-sound/listen
2.
3.

Actual Results:  
* ERROR: media-sound/listen-0.5-r1 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called pkg_setup
 *    listen-0.5-r1.ebuild, line   68:  Called built_with_use 'dev-python/gnome-python-extras' 'firefox'
 *           eutils.eclass, line 1740:  Called die
 * The specific snippet of code:
 *                  die)   die "$PKG does not actually support the $1 USE flag!";;
 *  The die message:
 *   dev-python/gnome-python-extras-2.19.1-r3 does not actually support the firefox USE flag! 


Expected Results:  
media-sound/listen properly installed.

emerge --info

Portage 2.2_rc18 (default/linux/x86/2008.0, gcc-4.3.2, glibc-2.9_p20081201-r0, 2.6.27-gentoo-r6 i686)
=================================================================
System uname: Linux-2.6.27-gentoo-r6-i686-AMD_Athlon-tm-_64_X2_Dual_Core_Processor_4200+-with-glibc2.0
Timestamp of tree: Tue, 23 Dec 2008 13:00:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p48
dev-java/java-config: 1.3.7-r1, 2.1.6-r1
dev-lang/python:     2.5.2-r8
dev-util/ccache:     2.4-r8
dev-util/cmake:      2.6.2
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.4.0
sys-apps/sandbox:    1.2.18.1-r3
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.7.9-r1, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.19
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="x86 ~x86"
ALSA_CARDS="hda_intel"
ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol"
APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias"
ARCH="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CCACHE_SIZE="1G"
CFLAGS="-O2 -march=k8-sse3 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CLASSPATH="."
CLEAN_DELAY="5"
COLLISION_IGNORE="/lib/modules"
COLORTERM="gnome-terminal"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CVS_RSH="ssh"
CXXFLAGS="-O2 -march=k8-sse3 -pipe -fomit-frame-pointer"
DBUS_SESSION_BUS_ADDRESS="unix:abstract=/tmp/dbus-T3BwbpqDJE,guid=adcd7fa71c6e91470af6e0eb49473a2c"
DISPLAY=":0.0"
DISTDIR="/usr/portage/distfiles"
EDITOR="/bin/nano"
ELIBC="glibc"
EMERGE_DEFAULT_OPTS="--verbose --ask"
EMERGE_WARNING_DELAY="10"
FEATURES="ccache distlocks fixpackages metadata-transfer parallel parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch"
FETCHCOMMAND="/usr/bin/wget -t 5 -T 60 --passive-ftp -O "${DISTDIR}/${FILE}" "${URI}""
FLTK_DOCDIR="/usr/share/doc/fltk-2.0_pre6525/html"
GCC_SPECS=""
GDK_USE_XFT="1"
GENTOO_MIRRORS="http://ftp.snt.utwente.nl/pub/os/linux/gentoo ftp://gentoo.tiscali.nl/pub/mirror/gentoo/"
GNOME_DESKTOP_SESSION_ID="Default"
GNOME_KEYRING_SOCKET="/tmp/keyring-tQg7oj/socket"
GTK_MODULES="gnomebreakpad"
GTK_RC_FILES="/etc/gtk/gtkrc:/home/theimon/.gtkrc-1.2-gnome2"
GUILE_LOAD_PATH="/usr/share/guile/1.8"
HOME="/root"
HUSHLOGIN="FALSE"
INFOPATH="/usr/share/info:/usr/share/binutils-data/i686-pc-linux-gnu/2.19/info:/usr/share/gcc-data/i686-pc-linux-gnu/4.3.2/info"
INPUT_DEVICES="keyboard mouse"
JAVAC="/etc/java-config-2/current-system-vm/bin/javac"
JAVA_HOME="/etc/java-config-2/current-system-vm"
JDK_HOME="/etc/java-config-2/current-system-vm"
KERNEL="linux"
LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text"
LDFLAGS="-Wl,-O1"
LESS="-R -M --shift 5"
LESSOPEN="|lesspipe.sh %s"
LINGUAS="en en_US"
LOGNAME="root"
LS_COLORS="rs=0:di=01;34:ln=01;36:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=01;05;37;41:mi=01;05;37;41:su=37;41:sg=30;43:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.lzma=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.dz=01;31:*.gz=01;31:*.bz2=01;31:*.bz=01;31:*.tbz2=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.rar=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.svg=01;35:*.svgz=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.flv=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.pdf=00;32:*.ps=00;32:*.txt=00;32:*.patch=00;32:*.diff=00;32:*.log=00;32:*.tex=00;32:*.doc=00;32:*.aac=00;36:*.au=00;36:*.flac=00;36:*.mid=00;36:*.midi=00;36:*.mka=00;36:*.mp3=00;36:*.mpc=00;36:*.ogg=00;36:*.ra=00;36:*.wav=00;36:"
MAKE_OPTS="-j3"
MANPATH="/etc/java-config-2/current-system-vm/man:/usr/local/share/man:/usr/share/man:/usr/share/binutils-data/i686-pc-linux-gnu/2.19/man:/usr/share/gcc-data/i686-pc-linux-gnu/4.3.2/man:/etc/java-config/system-vm/man/:/usr/lib/php5/man/:/usr/qt/3/doc/man"
NETBEANS="apisupport cnd groovy gsf harness ide identity j2ee java mobility nb php profiler soa visualweb webcommon websvccommon xml"
OLDPWD="/home/theimon"
OPENGL_PROFILE="nvidia"
ORBIT_SOCKETDIR="/tmp/orbit-theimon"
PAGER="/usr/bin/less"
PATH="/sbin:/bin:/usr/sbin:/usr/bin"
PKGDIR="/usr/portage/packages"
PKG_CONFIG_PATH="/usr/qt/3/lib/pkgconfig"
PORTAGE_ARCHLIST="ppc s390 amd64 x86 ppc64 x86-fbsd m68k arm sparc sh mips ia64 alpha hppa sparc-fbsd"
PORTAGE_BINHOST_CHUNKSIZE="3000"
PORTAGE_BIN_PATH="/usr/lib/portage/bin"
PORTAGE_COMPRESS_EXCLUDE_SUFFIXES="css gif htm[l]? jp[e]?g js pdf png"
PORTAGE_CONFIGROOT="/"
PORTAGE_COUNTER_HASH="e3c7400720daf197d081eb9fa607b95b"
PORTAGE_DEBUG="0"
PORTAGE_DEPCACHEDIR="/var/cache/edb/dep"
PORTAGE_ELOG_CLASSES="log warn error"
PORTAGE_ELOG_MAILFROM="portage@localhost"
PORTAGE_ELOG_MAILSUBJECT="[portage] ebuild log for ${PACKAGE} on ${HOST}"
PORTAGE_ELOG_MAILURI="root"
PORTAGE_ELOG_SYSTEM="save_summary echo"
PORTAGE_FETCH_CHECKSUM_TRY_MIRRORS="5"
PORTAGE_FETCH_RESUME_MIN_SIZE="350K"
PORTAGE_GID="250"
PORTAGE_INST_GID="0"
PORTAGE_INST_UID="0"
PORTAGE_PYM_PATH="/usr/lib/portage/pym"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_RSYNC_RETRIES="3"
PORTAGE_TMPDIR="/var/tmp"
PORTAGE_VERBOSE="1"
PORTAGE_WORKDIR_MODE="0700"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/ftd4linux /usr/portage/local/layman/sunrise /usr/portage/local/layman/gnome"
PRELINK_PATH_MASK="/usr/lib/klibc"
PROFILE_ONLY_VARIABLES="ARCH ELIBC KERNEL USERLAND"
PWD="/usr/src/linux"
QMAKESPEC="linux-g++"
QTDIR="/usr/qt/3"
RESUMECOMMAND="/usr/bin/wget -c -t 5 -T 60 --passive-ftp -O "${DISTDIR}/${FILE}" "${URI}""
ROOT="/"
ROOTPATH="/opt/bin:/usr/i686-pc-linux-gnu/gcc-bin/4.3.2:/usr/qt/3/bin"
RPMDIR="/usr/portage/rpm"
SANE_CONFIG_DIR="/etc/sane.d"
SESSION_MANAGER="local/know-where-to-run:@/tmp/.ICE-unix/3338,unix/know-where-to-run:/tmp/.ICE-unix/3338"
SHELL="/bin/bash"
SHLVL="4"
SSH_AUTH_SOCK="/tmp/keyring-tQg7oj/ssh"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
TERM="xterm"
USB_DEVFS_PATH="/dev/bus/usb"
USE="3dnow 3dnowext X a52 aac aalib acl acpi alsa apm asf audacious audiofile authfile automount avahi bash-completion blender bonobo bzip2 cairo caps ccache cdda cddb cdparanoia cdr cli corba cpudetection cracklib crypt ctype cups cupsddk curl curlwrappers custom-optimization dbus dga divx divx4linux dri dts dvd dvdnav dvdr dvdread emerald encode equalizer esd exif expat fam fame fastbuild ffmpeg flac foomatic fortran ftp gcdmaster gif gimp glitz glut glx gmedia gnome gnome-keyring gnutls gphoto2 gstreamer gtk gtk2 gtkhtml guile hal howl iconv isdnlog java javascript jikes jpeg lame lash libnotify libsamplerate live lm_sensors mad mdnsresponder-compat midi mime mmap mmkeys mmx mmxext mono motif mp3 mpeg msn mtp mudflap musepack nautilus ncurses neXt newspr nls nntp normalize nptl nptlonly nsplugin nvidia ogg oggvorbis openal opengl openmp oss pam pcntl pcre pdf perl png posix profile python quicktime rar readline realmedia recode reflection rtc rtsp scanner sdl session shout simplexml skins sloppy-lock smp sndfile snmp spell spl srt sse sse2 sse3 ssl ssse3 startup-notification stream subtitles subversion svg swscaler symlink sysfs szip tcpd threads threadsafe trayicon truetype unicode unsupported usb userlocales verbose vlm vorbis wav wavpack win32codecs wma wmf wmp wxwindows x264 x86 xattr xcb xcomposite xft xine xine-lib xinetd xml xorg xosd xsl xulrunner xv xvid xvmc" ALSA_CARDS="hda_intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_US" USERLAND="GNU" VIDEO_CARDS="nvidia"
USER="root"
USERLAND="GNU"
USE_EXPAND="ALSA_CARDS ALSA_PCM_PLUGINS APACHE2_MODULES APACHE2_MPMS CAMERAS CROSSCOMPILE_OPTS DVB_CARDS ELIBC FCDSL_CARDS FOO2ZJS_DEVICES FRITZCAPI_CARDS INPUT_DEVICES KERNEL LCD_DEVICES LINGUAS LIRC_DEVICES MISDN_CARDS NETBEANS_MODULES USERLAND VIDEO_CARDS"
USE_EXPAND_HIDDEN="CROSSCOMPILE_OPTS ELIBC KERNEL USERLAND"
USE_ORDER="env:pkg:conf:defaults:pkginternal:env.d"
VIDEO_CARDS="nvidia"
WINDOWID="50331834"
WINDOWPATH="8"
XAUTHORITY="/root/.xauth4aSukq"
XDG_SESSION_COOKIE="83d4daf6253d843610d94b0046e43dd1-1229404715.639671-1086661690"
XERCESC_NLS_HOME="/usr/share/xerces-c/msg"
_="/usr/bin/emerge"
Comment 1 Rafał Mużyło 2008-12-23 17:13:44 UTC
Is that ebuild from the tree or from one of the overlays ?

But anyway, what you probably want is xulrunner useflag
in gnome-python-extras.
Comment 2 Tijmen van Hoeckel 2008-12-24 03:53:00 UTC
(In reply to comment #1)
> Is that ebuild from the tree or from one of the overlays ?
> 
> But anyway, what you probably want is xulrunner useflag
> in gnome-python-extras.
> 

The ebuild is from the tree. I don't know if there is any overlay which provides Listen at all.

I have the xulrunner USE-flag in my make.conf. Gnome-python-extras doesn't seem to care at all though. So at this point I'm not sure where the problem lies. Is it gnome-python-extras which doesn't pick up USE-flags? Or is it an error in the Listen ebuild?

Comment 3 Rafał Mużyło 2008-12-24 14:09:22 UTC
OK, now I see what the problem is:
listen ebuild was not updated when dev-python/gnome-python-extras
became a meta.
Now it should check dev-python/gtkmozembed-python for that useflag.
Comment 4 Tijmen van Hoeckel 2008-12-25 04:45:54 UTC
Seems like a reasonable explanation to me. I hope someone can find the time to fix the ebuild :)   
Comment 5 Fabiano Francesconi 2009-04-26 11:36:15 UTC
The problem seems to be still there.

Any fix or workaround?
Comment 6 Geert Vanhaute 2009-04-28 20:10:13 UTC
Created attachment 189733 [details]
listen-0.5-r1.ebuild

Why isn't this in portage yet?
Comment 7 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-07-06 17:00:58 UTC
I'd call QA on this since the package seems to have been broken trivially for quite a while...
Comment 8 Samuli Suominen gentoo-dev 2009-07-17 09:07:47 UTC
0.6.2 in portage, 0.5* removed.