Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 25224 - PROVIDE from an eclass fails
Summary: PROVIDE from an eclass fails
Status: RESOLVED DUPLICATE of bug 1343
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
: 23349 (view as bug list)
Depends on:
Blocks:
 
Reported: 2003-07-24 20:06 UTC by Eric Olinger
Modified: 2005-07-17 13:06 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Olinger 2003-07-24 20:06:31 UTC
Openbox should provide virtual/blackbox. Most, if not all, of the packages
that depend on virtual/blackbox work under Openbox. I haven't tested all
packages that require it but I currently run bbtime, bbapm, bbrun, bbpager on
Openbox, and I have also run bbdate on Openbox.

Reproducible: Always
Steps to Reproduce:
1. emerge -p openbox bbapm

Actual Results:  
These are the packages that I would merge, in order:
[ebuild   N  ] x11-wm/openbox-2.3.0
[ebuild   N  ] x11-wm/blackbox-0.65.0
[ebuild   N  ] x11-misc/bbapm-0.0.1-r3

Expected Results:  
These are the packages that I would merge, in order:
[ebuild   N  ] x11-wm/openbox-2.3.0
[ebuild   N  ] x11-misc/bbapm-0.0.1-r3
Comment 1 Nick Hadaway 2003-07-30 07:35:43 UTC
This appears to be a problem with how emerge -p determines dependancies... virtual/openbox is declared via the commonbox.eclass... 

My thought is maybe emerge doesn't realize this is gotten from the eclass... so it thinks blackbox needs to be installed... 

emerge openbox by itself first... you will find that the problem no longer is there as portage then understands that openbox fills the virtual/blackbox need.

Looking further into this...but at least now you should be able to do things without having blackbox installed.
Comment 2 Nick Hadaway 2003-08-15 20:25:22 UTC
This appears to be a problem with portage.  When doing an emerge (like noted in this bug), emerge should consider any inherited eclass' DEPENDs, RDEPENDs, and PROVIDEs.
Comment 3 SpanKY gentoo-dev 2003-08-15 22:02:26 UTC
this gets back to what are we doing with new{,r,c}depend 
Comment 4 Brandon Hale (RETIRED) gentoo-dev 2003-08-22 14:14:24 UTC
*** Bug 23349 has been marked as a duplicate of this bug. ***
Comment 5 Marius Mauch (RETIRED) gentoo-dev 2004-04-01 01:24:04 UTC

*** This bug has been marked as a duplicate of 1343 ***