Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 251093 - x11-base/xorg-server-1.5.3 upgrade guide
Summary: x11-base/xorg-server-1.5.3 upgrade guide
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Server (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
: 252433 252480 274087 (view as bug list)
Depends on:
Blocks: 251832
  Show dependency tree
 
Reported: 2008-12-16 00:39 UTC by Francois Chenier
Modified: 2009-06-23 05:07 UTC (History)
10 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
x11 upgrade guide v1 (x11 upgrade guide.txt,2.99 KB, text/plain)
2009-03-27 23:33 UTC, Rémi Cardona
Details
basic trackpoint-specific configuration to get scroll function (11-trackpoint.fdi,326 bytes, application/xml)
2009-03-29 15:36 UTC, Andreas Sturmlechner
Details
x11 upgrade guide v2 (x11 upgrade guide.txt,4.49 KB, text/plain)
2009-03-29 23:27 UTC, Rémi Cardona
Details
xml-ified version of remi's guide (upgrading-to-xorg-1.5.xml,6.10 KB, text/plain)
2009-03-30 03:15 UTC, Łukasz Damentko (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Francois Chenier 2008-12-16 00:39:17 UTC
Thanks this mate (http://lists.ibiblio.org/pipermail/sm-users/2008-November/001184.html) but if after upgrading xorg-server to 1.5.3 your keyboard or mouse does not work any more, just do this ...

> All,
>
> If, after updating to xorg-server 1.5.3, you no longer have the use of
> a standard keyboard or mouse (using the kbd or mouse drivers), you will
> want to add the following to /etc/X11/xorg.conf:
>
> Section "ServerFlags"
>        Option  "AllowEmptyInput"       "false"
> EndSection
>
> 
> Otherwise devices using the kbd and mouse drivers will be disabled.
> Devices using other inputs (e.g. synaptics or evdev) will continue to
> work fine (with or without the above).
>
> -sandalle

Reproducible: Always

Steps to Reproduce:
1.sudo emerge =x11-base/xorg-server-1.5.3
2.logoff
3.reboot (or restart X11) et voilà !!!
Comment 1 Federico Fissore 2008-12-16 09:48:25 UTC
I confirm problem and solution

thank you
Comment 2 Jeff Kowalczyk 2008-12-16 14:09:20 UTC
Also confirming problem and fix. Thinkpad T61p Nvidia Fx 570M.
Comment 3 Rémi Cardona gentoo-dev 2008-12-16 16:36:14 UTC
Well, that's not a bug per se. It's how Xorg now works if you have USE=hal.

You have 3 possibilities :
1) rebuild xorg-server with USE=-hal
2) use the AutoAddDevices/AutoEnableDevices/AllowEmptyInput options in your xorg.conf
3) remove all input sections from your xorg.conf and properly set-up HAL

Basically, I think we/I need to document this.

Thanks
Comment 4 Marcin Deranek 2008-12-16 22:42:52 UTC
Bear in mind that setting AllowEmptyInput to false while using evdev-2.1 will cause xorg to crach while pressing ctrl+c:

http://bugs.archlinux.org/task/12372
Comment 5 Francois Chenier 2008-12-17 00:53:07 UTC
(In reply to comment #3)

> Basically, I think we/I need to document this.

I agree. Because of the severity of this issue (I had to reboot my kernel with nox option), just add a warning to this ebuild and close this bug.

Regards

Comment 6 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2008-12-25 21:22:05 UTC
*** Bug 252480 has been marked as a duplicate of this bug. ***
Comment 7 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2008-12-25 21:41:16 UTC
*** Bug 252433 has been marked as a duplicate of this bug. ***
Comment 8 ray keung 2009-01-09 06:03:08 UTC
Here is what worked for me (no need to remove input sections from xorg.conf):
in xorg.conf 
1.change driver for Mouse from "mouse" to "evdev"
2.change driver for Keyboard from "kbd" to "evdev"

i tried removing all input sections and having hald adding the devices for me automatically but the keyboard repeat rate was bonkers.
Comment 9 Frossie 2009-01-13 10:30:03 UTC
(In reply to comment #8)
> Here is what worked for me (no need to remove input sections from xorg.conf):
> in xorg.conf 
> 1.change driver for Mouse from "mouse" to "evdev"
> 2.change driver for Keyboard from "kbd" to "evdev"

That is what did the trick for me, but I also needed to add evdev to INPUT_DEVICES in make.conf

Also, another thing to check if you are using hal is to make sure you are starting hald as a boot service.

I think adding a URL to this bug report at least as a comment at the end of the xorg-server build would be useful. 


Comment 10 Andreas Sturmlechner gentoo-dev 2009-03-11 00:40:01 UTC
I think we can only solve this 'bug' by an upgrade guide and a big red flashing warning at the end of emerge xorg-server.
Comment 11 Balint Dobai-Pataky 2009-03-11 06:31:49 UTC
reemerging x11-base/xorg-server-1.5.3-r3 with -hal does not do the trick for me.
i can't switch to evdev for mouse:( #261989
control-c crashes X with evdev-2.2.0-r1
Comment 12 Rémi Cardona gentoo-dev 2009-03-11 10:13:48 UTC
(In reply to comment #11)
> reemerging x11-base/xorg-server-1.5.3-r3 with -hal does not do the trick for
> me.
> i can't switch to evdev for mouse:( #261989
> control-c crashes X with evdev-2.2.0-r1

Let's keep bugs on topic, please. Open a new bug.

Thanks
Comment 13 Rémi Cardona gentoo-dev 2009-03-27 23:33:15 UTC
Created attachment 186497 [details]
x11 upgrade guide v1

Sigh, finally! A small upgrade guide.

If anyone wants to pitch in ideas, comments, text, I'm all ears.

Donnie, how do we proceed with the stabilization ?

Thanks
Comment 14 Pacho Ramos gentoo-dev 2009-03-28 08:45:44 UTC
I think that would be interesting add specific information about setting keymap with "hal way", as most of users will need to do it. In summary, I did the following:
cp /usr/share/hal/fdi/policy/10osvendor/10-keymap.fdi /etc/hal/fdi/policy/

And modify:
<merge key="input.xkb.layout" type="string">us</merge>

as needed (in my case, "es")

I think that this guide should also include information for solving bug 236983 , but we need, at first, to know what exact options will allow most of users recover past synaptics behavior (we can discuss it in related bug)

Thanks! :-)
Comment 15 Andreas Sturmlechner gentoo-dev 2009-03-29 15:36:29 UTC
Created attachment 186659 [details]
basic trackpoint-specific configuration to get scroll function

Added a basic configuration for trackpoint devices found on IBM/Lenovo Thinkpad notebooks. It makes scrolling via the trackpoint+3rd button possible as it is intended for use. I couldn't find an existing template for that in /usr/share/hal/fdi/policy/10osvendor and looked that one up on the web. Apart from that the standard 10-x11-input.fdi file works, loading evdev for the trackpoint.

Imo we should either add that information to the manual, or include it in the list of templates.
Comment 16 Rémi Cardona gentoo-dev 2009-03-29 23:01:51 UTC
(In reply to comment #14)
> I think that would be interesting add specific information about setting keymap
> with "hal way", as most of users will need to do it. In summary, I did the
> following:
> cp /usr/share/hal/fdi/policy/10osvendor/10-keymap.fdi /etc/hal/fdi/policy/
> 
> And modify:
> <merge key="input.xkb.layout" type="string">us</merge>
> 
> as needed (in my case, "es")

Right, it makes sense to have these instructions directly in the upgrade guide.

> I think that this guide should also include information for solving bug 236983
> , but we need, at first, to know what exact options will allow most of users
> recover past synaptics behavior (we can discuss it in related bug)

Not yet, I'll only put 2.1.3 on the upgrade list, we can do >=2.2.1 later on.

(In reply to comment #15)
> Created an attachment (id=186659) [edit]
> basic trackpoint-specific configuration to get scroll function
> 
> Added a basic configuration for trackpoint devices found on IBM/Lenovo Thinkpad
> notebooks. It makes scrolling via the trackpoint+3rd button possible as it is
> intended for use. I couldn't find an existing template for that in
> /usr/share/hal/fdi/policy/10osvendor and looked that one up on the web. Apart
> from that the standard 10-x11-input.fdi file works, loading evdev for the
> trackpoint.
> 
> Imo we should either add that information to the manual, or include it in the
> list of templates.

I guess trackpoint users needed to do that before evdev came to light. I'm not sure it's worth patching the driver to include those options. I'll add a note about evdev's man page though.

Thanks
Comment 17 Rémi Cardona gentoo-dev 2009-03-29 23:27:30 UTC
Created attachment 186694 [details]
x11 upgrade guide v2

Here's an updated version of the upgrade guide. I think we're good for stabilization. All the basics are nicely covered.

Banzai!
Comment 18 Łukasz Damentko (RETIRED) gentoo-dev 2009-03-30 03:15:51 UTC
Created attachment 186706 [details]
xml-ified version of remi's guide

I converted remi's guide to GuideXML so he can post it to desktop/X project space.

Source is in the attachment. Online version is available for preview here:

http://dev.gentoo.org/~rane/other/upgrading-to-xorg-1.5.xml
Comment 19 Rémi Cardona gentoo-dev 2009-03-30 06:42:48 UTC
Brilliant, thanks a bunch Łukasz!
Comment 20 Pacho Ramos gentoo-dev 2009-03-30 06:47:35 UTC
(In reply to comment #16
> > I think that this guide should also include information for solving bug 236983
> > , but we need, at first, to know what exact options will allow most of users
> > recover past synaptics behavior (we can discuss it in related bug)
> 
> Not yet, I'll only put 2.1.3 on the upgrade list, we can do >=2.2.1 later on.

But, isn't it a x11-drivers/xf86-input-synaptics "problem"? (not a x11-drivers/xf86-input-evdev one)

Best regards :-)
Comment 21 Frederik 'Freso' S. Olesen 2009-03-30 19:45:48 UTC
Just a note that the current guide lists
> INPUT_DRIVER="evdev"
which really should say
> INPUT_DEVICES="evdev"
instead. (Unless, of course, this has changed since the last stable Xorg release... but then I guess this should be documented as well.)
Comment 22 Rémi Cardona gentoo-dev 2009-03-31 09:20:40 UTC
(In reply to comment #20)
> But, isn't it a x11-drivers/xf86-input-synaptics "problem"? (not a
> x11-drivers/xf86-input-evdev one)

Indeed, and I've added links on how to configure the synaptics driver. If you want to contribute an official "synatpics HOWTO", I'm sure we can work it out :)

(In reply to comment #21)
> Just a note that the current guide lists
> > INPUT_DRIVER="evdev"
> which really should say
> > INPUT_DEVICES="evdev"
> instead. (Unless, of course, this has changed since the last stable Xorg
> release... but then I guess this should be documented as well.)

Thanks for catching this. Fixed in cvs.

I consider this bug to be solved. If you have any more issues with the upgrade guide, please open new bug reports.

Thanks
Comment 23 Hongjiu Zhang 2009-06-23 05:07:46 UTC
*** Bug 274087 has been marked as a duplicate of this bug. ***