Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 251024 - sys-apps/openrc-0.4.[0-1] Init: no more processes left in this runlevel
Summary: sys-apps/openrc-0.4.[0-1] Init: no more processes left in this runlevel
Status: RESOLVED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] baselayout (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords:
: 252632 359109 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-12-15 14:13 UTC by Wolf
Modified: 2011-05-13 17:13 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
gentoo-2.6.27-r6 kernel .config (kernel.config,49.14 KB, text/plain)
2008-12-15 14:17 UTC, Wolf
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Wolf 2008-12-15 14:13:56 UTC
After doing a fresh nuke-and-pave install on my ThinkPad T61p, I upgraded to the new BaseLayout2 + OpenRC 0.4.0 system. While it boots very fast, shutdown and reboots now require me to use the Magic SysRq keystrokes or hold down the power button. The last message that comes up every time (and is AFAIK correct as a forced OOM panic returns no processes killable) is:

Init: no more processes left in this runlevel

I confirmed that this configuration causes this and that it's not a mixedup-package situation by doing a successful emerge -vea world without error, rebooting, repeating that process and the error still occuring after another reboot.

This does not appear to be related to 218576, 219184, 239922. It may be related to 246502 but I'm unsure.
Comment 1 Wolf 2008-12-15 14:14:29 UTC
/sbin/lspci results:
00:00.0 Host bridge: Intel Corporation Mobile Memory Controller Hub (rev 0c)
00:01.0 PCI bridge: Intel Corporation Mobile PCI Express Root Port (rev 0c)
00:19.0 Ethernet controller: Intel Corporation 82566MM Gigabit Network Connection (rev 03)
00:1a.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Contoller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 2 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 3 (rev 03)
00:1c.3 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 4 (rev 03)
00:1c.4 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 5 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev f3)
00:1f.0 ISA bridge: Intel Corporation Mobile LPC Interface Controller (rev 03)
00:1f.1 IDE interface: Intel Corporation Mobile IDE Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation Mobile SATA AHCI Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801H (ICH8 Family) SMBus Controller (rev 03)
01:00.0 VGA compatible controller: nVidia Corporation Device 040c (rev a1)
03:00.0 Network controller: Intel Corporation Device 4230 (rev 61)
15:00.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev ba)
15:00.1 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 04)
15:00.2 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 21)
15:00.3 System peripheral: Ricoh Co Ltd Device 0843 (rev ff)
15:00.4 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 11)
15:00.5 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev 11)
Comment 2 Wolf 2008-12-15 14:14:47 UTC
/etc/portage/package.unmask
=sys-apps/openrc-0.4.0

/etc/portage/package.keywords
sys-kernel/gentoo-sources ~amd64
net-misc/ntpclient ~amd64
net-wireless/iwl4965-ucode ~amd64
net-wireless/wpa_supplicant ~amd64
app-benchmarks/bootchart ~amd64
sys-devel/gcc ~amd64
sys-libs/glibc ~amd64
sys-apps/portage ~amd64
app-admin/eselect-news ~amd64
app-admin/eselect ~amd64
sys-libs/gpm ~amd64
sys-libs/gpm ~amd64
sys-apps/baselayout ~amd64
sys-apps/openrc ~amd64
sys-fs/udev ~amd64
x11-drivers/nvidia-drivers ~amd64
x11-base/xorg-server ~amd64
x11-libs/pixman ~amd64
x11-libs/libpciaccess ~amd64
x11-proto/xproto ~amd64
x11-apps/xauth ~amd64
x11-libs/libXrender ~amd64
x11-proto/xextproto ~amd64
x11-libs/libXau ~amd64
x11-libs/libXext ~amd64
x11-proto/inputproto ~amd64
x11-libs/xtrans ~amd64
x11-misc/xkeyboard-config ~amd64
media-libs/mesa ~amd64
x11-libs/libdrm ~amd64
x11-libs/libX11 ~amd64
x11-proto/xf86driproto ~amd64
x11-libs/libXxf86vm ~amd64
x11-apps/rgb ~amd64
x11-apps/xinit ~amd64
x11-proto/randrproto ~amd64
x11-libs/libXfont ~amd64
x11-proto/renderproto ~amd64
x11-drivers/xf86-input-synaptics ~amd64
x11-drivers/xf86-input-keyboard ~amd64
x11-drivers/xf86-input-evdev ~amd64
x11-drivers/xf86-input-mouse ~amd64
net-misc/netkit-rsh ~amd64
app-emulation/kvm ~amd64
x11-wm/compiz-fusion ~amd64
x11-plugins/compiz-fusion-plugins-extra ~amd64
x11-plugins/compiz-fusion-plugins-main ~amd64
x11-wm/compiz ~amd64
x11-wm/emerald ~amd64
x11-apps/ccsm ~amd64
dev-python/compizconfig-python ~amd64
x11-libs/libcompizconfig ~amd64
x11-themes/emerald-themes ~amd64
x11-libs/compiz-bcop ~amd64
=kde-base/kdebase-3.5.9-r4 ~amd64
app-emulation/wine ~amd64
app-antivirus/clamav ~amd64
app-laptop/laptop-mode-tools ~amd64
sys-apps/smartmontools ~amd64
sys-apps/hdparm ~amd64
www-client/mozilla-firefox ~amd64
net-libs/xulrunner ~amd64
dev-libs/nspr ~amd64
dev-libs/nss ~amd64
dev-db/sqlite ~amd64
media-libs/fmod ~amd64
dev-util/cmake ~amd64
dev-java/ibm-jdk-bin ~amd64
www-client/mozilla-firefox-bin ~amd64
net-www/netscape-flash ~amd64
dev-lang/nasm ~amd64
app-shells/bash ~amd64
sys-apps/busybox ~amd64
app-admin/logrotate ~amd64

/etc/portage/package.use
sys-kernel/gentoo-sources symlink
net-misc/dhcpcd -zeroconf -compat
app-benchmarks/bootchart java
sys-devel/gcc -fortran
x11-drivers/nvidia-drivers acpi
media-libs/libsdl X oss opengl
app-emulation/kvm havekernel
x11-libs/gtk+ -cups
x11-libs/cairo X
x11-libs/pango X
x11-libs/cairo glitz svg
app-emulation/wine -cups oss jpeg
app-laptop/laptop-mode-tools acpi
www-client/mozilla-firefox xulrunner
dev-java/sunjdk nsplugin X alsa
dev-java/sun-jdk nsplugin X alsa
www-client/mozilla-firefox java
net-misc/openvpn examples iproute2 passwordsave
media-libs/fmod doc examples
media-libs/fmod ~amd64
dev-java/sun-jdk nsplugin
dev-java/ibm-jdk-bin nsplugin X
app-emulation/emul-linux-x86-java nsplugin
app-emulation/emul-linux-x86-java X alsa
www-client/mozilla-firefox iceweasel
dev-lang/nasm doc

/var/lib/portage/world
app-admin/logrotate
app-admin/sudo
app-admin/syslog-ng
app-antivirus/clamav
app-arch/p7zip
app-arch/unrar
app-benchmarks/bootchart
app-emulation/kvm
app-emulation/wine
app-laptop/laptop-mode-tools
app-portage/gentoolkit
dev-lang/nasm
dev-libs/dbus-glib
dev-util/cmake
dev-util/subversion
kde-base/kdebase-startkde
kde-base/kdm
kde-base/klaptopdaemon
kde-base/konsole
media-libs/fmod
media-sound/smixer
media-video/mplayer
net-misc/bridge-utils
net-misc/dhcpcd
net-misc/ntpclient
net-misc/openvpn
net-p2p/ctorrent
net-wireless/iwl4965-ucode
net-wireless/wireless-tools
net-wireless/wpa_supplicant
net-www/netscape-flash
net-www/nspluginwrapper
sys-apps/hdparm
sys-apps/smartmontools
sys-apps/usbutils
sys-apps/usermode-utilities
sys-boot/grub-static
sys-kernel/gentoo-sources
sys-process/vixie-cron
virtual/jre
www-client/links
www-client/mozilla-firefox
x11-drivers/nvidia-drivers
x11-proto/damageproto
x11-wm/compiz-fusion
x11-wm/metacity

/usr/portage/metadata/timestamp
Mon Dec 15 10:08:53 UTC 2008
Comment 3 Wolf 2008-12-15 14:15:41 UTC
emerge --info

Portage 2.1.6.1 (default/linux/amd64/2008.0, gcc-4.3.2, glibc-2.9_p20081201-r0, 2.6.27-gentoo-r6retzopan x86_64)
=================================================================
System uname: Linux-2.6.27-gentoo-r6retzopan-x86_64-Intel-R-_Core-TM-2_Duo_CPU_T9300_@_2.50GHz-with-glibc2.2.5
Timestamp of tree: Mon, 15 Dec 2008 10:30:01 +0000
app-shells/bash:     3.2_p48
dev-java/java-config: 1.3.7-r1, 2.1.6
dev-lang/python:     2.4.4-r13, 2.5.2-r7
dev-python/pycrypto: 2.0.1-r6
dev-util/cmake:      2.6.2
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.4.0
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r2
sys-devel/automake:  1.7.9-r1, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -fomit-frame-pointer -s"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -pipe -fomit-frame-pointer -s"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LDFLAGS="-Wl,-O1 -s"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="acl amd64 berkdb bzip2 cli cracklib crypt cups dri fortran gdbm iconv isdnlog midi mmx mudflap multilib ncurses nls nptl nptlonly openmp pam pcre perl pppd python readline reflection session spl sse sse2 ssl sysfs tcpd unicode xcb xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 4 Wolf 2008-12-15 14:17:35 UTC
Created attachment 175330 [details]
gentoo-2.6.27-r6 kernel .config
Comment 5 Matthias Schwarzott gentoo-dev 2008-12-16 15:14:44 UTC
What version of sysvinit do you have installed? If yes, did you update your config-files. If not, did you force portage not to update sysvinit?

Only the newest revision does work correct with openrc-0.4.0 as only this has the necessary additions to /etc/inittab.
This is related to Bug #246502.
Comment 6 Wolf 2008-12-16 17:07:35 UTC
After emerging baselayout2 and openrc-0.4.0, my sysvinit was 2.86-r10. ~amd64 on sysvinit shows an r11 available, that solved the issue with the extra 'halt' and 'reboot' calls in the inittab.

I guess package.unmask makes it ignore dependancies entirely? I hadn't seen any bitching from the various -vea or -vuaND world's I'd done, and there is a dependancy listed in the ebuild for openrc-0.4.0 so this isn't a bug. Might need to mention that in the guide, if possible? Thanks for sorting that out!
Comment 7 Doug Goldstein gentoo-dev 2008-12-16 17:27:08 UTC
OpenRC 0.4.0 should still be masked...
Comment 8 Panagiotis Christopoulos (RETIRED) gentoo-dev 2008-12-26 21:40:21 UTC
*** Bug 252632 has been marked as a duplicate of this bug. ***
Comment 9 Panagiotis Christopoulos (RETIRED) gentoo-dev 2008-12-26 21:42:38 UTC
I reopen, as the same seems to happen in openrc-0.4.1 again. See bug 252632
Comment 10 Wolf 2008-12-26 22:10:33 UTC
Can you please make sure you run etc-update, and apply any required modifications to your /etc/inittab file?

Also, please post the results of these commands:

grep halt /etc/inittab
grep reboot /etc/inittab

In my case, I have these lines:

*@* ~ $ grep halt /etc/inittab

l0s:0:wait:/sbin/halt -dhip

*@* ~ $ grep reboot /etc/inittab

l6:6:wait:/sbin/rc reboot
l6r:6:wait:/sbin/reboot -dk

Note the "halt -dhip" and "reboot -dk" lines, if these are missing, you'll get the above-mentioned 'No processes left' error.
Comment 11 Tom Wunder 2008-12-26 22:26:38 UTC
(In reply to comment #10)
> l0s:0:wait:/sbin/halt -dhip
> l6r:6:wait:/sbin/reboot -dk

These lines were missing in my OpenRC-0.4.1 installation, I don't know why. After adding them everything works fine!
Comment 12 Wolf 2008-12-26 22:55:29 UTC
They're not part of openrc AFAIK, they're installed as part of sysvinit . -r11 installed them for me at least, solving this bug initially with OpenRC 0.4.0
Comment 13 Doug Goldstein gentoo-dev 2008-12-27 16:00:50 UTC
You need to have sys-apps/sysvinit-2.86-r11 or higher installed on your system. The OpenRC ebuild has a blocker on lower versions.
Comment 14 Panagiotis Christopoulos (RETIRED) gentoo-dev 2008-12-27 16:19:04 UTC
(In reply to comment #13)
> You need to have sys-apps/sysvinit-2.86-r11 or higher installed on your system.
> The OpenRC ebuild has a blocker on lower versions.
> 

I reopened the bug, because he said that he already had sysvinit-2.86-r12. I copy paste the lines from bug 252632. I found it weird.

dadsnote etc # emerge -pv sysvinit openrc baselayout

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] sys-apps/sysvinit-2.86-r12  USE="(-ibm) (-selinux) -static" 0
kB
[ebuild   R   ] sys-apps/baselayout-2.0.0  USE="-build" 0 kB
[ebuild   R   ] sys-apps/openrc-0.4.1  USE="ncurses pam unicode -debug" 0 kB

Total: 3 packages (3 reinstalls), Size of downloads: 0 kB 

Comment 15 Doug Goldstein gentoo-dev 2008-12-29 14:42:02 UTC
I would re-emerge openrc and sysvinit. Some people had them specifically unmasked on their systems and the first few iterations in CVS (while the package was masked) did not contain all the necessary migration code since we were busy breaking our development systems to catch all the migration cases and then coding them in.
Comment 16 Doug Goldstein gentoo-dev 2009-02-05 17:10:52 UTC
Closing as INVALID, unless we get confirmation that they were re-emerged and it didn't resolve the issue.
Comment 17 Tiago Santos 2009-02-10 17:37:29 UTC
I just messed with this bug here, re-emerging sysvinit didn't solve for the first time
For some reason, it doesnt change /etc/inittab if it already exists
when i renamed it and re-emerged, then it created a new inittab file, with everything alright
You guys should check out why it doesnt even create a ._cfg file when inittab already exists
Comment 18 Gary HUnt 2009-05-23 00:03:13 UTC
same here.

Does not touch inittab file (if file exits).


Comment 19 nopenope 2010-05-05 18:05:45 UTC
very same here. Adding by hand to inittab file the halt and reboot commands fixed the problem.

No ._cfg file was created by sysvinit emerge

some info:

sysvinit version I'm using is:
sys-apps/sysvinit-2.87-r3


variables:

$CONFIG_PROTECT:
/usr/share/X11/xkb /usr/share/config

$CONFIG_PROTECT_MASK: 
/etc/gentoo-release /etc/sandbox.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/terminfo /etc/ca-certificates.conf /etc/texmf/web2c /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/revdep-rebuild

Comment 20 SpanKY gentoo-dev 2011-04-30 07:20:19 UTC
*** Bug 359109 has been marked as a duplicate of this bug. ***
Comment 21 Tom Noonan 2011-05-02 02:15:54 UTC
I hit this on IA64 after following the guide.  (See bug 359109)  Why is this invalid?
Comment 22 Peter Volkov (RETIRED) gentoo-dev 2011-05-13 12:12:58 UTC
(In reply to comment #21)
> I hit this on IA64 after following the guide.  (See bug 359109)  Why is this
> invalid?

Because it happens due to /etc/inittab being not updated by human. If you are sure (you are able to reproduce) that this happens due to bug in our tools (portage/dispatch-conf) and that this is not hardware/human issue, please, open new bug report for portage team. Currently this looks like you've confirmed keeping old inittab file some time ago.
Comment 23 Tom Noonan 2011-05-13 12:59:10 UTC
"Because it happens due to /etc/inittab being not updated by human."

Fair enough.  However, you have multiple users saying their inittab which works with baselayout 1 does not work with baselayout 2.  My inittab was not very old, the install was only done fresh a year ago.  The migration guide at http://www.gentoo.org/doc/en/openrc-migration.xml does not mention /etc/inittab and your tools do not provide a ._conf file when upgraded.  This is not purely a user error.

The proper action here is to change this to a documentation bug so you can inform the users, not to simply close as invalid.  I propose marking this as a duplicate of bug 213998, which is the OpenRC documentation tracker bug.  I apparently do not have the rights to do this myself.
Comment 24 Tom Noonan 2011-05-13 13:11:04 UTC
I used the wrong bug number in my previous message.

http://bugs.gentoo.org/show_bug.cgi?id=213988
Comment 25 Peter Volkov (RETIRED) gentoo-dev 2011-05-13 17:13:42 UTC
Tom, it is really good idea to document problems with solutions and for them it could be really great idea to have something like Microsoft's kb articles (this already popped up on -dev mailing list once or twice). But in Gentoo we have only power to maintain documentation only for things "how they should work" and all other issues are documented here, in Bugzilla. So documentation request is already FIXED and initial bug is invalid.