Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 25093 - emerge kde fails because of error in installing cdparanoia-3.9.8
Summary: emerge kde fails because of error in installing cdparanoia-3.9.8
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High major (vote)
Assignee: Gentoo Linux bug wranglers
Depends on:
Reported: 2003-07-22 20:43 UTC by N!P6u
Modified: 2004-01-01 16:59 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description N!P6u 2003-07-22 20:43:07 UTC
I am trying to "emerge kde" but the process halts after it tries to install

Reproducible: Always
Steps to Reproduce:
1.emerge kde

Actual Results:  
 utils.h:208: warning: depricated use of label at the end of compount statement
gcc -march=k6-2 -O3 -pipe -fomit-frame-pointer -c smallft.c
{standard input}: Assembler Messages
{standard input}: 1199: Error: Value of ffffffffffffff79 too large for field of
bytes at 0000000000000c91
make[2]: *** [smallft.o] Error 1
make[2]: Leaving Directory
make[1]: Leaving Directory
make: *** [all] Error 2

!!! Error: media-sound/cdparanoia-3.9.8 failed
!!! Function src_compile, line 23, Exitcode 2
!!! (no error message) 

I get the same error when I try:
emerge paranoia

I am using CFLAGS="-march=k6-2 -O3 -pipe -fomit-frame-pointer"
Comment 1 SpanKY gentoo-dev 2003-07-22 20:54:57 UTC
you are using the wrong march flag 
change it to march=k6 
please review Bug 24379 
Comment 2 N!P6u 2003-07-22 21:17:32 UTC
I tried with march=k6, mcpu=k6-2 and mcpu=k6 and none of those worked.
Comment 3 Martin Holzer (RETIRED) gentoo-dev 2003-07-22 22:38:02 UTC
use i586 instead
Comment 4 N!P6u 2003-07-22 22:49:46 UTC
Thanks Martin! I586 Seems to work for cdparanoia-3.9.8 patch.

So, is this the bug with cdparanoia-3.9.8 patch that it does not support "k6" and "k6-2" flags for cpu and arch?
Comment 5 Martin Holzer (RETIRED) gentoo-dev 2003-07-23 00:31:14 UTC
there are some bugs with k6, k6-2 and k6-3 in gentoo bugzilla.
in ebuilds, flag-o-magic is used to replace your CFLAGS from k6* to i586 to prevent most of this issues
Comment 6 Mitchell 2004-01-01 16:59:45 UTC
flag-o-matic has not been configured for this ebuild so you have to set the CFLAGS and CXXFLAGS by hand in order to have this program compile without issue.