Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 250926 - dev-python/visual fails to build with gcc 4.3
Summary: dev-python/visual fails to build with gcc 4.3
Status: RESOLVED DUPLICATE of bug 237421
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Python Gentoo Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gcc-4.3
  Show dependency tree
 
Reported: 2008-12-14 13:37 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2009-02-15 19:50 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (visual-3.2.9-r1:20081214-084012.log,13.27 KB, text/plain)
2008-12-14 13:38 UTC, Diego Elio Pettenò (RETIRED)
Details
"build.log" (build.log,37.31 KB, text/plain)
2008-12-14 13:38 UTC, Diego Elio Pettenò (RETIRED)
Details
patch to allow building with gcc 4.3 (visual-3.2.9-gcc43.patch,319 bytes, patch)
2009-01-24 22:39 UTC, Gene Seto
Details | Diff
updated ebuild to include gcc 4.3 patches (visual-3.2.9-r1.ebuild,1.91 KB, text/plain)
2009-01-24 22:39 UTC, Gene Seto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2008-12-14 13:37:51 UTC
Check attached build log and "build.log" (by the way it would be nice if it was possible to disable the "quiet" option, it's not so nice to see the build fail with no error message).

Thanks,
Diego
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2008-12-14 13:38:15 UTC
Created attachment 175243 [details]
Build log
Comment 2 Diego Elio Pettenò (RETIRED) gentoo-dev 2008-12-14 13:38:51 UTC
Created attachment 175244 [details]
"build.log"
Comment 3 Gene Seto 2009-01-24 22:39:17 UTC
Created attachment 179604 [details, diff]
patch to allow building with gcc 4.3

taken from debian 
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=455680
Comment 4 Gene Seto 2009-01-24 22:39:41 UTC
Created attachment 179606 [details]
updated ebuild to include gcc 4.3 patches
Comment 5 Peter Alfredsen (RETIRED) gentoo-dev 2009-02-15 19:50:07 UTC

*** This bug has been marked as a duplicate of bug 237421 ***