Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 25086 - Requesting addition of FT3xx module (FastTrak 376/Promise PDC20376)
Summary: Requesting addition of FT3xx module (FastTrak 376/Promise PDC20376)
Alias: None
Product: Gentoo Release Media
Classification: Unclassified
Component: Everything (show other bugs)
Hardware: x86 Linux
: High enhancement (vote)
Assignee: Bob Johnson (RETIRED)
Depends on:
Reported: 2003-07-22 15:24 UTC by Bryan Stine (RETIRED)
Modified: 2003-08-07 17:54 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

FT3xx source distribution (tar.bz2) (ft3xx.tar.bz2,112.75 KB, application/x-tbz)
2003-07-22 15:26 UTC, Bryan Stine (RETIRED)

Note You need to log in before you can comment on or make changes to this bug.
Description Bryan Stine (RETIRED) gentoo-dev 2003-07-22 15:24:35 UTC
Seemant suggested I contact Livewire, which will be done, but I'm posting a bug on here for 
tracking and good measure. 
This is a request to have the attached module added to the LiveCD. This module provides 
access to any S/ATA drives connected to a PDC20376 (and possibly other PDC2023xx) 
controller, commonly found on new motherboards for IDE RAID capabilities (and also Serial 
ATA). This is a (half?) open-source version of the proprietary Promise driver, which can be 
compiled as a module for any recent 2.4 kernel, and upon insertion will provide SCSI (sdX) 
device access to the IDE drives. 
Please note that so far, I have only been able to get this module to boot to a live system (with 
an initrd, of course) at acceptable speeds on Livewire's 2.4.21-gss kernel (copied from the 
new experimental XFree-enabled LiveCDs). With any other kernel I've compiled, it reverts to 
extremely slow (PIO, I believe) data transfer, and renders the system just about unusable. I've 
posted on gentoo-user about this issue, and await reply. 

Reproducible: Always
Steps to Reproduce:

Please Note: There currently are drivers for the PDC202xx series in the kernel, however they 
are not compatible with the newer line. 
Also, I've read on another mailing list (possibly LKML) that a developer is actively working on a 
fully open-source kernel driver (which would be able to build into the kernel), however it may 
be a long time before such a driver is released. Promise is (apparently) refusing to distribute 
specifications for the controller to open source developers.
Comment 1 Bryan Stine (RETIRED) gentoo-dev 2003-07-22 15:26:03 UTC
Created attachment 14890 [details]
FT3xx source distribution (tar.bz2)

This is the ft3xx driver, converted from a DOS-format zip to a UNIX-format
Comment 2 Bob Johnson (RETIRED) gentoo-dev 2003-07-22 15:33:17 UTC
was announced on lkml today if you havent seen yet ,that promise 
has gpl'ed this driver now, and  a few ppl (-ac,etc) are already working 
on it heavily. 
Im trying to think why the 2.4.21-gss would work good for you. 
This is a kernel that i havent even released in portage. 
Its pretty vanilla in reality, besides xfs,evms,etc. 
You might check out the kernel config of the livecd. 
Comment 3 Bryan Stine (RETIRED) gentoo-dev 2003-07-22 15:55:44 UTC
Wow...that's unbelievably good news for me :-) 
I was using the config (/proc/config) from your kernel with genkernel and make 
oldconfig on the kernels I tried. The fact that it's pretty vanilla could be why it's 
operating well for me. There may be a patch in the portage kernels that aren't 
working well with that driver for some reason. Even so, I should be able to make 
do for now until Alan and the others get a good driver working in-kernel. 
Thanks for the great news. Should this be closed, resolved? 
Comment 4 Bryan Stine (RETIRED) gentoo-dev 2003-07-22 15:58:40 UTC
I've got the URL here for the LKML announcement in the archives, just in case 
someone comes here searching for something about that driver. 
The file is linked in that article. 
Comment 5 Bryan Stine (RETIRED) gentoo-dev 2003-07-22 16:37:33 UTC
Upon closer inspection and failed attempts to load that module, it seems like that's not matching what I want. The listed chipsets that the driver supports is:

PDC20318        Promise SATA150 TX4
PDC20375        Promise SATA150 TX2plus
PDC20378        Promise SATA 378
PDC20618        Promise Ultra 618

Unfortunately, the PDC20376 isn't listed. So, I'm still left looking for a driver, evidently.
Comment 6 Bob Johnson (RETIRED) gentoo-dev 2003-07-22 16:57:49 UTC
will see what happens with the recent release 
Comment 7 Bryan Stine (RETIRED) gentoo-dev 2003-07-22 17:00:45 UTC
Roger that. Since the PDC20375 is supported, it may be much easier for them now to get the software RAID support required and have a semi-elegant driver solution in the kernel for their RAID-enabled chipsets.
Comment 8 Bryan Stine (RETIRED) gentoo-dev 2003-07-28 19:12:16 UTC
Just a little update...

I've found a third-party patch from some Mandrake list while Googling around for some news. The patch is here:

And its parent post is here (in French):

This patch allows the driver to recognize my FastTrak 376 and the SATA drive connected to it, however the SCSI transfer fails upon attempting to mount the root filesystem. I'm currently looking to further solutions.
Comment 9 Bryan Stine (RETIRED) gentoo-dev 2003-08-07 17:54:57 UTC
Another update...this time a good one. I've got the pdc-ultra driver working under multiple kernels reliably. It turned out to be a rather ugly problem with ACPI PCI routing, solved by pci=noacpi. Hopefully that driver and one of the PDC20376 patches will make it into a mainstream kernel in due time. Until then, this is a good open-source solution for FastTrak 376 users.