Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 250850 - Stabilize =sci-geosciences/grass-6.3.0
Summary: Stabilize =sci-geosciences/grass-6.3.0
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Steve Arnold
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on: 270916 285475
Blocks: 266066
  Show dependency tree
 
Reported: 2008-12-13 17:50 UTC by Samuli Suominen
Modified: 2010-02-03 20:56 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Samuli Suominen gentoo-dev 2008-12-13 17:50:15 UTC
Please do, and make sure it builds against =media-video/ffmpeg-0.4.9_p20081014.
Comment 1 Samuli Suominen gentoo-dev 2008-12-15 13:18:55 UTC
x86 stable
Comment 2 Samuli Suominen gentoo-dev 2008-12-15 13:21:59 UTC
or not, it needs new postgres stable..
Comment 3 Samuli Suominen gentoo-dev 2008-12-15 13:24:12 UTC
dev-zero, deptree is broken -- can >=dev-db/postgresql-base-8.3 be stabilized?
Comment 4 Samuli Suominen gentoo-dev 2008-12-16 15:38:33 UTC
(In reply to comment #3)
> dev-zero, deptree is broken -- can >=dev-db/postgresql-base-8.3 be stabilized?
> 

nerdboy, or backport ffmpeg fix to current stable. otherwise archteams will have to revert back to ~arch with this package, or package.use.mask ffmpeg etc.

which way is preferred?
Comment 5 Steve Arnold gentoo-dev 2008-12-18 04:26:35 UTC
I'd rather shoot for stablizing on the newer interfaces; is that do-able?
Comment 6 Samuli Suominen gentoo-dev 2008-12-18 06:21:04 UTC
(In reply to comment #5)
> I'd rather shoot for stablizing on the newer interfaces; is that do-able?
> 

No response from dev-zero, so I'm afraid x86 will have to revert all of it's stable keywords soon.. One package pulling old ffmpeg, another new ffmpeg isn't just acceptable = broken deptree.
Comment 7 Steve Arnold gentoo-dev 2008-12-18 07:29:41 UTC
I thought there was a push for other packages depending on ffmpeg to update to the new header layout...  Is there some timetable we can shoot for?
Comment 8 Samuli Suominen gentoo-dev 2008-12-18 10:24:31 UTC
(In reply to comment #7)
> I thought there was a push for other packages depending on ffmpeg to update to
> the new header layout...  Is there some timetable we can shoot for?
> 

Yesterday.
Comment 9 Samuli Suominen gentoo-dev 2008-12-18 10:25:21 UTC
!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

media-video/ffmpeg:0

  ('ebuild', '/', 'media-video/ffmpeg-0.4.9_p20070616-r3', 'merge') pulled in by
    <media-video/ffmpeg-0.4.9_p20070616-r20 required by ('ebuild', '/', 'sci-geosciences/grass-6.2.1', 'merge')
    (and 1 more)

  ('ebuild', '/', 'media-video/ffmpeg-0.4.9_p20081014', 'merge') pulled in by
    >=media-video/ffmpeg-0.4.9_p20081014 required by ('ebuild', '/', 'media-plugins/gst-plugins-ffmpeg-0.10.5', 'merge')
    >=media-video/ffmpeg-0.4.9_p20080326 required by ('ebuild', '/', 'app-cdr/k3b-1.0.5-r3', 'merge')
    (and 1 more)

stable sci-geo/grass is the only incompatible package we have in tree
Comment 10 Ferris McCormick (RETIRED) gentoo-dev 2008-12-18 14:53:26 UTC
Please advise on postgresql-base.  grass-6.3.0 is fine on sparc, but without postgresql-base, we can't mark it stable, and reverting all versions of grass to ~sparc doesn't make any sense.
Comment 11 Steve Arnold gentoo-dev 2008-12-19 22:04:03 UTC
I guess we'll have to hang loose for a bit on postgres...  I thought Samuli was going to file a stable bug on pg 8.3 and link it to this one...
Comment 12 Steve Arnold gentoo-dev 2008-12-19 22:04:45 UTC
Grass 6.2.1 is updated for ffmpeg, btw...
Comment 13 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2008-12-21 05:01:46 UTC
(In reply to comment #12)
> Grass 6.2.1 is updated for ffmpeg, btw...
> 

Samuli, I have confirmed that grass-6.2.1 compiles against ffmpeg-0.4.9_p20081014. Since postgresql-base isn't ready to go, I'm not seeing an urgency here. So, I am going to remove all the arches for now.

  19 Dec 2008; Steve Arnold <nerdboy@gentoo.org>
  +files/grass-6.2.1-gcc43.patch, grass-6.2.1.ebuild:
  Backported ffmpeg fixup and use flag cleanup (see bug #250850).  Also 
  added ggc 4.3 include patch.  Still need postgres 8.3 pushed to stable
  before Grass 6.3 can go stable.

Maintainers, feel free to add us back when everything is sorted out. Thanks.
Comment 14 Samuli Suominen gentoo-dev 2008-12-21 08:51:40 UTC
I was waiting for an advise from postgres maintainers, but without response. I won't be needing this in stable anymore, please open a new bug when you get
postgres sorted out. Thanks.
Comment 15 Steve Arnold gentoo-dev 2009-04-22 02:38:34 UTC
Can we pleeeeeease get some stable action on pg 8.3?  The stable grass (6.2.1) is now broken due to compiler updates, and upstream already has several 6.4.0 rc releases out.  Many of us would like to stablize Grass 6.3.0 but we can't without some pg luv.  And no, I don't have time to do any extra work, since I already volunteered to work on some new sci-packages.  And I have exams to grade...
Comment 16 Samuli Suominen gentoo-dev 2009-06-01 09:48:16 UTC
(In reply to comment #15)
> Can we pleeeeeease get some stable action on pg 8.3?  The stable grass (6.2.1)
> is now broken due to compiler updates, and upstream already has several 6.4.0
> rc releases out.  Many of us would like to stablize Grass 6.3.0 but we can't
> without some pg luv.  And no, I don't have time to do any extra work, since I
> already volunteered to work on some new sci-packages.  And I have exams to
> grade...
> 

12:44 <@dev-zero> ssuominen: I'm not opening a bug, but you can
12:44 <@graaff> dev-zero: for fcgi the proper term is "maintain" (with the quotes). Feel 
                free to improve it where you see fit.
12:44 <@graaff> Or ping me and I'll have a look at it.
12:44 <@dev-zero> graaff: ok, thanks
12:44 <@ssuominen> dev-zero, psychoschlumpf: i'll open the bug if I can get my hands on a 
                   sensible list that needs to go stable 
12:45 <@ssuominen> dev-zero: would everything the virtuals pull in be sufficient?
12:45 <@dev-zero> ssuominen: no
12:45 <@ssuominen> see..
12:45 <+psychoschlumpf> ssuominen: no
12:45 <@dev-zero> you need postgresql-{docs,base,server}
12:47 <@ssuominen> and eselect-postgressql?
12:47 <@ssuominen> *and eselect-postgresql?
12:47 <@ssuominen> plus virtuals
12:48 <@ssuominen> plus libpq
12:48 <@ssuominen> possible libpqxx?
12:48 <@ssuominen> it's pretty huge list, might end up breaking tree
12:48 <+psychoschlumpf> libpqxx is something completely different
12:49 <+psychoschlumpf> 3rd party maintained C++ library
12:49 <@ssuominen> ok

So it seems we can open a bug for new postgres to be stable, but I'm still a bit unsure of the list.
Comment 17 Steve Arnold gentoo-dev 2009-07-18 18:38:33 UTC
Did you get anything firm on which packages you need?
Comment 18 Samuli Suominen gentoo-dev 2009-07-18 18:47:39 UTC
(In reply to comment #17)
> Did you get anything firm on which packages you need?
> 

I don't need anything; don't use grass and it's not a issue for me anymore. But, only thing I managed to get out was the irclog pasted previously.
Comment 19 Samuli Suominen gentoo-dev 2009-11-30 19:20:25 UTC
Bug 285475 should do?
Comment 20 Christian Faulhammer (RETIRED) gentoo-dev 2010-01-07 17:11:08 UTC
x86 stable
Comment 21 nixnut (RETIRED) gentoo-dev 2010-01-10 17:33:53 UTC
ppc stable
Comment 22 Raúl Porcel (RETIRED) gentoo-dev 2010-01-31 15:19:13 UTC
sparc stable
Comment 23 Markos Chandras (RETIRED) gentoo-dev 2010-02-03 20:56:23 UTC
Stable on amd64

All arches done