Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 250803 - kde-misc/yawp (Yet Another Weather Plasmoid)
Summary: kde-misc/yawp (Yet Another Weather Plasmoid)
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Default Assignee for New Packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-12-13 06:28 UTC by Marian Kyral
Modified: 2009-11-10 19:08 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
yawp-0.0.5.ebuild (yawp-0.0.5.ebuild,459 bytes, text/plain)
2008-12-13 06:28 UTC, Marian Kyral
Details
yawp-0.0.6.ebuild (yawp-0.0.6.ebuild,459 bytes, text/plain)
2008-12-14 22:09 UTC, Marian Kyral
Details
yawp-0.1.65.ebuild (yawp-0.1.65.ebuild,506 bytes, text/plain)
2009-01-25 13:52 UTC, Marian Kyral
Details
A patch file needed by version 0.1.65 to support KDE 4.2 RC and later (kde4.2.diff,531 bytes, patch)
2009-01-25 13:53 UTC, Marian Kyral
Details | Diff
yawp-0.2.ebuild (yawp-0.2.ebuild,543 bytes, text/plain)
2009-03-05 20:05 UTC, Marian Kyral
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marian Kyral 2008-12-13 06:28:02 UTC
Ebuild for yaWP-0.0.5

http://www.kde-look.org/content/show.php?content=94106

Reproducible: Always

Steps to Reproduce:
Comment 1 Marian Kyral 2008-12-13 06:28:46 UTC
Created attachment 175180 [details]
yawp-0.0.5.ebuild
Comment 2 Marian Kyral 2008-12-14 22:09:43 UTC
Created attachment 175286 [details]
yawp-0.0.6.ebuild
Comment 3 Rahul Jain 2009-01-25 11:37:22 UTC
Umm, am getting this error:

  PLASMA_FOUND -> nothing, it's always there if KDE4, version 4.2 or newer
  has been found.                                                         

  If you see this error message in a module within KDE/, update it from svn,
  it has been fixed already.                                                

Call Stack (most recent call first):
  CMakeLists.txt:5 (find_package)   


-- Configuring incomplete, errors occurred!
 *                                         
 * ERROR: kde-plasmoids/yawp-0.0.6 failed. 
 * Call stack:                             
 *               ebuild.sh, line   49:  Called src_configure
 *             environment, line 2522:  Called cmake-utils_src_configure
 *             environment, line  595:  Called cmake-utils_src_configureout
 *             environment, line  614:  Called die                         
 * The specific snippet of code:                                           
 *       cmake -C "${TMPDIR}/gentoo_common_config.cmake" ${cmakeargs} "${S}" || die "Cmake failed";
 *  The die message:                                                                               
 *   Cmake failed                                                                                  
 *                                                                                                 
 * If you need support, post the topmost build error, and the call stack if relevant.              
 * A complete build log is located at '/var/tmp/portage/kde-plasmoids/yawp-0.0.6/temp/build.log'.  
 * The ebuild environment file is located at '/var/tmp/portage/kde-plasmoids/yawp-0.0.6/temp/environment'.
 * This ebuild is from an overlay named 'bugzilla': '/usr/local/portage/layman/bugzilla/'                 


Any idea why?
Comment 4 Marian Kyral 2009-01-25 12:03:03 UTC
(In reply to comment #3)
> Umm, am getting this error:
> 
>   PLASMA_FOUND -> nothing, it's always there if KDE4, version 4.2 or newer
>   has been found.                                                         
> 
>   If you see this error message in a module within KDE/, update it from svn,
>   it has been fixed already.                                                
> 
> Call Stack (most recent call first):
>   CMakeLists.txt:5 (find_package)   
> 
...                                                                            
>  * If you need support, post the topmost build error, and the call stack if
> relevant.              
>  * A complete build log is located at
> '/var/tmp/portage/kde-plasmoids/yawp-0.0.6/temp/build.log'.  
>  * The ebuild environment file is located at
> '/var/tmp/portage/kde-plasmoids/yawp-0.0.6/temp/environment'.
>  * This ebuild is from an overlay named 'bugzilla':
> '/usr/local/portage/layman/bugzilla/'                 
> 
> 
> Any idea why?
> 

If you are using KDE 4.2 RC - there was a change in cmake. You can try the latest svn version.
I'll try to prepare an ebuild for version 0.1.65.
Comment 5 Marian Kyral 2009-01-25 13:52:35 UTC
Created attachment 179671 [details]
yawp-0.1.65.ebuild

New version with accuweather.com support
Comment 6 Marian Kyral 2009-01-25 13:53:52 UTC
Created attachment 179672 [details, diff]
A patch file needed by version 0.1.65 to support KDE 4.2 RC and later
Comment 7 Rahul Jain 2009-01-25 14:43:32 UTC
Thanks! That works like a charm
Comment 8 Rahul Jain 2009-02-04 13:45:32 UTC
Um, somehow i cannot change the yawp settings - each time I click on yawp settings nothing happens - any idea?
Comment 9 Rahul Jain 2009-02-04 13:45:59 UTC
Or there must be a way to change the default station via the cli ?
Comment 10 Marian Kyral 2009-02-04 13:57:37 UTC
Well, in this case you have some problems with plasma. What version of KDE are you using? Did it work before? Did you update KDE in the meantime?

Could you try the default plasma settings?

1) kquitapp plasma
2) rename the .kde4/share/config/plasma* files
3) plasma
Comment 11 Rahul Jain 2009-02-05 14:37:29 UTC
It indeed looks like my plasma is messed up (I know it is because of other issues as well). Anyways the remove widget icon on yaWP works as the properties thing, so I am ok for now! :P
Comment 12 Marian Kyral 2009-03-05 20:05:51 UTC
Created attachment 184047 [details]
yawp-0.2.ebuild

Version bump.
Comment 13 Alex Alexander (RETIRED) gentoo-dev 2009-03-05 22:50:17 UTC
ebuild added to kde-testing overlay, thanks :)
Comment 14 Alex Alexander (RETIRED) gentoo-dev 2009-03-06 07:35:29 UTC
reopened bug since ebuild not in main tree
Comment 15 Samuli Suominen gentoo-dev 2009-11-10 19:08:56 UTC
In portage.