Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 250680 - app-i18n/scim-wijesekera fails to build with gcc 4.3
Summary: app-i18n/scim-wijesekera fails to build with gcc 4.3
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: CJK Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gcc-4.3
  Show dependency tree
 
Reported: 2008-12-12 09:39 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2008-12-28 19:22 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (scim-wijesekera-0.3.3:20081212-021156.log,33.33 KB, text/plain)
2008-12-12 09:39 UTC, Diego Elio Pettenò (RETIRED)
Details
gcc 4.3 patch (gcc-4.3.patch,635 bytes, patch)
2008-12-28 02:00 UTC, academicsam@gmail.com
Details | Diff
new ebuild that applies gcc-4.3 patch (scim-wijesekera-0.3.3-r1.ebuild,688 bytes, text/plain)
2008-12-28 02:01 UTC, academicsam@gmail.com
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2008-12-12 09:39:31 UTC
Check attached build log
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2008-12-12 09:39:53 UTC
Created attachment 175062 [details]
Build log
Comment 2 Peter Alfredsen (RETIRED) gentoo-dev 2008-12-19 21:17:05 UTC
@cjk: According to my info, the wijesekera layout in this package is now maintained in scim-m17n. Can you confirm that this is the case and remove the package if so?
Comment 3 MATSUU Takuto (RETIRED) gentoo-dev 2008-12-20 03:19:50 UTC
agree
Comment 4 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2008-12-20 20:40:19 UTC
# Jeremy Olexa <darkside@gentoo.org> (20 Dec 2008)
# Removed in 60 days. Does not compile with gcc-4.3. Use app-i18n/scim-m17n
# instead, bug 250680
app-i18n/scim-wijesekera
Comment 5 academicsam@gmail.com 2008-12-28 01:59:04 UTC
(In reply to comment #2)
> @cjk: According to my info, the wijesekera layout in this package is now
> maintained in scim-m17n. Can you confirm that this is the case and remove the
> package if so?
> 

I submitted the original ebuild. scim-m17n doesn't provide this keyboard. I've included a patch and a new ebuild that makes it compile with gcc 4.3. Hopefully this will stop it from being removed.

Thanks.
Sam
Comment 6 academicsam@gmail.com 2008-12-28 02:00:33 UTC
Created attachment 176553 [details, diff]
gcc 4.3 patch

adds #include <string.h> to make it compile with gcc 4.3
Comment 7 academicsam@gmail.com 2008-12-28 02:01:34 UTC
Created attachment 176555 [details]
new ebuild that applies gcc-4.3 patch
Comment 8 MATSUU Takuto (RETIRED) gentoo-dev 2008-12-28 16:17:46 UTC
removed p.mask.
Comment 9 MATSUU Takuto (RETIRED) gentoo-dev 2008-12-28 16:19:39 UTC
scim-wijesekera-0.3.3-r1 in cvs. thanks.
Comment 10 Sam Iam 2008-12-28 19:22:19 UTC
(In reply to comment #9)
> scim-wijesekera-0.3.3-r1 in cvs. thanks.
> 

Great! Thanks. I'll be happy to maintain this ebuild.

Sam